Add openvpn-nagios, an OpenVPN certificate monitoring plugin to be used

in nagios
This commit is contained in:
manu 2013-02-10 05:57:41 +00:00
parent eabb682a3d
commit 3f169ae736
6 changed files with 88 additions and 0 deletions

1
net/openvpn-nagios/DESCR Normal file
View file

@ -0,0 +1 @@
This OpenVPN plugin check certificate expiration for Nagios

View file

@ -0,0 +1,18 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1 2013/02/10 05:57:41 manu Exp $
In order to enable the use of this module, add this directive to a,
OpenVPN client configuration file
plugin ${OPENVPN_PLUGINSDIR}/openvpn-nagios.so
It can also be configured this way:
plugin ${OPENVPN_PLUGINSDIR}/openvpn-nagios.so -t 20 -d 2 -w 5 -c 3
-t timeut (default 20 s)
-d how many certificates expected in the chain (default 2)
-w days to expiration that trigger a warning (default 3 days)
-c days to expiration that trigger a critical (default 5 days)
===========================================================================

View file

@ -0,0 +1,30 @@
# $NetBSD: Makefile,v 1.1 2013/02/10 05:57:41 manu Exp $
#
.include "../../net/openvpn/Makefile.common"
DISTNAME= openvpn-nagios-20130210
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${OPENVPN_DISTFILE}
CATEGORIES= net
MASTER_SITES= http://ftp.espci.fr/pub/openvpn-nagios/
EXTRACT_SUFX= .tgz
MAINTAINER= manu@NetBSD.org
HOMEPAGE= http://ftp.espci.fr/pub/openvpn-nagios/
COMMENT= OpenVPN certificate checks for Nagios
LICENSE= 2-clause-bsd
PKG_DESTDIR_SUPPORT= user-destdir
USE_LIBTOOL= yes
USE_TOOLS+= install
MAKE_ENV+= OPENVPN_PLUGINSDIR=${PREFIX:Q}/${OPENVPN_PLUGINSDIR:Q}
MAKE_ENV+= OPENVPN_DISTNAME=${OPENVPN_DISTNAME:Q}
PLIST_SUBST+= OPENVPN_PLUGINSDIR=${OPENVPN_PLUGINSDIR:Q}
MESSAGE_SUBST+= OPENVPN_PLUGINSDIR=${PREFIX:Q}/${OPENVPN_PLUGINSDIR:Q}
DEPENDS+= openvpn>=2.3.0:../../net/openvpn
.include "../../mk/bsd.pkg.mk"

2
net/openvpn-nagios/PLIST Normal file
View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1 2013/02/10 05:57:41 manu Exp $
${OPENVPN_PLUGINSDIR}/openvpn-nagios.la

View file

@ -0,0 +1,9 @@
$NetBSD: distinfo,v 1.1 2013/02/10 05:57:41 manu Exp $
SHA1 (openvpn-2.3.0.tar.gz) = 18b51f7ba0b9e18939451d7787c00e04165efe90
RMD160 (openvpn-2.3.0.tar.gz) = f24ac128fcd874bf40e8ffd5161065e84170d69f
Size (openvpn-2.3.0.tar.gz) = 1130659 bytes
SHA1 (openvpn-nagios-20130210.tgz) = 8a0fd4e3eba27584aa53c5589c13d4b38af43ba2
RMD160 (openvpn-nagios-20130210.tgz) = 2a47893ec2db2c280adc7b9fbbea97794ec1a6f4
Size (openvpn-nagios-20130210.tgz) = 3034 bytes
SHA1 (patch-aa) = 272401960c17de892dc7783a4133b80dec5e909e

View file

@ -0,0 +1,28 @@
$NetBSD: patch-aa,v 1.1 2013/02/10 05:57:42 manu Exp $
--- Makefile.orig 2013-02-09 06:44:43.000000000 +0100
+++ Makefile 2013-02-09 18:41:18.000000000 +0100
@@ -1,9 +1,9 @@
-prefix=/usr/pkg
-PLUGINDIR=$(prefix)/lib/openvpn
-bindir=/usr/local/bin
+#prefix=/usr/pkg
+PLUGINDIR=${DESTDIR}${OPENVPN_PLUGINSDIR}
+bindir=${DESTDIR}${PREFIX}/bin
-OPENVPN_SRC=../openvpn-2.3.0
+OPENVPN_SRC=../${OPENVPN_DISTNAME}
CFLAGS= -Wall -Werror -ansi -g -I$(OPENVPN_SRC)/include -DBINDIR=\"$(bindir)\"
OPENVPN_GROUP=nobody
LIBTOOL=libtool
@@ -19,8 +19,9 @@
$(LIBTOOL) --mode=link --tag CC $(CC) -version-info 0:0:0 \
-rpath $(PLUGINDIR) -module -o $@ $? -lc -lutil
install: openvpn-nagios.la
+ $(INSTALL) -d -m 0755 $(PLUGINDIR)
$(LIBTOOL) --mode=install cp openvpn-nagios.la $(PLUGINDIR)/
$(LIBTOOL) --mode=finish
clean: