phpmyadmin: update to 4.8.3

The new package will be prefixed with the php version because the
dependencies are also specified with the version number in the
Makefile.

Changelog:

4.8.3 (2018-08-22)
- issue #14314 Error when naming a database '0'
- issue #14333 Fix NULL as default not shown
- issue #14229 Fixes issue with recent table list
- issue #14045 Fix slow performance on DB structure filtering
- issue #14327 Fix Editing server variable not showing save or cancel option
- issue #14377 Populate options for view create and edit
- issue #14171 2FA configuration fails if PHP doesn't have GD support
- issue #14390 Can't unhide tables
- issue #14382 "Visualize GIS data" icon missing
- issue #14435 Event scheduler status toggle doesn't work
- issue #14365 View not working on multiple servers
- issue #14207 Partition actions in table structure do not work
- issue #14375 Fixes ERR_BLOCKED_BY_XSS_AUDITOR on export table
- issue #14552 Blank message shown instead of MySQL error when adding trigger and other locations
- issue #14525 Fix PHP 7.3 warning: "continue" in "switch" is equal to "break"
- issue #14554 Icon missing when creating a new trigger, routine, and event
- issue #14422 Table comment not showing since 4.8.1
- issue #14426 Drop table doesn't work when you copy tables to another database
- issue #14581 Escaped HTML in 'Add a new server' setup
- issue #14548 [security] HTML injection in import warning messages, see PMASA-2018-5

4.8.2 (2018-06-21)
- issue #14370 WHERE 0 causes Fatal error
- issue #14225 Fix missing index icon
- issue        [security] XSS vulnerability in Designer, see PMASA-2018-3
- issue        [security] File inclusion and remote code execution vulnerability, see PMASA-2018-4

4.8.1 (2018-05-24)
- issue #12772 Fix case where the central columns attributes don't get filled in
- issue #14049 Fix case where the query builder doesn't work when selected column is *
- issue #14029 Revert "Browse" table CSS overflow
- issue #14241 Dropping indexes and foreign keys fail
- issue #14227 Relational linking broken
- issue #14246 Fixed error in configuration storage zero config
- issue #14128 Show 2FA Secret next to QR code
- issue #14212 XML Export from single table throws fatal error
- issue #14239 Line and some other charts ignore result set order of values chosen for the x-axis
- issue #14260 Fixed configuration for DefaultLang and Lang
- issue #14264 Linking for 'Distinct values' broken
- issue #13968 Fix MariaDB 10.2 current_timestamp()
- issue #14249 Fix for missing go button in view edit
- issue #14125 Fix for issues with spatial fields
- issue #14189 Remember table's sorting broken
- issue #14289 Fix multi-column sorting
- issue #14278 Fix central columns in-line edit bug
- issue #14066 Fix AUTO_INCREMENT error when only exporting table structure in database-level exports
- issue #13893 Simulating queries produces unexpected results
- issue #14309 Setup script icons missing

4.8.0.1 (2018-04-19)
- issue        [security] Multiple CSRF vulnerabilities, See PMASA-2018-02

4.8.0 (2018-04-07)
- issue #12946 Allow to export JSON with unescaped unicode chars
- issue #12983 Disable login button without solved reCaptcha
- issue #12315 Allow to remove individual segments from pie charts
- issue        Change label from "Improve table structure" to "Normalize" to match standard terminology
- issue #13087 Offer login as different user on access denied from MySQL
- issue #13110 Indicate when HTTPS is not properly reported on the server
- issue #13119 No database selected error when adding foreign key
- issue #12388 Improved database search to allow search for exact phrase match
- issue #13099 Report error when trying to copy database to same name
- issue #13167 Themes now have to contain metadata in theme.json
- issue #6363  phpMyAdmin no longer requires eval() in PHP
- issue #12386 The mbstring dependency is now optional
- issue #13269 Small refactoring in preparation to CSP
- issue #13384 Database link broken in Databases Page
- issue #13391 Configurable authentication logging using $cfg['AuthLog']
- issue #13086 Add support for Google Invisible Captcha
- issue #13058 Improved error reporting for reCAPTCHA
- issue #12899 Improved rendering of server variables table
- issue #12948 Fixed javascript editor for TIME values
- issue #13095 Fixed alignment of foreign keys editing
- issue #12944 Improved inline editor for JSON
- issue #13145 Improved layout of operations pages
- issue #13448 Add "format" query button in edit view form
- issue #6241  Implement Responsive Design/mobile interface
- issue        Use a single location for classes under PhpMyAdmin namespace
- issue #12354 Indicate SSL status on main page
- issue #5666  Configuration directives for defaults of Transformation options
- issue #12261 Remove inline JavaScript
- issue #13408 Show MySQL warnings when executing SQL queries
- issue #5827  Allow Designer to show tables from other databases
- issue #13268 Replace Query-By-Example with multi-table query generator interface
- issue #13576 Add privileges export to per-database listing
- issue        Consolidate functions into class files
- issue #13560 Add support for changing collation for all tables and columns in database
- issue #13303 Add support for creating fulltext index from table structure
- issue #13711 Lower default value for $cfg['MaxExactCount']
- issue #13722 DisableIS is not fully honored
- issue #6197  Added support for authentication using U2F and 2FA
- issue #13480 Avoid removing cookies on upgrade
- issue #13397 Remember state of navigation panel
- issue #11688 Reduced cookie usage
- issue #13466 Better utilization of user preferences
- issue #14042 Rename PMD to Designer
- issue #13940 Honor arg_separator in AJAX requests
- issue #14060 Can't edit rows in Internet Explorer
- issue #14096 Internet Explorer compatibility; fixes JavaScript error Object doesn't support property or method 'startsWith'

4.7.9 (2018-03-05)
- issue #13931 Fixed browsing tables with more results
- issue #13927 "Not an integer" when browsing a table
- issue #13887 "Input variables exceeded 1000" error relating to PHP's max_input_vars directive

4.7.8 (2018-02-20)
- issue #13914 Fixed resetting default setting values.
- issue #13758 Fixed fallback value for collation connection.
- issue #13938 Fixed error handling in PHP 7.2
- issue        [security] Fix XSS in Central Columns Feature, See PMASA-2018-01

         --- Older ChangeLogs can be found on our project website ---
                     https://www.phpmyadmin.net/old-stuff/ChangeLogs/
This commit is contained in:
tm 2018-12-10 19:27:46 +00:00
parent 2c580a7e18
commit 3f330fcdc2
8 changed files with 1830 additions and 1627 deletions

View file

@ -1,19 +1,15 @@
# $NetBSD: INSTALL,v 1.3 2012/08/28 15:54:54 tron Exp $
# $NetBSD: INSTALL,v 1.4 2018/12/10 19:27:46 tm Exp $
APACHE_USER=@APACHE_USER@
APACHE_GROUP=@APACHE_GROUP@
PMSETUPDIR=@PMSETUPDIR@
PMSETUPFILE=@PMSETUPFILE@
PMVARDIR=@PMVARDIR@
case ${STAGE} in
POST-INSTALL)
if [ ! -f ${PMSETUPFILE} ]; then
${MKDIR} ${PMSETUPDIR}
${CHOWN} ${APACHE_USER}:${APACHE_GROUP} ${PMSETUPDIR}
${CHMOD} 755 ${PMSETUPDIR}
${TOUCH} ${PMSETUPFILE}
${CHOWN} ${APACHE_USER}:${APACHE_GROUP} ${PMSETUPFILE}
${CHMOD} 644 ${PMSETUPFILE}
if [ ! -d ${PMVARDIR}/tmp ]; then
${MKDIR} -p ${PMVARDIR}/tmp
${CHOWN} -R ${APACHE_USER}:${APACHE_GROUP} ${PMVARDIR}
${CHMOD} -R 755 ${PMVARDIR}
fi
;;
esac

View file

@ -1,8 +1,9 @@
===========================================================================
$NetBSD: MESSAGE,v 1.14 2016/08/23 15:53:14 taca Exp $
$NetBSD: MESSAGE,v 1.15 2018/12/10 19:27:46 tm Exp $
No custom configuration files are stored in "${PMCONFDIR}", do not
change files there because they will removed during upgrades.
Do *not* edit "${CONF_INC_PHP}" to customize
this package because it is a link which will removed during upgrades.
The actual configuration file is "${PMCONFFILE}".
You will need to make phpMyAdmin accessible through your HTTP server.
@ -17,6 +18,6 @@ to make phpMyAdmin accessible through:
If you are setting up phpmyadmin for the first time you will need to
comment out the configuration block in your apache.conf which denies
access to the scripts directory. This only need to be done the first
access to the setup directory. This only need to be done the first
time you access your phpmyadmin installation.
===========================================================================

View file

@ -1,12 +1,12 @@
# $NetBSD: Makefile,v 1.153 2018/02/24 05:34:19 taca Exp $
# $NetBSD: Makefile,v 1.154 2018/12/10 19:27:46 tm Exp $
DISTNAME= phpMyAdmin-4.6.5.2-all-languages
PKGNAME= ${DISTNAME:S/-all-languages//:tl}
DISTNAME= phpMyAdmin-4.8.3-all-languages
PKGNAME= ${PHP_PKG_PREFIX}-${DISTNAME:S/-all-languages//:tl}
CATEGORIES= databases www
MASTER_SITES= https://files.phpmyadmin.net/phpMyAdmin/${PKGVERSION_NOREV}/
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
MAINTAINER= tm@core.io
HOMEPAGE= https://www.phpmyadmin.net/
COMMENT= Set of PHP-scripts to adminstrate MySQL over the WWW
LICENSE= gnu-gpl-v2
@ -20,16 +20,6 @@ DEPENDS+= ${PHP_PKG_PREFIX}-mysqli>=5.3.0:../../databases/php-mysqli
DEPENDS+= ${PHP_PKG_PREFIX}-gd>=5.3.0:../../graphics/php-gd
DEPENDS+= ${PHP_PKG_PREFIX}-json>=5.3.0:../../textproc/php-json
USE_TOOLS+= pax
FILES_SUBST+= APACHE_GROUP=${APACHE_GROUP} APACHE_USER=${APACHE_USER}
FILES_SUBST+= PMSETUPDIR=${PMSETUPDIR} PMSETUPFILE=${PMSETUPFILE}
MESSAGE_SUBST+= CONF_INC_PHP=${CONF_INC_PHP} PMCONFFILE=${PMCONFFILE}
CONF_INC_PHP= ${PREFIX}/share/phpmyadmin/config.inc.php
DOC_FILES= CONTRIBUTING.md ChangeLog DCO LICENSE README \
RELEASE-DATE-${PKGVERSION_NOREV}
.include "../../lang/php/phpversion.mk"
.if ${PKG_PHP_VERSION} < 71
@ -38,6 +28,8 @@ DEPENDS+= ${PHP_PKG_PREFIX}-mcrypt>=5.3.0:../../security/php-mcrypt
DEPENDS+= ${PHP_PKG_PREFIX}-pecl-mcrypt>=1.0.1:../../security/php-pecl-mcrypt
.endif
USE_TOOLS+= pax
APACHE_USER?= www
APACHE_GROUP?= www
@ -48,55 +40,61 @@ BUILD_DEFS+= APACHE_USER APACHE_GROUP VARBASE
PKG_USERS_VARS= APACHE_USER
PKG_GROUPS_VARS= APACHE_GROUP
PKG_SYSCONFSUBDIR= phpmyadmin
FILES_SUBST+= APACHE_GROUP=${APACHE_GROUP} APACHE_USER=${APACHE_USER}
FILES_SUBST+= PMCONFDIR=${PMCONFDIR} PMVARDIR=${PMVARDIR}
MESSAGE_SUBST+= PMCONFDIR=${PMCONFDIR} PMCONFFILE=${PMCONFFILE}
DOC_FILES= ChangeLog CODE_OF_CONDUCT.md CONTRIBUTING.md DCO LICENSE \
README RELEASE-DATE-${PKGVERSION_NOREV}
EXDIR= ${PREFIX}/share/examples/phpmyadmin
PMCONFDIR= ${PKG_SYSCONFDIR}
PMCONFFILE= ${PKG_SYSCONFDIR}/config.inc.php
PMSETUPDIR= ${VARBASE}/phpmyadmin
PMSETUPFILE= ${PMSETUPDIR}/config.inc.php
PMDIR= ${PREFIX}/share/phpmyadmin
PMVARDIR= ${VARBASE}/phpmyadmin
REPLACE_INTERPRETER+= php
REPLACE.php.old= /usr/bin/env php
REPLACE.php.new= ${PREFIX}/bin/php
REPLACE_FILES.php= vendor/bin/highlight-query vendor/bin/lint-query
REPLACE_FILES.php+= vendor/phpmyadmin/sql-parser/bin/highlight-query
REPLACE_FILES.php+= vendor/phpmyadmin/sql-parser/bin/lint-query
REPLACE_FILES.php+= vendor/phpmyadmin/sql-parser/bin/tokenize-query
REPLACE_SH+= vendor/paragonie/random_compat/build-phar.sh
CONF_FILES+= ${EXDIR}/apache.conf ${PKG_SYSCONFDIR}/apache.conf
SRCS= *.css *.ico *.php *.txt doc/html js libraries locale setup \
sql templates test themes
PKG_SYSCONFSUBDIR= phpmyadmin
SRCS= *.css *.ico *.php *.txt doc js libraries locale setup \
sql templates themes vendor
NO_BUILD= yes
CHECK_INTERPRETER_SKIP= share/phpmyadmin/test/install-runkit
SUBST_CLASSES+= paths
SUBST_FILES.paths+= ${WRKDIR}/phpmyadmin.conf
SUBST_FILES.paths+= ${WRKSRC}/libraries/vendor_config.php
SUBST_SED.paths+= -e "s|@PMDIR@|${PMDIR}|g"
SUBST_SED.paths+= -e 's|@@PMSETUPFILE@@|${PMSETUPFILE}|g'
SUBST_SED.paths+= -e "s|@PMVARDIR@|${PMVARDIR}|g"
SUBST_SED.paths+= -e "s|@PMCONFDIR@|${PMCONFDIR}/|g"
SUBST_STAGE.paths= post-configure
INSTALLATION_DIRS+= ${PREFIX}/share/doc/phpmyadmin \
${PREFIX}/share/examples/phpmyadmin \
${PMDIR}/doc ${PMDIR}/scripts
${PREFIX}/share/examples/phpmyadmin
post-extract:
${CP} ${FILESDIR}/phpmyadmin.conf ${WRKDIR}
do-configure:
cd ${WRKSRC}/libraries; \
${MV} ${WRKSRC}/config.sample.inc.php ${WRKDIR}/config.inc.php
pre-install:
cd ${WRKSRC}; \
${FIND} . -type f \( -name .buildinfo -o -name .jshintrc -o -name '*.orig' \) -exec ${RM} -f -- {} \;
do-install:
cd ${WRKSRC} && pax -rw ${SRCS} ${DESTDIR}${PMDIR}
${INSTALL_DATA} ${WRKDIR}/config.inc.php ${DESTDIR}${EXDIR}
${INSTALL_DATA} ${WRKSRC}/config.sample.inc.php ${DESTDIR}${EXDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${DESTDIR}${EXDIR}
${LN} -fs ${EXDIR} ${DESTDIR}${PREFIX}/share/phpmyadmin/examples
${LN} -fs ${EXDIR} ${DESTDIR}${PMDIR}/examples
cd ${WRKSRC} && \
${INSTALL_DATA} ${DOC_FILES} \
${DESTDIR}${PREFIX}/share/doc/phpmyadmin
${INSTALL_DATA} ${WRKDIR}/phpmyadmin.conf ${DESTDIR}${EXDIR}/apache.conf
${LN} -fs ${PMCONFFILE} ${DESTDIR}${CONF_INC_PHP}
.include "../../lang/php/phpversion.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.106 2016/12/30 04:44:43 taca Exp $
$NetBSD: distinfo,v 1.107 2018/12/10 19:27:46 tm Exp $
SHA1 (phpMyAdmin-4.6.5.2-all-languages.tar.xz) = 0870868690c2f97468cb764a13d5e6b3ffda35c7
RMD160 (phpMyAdmin-4.6.5.2-all-languages.tar.xz) = be40587f74dd1763226764891de38b12c8c30ec6
SHA512 (phpMyAdmin-4.6.5.2-all-languages.tar.xz) = 10fecd5f313b3685b3d4d7c86b20e9466abc54298267f2ed41cf81096fae5bf8472860ac3ebd5ecba8644b43f69eaf944625a8a12beaba637bcefba0940f3a11
Size (phpMyAdmin-4.6.5.2-all-languages.tar.xz) = 6136880 bytes
SHA1 (patch-libraries_vendor_config.php) = af587496e999bf1e92d6c5a9ab8053fe6e92a0f2
SHA1 (phpMyAdmin-4.8.3-all-languages.tar.xz) = 69d9ef27687d0e29bf039f49b01c89f80a99dd87
RMD160 (phpMyAdmin-4.8.3-all-languages.tar.xz) = 92848d08d04dbdd588a63bc554716d4d2685bfe5
SHA512 (phpMyAdmin-4.8.3-all-languages.tar.xz) = 95998eda6a2db9020671073c62458d819cbd5e54c5f56f467b109401f6b9ebd2dfbc34cc840980bf2d3a7ee3bc93683b7fe20d9bd72b537d8aa066d39089ff89
Size (phpMyAdmin-4.8.3-all-languages.tar.xz) = 5996528 bytes
SHA1 (patch-libraries_vendor__config.php) = e0fefe54dabf5fb716a315121c3cbec20925f73c

View file

@ -1,4 +1,4 @@
# $NetBSD: phpmyadmin.conf,v 1.4 2016/08/23 15:53:14 taca Exp $
# $NetBSD: phpmyadmin.conf,v 1.5 2018/12/10 19:27:46 tm Exp $
#
# phpmyadmin configuration file fragment for Apache
@ -19,13 +19,13 @@
</Directory>
#
# For security, don't serve pages from the phpmyadmin scripts directories.
# For security, don't serve pages from the phpmyadmin setup directories.
#
# NOTE: If you are setting up phpmyadmin for the first time you will need
# to comment this block out the first time you access your phpmyadmin
# installation.
#
<Directory "@PMDIR@/scripts">
<Directory "@PMDIR@/setup">
<IfModule !mod_authz_core.c>
Order deny,allow
Deny from all

View file

@ -0,0 +1,24 @@
$NetBSD: patch-libraries_vendor__config.php,v 1.1 2018/12/10 19:27:46 tm Exp $
As recommended by phpMyAdmin developers the temp directory should not be part of the webroot. User configuration should be also stored in the "etc"-folder to update the package without configuration changes.
--- libraries/vendor_config.php.orig 2018-08-22 13:36:50.000000000 +0000
+++ libraries/vendor_config.php
@@ -22,7 +22,7 @@ define('AUTOLOAD_FILE', './vendor/autolo
/**
* Directory where cache files are stored.
*/
-define('TEMP_DIR', './tmp/');
+define('TEMP_DIR', '@PMVARDIR@/tmp/');
/**
* Path to changelog file, can be gzip compressed. Useful when you want to
@@ -46,7 +46,7 @@ define('SQL_DIR', './sql/');
* It is not used directly in code, just a convenient
* define used further in this file.
*/
-define('CONFIG_DIR', '');
+define('CONFIG_DIR', '@PMCONFDIR@');
/**
* Filename of a configuration file.

View file

@ -1,16 +0,0 @@
$NetBSD: patch-libraries_vendor_config.php,v 1.3 2013/09/18 22:20:04 tron Exp $
Configure location of the configuration file in the vendor specific section
as suggested by the phpMyAdmin documentation.
--- libraries/vendor_config.php.orig 2013-09-05 17:34:46.000000000 +0100
+++ libraries/vendor_config.php 2013-09-18 21:07:38.000000000 +0100
@@ -28,7 +28,7 @@
/**
* Path to config file generated using setup script.
*/
-define('SETUP_CONFIG_FILE', './config/config.inc.php');
+define('SETUP_CONFIG_FILE', '@@PMSETUPFILE@@');
/**
* Whether setup requires writable directory where config