-export-dynamic is a linker option, pass it down as such.

This commit is contained in:
joerg 2013-06-13 21:43:26 +00:00
parent 263a9d4a1a
commit 3f3e244ec6
3 changed files with 37 additions and 1 deletions

View file

@ -1,7 +1,9 @@
$NetBSD: distinfo,v 1.7 2011/03/29 21:19:19 asau Exp $
$NetBSD: distinfo,v 1.8 2013/06/13 21:43:26 joerg Exp $
SHA1 (gforth-0.7.0.tar.gz) = 5bb357268cba683f2a8c63d2a4bcab8f41cb0086
RMD160 (gforth-0.7.0.tar.gz) = df0cef8cff25eddf670315c5497fc5634226968c
Size (gforth-0.7.0.tar.gz) = 2277918 bytes
SHA1 (patch-aa) = 88811b03619a597d202105c89b659576a9fd34b2
SHA1 (patch-ae) = 5ed4c1b54d6c2af55580183cdc9d66b70fffa955
SHA1 (patch-configure) = e6cf2ba54f5a6492943220a2a8b12e887dcfa527
SHA1 (patch-configure.in) = 4886054414beda7de68323143eecb03ef20c10f9

View file

@ -0,0 +1,18 @@
$NetBSD: patch-configure,v 1.1 2013/06/13 21:43:26 joerg Exp $
--- configure.orig 2013-06-13 17:12:24.000000000 +0000
+++ configure
@@ -3984,10 +3984,10 @@ test "$make_type" = "GNU Make" && GNUMAK
echo "${ECHO_T}$make_type" >&6; }
-{ echo "$as_me:$LINENO: checking whether the linker accepts -export-dynamic" >&5
-echo $ECHO_N "checking whether the linker accepts -export-dynamic... $ECHO_C" >&6; }
+{ echo "$as_me:$LINENO: checking whether the linker accepts -Wl,-export-dynamic" >&5
+echo $ECHO_N "checking whether the linker accepts -Wl,-export-dynamic... $ECHO_C" >&6; }
OLDLDFLAGS=$LDFLAGS
-LDFLAGS="$LDFLAGS -export-dynamic"
+LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
if test "$cross_compiling" = yes; then
ac_export_dynamic=no
else

View file

@ -0,0 +1,16 @@
$NetBSD: patch-configure.in,v 1.1 2013/06/13 21:43:26 joerg Exp $
--- configure.in.orig 2013-06-13 17:24:38.000000000 +0000
+++ configure.in
@@ -182,9 +182,9 @@ test "$make_type" = "GNU Make" && GNUMAK
AC_MSG_RESULT($make_type)
AC_SUBST(GNUMAKE)
-AC_MSG_CHECKING([whether the linker accepts -export-dynamic])
+AC_MSG_CHECKING([whether the linker accepts -Wl,-export-dynamic])
OLDLDFLAGS=$LDFLAGS
-LDFLAGS="$LDFLAGS -export-dynamic"
+LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
dnl AC_TRY_LINK gives false positive on rs6000-ibm-aix4.2.1.0
dnl AC_TRY_LINK(,,ac_export_dynamic=yes,ac_export_dynamic=no)
AC_TRY_RUN(main(){exit(0);},ac_export_dynamic=yes,ac_export_dynamic=no,ac_export_dynamic=no)