Update to 1.18.12 (during the freeze, for the bugfixes). From the changelog:

* Support platforms without a hostname command, fall back to
  reading /etc/hostname.
  Thanks, Chris Morgan
* commit: Support -mmessage, without a space, since eg git commit
  can be used that way.
  Thanks, martin f. krafft
* commit: When multiple parameters are given, use them all as the commit
  message, instead of the old behavior of only using the first parameter and
  throwing the rest away.
  Thanks, martin f. krafft
This commit is contained in:
schmonz 2019-12-24 06:00:24 +00:00
parent d12ef7f9f9
commit 3f90a41659
4 changed files with 20 additions and 31 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.16 2019/11/17 11:57:16 mef Exp $
# $NetBSD: Makefile,v 1.17 2019/12/24 06:00:24 schmonz Exp $
#
DISTNAME= etckeeper_1.18.10.orig
DISTNAME= etckeeper_1.18.12.orig
PKGNAME= ${DISTNAME:S/_/-/:S/.orig$//}
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/e/etckeeper/}

View file

@ -1,16 +1,16 @@
$NetBSD: distinfo,v 1.8 2019/11/17 11:57:16 mef Exp $
$NetBSD: distinfo,v 1.9 2019/12/24 06:00:24 schmonz Exp $
SHA1 (etckeeper_1.18.10.orig.tar.gz) = 8af0b7c6751939a3f18e33f54328f8495a8f0340
RMD160 (etckeeper_1.18.10.orig.tar.gz) = 4e795812cfb25d59afecf640b67b3127ce2cebd4
SHA512 (etckeeper_1.18.10.orig.tar.gz) = 57eb91823c37f364e7ade6b25d2ab91fc99d1192a606fd09370c2876a0440120a625f30167fc52fb16b53ef9f7a58a1329bfe9567cbc2c91da06a345ebbe8e05
Size (etckeeper_1.18.10.orig.tar.gz) = 86823 bytes
SHA1 (etckeeper_1.18.12.orig.tar.gz) = 6b2e368e280ab550efd81587c14980227290d145
RMD160 (etckeeper_1.18.12.orig.tar.gz) = e514e6f3346f2ff937eb13bfedbdc2f2463495ed
SHA512 (etckeeper_1.18.12.orig.tar.gz) = 7fb75d89bbf69d5ef29fc93f34f8368f0d93adb6f89a96be4769be4a58faff793682f5a5fc6f6f2bf51bc5a151a28b61319396a4298cbf0aa75ff3c1bbb660d7
Size (etckeeper_1.18.12.orig.tar.gz) = 90243 bytes
SHA1 (patch-bash__completion) = 95936127f98a76b4b7b66ddc170ba6c1e1e4c0d9
SHA1 (patch-commit.d_50vcs-commit) = 2776cf73cc1211b4beaf14ce05aeb96ff422a19a
SHA1 (patch-commit.d_50vcs-commit) = 488487b4cc0d237c28118f592cda33c526b3b2d6
SHA1 (patch-debian_cron.daily) = b702508cbb4dd42a3ae9f4a0b4be3a763edaf131
SHA1 (patch-etckeeper) = 07a6b61b6c79096065953d22087c32ea5d776f2c
SHA1 (patch-etckeeper.8) = 7e72a7889e0478463eb2b304d2cadb44cd97aa52
SHA1 (patch-etckeeper.conf) = 2ec40032b5c297b97fdd76b3309619319c5849c0
SHA1 (patch-init.d_40vcs-init) = d267d4e7e2b82353614ed15455c2739e1c8f92d6
SHA1 (patch-init.d_40vcs-init) = 695ed382a955cf95f257a2cf9851133adee8be69
SHA1 (patch-list-installed.d_50list-installed) = 966c9471767a1808010af62117edc892e88670a2
SHA1 (patch-post-install.d_50vcs-commit) = a1b5cf25a9b3a421169dd8c5283f61b6dedad803
SHA1 (patch-pre-install.d_10packagelist) = c2a305746aca54091856c2b70543abd42410446a

View file

@ -1,13 +1,13 @@
$NetBSD: patch-commit.d_50vcs-commit,v 1.3 2017/06/29 17:19:13 schmonz Exp $
$NetBSD: patch-commit.d_50vcs-commit,v 1.4 2019/12/24 06:00:24 schmonz Exp $
Test more carefully for a possibly missing binary. From Nathan Arthur in
private mail.
--- commit.d/50vcs-commit.orig 2016-07-17 23:01:39.000000000 +0000
--- commit.d/50vcs-commit.orig 2019-11-29 15:43:52.000000000 +0000
+++ commit.d/50vcs-commit
@@ -23,9 +23,11 @@ fi
hostname=`hostname`
hostname=`hostname 2>/dev/null || cat /etc/hostname`
hostname="${hostname%%.*}"
-dnsdomainname=`dnsdomainname 2>/dev/null || true`
-if [ -n "$dnsdomainname" ]; then

View file

@ -1,26 +1,15 @@
$NetBSD: patch-init.d_40vcs-init,v 1.1 2013/05/27 08:36:00 sbd Exp $
$NetBSD: patch-init.d_40vcs-init,v 1.2 2019/12/24 06:00:24 schmonz Exp $
Change '/etc' to ${ETCKEEPER_DIR}
--- init.d/40vcs-init.orig 2011-02-22 20:19:36.000000000 +0000
--- init.d/40vcs-init.orig 2019-11-29 15:43:52.000000000 +0000
+++ init.d/40vcs-init
@@ -3,15 +3,15 @@ set -e
@@ -1,7 +1,7 @@
#!/bin/sh
set -e
-description="$(hostname 2>/dev/null || cat /etc/hostname) /etc repository"
+description="$(hostname 2>/dev/null || cat /etc/hostname) ${ETCKEEPER_DIR} repository"
if [ "$VCS" = git ] && [ ! -e .git ]; then
git init
- echo "$(hostname) /etc repository" > .git/description
+ echo "$(hostname) ${ETCKEEPER_DIR} repository" > .git/description
elif [ "$VCS" = hg ] && [ ! -e .hg ]; then
hg init
echo "[web]" > .hg/hgrc
- echo "description = $(hostname) /etc repository" >> .hg/hgrc
+ echo "description = $(hostname) ${ETCKEEPER_DIR} repository" >> .hg/hgrc
elif [ "$VCS" = bzr ] && [ ! -e .bzr ]; then
bzr init
- bzr nick "$(hostname) /etc repository"
+ bzr nick "$(hostname) ${ETCKEEPER_DIR} repository"
elif [ "$VCS" = darcs ] && [ ! -e _darcs ]; then
darcs initialize
- echo "$(hostname) /etc repository" > _darcs/prefs/motd
+ echo "$(hostname) ${ETCKEEPER_DIR} repository" > _darcs/prefs/motd
fi
echo "$description" > .git/description