Initial import of fooseti, version 0.6.6.
fooseti is a simple frontend for the Seti@home client. It shows the current status of the client in a GTK+ window, allowing to start and stop it when wanted. Note that it does not support account configuration. Provided in PR pkg/19576 by Juan RP, with several changes by me.
This commit is contained in:
parent
efeb9f788a
commit
3f9c32fcda
6 changed files with 81 additions and 0 deletions
3
misc/fooseti/DESCR
Normal file
3
misc/fooseti/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
fooseti is a simple frontend for the Seti@home client. It shows the current
|
||||
status of the client in a GTK+ window, allowing to start and stop it when
|
||||
wanted. Note that it does not support account configuration.
|
30
misc/fooseti/Makefile
Normal file
30
misc/fooseti/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/12/28 15:37:37 jmmv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= fooseti-0.6.6
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www-personal.engin.umich.edu/~agorski/fooseti/
|
||||
|
||||
MAINTAINER= jrp@hispabsd.org
|
||||
HOMEPAGE= http://www-personal.engin.umich.edu/~agorski/fooseti/
|
||||
COMMENT= Simple GTK+ frontend for the Seti@home client
|
||||
|
||||
DEPENDS+= setiathome>=3.00:../../misc/setiathome
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_BUILDLINK2= YES
|
||||
USE_X11= YES
|
||||
|
||||
CPPFLAGS+= -DPKG_BINDIR=\"\\\"${LOCALBASE}/bin\\\"\"
|
||||
|
||||
DOCS= AUTHORS BUGS COPYING ChangeLog INSTALL NEWS NOTES README TODO
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/fooseti
|
||||
.for doc in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${doc} ${PREFIX}/share/doc/fooseti
|
||||
.endfor
|
||||
.undef doc
|
||||
|
||||
.include "../../x11/gtk/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
12
misc/fooseti/PLIST
Normal file
12
misc/fooseti/PLIST
Normal file
|
@ -0,0 +1,12 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/12/28 15:37:37 jmmv Exp $
|
||||
bin/fooseti
|
||||
share/doc/fooseti/AUTHORS
|
||||
share/doc/fooseti/BUGS
|
||||
share/doc/fooseti/COPYING
|
||||
share/doc/fooseti/ChangeLog
|
||||
share/doc/fooseti/INSTALL
|
||||
share/doc/fooseti/NEWS
|
||||
share/doc/fooseti/NOTES
|
||||
share/doc/fooseti/README
|
||||
share/doc/fooseti/TODO
|
||||
@dirrm share/doc/fooseti
|
6
misc/fooseti/distinfo
Normal file
6
misc/fooseti/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/12/28 15:37:37 jmmv Exp $
|
||||
|
||||
SHA1 (fooseti-0.6.6.tar.gz) = c4c2226ef5ae44cbf238aa9543ded908d013b4f9
|
||||
Size (fooseti-0.6.6.tar.gz) = 61863 bytes
|
||||
SHA1 (patch-aa) = ed34c9e9939830610a6544b1536faf1b477c995b
|
||||
SHA1 (patch-ab) = b3cc6f7451efdd481f0c168dcbfb19561db20e23
|
13
misc/fooseti/patches/patch-aa
Normal file
13
misc/fooseti/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/12/28 15:37:37 jmmv Exp $
|
||||
|
||||
--- src/prefs.c.orig Sun Dec 23 17:34:14 2001
|
||||
+++ src/prefs.c
|
||||
@@ -183,7 +183,7 @@ show_prefs()
|
||||
if (seti.client != NULL)
|
||||
gtk_entry_set_text(GTK_ENTRY(client), seti.client);
|
||||
else
|
||||
- gtk_entry_set_text(GTK_ENTRY(client), "setiathome");
|
||||
+ gtk_entry_set_text(GTK_ENTRY(client), PKG_BINDIR "/setiathome");
|
||||
|
||||
if (options.name)
|
||||
gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(name_check), TRUE);
|
17
misc/fooseti/patches/patch-ab
Normal file
17
misc/fooseti/patches/patch-ab
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2002/12/28 15:37:37 jmmv Exp $
|
||||
|
||||
--- src/fileIO.c.orig Mon Dec 24 02:15:53 2001
|
||||
+++ src/fileIO.c
|
||||
@@ -344,10 +344,10 @@ runClient()
|
||||
show_error(NULLPATH);
|
||||
} // if the path is null
|
||||
else {
|
||||
- client = g_strdup_printf("%s/%s", seti.path, seti.client);
|
||||
+ client = g_strdup_printf("%s", seti.client);
|
||||
|
||||
if(!stat(client, &statBuf)) {
|
||||
- command = g_strdup_printf("cd %s ; ./%s %s &", seti.path, seti.client, data.args);
|
||||
+ command = g_strdup_printf("cd %s ; %s %s &", seti.path, seti.client, data.args);
|
||||
system(command);
|
||||
g_free(command);
|
||||
update();
|
Loading…
Reference in a new issue