py-meson: SunOS does not use GNU ld. Bump PKGREVISION.
This commit is contained in:
parent
57317c8374
commit
3fb110fbe5
3 changed files with 7 additions and 15 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.17 2019/03/08 11:34:49 prlw1 Exp $
|
||||
# $NetBSD: Makefile,v 1.18 2019/03/11 12:08:19 jperkin Exp $
|
||||
|
||||
DISTNAME= meson-0.49.2
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=m/meson/}
|
||||
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.16 2019/03/08 11:34:49 prlw1 Exp $
|
||||
$NetBSD: distinfo,v 1.17 2019/03/11 12:08:19 jperkin Exp $
|
||||
|
||||
SHA1 (meson-0.49.2.tar.gz) = 9c16f7a72ea15669efdcbc7ac01cf3e00ffb55c8
|
||||
RMD160 (meson-0.49.2.tar.gz) = 6ce4677fedba1bff8e4174a16c4361d1364b0abd
|
||||
SHA512 (meson-0.49.2.tar.gz) = 4aca4c273e7c23034c1ed76aa48c914aef34ca4be9df9d5810b8dd3dac9f5f67aa577a682490aa3d81c0503b5a5a8ac1e2452b2f2fdd7a5c7db2aa504047b87d
|
||||
Size (meson-0.49.2.tar.gz) = 1340730 bytes
|
||||
SHA1 (patch-mesonbuild_compilers_compilers.py) = 118aaa4de372b744252bfa0969dbe2fe1bada88e
|
||||
SHA1 (patch-mesonbuild_compilers_compilers.py) = 6b1be661a9fe97e55cf394ff06a33fe72c85f434
|
||||
SHA1 (patch-mesonbuild_environment.py) = f599ec7c708037002da5d9ee4ca0ccfb31b2e307
|
||||
SHA1 (patch-mesonbuild_minstall.py) = 64bcbdac0d37cabd114349de34646820893bb212
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-mesonbuild_compilers_compilers.py,v 1.5 2019/03/08 11:34:49 prlw1 Exp $
|
||||
$NetBSD: patch-mesonbuild_compilers_compilers.py,v 1.6 2019/03/11 12:08:19 jperkin Exp $
|
||||
|
||||
Support SunOS-specific GCC behaviour.
|
||||
Limit GNU ld options correctly.
|
||||
|
@ -57,15 +57,7 @@ Limit GNU ld options correctly.
|
|||
sostr = '' if soversion is None else '.' + soversion
|
||||
return ['-Wl,-soname,%s%s.%s%s' % (prefix, shlib_name, suffix, sostr)]
|
||||
elif compiler_type.is_windows_compiler:
|
||||
@@ -1359,6 +1372,7 @@ def get_compiler_uses_gnuld(c):
|
||||
CompilerType.GCC_STANDARD,
|
||||
CompilerType.GCC_MINGW,
|
||||
CompilerType.GCC_CYGWIN,
|
||||
+ CompilerType.GCC_SUNOS,
|
||||
CompilerType.CLANG_STANDARD,
|
||||
CompilerType.CLANG_MINGW,
|
||||
CompilerType.ICC_STANDARD,
|
||||
@@ -1474,6 +1488,8 @@ class GnuLikeCompiler(abc.ABC):
|
||||
@@ -1474,6 +1487,8 @@ class GnuLikeCompiler(abc.ABC):
|
||||
def get_buildtype_linker_args(self, buildtype):
|
||||
if self.compiler_type.is_osx_compiler:
|
||||
return apple_buildtype_linker_args[buildtype]
|
||||
|
@ -74,7 +66,7 @@ Limit GNU ld options correctly.
|
|||
return gnulike_buildtype_linker_args[buildtype]
|
||||
|
||||
@abc.abstractmethod
|
||||
@@ -1538,6 +1554,8 @@ class GnuLikeCompiler(abc.ABC):
|
||||
@@ -1538,6 +1553,8 @@ class GnuLikeCompiler(abc.ABC):
|
||||
if self.compiler_type.is_osx_compiler:
|
||||
# Apple ld
|
||||
return ['-Wl,-undefined,dynamic_lookup']
|
||||
|
|
Loading…
Reference in a new issue