Update from version 1.3.2 (upstream 1.003002) to version 1.4.4 (upstream

1.004004).

Pkgsrc changes:
- Set LICENSE
- Set PERL5_MODULE_TYPE to Module::Install
- Add patch to prevent the ad hoc execution of interactive CPAN.pm's first time
configuration by Makefile.PL

Upstream changes:
1.004004 2009-08-05

        - Add dependency on Extutils::Install 1.43 and install in --bootstrap
          otherwise we fail to build with latest MakeMaker on OpenSolaris (t0m)

        - Fix Win32 / Cygwin detection (emazep).

1.004003 2009-16-16
        - Stop Makefile.PL exploding if your CPAN is too old to have
          CPAN::HandleConfig. Needed when installing local::lib via CPAN
          using an old CPAN version (t0m)
        - Fix warning from Makefile.PL about ExtUtils::MakeMaker::prompt (t0m)
        - Set PERL5LIB back to calculated @INC with --self-contained, to stop
          invoking other perl scripts from losing the local::lib if they
          mangle @INC from $ENV{PERL5LIB}, and fix install of 'difficult'
          modules with such as Test::Deep (t0m)

1.004002 2009-06-15
        - Fixed up INC untaint procedure to skip/ignore CODE, ARRAY,
          blessed entries. (grink)
        - Include test in xt/ for the above

        - Put PERL5LIB first, so it'll be favored over privlibexp and
          archlibexp when self contained.
        - Automatically untaint @INC (t0m)
        - Prevent @INC from growing when you have multiple scripts using
          --self-contained called from inside one another. (grink by way of t0m)
        - eg/scripted_install.pl now no longer requires TARGET, but still
          respects it. (confound)

1.004001 2009-05-21
        - Clean up CPAN.pm's environment variable the same way we do for
          CPANPLUS. Add an example program showing local::lib employed
          programmatically (confound).

        - Add the beginnings of a troubleshooting section (pattern).

1.004000 2009-05-14
        - Don't allow dangerous settings for CPAN.pm that affect where CPAN
          installs stuff, as this conflicts with what we're trying to do.

        - Make sure that our Makefile is written to the correct directory when
          bootstrapping (confound).

1.003004 2009-05-12
        - Additional documentation and examples concerning having multiple
          local::lib enviornments (amiri)

        - Some install tests courtesy of Hans Dieter Pearcey <hdp@cpan.org>.
          Thanks!

1.003003 2009-04-09
        - Expose the internals per RT #36846.
        - Fix the MANIFEST up a bit.
This commit is contained in:
seb 2009-08-23 13:47:03 +00:00
parent 125a781865
commit 3fbdea03dd
3 changed files with 83 additions and 7 deletions

View file

@ -1,10 +1,11 @@
# $NetBSD: Makefile,v 1.2 2009/02/26 22:48:43 seb Exp $
# $NetBSD: Makefile,v 1.3 2009/08/23 13:47:03 seb Exp $
#
DISTNAME= local-lib-1.003002
PKGNAME= p5-local-lib-1.3.2
DISTNAME= local-lib-1.004004
PKGNAME= p5-local-lib-1.4.4
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=../../authors/id/A/AP/APEIRON/}
LICENSE= ${PERL5_LICENSE}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://search.cpan.org/dist/local-lib/
@ -14,6 +15,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
USE_LANGUAGES= # empty
PERL5_PACKLIST= auto/local/lib/.packlist
PERL5_MODULE_TYPE= Module::Install
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.2 2009/02/26 22:48:43 seb Exp $
$NetBSD: distinfo,v 1.3 2009/08/23 13:47:03 seb Exp $
SHA1 (local-lib-1.003002.tar.gz) = b2ac54ea63951e90bbfe7cdcab590ec1626883ab
RMD160 (local-lib-1.003002.tar.gz) = 145097769bf8e398a1142de49c8c50097dc2497a
Size (local-lib-1.003002.tar.gz) = 24962 bytes
SHA1 (local-lib-1.004004.tar.gz) = f85a14619e596c8b7c13dfbdf6c403328c26d319
RMD160 (local-lib-1.004004.tar.gz) = 006a5d96118a1b89cd16e294b8afec7eb3f7186e
Size (local-lib-1.004004.tar.gz) = 31988 bytes
SHA1 (patch-aa) = 35f4d35c67f3dce9313a4f3e36f3c53196ad1e54

View file

@ -0,0 +1,73 @@
$NetBSD: patch-aa,v 1.1 2009/08/23 13:47:04 seb Exp $
Prevent CPAN's interactive configuration process to take place!
--- Makefile.PL.orig 2009-08-06 02:45:48.000000000 +0000
+++ Makefile.PL
@@ -123,36 +123,36 @@ delete $ENV{PERL5_CPAN_IS_RUNNING} if $n
# and make sure that the user doesn't have any existing CPAN config that'll
# cause us problems for the next few steps.
-{
- local $@;
- eval { require CPAN::HandleConfig; };
- # Need newish CPAN.pm for this, ergo skip it if that version of CPAN isn't
- # installed yet.
- # It will already be installed by the time we reach here if bootstrapping,
- # otherwise, if we're running from CPAN then it will be installed soon
- # enough, and we'll come back here..
- if (!$@) {
- CPAN::HandleConfig->load;
- for my $eumm_setting ( qw/makepl_arg make_install_arg/ ) {
- if ($CPAN::Config->{$eumm_setting} =~ /(?:PREFIX|INSTALL_BASE)/) {
- die "Possibly invalid config detected in $eumm_setting: " . $CPAN::Config->{$eumm_setting};
- }
- }
-
- for my $mb_setting (qw/mbuild_arg mbuild_install_arg mbuildpl_arg/) {
- if ($CPAN::Config->{$mb_setting} =~ /(?:--prefix|--install_base)/) {
- die "Possibly invalid config detected in $mb_setting: " . $CPAN::Config->{$mb_setting};
- }
- }
- }
- else {
- my $error = $@;
- require CPAN;
- # Explode if it looks like requiring CPAN::HandleConfig should
- # have worked, but didn't.
- die($error) if $CPAN::VERSION >= $required_CPAN;
- }
-}
+#{
+# local $@;
+# eval { require CPAN::HandleConfig; };
+# # Need newish CPAN.pm for this, ergo skip it if that version of CPAN isn't
+# # installed yet.
+# # It will already be installed by the time we reach here if bootstrapping,
+# # otherwise, if we're running from CPAN then it will be installed soon
+# # enough, and we'll come back here..
+# if (!$@) {
+# CPAN::HandleConfig->load;
+# for my $eumm_setting ( qw/makepl_arg make_install_arg/ ) {
+# if ($CPAN::Config->{$eumm_setting} =~ /(?:PREFIX|INSTALL_BASE)/) {
+# die "Possibly invalid config detected in $eumm_setting: " . $CPAN::Config->{$eumm_setting};
+# }
+# }
+#
+# for my $mb_setting (qw/mbuild_arg mbuild_install_arg mbuildpl_arg/) {
+# if ($CPAN::Config->{$mb_setting} =~ /(?:--prefix|--install_base)/) {
+# die "Possibly invalid config detected in $mb_setting: " . $CPAN::Config->{$mb_setting};
+# }
+# }
+# }
+# else {
+# my $error = $@;
+# require CPAN;
+# # Explode if it looks like requiring CPAN::HandleConfig should
+# # have worked, but didn't.
+# die($error) if $CPAN::VERSION >= $required_CPAN;
+# }
+#}
if ($bootstrapping) {
auto_install_now;