Compile with the OpenSSL in NetBSD-current.
Patch from ssldump bug tracker, via <veego>.
This commit is contained in:
parent
aab35a3fe8
commit
3fe45256b1
3 changed files with 26 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.14 2005/05/22 20:08:31 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2005/12/11 18:29:53 salo Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ssldump-0.9b3
|
||||
PKGREVISION= 3
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.rtfm.com/ssldump/
|
||||
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.4 2005/02/24 13:10:13 agc Exp $
|
||||
$NetBSD: distinfo,v 1.5 2005/12/11 18:29:53 salo Exp $
|
||||
|
||||
SHA1 (ssldump-0.9b3.tar.gz) = a633a9a811a138eac5ed440d583473b644135ef5
|
||||
RMD160 (ssldump-0.9b3.tar.gz) = 941cf8f2ef8459ec4f9ce65772e134505d46566f
|
||||
Size (ssldump-0.9b3.tar.gz) = 137435 bytes
|
||||
SHA1 (patch-aa) = 8ab6a65c0e338e99249a0c90b87340252494020a
|
||||
|
|
22
security/ssldump/patches/patch-aa
Normal file
22
security/ssldump/patches/patch-aa
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-aa,v 1.1 2005/12/11 18:29:53 salo Exp $
|
||||
|
||||
--- ssl/ssldecode.c-orig 2002-08-17 03:33:17.000000000 +0200
|
||||
+++ ssl/ssldecode.c
|
||||
@@ -51,6 +51,7 @@
|
||||
#include <openssl/ssl.h>
|
||||
#include <openssl/hmac.h>
|
||||
#include <openssl/evp.h>
|
||||
+#include <openssl/md5.h>
|
||||
#include <openssl/x509v3.h>
|
||||
#endif
|
||||
#include "ssldecode.h"
|
||||
@@ -131,7 +132,8 @@ int ssl_decode_ctx_create(dp,keyfile,pas
|
||||
ssl_decode_ctx *d=0;
|
||||
int r,_status;
|
||||
|
||||
- SSLeay_add_all_algorithms();
|
||||
+ SSL_library_init();
|
||||
+ OpenSSL_add_all_algorithms();
|
||||
if(!(d=(ssl_decode_ctx *)malloc(sizeof(ssl_decode_ctx))))
|
||||
ABORT(R_NO_MEMORY);
|
||||
if(!(d->ssl_ctx=SSL_CTX_new(SSLv23_server_method())))
|
Loading…
Reference in a new issue