Removed patch-am, which had been added accidentally. The problem that it

tried to solve is properly fixed by patch-an.
This commit is contained in:
rillig 2006-07-12 16:32:00 +00:00
parent 02f9266fc6
commit 400986994e
2 changed files with 1 additions and 26 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.13 2006/07/12 16:30:03 rillig Exp $
$NetBSD: distinfo,v 1.14 2006/07/12 16:32:00 rillig Exp $
SHA1 (nss-3.11.tar.gz) = 0abccde9a351fb9fa662c75754eb980e04fad482
RMD160 (nss-3.11.tar.gz) = 90be4b42e490084c23451ce8abcf089150357d1e
@ -12,5 +12,4 @@ SHA1 (patch-ah) = 01e8644a0a1dfc70985aed213fc753f376560865
SHA1 (patch-ai) = 995add5e536bb0fba425295cc7972b8725f4e10d
SHA1 (patch-ak) = 4816bf73acfa3edcd0a74d0e235eee7974b42dd6
SHA1 (patch-al) = 711ae5b0ed4a5b8dd8e3735b25fcc5419c27e63e
SHA1 (patch-am) = c1495a4262a82b4795f667b1f89009658de1f236
SHA1 (patch-an) = eccddecb756410c61fad1e745564eccebf740740

View file

@ -1,24 +0,0 @@
$NetBSD: patch-am,v 1.1 2006/07/12 16:30:04 rillig Exp $
Prevent an endless recursion, resulting in a segmentation fault.
--- mozilla/security/nss/lib/freebl/loader.c.orig 2006-07-12 18:03:20.000000000 +0200
+++ mozilla/security/nss/lib/freebl/loader.c 2006-07-12 18:02:55.000000000 +0200
@@ -39,6 +39,9 @@
* ***** END LICENSE BLOCK ***** */
/* $Id: patch-am,v 1.1 2006/07/12 16:30:04 rillig Exp $ */
+#undef NDEBUG
+#include <assert.h>
+
#include "loader.h"
#include "prmem.h"
#include "prerror.h"
@@ -926,6 +928,7 @@ RNG_RNGInit(void)
{
if (!vector && PR_SUCCESS != freebl_RunLoaderOnce())
return SECFailure;
+ assert(vector->p_RNG_RNGInit != RNG_RNGInit);
return (vector->p_RNG_RNGInit)();
}