Update to 804.033:
Tk-804.033 release (2015-02-21) ------------------ Tests New t/pod.t test (github pull request #16) Tk-804.032_501 release (2015-01-31) ---------------------- Fixes Teach perl/Tk where OS X Yosemite Xquartz puts the X11 files (github pull request #12) Pushstack experiment to workaround crashes with perl 5.20.x and XFT=0 (RT #96543) Tk::Text: don't insert ctrl and meta key presses (github issue #9) Fix memory leak in canvas text item handling with XFT=1 (RT #100211) Use public version of Perl_utf8_hop (RT #100878) FixBuggyUTF8String is not called anymore for new perls Improvements Use Cwd::getcwd() instead of Cwd::cwd() (performance improvement) Tests t/font.t does not fail with only one font family installed (RT #99411) unicode.t - update textwidget before examining new state (RT #100153) Compatibility with old Test::More versions without note() and isa_ok class check Workaround for core dumps in some fork-using tests (RT #100399) Workaround for more timing problems in wm-tcl.h Tk-804.032_500 release (2014-11-06) ---------------------- Fixes Freetype header files may now be in /usr/include/freetype2/freetype.h in newer freetype installations (e.g. Debian/jessie). https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=740207 Tk::MainWindow::Create without args used to segfault. Fix X11 discovery on non-x86_64 platforms (RT #95590). Fix new sprintf warning with perl 5.21.x. Workaround behaviour change in ExtUtils::MakeMaker 6.99_10 (PERL value is now quoted), which caused build failures (RT #100044). Tests Fix race condition in t/errordialog.t t/create.t uses Test::More Remove useless hostname and getlogin retrieval in t/fileevent.t (RT #98889). Use pipe instead of stdin in t/fileevent2.t (RT #98891). Fix font-related issues with t/entry.t (RT #98831). Documentation New Pod ErrorDialog.pod (github pull request #6).
This commit is contained in:
parent
c4b08972fc
commit
4043a3986a
4 changed files with 8 additions and 49 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.86 2014/11/13 08:30:16 markd Exp $
|
||||
# $NetBSD: Makefile,v 1.87 2015/03/04 08:55:35 wiz Exp $
|
||||
|
||||
DISTNAME= Tk-804.032
|
||||
DISTNAME= Tk-804.033
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
CATEGORIES= x11 tk perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Tk/}
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.22 2014/11/13 08:30:16 markd Exp $
|
||||
$NetBSD: distinfo,v 1.23 2015/03/04 08:55:35 wiz Exp $
|
||||
|
||||
SHA1 (Tk-804.032.tar.gz) = 031818e80effe164772b9ca83c02f7d188efaa14
|
||||
RMD160 (Tk-804.032.tar.gz) = c66b3ada23f985dd002ba093f20d044b5afcc1dc
|
||||
Size (Tk-804.032.tar.gz) = 6933200 bytes
|
||||
SHA1 (patch-aa) = 6bfff2aa899da00783c339aa207bd72c08b2b789
|
||||
SHA1 (Tk-804.033.tar.gz) = 3a6c9eaab585218d01c06d12d4ea1b89a2ad1ffe
|
||||
RMD160 (Tk-804.033.tar.gz) = 478b4e3aa844e700641d25a10753498b9e1a7557
|
||||
Size (Tk-804.033.tar.gz) = 6924238 bytes
|
||||
SHA1 (patch-aa) = 7f4a97b0f97e474ce6f0d0cfeb9d49e8eb703917
|
||||
SHA1 (patch-ac) = 8918f9a9dfd884ed8d7b76b0615e266ffa392a44
|
||||
SHA1 (patch-ad) = 09e322a0adf7c8abf98d2ed202c1f52e6bca97f6
|
||||
SHA1 (patch-ah) = 1b75be678e1bb31a182b3f9dcb9063bf4fc086a1
|
||||
SHA1 (patch-ai) = f6ef20cb48f3ee08335a6410e873f3b5aa277b20
|
||||
SHA1 (patch-aj) = ba3dfe1e7b7a19af1240b37186ab69d857d925f4
|
||||
|
|
|
@ -1,34 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.5 2014/11/13 08:30:16 markd Exp $
|
||||
|
||||
Workaround behaviour change in ExtUtils::MakeMaker 6.99_10 (PERL
|
||||
value is now quoted), which caused build failures (RT #100044).
|
||||
$NetBSD: patch-aa,v 1.6 2015/03/04 08:55:35 wiz Exp $
|
||||
|
||||
--- Tk/MMutil.pm.orig 2013-11-15 23:50:03.000000000 +0000
|
||||
+++ Tk/MMutil.pm
|
||||
@@ -115,19 +115,15 @@ sub mTk_CHO
|
||||
$self->{O_FILES} = [grep s/\.c(pp|xx|c)?$/$self->{OBJ_EXT}/i, @o_files] ;
|
||||
$self->{'MTK'} = $mTk;
|
||||
my $tk = installed_tk();
|
||||
- my $perl = $self->{'PERL'};
|
||||
- if ($IsWin32 && !-f $perl && -f "$perl.exe")
|
||||
- {
|
||||
- print "perl=$perl X=$^X\n";
|
||||
- $perl = "$perl.exe";
|
||||
- $self->{'PERL'} = $perl;
|
||||
- }
|
||||
+ my $perl = $^X;
|
||||
foreach my $file (sort keys %$mTk)
|
||||
{
|
||||
unless (-f $file && -M $file < -M $mTk->{$file})
|
||||
{
|
||||
warn "Extracting $file\n";
|
||||
- system($perl,"$tk/pTk/Tcl-pTk",$mTk->{$file},$file);
|
||||
+ my @cmd = ($perl,"$tk/pTk/Tcl-pTk",$mTk->{$file},$file);
|
||||
+ system @cmd;
|
||||
+ die "The command '@cmd' failed with $?" if $? != 0;
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -313,10 +309,13 @@ sub const_config
|
||||
# }
|
||||
$self->{'LDFLAGS'} =~ s/-flat_namespace//;
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.3 2013/05/31 20:13:24 adam Exp $
|
||||
|
||||
--- myConfig.orig 2012-01-22 18:50:31.000000000 +0000
|
||||
+++ myConfig
|
||||
@@ -346,7 +346,7 @@ if ($win_arch eq 'x') {
|
||||
#
|
||||
# Prefer 64bit libraries on certain architectures
|
||||
#
|
||||
- unless (defined $xlib and $Config{'archname'} =~ m/x86_64/)
|
||||
+ if (!defined $xlib and $Config{'archname'} =~ m/x86_64/)
|
||||
{
|
||||
$xlib = &lX11(0, chooseX11(</usr/X11*/lib64>));
|
||||
}
|
Loading…
Reference in a new issue