webp-pixbuf-loader: update to 0.2.7.

Upstream changes:
 https://github.com/aruiz/webp-pixbuf-loader/releases/tag/0.2.7
> Fixes prepare/Update signal emitions and support for 0ms frames
This commit is contained in:
tsutsui 2024-02-16 11:21:22 +00:00
parent e96117daa8
commit 4077269647
3 changed files with 6 additions and 55 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.5 2024/01/28 13:12:42 wiz Exp $
# $NetBSD: Makefile,v 1.6 2024/02/16 11:21:22 tsutsui Exp $
DISTNAME= webp-pixbuf-loader-0.2.6
DISTNAME= webp-pixbuf-loader-0.2.7
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GITHUB:=aruiz/}
GITHUB_PROJECT= ${DISTNAME:S/-${PKGVERSION_NOREV}//}

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.4 2024/01/28 13:12:42 wiz Exp $
$NetBSD: distinfo,v 1.5 2024/02/16 11:21:22 tsutsui Exp $
BLAKE2s (webp-pixbuf-loader-0.2.6.tar.gz) = f73afd60c01299caa8b7b02814a9173f20e26c67234a0283ea00a1fe00c7776b
SHA512 (webp-pixbuf-loader-0.2.6.tar.gz) = b8e01f4c2ebf00ccacfb07b672593dc1036e69641a717b0855ee581bd88ce5a4aa206beff4363a44b5861411b5fe7186486fd04c4f3fc6fb30483e6298bde663
Size (webp-pixbuf-loader-0.2.6.tar.gz) = 9136752 bytes
SHA1 (patch-io-webp.c) = c1f9121dfff42cfd445a627bf0f361dec6ce0a52
BLAKE2s (webp-pixbuf-loader-0.2.7.tar.gz) = 50f9c8afb3103a473a45cd52081608f9f7a84f34d69b3b8e5ca89562917293e1
SHA512 (webp-pixbuf-loader-0.2.7.tar.gz) = d7abc791b6cdb93b47929e82fbf8b51e5da2848fa43ae65b68fb0505b4da765f938dd290a82d25598d1e5cf9e8f68d6c91a4da814b1194427b4917d03c935910
Size (webp-pixbuf-loader-0.2.7.tar.gz) = 9137358 bytes

View File

@ -1,48 +0,0 @@
$NetBSD: patch-io-webp.c,v 1.3 2023/08/13 00:34:47 tsutsui Exp $
- update_func() shall be called for proper signal delivery
https://github.com/aruiz/webp-pixbuf-loader/pull/73
--- io-webp.c.orig 2023-03-30 00:29:21.000000000 +0000
+++ io-webp.c
@@ -143,6 +143,8 @@ stop_load (gpointer data, GError **error
{
if (context->prepare_func)
context->prepare_func (pb, GDK_PIXBUF_ANIMATION (anim), context->user_data);
+ if (context->update_func)
+ context->update_func (pb, 0, 0, context->width, context->height, context->user_data);
ret = TRUE;
}
@@ -174,6 +176,9 @@ stop_load (gpointer data, GError **error
return FALSE;
}
+ if (context->prepare_func)
+ context->prepare_func (pb, NULL, context->user_data);
+
if (icc_data)
{
gdk_pixbuf_set_option (pb, "icc-profile", icc_data);
@@ -187,10 +192,8 @@ stop_load (gpointer data, GError **error
context->buffer->len, &config);
if (status == VP8_STATUS_OK)
{
- if (context->prepare_func)
- context->prepare_func (pb, NULL, context->user_data);
-
- g_clear_object (&pb);
+ if (context->update_func)
+ context->update_func (pb, 0, 0, context->width, context->height, context->user_data);
ret = TRUE;
}
@@ -198,6 +201,8 @@ stop_load (gpointer data, GError **error
g_set_error (error, GDK_PIXBUF_ERROR, GDK_PIXBUF_ERROR_FAILED,
"WebP decoder failed with VP8 status code: %d", status);
}
+
+ g_clear_object (&pb);
}
if (context->buffer)