Added package devel/ocaml-js-build-tools, some Jane Street build tools for

OCaml.
This commit is contained in:
jaapb 2016-06-20 14:50:11 +00:00
parent a5e236f1b1
commit 409621ca55
6 changed files with 92 additions and 0 deletions

View file

@ -0,0 +1,5 @@
The package contains two libraries:
opam2oasis_install, a small library that we use to generate opam .install files
from the steup.log file generated by oasis;
js-build-tools.ocamlbuild_goodies, an ocamlbuild plugin containing several
hacks and utilities that we often need.

View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1 2016/06/20 14:50:11 jaapb Exp $
VERSION= 113.33.04
GITHUB_PROJECT= js-build-tools
DISTNAME= ${GITHUB_PROJECT}-${VERSION}
PKGNAME= ${GITHUB_PROJECT}-${DISTNAME}
PKGNAME= ocaml-${DISTNAME}
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=janestreet/}
MAINTAINER= jaapb@NetBSD.org
HOMEPAGE= https://github.com/janestreet/js-build-tools/
COMMENT= OCaml build helper tools from Jane Street
LICENSE= apache-2.0
HAS_CONFIGURE= yes
USE_LANGUAGES= # none
OCAML_USE_FINDLIB= yes
.include "../../devel/ocaml-oasis/buildlink3.mk"
.include "../../devel/ocamlbuild/buildlink3.mk"
.include "../../misc/ocaml-opam/buildlink3.mk"
.include "../../mk/ocaml.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,20 @@
@comment $NetBSD: PLIST,v 1.1 2016/06/20 14:50:12 jaapb Exp $
${OCAML_SITELIB}/js-build-tools/META
${PLIST.ocaml-opt}${OCAML_SITELIB}/js-build-tools/jane_street_ocamlbuild_goodies.a
${OCAML_SITELIB}/js-build-tools/jane_street_ocamlbuild_goodies.annot
${OCAML_SITELIB}/js-build-tools/jane_street_ocamlbuild_goodies.cma
${OCAML_SITELIB}/js-build-tools/jane_street_ocamlbuild_goodies.cmi
${OCAML_SITELIB}/js-build-tools/jane_street_ocamlbuild_goodies.cmt
${OCAML_SITELIB}/js-build-tools/jane_street_ocamlbuild_goodies.cmti
${PLIST.ocaml-opt}${OCAML_SITELIB}/js-build-tools/jane_street_ocamlbuild_goodies.cmx
${PLIST.ocaml-opt}${OCAML_SITELIB}/js-build-tools/jane_street_ocamlbuild_goodies.cmxa
${PLIST.ocaml-opt}${OCAML_SITELIB}/js-build-tools/jane_street_ocamlbuild_goodies.cmxs
${PLIST.ocaml-opt}${OCAML_SITELIB}/js-build-tools/oasis2opam_install.a
${OCAML_SITELIB}/js-build-tools/oasis2opam_install.annot
${OCAML_SITELIB}/js-build-tools/oasis2opam_install.cma
${OCAML_SITELIB}/js-build-tools/oasis2opam_install.cmi
${OCAML_SITELIB}/js-build-tools/oasis2opam_install.cmt
${OCAML_SITELIB}/js-build-tools/oasis2opam_install.cmti
${PLIST.ocaml-opt}${OCAML_SITELIB}/js-build-tools/oasis2opam_install.cmx
${PLIST.ocaml-opt}${OCAML_SITELIB}/js-build-tools/oasis2opam_install.cmxa
${PLIST.ocaml-opt}${OCAML_SITELIB}/js-build-tools/oasis2opam_install.cmxs

View file

@ -0,0 +1,13 @@
# $NetBSD: buildlink3.mk,v 1.1 2016/06/20 14:50:12 jaapb Exp $
BUILDLINK_TREE+= ocaml-js-build-tools
.if !defined(OCAML_JS_BUILD_TOOLS_BUILDLINK3_MK)
OCAML_JS_BUILD_TOOLS_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.ocaml-js-build-tools+= ocaml-js-build-tools>=113.33.04
BUILDLINK_PKGSRCDIR.ocaml-js-build-tools?= ../../devel/ocaml-js-build-tools
.endif # OCAML_JS_BUILD_TOOLS_BUILDLINK3_MK
BUILDLINK_TREE+= -ocaml-js-build-tools

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2016/06/20 14:50:12 jaapb Exp $
SHA1 (js-build-tools-113.33.04.tar.gz) = ab2efaaad4942f5414831566a07fd8cfdd680d01
RMD160 (js-build-tools-113.33.04.tar.gz) = c8d03ef1e11d39173f0c9d45b0873ef16bec8639
SHA512 (js-build-tools-113.33.04.tar.gz) = 232c376d09fef5d6e7a7e4eb72f0123eda8a20ee7f0a64c4db5f237294a3755cb539d4d165cbbbb31d5396a182a2f94543eeb265235b4dd5866682a1ab49536b
Size (js-build-tools-113.33.04.tar.gz) = 10782 bytes
SHA1 (patch-Makefile) = 73347a64a29a0fde8ccc0cbae967a954b142ee71

View file

@ -0,0 +1,23 @@
$NetBSD: patch-Makefile,v 1.1 2016/06/20 14:50:12 jaapb Exp $
Install into the proper directory
--- Makefile.orig 2016-05-09 12:01:24.000000000 +0000
+++ Makefile
@@ -2,7 +2,7 @@
SETUP := setup.exe
NAME := js-build-tools
-PREFIX = $(shell grep ^prefix= setup.data | cut -d\" -f 2)
+#PREFIX = $(shell grep ^prefix= setup.data | cut -d\" -f 2)
# Default rule
default: build
@@ -30,7 +30,7 @@ $(NAME).install: install.ml setup.log se
ocaml -I "$(OCAML_TOPLEVEL_PATH)" install.ml
install: $(NAME).install
- opam-installer -i --prefix $(PREFIX) $(NAME).install
+ opam-installer -i --prefix ${DESTDIR}$(PREFIX) --libdir ${OCAML_SITELIBDIR} $(NAME).install
uninstall: $(NAME).install
opam-installer -u --prefix $(PREFIX) $(NAME).install