Update gmp to 4.0.1. Changes:
* Bug fixes. * Speed improvements. * Upwardly binary compatible with 3.x versions. * New CPU support: IA-64, Pentium 4. * Improved CPU support: 21264, Cray vector systems. * Support for all MIPS ABIs: o32, n32, 64. * New systems supported: Darwin, SCO, Windows DLLs. * New divide-and-conquer square root algorithm. * New algorithms chapter in the manual. * New malloc reentrant temporary memory method. * New C++ class interface by Gerardo Ballabio (beta). * Revamped configure, featuring ABI selection. * Speed improvements for mpz_powm and mpz_powm_ui (mainly affecting small operands). * mpz_perfect_power_p now properly recognizes 0, 1, and negative perfect powers. * mpz_hamdist now supports negative operands. * mpz_jacobi now accepts non-positive denominators. * mpz_powm now supports negative exponents. * mpn_mul_1 operand overlap requirements relaxed. * Float input and output uses locale specific decimal point where available. * New gmp_printf, gmp_scanf and related functions. * New division functions: mpz_cdiv_q_2exp, mpz_cdiv_r_2exp, mpz_divexact_ui. * New divisibility tests: mpz_divisible_p, mpz_divisible_ui_p, mpz_divisible_2exp_p, mpz_congruent_p, mpz_congruent_ui_p, mpz_congruent_2exp_p. * New Fibonacci function: mpz_fib2_ui. * New Lucas number functions: mpz_lucnum_ui, mpz_lucnum2_ui. * Other new integer functions: mpz_cmp_d, mpz_cmpabs_d, mpz_get_d_2exp, mpz_init2, mpz_kronecker, mpz_lcm_ui, mpz_realloc2. * New rational I/O: mpq_get_str, mpq_inp_str, mpq_out_str, mpq_set_str. * Other new rational functions: mpq_abs, mpq_cmp_si, mpq_div_2exp, mpq_mul_2exp, mpq_set_f. * New float tests: mpf_integer_p, mpf_fits_sint_p, mpf_fits_slong_p, mpf_fits_sshort_p, mpf_fits_uint_p, mpf_fits_ulong_p, mpf_fits_ushort_p. * Other new float functions: mpf_cmp_d, mpf_get_default_prec, mpf_get_si, mpf_get_ui, mpf_get_d_2exp. * New random functions: gmp_randinit_default, gmp_randinit_lc_2exp_size. * New demo expression string parser (see demos/expr). * New preliminary perl interface (see demos/perl). * Tuned algorithm thresholds for many more CPUs.
This commit is contained in:
parent
00a89aba55
commit
40d8739477
7 changed files with 12 additions and 104 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.10 2002/02/18 15:14:11 seb Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2002/04/10 12:37:53 hubertf Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gmp-3.1.1
|
||||
DISTNAME= gmp-4.0.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=gmp/}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2002/02/18 15:14:11 seb Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2002/04/10 12:37:53 hubertf Exp $
|
||||
include/gmp.h
|
||||
@unexec ${INSTALL_INFO} --delete --info-dir=%D/info %D/info/gmp.info
|
||||
info/gmp.info
|
||||
|
@ -7,8 +7,12 @@ info/gmp.info-1
|
|||
info/gmp.info-2
|
||||
info/gmp.info-3
|
||||
info/gmp.info-4
|
||||
info/gmp.info-5
|
||||
info/gmp.info-6
|
||||
info/gmp.info-7
|
||||
info/gmp.info-8
|
||||
lib/libgmp.a
|
||||
lib/libgmp.la
|
||||
lib/libgmp.so
|
||||
lib/libgmp.so.4
|
||||
lib/libgmp.so.4.1
|
||||
lib/libgmp.so.5
|
||||
lib/libgmp.so.5.1
|
||||
|
|
|
@ -1,8 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/21 00:44:20 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2002/04/10 12:37:53 hubertf Exp $
|
||||
|
||||
SHA1 (gmp-3.1.1.tar.gz) = 485fba815e7d972b2a1f57a12ab56757ca10ec5f
|
||||
Size (gmp-3.1.1.tar.gz) = 1033780 bytes
|
||||
SHA1 (patch-aa) = f5081b5a91d82dc33d9c42f404caa35f1155249e
|
||||
SHA1 (patch-ab) = 6569a0e4f817dca207556eddc932ed8e4494c9a8
|
||||
SHA1 (patch-ac) = 76281686bd0695698592a1c674118e835b32d87e
|
||||
SHA1 (patch-ad) = 79674979b5d6d32921a31183a2ce3c159cb249c4
|
||||
SHA1 (gmp-4.0.1.tar.gz) = 3ead9745123e1324c0f0ab9985d4cb28b6d74655
|
||||
Size (gmp-4.0.1.tar.gz) = 1745294 bytes
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.5 2000/12/31 14:05:30 skrll Exp $
|
||||
|
||||
--- mpn/arm/add_n.S.orig Mon Jul 24 18:04:21 2000
|
||||
+++ mpn/arm/add_n.S
|
||||
@@ -35,9 +35,9 @@
|
||||
|
||||
.text
|
||||
.align 0
|
||||
- .global __gmpn_add_n
|
||||
- .type __gmpn_add_n,%function
|
||||
-__gmpn_add_n:
|
||||
+ .global ___gmpn_add_n
|
||||
+ .type ___gmpn_add_n,%function
|
||||
+___gmpn_add_n:
|
||||
stmfd sp!, { r8, r9, lr }
|
||||
movs n, n, lsr #1
|
||||
bcc skip1
|
||||
@@ -74,4 +74,4 @@
|
||||
adc r0, n, #0
|
||||
ldmfd sp!, { r8, r9, pc }
|
||||
end:
|
||||
- .size __gmpn_add_n, end - __gmpn_add_n
|
||||
+ .size ___gmpn_add_n, end - ___gmpn_add_n
|
|
@ -1,23 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2000/12/31 14:05:30 skrll Exp $
|
||||
|
||||
--- mpn/arm/addmul_1.S.orig Mon Jul 24 18:04:21 2000
|
||||
+++ mpn/arm/addmul_1.S
|
||||
@@ -35,9 +35,9 @@
|
||||
|
||||
.text
|
||||
.align 0
|
||||
- .global __gmpn_addmul_1
|
||||
- .type __gmpn_addmul_1,%function
|
||||
-__gmpn_addmul_1:
|
||||
+ .global ___gmpn_addmul_1
|
||||
+ .type ___gmpn_addmul_1,%function
|
||||
+___gmpn_addmul_1:
|
||||
stmfd sp!, { r8-r11, lr }
|
||||
mov z, #0
|
||||
mov ip, #0
|
||||
@@ -86,4 +86,4 @@
|
||||
mov r0, ip
|
||||
ldmfd sp!, { r8-r11, pc }
|
||||
end:
|
||||
- .size __gmpn_addmul_1, end - __gmpn_addmul_1
|
||||
+ .size ___gmpn_addmul_1, end - ___gmpn_addmul_1
|
|
@ -1,23 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2000/12/31 14:05:30 skrll Exp $
|
||||
|
||||
--- mpn/arm/mul_1.S.orig Mon Jul 24 18:04:21 2000
|
||||
+++ mpn/arm/mul_1.S
|
||||
@@ -35,9 +35,9 @@
|
||||
|
||||
.text
|
||||
.align 0
|
||||
- .global __gmpn_mul_1
|
||||
- .type __gmpn_mul_1,%function
|
||||
-__gmpn_mul_1:
|
||||
+ .global ___gmpn_mul_1
|
||||
+ .type ___gmpn_mul_1,%function
|
||||
+___gmpn_mul_1:
|
||||
stmfd sp!, { r8, r9, lr }
|
||||
ands ip, n, #1
|
||||
beq skip1
|
||||
@@ -78,4 +78,4 @@
|
||||
mov r0, ip
|
||||
ldmfd sp!, { r8, r9, pc }
|
||||
end:
|
||||
- .size __gmpn_mul_1, end - __gmpn_mul_1
|
||||
+ .size ___gmpn_mul_1, end - ___gmpn_mul_1
|
|
@ -1,23 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2000/12/31 14:05:30 skrll Exp $
|
||||
|
||||
--- mpn/arm/sub_n.S.orig Mon Jul 24 18:04:21 2000
|
||||
+++ mpn/arm/sub_n.S
|
||||
@@ -35,9 +35,9 @@
|
||||
|
||||
.text
|
||||
.align 0
|
||||
- .global __gmpn_sub_n
|
||||
- .type __gmpn_sub_n,%function
|
||||
-__gmpn_sub_n:
|
||||
+ .global ___gmpn_sub_n
|
||||
+ .type ___gmpn_sub_n,%function
|
||||
+___gmpn_sub_n:
|
||||
stmfd sp!, { r8, r9, lr }
|
||||
subs ip, ip, ip
|
||||
tst n, #1
|
||||
@@ -76,4 +76,4 @@
|
||||
and r0, r0, #1
|
||||
ldmfd sp!, { r8, r9, pc }
|
||||
end:
|
||||
- .size __gmpn_sub_n, end - __gmpn_sub_n
|
||||
+ .size ___gmpn_sub_n, end - ___gmpn_sub_n
|
Loading…
Reference in a new issue