Removed, because SSL functionality and bundle is already present in gnustep-base

This commit is contained in:
adam 2006-01-29 21:35:40 +00:00
parent 128b862a11
commit 40debec691
6 changed files with 0 additions and 104 deletions

View file

@ -1,11 +0,0 @@
This is the Secure Socket Layer (SSL) bundle separated out of the
GNUstep Base Library.
The GNUstep Base Library is a library of general-purpose, non-graphical
Objective C objects. For example, it includes classes for strings,
object collections, byte streams, typed coders, invocations,
notifications, notification dispatchers, moments in time, network ports,
remote object messaging support (distributed objects), and event loops.
It provides functionality that aims to implement the non-graphical
portion of the OpenStep standard (the Foundation library).

View file

@ -1,39 +0,0 @@
# $NetBSD: Makefile,v 1.10 2005/12/05 20:50:56 rillig Exp $
#
DISTNAME= gnustep-base-1.10.1
PKGNAME= ${DISTNAME:S/base/ssl/}
CATEGORIES= security gnustep
MASTER_SITES= ${MASTER_SITE_GNUSTEP:=core/}
MAINTAINER= rh@NetBSD.org
HOMEPAGE= http://www.gnustep.org/
COMMENT= GNUstep SSL bundle
BUILDLINK_DEPENDS.gnustep-base+= gnustep-base>1.10.1
PTHREAD_LIBS= -lpthread
BUILD_DIRS= SSL
MAKEFILE= GNUmakefile
USE_TOOLS+= gmake
GNU_CONFIGURE= yes
GNU_CONFIGURE_PREFIX= ${PREFIX}/share/GNUstep
CONFIGURE_ARGS+= --exec-prefix=${PREFIX}/libexec/GNUstep
CONFIGURE_ENV+= INSTALL_PROGRAM=${INSTALL_SCRIPT:Q}
SUBST_CLASSES+= gsssl
SUBST_STAGE.gsssl= pre-configure
SUBST_FILES.gsssl= SSL/configure base.make.in
SUBST_SED.gsssl= -e 's|@PTHREAD_LIBS@|${PTHREAD_LIBS}|g'
.include "../../devel/gnustep-base/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.if defined(PTHREAD_TYPE) && (${PTHREAD_TYPE} == "pth")
PTHREAD_LIBS+= -lpth
.endif
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/04/11 00:08:11 rh Exp $
share/GNUstep/System/Library/Bundles/SSL.bundle/Resources/Info-gnustep.plist
share/GNUstep/System/Library/Bundles/SSL.bundle/SSL
share/GNUstep/System/Library/Bundles/SSL.bundle/stamp.make
@dirrm share/GNUstep/System/Library/Bundles/SSL.bundle/Resources
@dirrm share/GNUstep/System/Library/Bundles/SSL.bundle

View file

@ -1,22 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.2 2004/09/24 01:58:53 rh Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
GNUSTEP_SSL_BUILDLINK3_MK:= ${GNUSTEP_SSL_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= gnustep-ssl
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Ngnustep-ssl}
BUILDLINK_PACKAGES+= gnustep-ssl
.if !empty(GNUSTEP_SSL_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.gnustep-ssl+= gnustep-ssl>=1.9.1
BUILDLINK_RECOMMENDED.gnustep-ssl+= gnustep-ssl>=1.10.0
BUILDLINK_PKGSRCDIR.gnustep-ssl?= ../../security/gnustep-ssl
.endif # GNUSTEP_SSL_BUILDLINK3_MK
.include "../../devel/gnustep-base/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.5 2005/11/04 11:22:24 rillig Exp $
SHA1 (gnustep-base-1.10.1.tar.gz) = 2835e23fe5627dc59028409acca288bbd9f8f524
RMD160 (gnustep-base-1.10.1.tar.gz) = f445d222d33db292de3a77d26366645bd1cf1a62
Size (gnustep-base-1.10.1.tar.gz) = 1909988 bytes
SHA1 (patch-aa) = 96cb92d28086344df9bbfe2ce60f07856152b8db

View file

@ -1,20 +0,0 @@
$NetBSD: patch-aa,v 1.2 2005/11/04 11:22:24 rillig Exp $
--- SSL/GNUmakefile.orig 2004-01-13 12:39:43.000000000 +1000
+++ SSL/GNUmakefile
@@ -35,7 +35,6 @@ include $(GNUSTEP_MAKEFILES)/common.make
srcdir = .
PACKAGE_NAME = gnustep-base
-ifneq ($(base),no)
ifeq ($(HAVE_OPENSSL), yes)
# The bundles to be compiled
@@ -53,7 +52,6 @@ SSL_PRINCIPAL_CLASS = GSSSLHandle
SSL_BUNDLE_LIBS = $(SSLLIBS) -lgnustep-base -lobjc
endif
-endif
# GNUSTEP_INSTALL_PREFIX must be defined here and not in config.h because
# the installing person may set it on the `make' command line.