Changes 0.9:

* copymode

   The copymode gives easy acess to the scroll back buffer. The commands
   use vi style keybindings, use Mod+v to activate it, navigate with
   h,j,k,l,^,$,g,H,M,L,G search with / (forward) and ? (backwards) select
   text with v and copy it with y. Then later paste it with MOD+p.

   The search functionality is also available directly via MOD+/ and MOD+?.

   Read the manual page for further information. This could be useful
   for st users who want a scroll back buffer.

 * alternate screen mode

   The alternate mode is for example used by midnight commander when you
   press CTRL+o to switch between the file manager and the shell where the
   output is now preserved even after multiple switches back and forth.

 * dvtm now ships its own terminfo file dvtm.info (which at this time is
   mostly a copy of the previously used rxvt one) as a consequence $TERM
   within dvtm window is now set to dvtm{,-256color} depending on whether
   the "outer" terminal supports 256 color mode. The value of $TERM within
   dvtm can be overriden by the environment variable DVTM_TERM which
   will be appropriately suffixed by "-256color" if possible.

   So make sure to install the shipped dvtm.info terminal description file
   ("make install" does it by default).

 * MOD+C creates a new window with the same working directory as the
   currently active window (this relies on the /proc filesystem and thus
   only works on Linux furthermore it expects a POSIX.1-2008 conformant
   realpath(3) implementation).

 * -M command line flag to disable mouse support upon startup so that dvtm's
   mouse handling doesn't interfere with standard X text selection

 * -t command line flag to set a static title of the dvtm "root window" i.e.
   the terminal in which dvtm itself runs. If the flag is omitted dvtm now
   sets the title to the one of the currently focused window.

 * dvtm now follows the config.def.h conventions of the other suckless
   projects which prevents conflicts with config.h and thus allows easier
   tracking of the git repository.

 * various terminal emulation fixes

 * various code cleanups all over the place
This commit is contained in:
adam 2013-05-21 12:34:02 +00:00
parent c18b8a2a8b
commit 40f45af31a
3 changed files with 14 additions and 13 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.8 2013/02/16 09:28:59 shattered Exp $
#
# $NetBSD: Makefile,v 1.9 2013/05/21 12:34:02 adam Exp $
DISTNAME= dvtm-0.8
DISTNAME= dvtm-0.9
CATEGORIES= misc
MASTER_SITES= http://www.brain-dump.org/projects/dvtm/
@ -10,8 +9,8 @@ HOMEPAGE= http://www.brain-dump.org/projects/dvtm/
COMMENT= Dynamic virtual terminal manager
LICENSE= mit
NO_CONFIGURE= yes
USE_LANGUAGES= c99
NO_CONFIGURE= yes
CURSES_DEFAULT= ncurses
SUBST_CLASSES+= config

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.8 2013/02/16 09:28:59 shattered Exp $
$NetBSD: distinfo,v 1.9 2013/05/21 12:34:02 adam Exp $
SHA1 (dvtm-0.8.tar.gz) = 367fe528010a69c705cd046f63201c61086c14ec
RMD160 (dvtm-0.8.tar.gz) = 1ce8abb46dcac72b490d9c86a59d3e1c904c8df0
Size (dvtm-0.8.tar.gz) = 27543 bytes
SHA1 (patch-aa) = 2de5ef5ff718918b61c9c73a1137efaefeaf81c1
SHA1 (dvtm-0.9.tar.gz) = 74b9d1f5172fddd6839d932e483d36c6d0ef4b04
RMD160 (dvtm-0.9.tar.gz) = 26dd89e223c7b903ff14a93e5442855b02a72669
Size (dvtm-0.9.tar.gz) = 34557 bytes
SHA1 (patch-aa) = 2161324f44bf0e368a8476b64f5800e369f1486a

View file

@ -1,11 +1,11 @@
$NetBSD: patch-aa,v 1.4 2009/02/19 19:22:22 tonio Exp $
$NetBSD: patch-aa,v 1.5 2013/05/21 12:34:02 adam Exp $
Do not use rudimentary mkdir(1), cp(1) and chmod(1): install(1) is
simpler and more elegant to install binaries.
--- Makefile.orig 2009-02-08 22:52:37.000000000 +0100
--- Makefile.orig 2013-04-03 11:18:46.000000000 +0000
+++ Makefile
@@ -20,6 +20,7 @@ ${OBJ}: config.h config.mk
@@ -23,6 +23,7 @@ ${OBJ}: config.h config.mk
dvtm: ${OBJ}
@echo CC -o $@
@${CC} -o $@ ${OBJ} ${LDFLAGS}
@ -13,7 +13,7 @@ simpler and more elegant to install binaries.
debug: clean
@make CFLAGS='${DEBUG_CFLAGS}'
@@ -40,18 +41,12 @@ dist: clean
@@ -42,20 +43,13 @@ dist: clean
@rm -rf dvtm-${VERSION}
install: dvtm
@ -33,6 +33,8 @@ simpler and more elegant to install binaries.
- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/dvtm.1
+ ${BSD_INSTALL_MAN_DIR} ${DESTDIR}${MANPREFIX}/man1
+ ${BSD_INSTALL_MAN} dvtm.1.out ${DESTDIR}${MANPREFIX}/man1/dvtm.1
@echo installing terminfo description
- @tic -s dvtm.info
uninstall:
@echo removing executable file from ${DESTDIR}${PREFIX}/bin