Update to 1.0.18.

The rlimit issue adressed in patches ac,ad,ae was already addressed in
release 1.0.11, so remove them.

Omega 1.0.18 (2010-02-14):

indexers:

* Make the default charset "utf-8" not "UTF-8" as we lower case explicitly
  specified character sets to compare to see if we need to reparse.  Previously
  XML documents which explicitly specified their character set as UTF-8 would
  cause needless restart or the parser.

* omindex:

  + Increase the wdf boost for the document title from 2 to 5, since 2 isn't
    really enough.

* scriptindex:

  + Don't abort with "Unknown Exception" if indexing is disallowed or we hit
    </body> for a document which had an overridden character set.  Fixes
    ticket#410.

Omega 1.0.17 (2009-11-18):

indexers:

* omindex:

  + On Linux, change the memory limit on external filters to use _SC_PHYS_PAGES
    since _SC_AVPHYS_PAGES excludes pages used by the OS cache and so will
    often report a really low value.  Fixes Debian bug#548987 and ticket#358.

  + Fix likely crash when reading output from external filter program if read()
    is interrupted by a signal.

  + Fix potential crash when indexing PostScript files (fixed by using delete[]
    (not delete) for array allocated by new[]).

testsuite:

* utf8converttest: Charset "8859_1" isn't understood by Solaris libiconv, and
  isn't a standard charset name, so just test it when using our built-in
  converter and GNU libc.

portability:

* Fix build failure on Mac OS X 10.6.

* Also check for socketpair() in -lxnet if it isn't found without, which
  enables resource limits on external filter programs called by omindex on
  Solaris, and possibly some other platforms.  Fixes ticket#412.
This commit is contained in:
wiz 2010-02-16 14:53:13 +00:00
parent 5ab99ca677
commit 410d26d738
5 changed files with 7 additions and 123 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.12 2009/09/10 18:54:29 schmonz Exp $
# $NetBSD: Makefile,v 1.13 2010/02/16 14:53:13 wiz Exp $
#
DISTNAME= xapian-omega-1.0.16
DISTNAME= xapian-omega-1.0.18
CATEGORIES= textproc
MASTER_SITES= http://oligarchy.co.uk/xapian/1.0.16/
MASTER_SITES= http://oligarchy.co.uk/xapian/1.0.18/
MAINTAINER= schmonz@NetBSD.org
HOMEPAGE= http://xapian.org/docs/omega/overview.html

View file

@ -1,10 +1,7 @@
$NetBSD: distinfo,v 1.8 2009/09/10 18:54:29 schmonz Exp $
$NetBSD: distinfo,v 1.9 2010/02/16 14:53:13 wiz Exp $
SHA1 (xapian-omega-1.0.16.tar.gz) = 2af78a00838ae56b63ccc907aa82051767b26c27
RMD160 (xapian-omega-1.0.16.tar.gz) = a69e16a75cf06b5c4675aae77c34e0df577353a2
Size (xapian-omega-1.0.16.tar.gz) = 511279 bytes
SHA1 (xapian-omega-1.0.18.tar.gz) = 713fe78f840942147eda31c681212b3a2f5d815d
RMD160 (xapian-omega-1.0.18.tar.gz) = 2645e40ce7884d8f9cba8431f0e134f8b970f926
Size (xapian-omega-1.0.18.tar.gz) = 515518 bytes
SHA1 (patch-aa) = a95ffd453b84c39d1b2b912aefd90af6929e2f1d
SHA1 (patch-ab) = 6e845f6a61d7e36715b4a1bde217ff31ea0999e5
SHA1 (patch-ac) = 49dc336eefdd1bafd8343e60ad01412127753989
SHA1 (patch-ad) = 4a09fdb782f11cb94040cd892dcd0b92bd8d1785
SHA1 (patch-ae) = 2ef335339fd36f4e5ff8d1a1a0dbe42bed3c4bf8

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ac,v 1.2 2009/04/20 22:25:38 schmonz Exp $
--- config.h.in.orig 2009-04-19 08:33:24.000000000 -0400
+++ config.h.in
@@ -48,6 +48,9 @@
/* Define to 1 if you have the `pstat_getdynamic' function. */
#undef HAVE_PSTAT_GETDYNAMIC
+/* Define to 1 if you have RLIMIT_AS for setrlimit(). */
+#undef HAVE_RLIMIT_AS
+
/* Define to 1 if you have the `setrlimit' function. */
#undef HAVE_SETRLIMIT

View file

@ -1,23 +0,0 @@
$NetBSD: patch-ad,v 1.2 2009/04/20 22:25:38 schmonz Exp $
--- configure.ac.orig 2009-04-19 08:28:01.000000000 -0400
+++ configure.ac
@@ -110,6 +110,18 @@ dnl omindex uses fork(), socketpair(), a
dnl limits on filter programs.
AC_CHECK_FUNCS([mmap fork setrlimit socketpair sysmp pstat_getdynamic])
+dnl * Do we have RLIMIT_AS?
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <sys/resource.h>
+]], [[
+ struct rlimit r;
+ getrlimit(RLIMIT_AS, &r);
+]])],[
+ AC_DEFINE(HAVE_RLIMIT_AS,, Define if you have RLIMIT_AS for setrlimit())
+],[])
+
dnl Check that snprintf actually works as it's meant to.
dnl
dnl Linux 'man snprintf' warns:

View file

@ -1,76 +0,0 @@
$NetBSD: patch-ae,v 1.4 2009/09/10 18:54:29 schmonz Exp $
--- configure.orig 2009-09-10 02:42:54.000000000 -0400
+++ configure
@@ -15846,6 +15846,62 @@ fi
done
+cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <sys/resource.h>
+
+int
+main ()
+{
+
+ struct rlimit r;
+ getrlimit(RLIMIT_AS, &r);
+
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext
+if { (ac_try="$ac_compile"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
+$as_echo "$ac_try_echo") >&5
+ (eval "$ac_compile") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_cxx_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest.$ac_objext; then
+
+
+cat >>confdefs.h <<\_ACEOF
+#define HAVE_RLIMIT_AS /**/
+_ACEOF
+
+
+else
+ $as_echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+
+fi
+
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+
{ $as_echo "$as_me:$LINENO: checking for working ISO C90 conforming snprintf" >&5
$as_echo_n "checking for working ISO C90 conforming snprintf... " >&6; }
ac_cv_func_snprintf_noniso=no
@@ -17520,6 +17576,8 @@ do
case $ac_option in
# Handling of the options.
-recheck | --recheck | --rechec | --reche | --rech | --rec | --re | --r)
+ : Avoid regenerating within pkgsrc
+ exit 0
ac_cs_recheck=: ;;
--version | --versio | --versi | --vers | --ver | --ve | --v | -V )
$as_echo "$ac_cs_version"; exit ;;