experimental version of BIND9
This commit is contained in:
parent
d839a9eba5
commit
4117ea3cc8
7 changed files with 417 additions and 0 deletions
45
net/bind9-current/Makefile
Normal file
45
net/bind9-current/Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2000/12/15 18:41:50 itojun Exp $
|
||||
#
|
||||
|
||||
DISTNAME= bind-${BIND_VERSION}
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.isc.org/isc/bind9/${BIND_VERSION}/
|
||||
|
||||
MAINTAINER= hubertf@NetBSD.org
|
||||
HOMEPAGE= http://www.isc.org/products/BIND/
|
||||
|
||||
DEPENDS+= unproven-pthreads>=0.17:../../devel/unproven-pthreads
|
||||
|
||||
# IPv6 ready, automatically detected
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
BUILD_DEFS+= USE_INET6
|
||||
|
||||
# Sync these with devel/unproven-pthreads:
|
||||
ONLY_FOR_PLATFORM= NetBSD-*-i386 NetBSD-*-arm32 NetBSD-*-m68k
|
||||
|
||||
# No need to set USE_INET6, will auto-detect.
|
||||
BIND_VERSION= 9.1.0b1
|
||||
DIST_SUBDIR= bind/${BIND_VERSION}
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--with-mit-pthreads \
|
||||
--with-libtool=yes \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var
|
||||
LDFLAGS+= -Wl,-R${LOCALBASE}/pthreads/lib -L${LOCALBASE}/pthreads/lib
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${PREFIX}/share/doc/bind9
|
||||
${MKDIR} ${PREFIX}/share/doc/bind9/arm
|
||||
${MKDIR} ${PREFIX}/share/doc/bind9/draft
|
||||
${MKDIR} ${PREFIX}/share/doc/bind9/misc
|
||||
${MKDIR} ${PREFIX}/share/doc/bind9/rfc
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/bind9
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/arm/* ${PREFIX}/share/doc/bind9/arm
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/draft/* ${PREFIX}/share/doc/bind9/draft
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/misc/* ${PREFIX}/share/doc/bind9/misc
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/rfc/* ${PREFIX}/share/doc/bind9/rfc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/man/bin/*.8 ${PREFIX}/man/man8
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/man/bin/*.5 ${PREFIX}/man/man5
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/man/dnssec/*.8 ${PREFIX}/man/man8
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
net/bind9-current/files/md5
Normal file
3
net/bind9-current/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2000/12/15 18:41:50 itojun Exp $
|
||||
|
||||
MD5 (bind/9.1.0b1/bind-9.1.0b1.tar.gz) = 3014803c261d5c267530492c9d5a0b51
|
3
net/bind9-current/files/patch-sum
Normal file
3
net/bind9-current/files/patch-sum
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2000/12/15 18:41:50 itojun Exp $
|
||||
|
||||
MD5 (patch-aa) = 3be805415711351895d5a56902402991
|
9
net/bind9-current/patches/patch-aa
Normal file
9
net/bind9-current/patches/patch-aa
Normal file
|
@ -0,0 +1,9 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/12/15 18:41:50 itojun Exp $
|
||||
|
||||
--- Makefile.in.orig Wed Dec 6 05:19:14 2000
|
||||
+++ Makefile.in Sat Dec 16 03:17:07 2000
|
||||
@@ -37,3 +37,3 @@
|
||||
install:: isc-config.sh installdirs
|
||||
- ${INSTALL_PROGRAM} isc-config.sh ${DESTDIR}${bindir}
|
||||
+ ${BSD_INSTALL_SCRIPT} isc-config.sh ${DESTDIR}${bindir}
|
||||
|
1
net/bind9-current/pkg/COMMENT
Normal file
1
net/bind9-current/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
Version 9 of the Berkeley Internet Name Daemon, implementation of DNS
|
14
net/bind9-current/pkg/DESCR
Normal file
14
net/bind9-current/pkg/DESCR
Normal file
|
@ -0,0 +1,14 @@
|
|||
BIND version 9 is a major rewrite of nearly all aspects of the
|
||||
underlying BIND architecture. This re-architecting of BIND was
|
||||
necessitated by the expected demands of:
|
||||
|
||||
- Domain name system growth, particularly in very large
|
||||
zones such as .COM
|
||||
- Protocol enhancements necessary to securely query and
|
||||
update zones
|
||||
- Protocol enhancements necessary to take advantage of
|
||||
certain architectural features of IP version 6
|
||||
|
||||
The 9.0.0 release, and this release candidate, is aimed at
|
||||
early adopters and those who wish to make use of new 9.0
|
||||
features, such as IPv6 and DNSSEC secure resolution support.
|
342
net/bind9-current/pkg/PLIST
Normal file
342
net/bind9-current/pkg/PLIST
Normal file
|
@ -0,0 +1,342 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2000/12/15 18:41:52 itojun Exp $
|
||||
bin/dig
|
||||
bin/host
|
||||
bin/isc-config.sh
|
||||
bin/nslookup
|
||||
bin/nsupdate
|
||||
include/dns/a6.h
|
||||
include/dns/acl.h
|
||||
include/dns/adb.h
|
||||
include/dns/byaddr.h
|
||||
include/dns/cache.h
|
||||
include/dns/callbacks.h
|
||||
include/dns/cert.h
|
||||
include/dns/compress.h
|
||||
include/dns/confacl.h
|
||||
include/dns/confcache.h
|
||||
include/dns/confcommon.h
|
||||
include/dns/confctl.h
|
||||
include/dns/confctx.h
|
||||
include/dns/confip.h
|
||||
include/dns/confkeys.h
|
||||
include/dns/conflog.h
|
||||
include/dns/conflsn.h
|
||||
include/dns/conflwres.h
|
||||
include/dns/confparser.h
|
||||
include/dns/confresolv.h
|
||||
include/dns/confrrset.h
|
||||
include/dns/confview.h
|
||||
include/dns/confzone.h
|
||||
include/dns/db.h
|
||||
include/dns/dbiterator.h
|
||||
include/dns/dbtable.h
|
||||
include/dns/dispatch.h
|
||||
include/dns/dnssec.h
|
||||
include/dns/enumclass.h
|
||||
include/dns/enumtype.h
|
||||
include/dns/events.h
|
||||
include/dns/fixedname.h
|
||||
include/dns/journal.h
|
||||
include/dns/keyflags.h
|
||||
include/dns/keytable.h
|
||||
include/dns/keyvalues.h
|
||||
include/dns/lib.h
|
||||
include/dns/log.h
|
||||
include/dns/master.h
|
||||
include/dns/masterdump.h
|
||||
include/dns/message.h
|
||||
include/dns/name.h
|
||||
include/dns/namedconf.h
|
||||
include/dns/ncache.h
|
||||
include/dns/nxt.h
|
||||
include/dns/peer.h
|
||||
include/dns/rbt.h
|
||||
include/dns/rcode.h
|
||||
include/dns/rdata.h
|
||||
include/dns/rdataclass.h
|
||||
include/dns/rdatalist.h
|
||||
include/dns/rdataset.h
|
||||
include/dns/rdatasetiter.h
|
||||
include/dns/rdataslab.h
|
||||
include/dns/rdatastruct.h
|
||||
include/dns/rdatatype.h
|
||||
include/dns/request.h
|
||||
include/dns/resolver.h
|
||||
include/dns/result.h
|
||||
include/dns/rootns.h
|
||||
include/dns/sdb.h
|
||||
include/dns/secalg.h
|
||||
include/dns/secproto.h
|
||||
include/dns/ssu.h
|
||||
include/dns/tcpmsg.h
|
||||
include/dns/time.h
|
||||
include/dns/tkey.h
|
||||
include/dns/tsig.h
|
||||
include/dns/ttl.h
|
||||
include/dns/types.h
|
||||
include/dns/validator.h
|
||||
include/dns/view.h
|
||||
include/dns/xfrin.h
|
||||
include/dns/zone.h
|
||||
include/dns/zt.h
|
||||
include/dst/dst.h
|
||||
include/dst/lib.h
|
||||
include/dst/result.h
|
||||
include/isc/app.h
|
||||
include/isc/assertions.h
|
||||
include/isc/base64.h
|
||||
include/isc/bitstring.h
|
||||
include/isc/boolean.h
|
||||
include/isc/buffer.h
|
||||
include/isc/bufferlist.h
|
||||
include/isc/commandline.h
|
||||
include/isc/condition.h
|
||||
include/isc/dir.h
|
||||
include/isc/entropy.h
|
||||
include/isc/error.h
|
||||
include/isc/event.h
|
||||
include/isc/eventclass.h
|
||||
include/isc/file.h
|
||||
include/isc/formatcheck.h
|
||||
include/isc/fsaccess.h
|
||||
include/isc/heap.h
|
||||
include/isc/hex.h
|
||||
include/isc/hmacmd5.h
|
||||
include/isc/int.h
|
||||
include/isc/interfaceiter.h
|
||||
include/isc/lang.h
|
||||
include/isc/lex.h
|
||||
include/isc/lfsr.h
|
||||
include/isc/lib.h
|
||||
include/isc/list.h
|
||||
include/isc/log.h
|
||||
include/isc/magic.h
|
||||
include/isc/md5.h
|
||||
include/isc/mem.h
|
||||
include/isc/msgcat.h
|
||||
include/isc/mutex.h
|
||||
include/isc/mutexblock.h
|
||||
include/isc/net.h
|
||||
include/isc/netaddr.h
|
||||
include/isc/netdb.h
|
||||
include/isc/offset.h
|
||||
include/isc/once.h
|
||||
include/isc/ondestroy.h
|
||||
include/isc/os.h
|
||||
include/isc/platform.h
|
||||
include/isc/print.h
|
||||
include/isc/quota.h
|
||||
include/isc/random.h
|
||||
include/isc/ratelimiter.h
|
||||
include/isc/region.h
|
||||
include/isc/resource.h
|
||||
include/isc/result.h
|
||||
include/isc/resultclass.h
|
||||
include/isc/rwlock.h
|
||||
include/isc/serial.h
|
||||
include/isc/sha1.h
|
||||
include/isc/sockaddr.h
|
||||
include/isc/socket.h
|
||||
include/isc/stdio.h
|
||||
include/isc/stdtime.h
|
||||
include/isc/string.h
|
||||
include/isc/symtab.h
|
||||
include/isc/task.h
|
||||
include/isc/taskpool.h
|
||||
include/isc/thread.h
|
||||
include/isc/time.h
|
||||
include/isc/timer.h
|
||||
include/isc/types.h
|
||||
include/isc/util.h
|
||||
include/lwres/context.h
|
||||
include/lwres/int.h
|
||||
include/lwres/ipv6.h
|
||||
include/lwres/lang.h
|
||||
include/lwres/list.h
|
||||
include/lwres/lwbuffer.h
|
||||
include/lwres/lwpacket.h
|
||||
include/lwres/lwres.h
|
||||
include/lwres/net.h
|
||||
include/lwres/netdb.h
|
||||
include/lwres/platform.h
|
||||
include/lwres/result.h
|
||||
include/omapi/compatibility.h
|
||||
include/omapi/lib.h
|
||||
include/omapi/omapi.h
|
||||
include/omapi/private.h
|
||||
include/omapi/result.h
|
||||
include/omapi/types.h
|
||||
lib/libdns.a
|
||||
lib/libdns.la
|
||||
lib/libdns.so.3.0
|
||||
lib/libisc.a
|
||||
lib/libisc.la
|
||||
lib/libisc.so.3.0
|
||||
lib/liblwres.a
|
||||
lib/liblwres.la
|
||||
lib/liblwres.so.2.0
|
||||
lib/libomapi.a
|
||||
lib/libomapi.la
|
||||
lib/libomapi.so.3.0
|
||||
sbin/dnssec-keygen
|
||||
sbin/dnssec-makekeyset
|
||||
sbin/dnssec-signkey
|
||||
sbin/dnssec-signzone
|
||||
sbin/lwresd
|
||||
sbin/named
|
||||
sbin/rndc
|
||||
share/doc/bind9/README
|
||||
share/doc/bind9/arm/Bv9ARM-book.xml
|
||||
share/doc/bind9/arm/Bv9ARM.ch01.html
|
||||
share/doc/bind9/arm/Bv9ARM.ch02.html
|
||||
share/doc/bind9/arm/Bv9ARM.ch03.html
|
||||
share/doc/bind9/arm/Bv9ARM.ch04.html
|
||||
share/doc/bind9/arm/Bv9ARM.ch05.html
|
||||
share/doc/bind9/arm/Bv9ARM.ch06.html
|
||||
share/doc/bind9/arm/Bv9ARM.ch07.html
|
||||
share/doc/bind9/arm/Bv9ARM.ch08.html
|
||||
share/doc/bind9/arm/Bv9ARM.ch09.html
|
||||
share/doc/bind9/arm/Bv9ARM.html
|
||||
share/doc/bind9/arm/README-SGML
|
||||
share/doc/bind9/arm/catalog
|
||||
share/doc/bind9/arm/catalog.in
|
||||
share/doc/bind9/arm/genhtml.sh
|
||||
share/doc/bind9/arm/genhtml.sh.in
|
||||
share/doc/bind9/arm/isc.color.gif
|
||||
share/doc/bind9/arm/nominum-docbook-html.dsl
|
||||
share/doc/bind9/arm/nominum-docbook-html.dsl.in
|
||||
share/doc/bind9/arm/validate.sh
|
||||
share/doc/bind9/arm/validate.sh.in
|
||||
share/doc/bind9/draft/draft-costanzo-dns-gl-03.txt
|
||||
share/doc/bind9/draft/draft-ietf-dhc-dhcp-dns-12.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-ad-is-secure-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-apl-rr-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-axfr-clarify-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-dhcid-rr-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-dnsmib-historical-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-dnssec-okbit-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-dnssec-roadmap-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-edns0dot5-02.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-gss-tsig-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-ixfr-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-message-size-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-rfc2782bis-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-unknown-rrs-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-dnsext-zone-status-03.txt
|
||||
share/doc/bind9/draft/draft-ietf-enum-rqmts-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-aceid-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-brace-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-cjk-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-compare-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-dnsii-mdnp-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-dnsii-mdnr-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-dnsii-trace-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-dude-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-icu-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-idna-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-idne-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-idnra-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-iptr-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-jpchar-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-lace-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-nameprep-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-race-03.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-requirements-03.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-sace-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-udns-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-utf6-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-version-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-idn-vidn-00.txt
|
||||
share/doc/bind9/draft/draft-ietf-ipngwg-default-addr-select-01.txt
|
||||
share/doc/bind9/draft/draft-ietf-ipngwg-dns-lookups-08.txt
|
||||
share/doc/bind9/draft/draft-ietf-ipngwg-prefix-rr-disc-00.txt
|
||||
share/doc/bind9/draft/draft-klensin-dns-role-00.txt
|
||||
share/doc/bind9/draft/draft-kosters-dnsext-dnssec-opt-in-00.txt
|
||||
share/doc/bind9/draft/draft-msawyer-dnsext-edns-attributes-00.txt
|
||||
share/doc/bind9/draft/draft-sawyer-dnsext-edns0-zone-option-00.txt
|
||||
share/doc/bind9/draft/draft-skwan-gss-tsig-06.txt
|
||||
share/doc/bind9/draft/draft-skwan-utf8-dns-04.txt
|
||||
share/doc/bind9/draft/draft-whr-dnsext-secure-online-update-00.txt
|
||||
share/doc/bind9/misc/dnssec
|
||||
share/doc/bind9/misc/ipv6
|
||||
share/doc/bind9/misc/migration
|
||||
share/doc/bind9/misc/options
|
||||
share/doc/bind9/misc/sdb
|
||||
share/doc/bind9/rfc/index
|
||||
share/doc/bind9/rfc/rfc1032.txt
|
||||
share/doc/bind9/rfc/rfc1033.txt
|
||||
share/doc/bind9/rfc/rfc1034.txt
|
||||
share/doc/bind9/rfc/rfc1035.txt
|
||||
share/doc/bind9/rfc/rfc1101.txt
|
||||
share/doc/bind9/rfc/rfc1122.txt
|
||||
share/doc/bind9/rfc/rfc1123.txt
|
||||
share/doc/bind9/rfc/rfc1183.txt
|
||||
share/doc/bind9/rfc/rfc1348.txt
|
||||
share/doc/bind9/rfc/rfc1535.txt
|
||||
share/doc/bind9/rfc/rfc1536.txt
|
||||
share/doc/bind9/rfc/rfc1537.txt
|
||||
share/doc/bind9/rfc/rfc1591.txt
|
||||
share/doc/bind9/rfc/rfc1611.txt
|
||||
share/doc/bind9/rfc/rfc1612.txt
|
||||
share/doc/bind9/rfc/rfc1706.txt
|
||||
share/doc/bind9/rfc/rfc1712.txt
|
||||
share/doc/bind9/rfc/rfc1750.txt
|
||||
share/doc/bind9/rfc/rfc1876.txt
|
||||
share/doc/bind9/rfc/rfc1982.txt
|
||||
share/doc/bind9/rfc/rfc1995.txt
|
||||
share/doc/bind9/rfc/rfc1996.txt
|
||||
share/doc/bind9/rfc/rfc2052.txt
|
||||
share/doc/bind9/rfc/rfc2104.txt
|
||||
share/doc/bind9/rfc/rfc2119.txt
|
||||
share/doc/bind9/rfc/rfc2133.txt
|
||||
share/doc/bind9/rfc/rfc2136.txt
|
||||
share/doc/bind9/rfc/rfc2137.txt
|
||||
share/doc/bind9/rfc/rfc2163.txt
|
||||
share/doc/bind9/rfc/rfc2168.txt
|
||||
share/doc/bind9/rfc/rfc2181.txt
|
||||
share/doc/bind9/rfc/rfc2230.txt
|
||||
share/doc/bind9/rfc/rfc2308.txt
|
||||
share/doc/bind9/rfc/rfc2373.txt
|
||||
share/doc/bind9/rfc/rfc2374.txt
|
||||
share/doc/bind9/rfc/rfc2375.txt
|
||||
share/doc/bind9/rfc/rfc2418.txt
|
||||
share/doc/bind9/rfc/rfc2535.txt
|
||||
share/doc/bind9/rfc/rfc2536.txt
|
||||
share/doc/bind9/rfc/rfc2537.txt
|
||||
share/doc/bind9/rfc/rfc2538.txt
|
||||
share/doc/bind9/rfc/rfc2539.txt
|
||||
share/doc/bind9/rfc/rfc2540.txt
|
||||
share/doc/bind9/rfc/rfc2541.txt
|
||||
share/doc/bind9/rfc/rfc2553.txt
|
||||
share/doc/bind9/rfc/rfc2671.txt
|
||||
share/doc/bind9/rfc/rfc2672.txt
|
||||
share/doc/bind9/rfc/rfc2673.txt
|
||||
share/doc/bind9/rfc/rfc2782.txt
|
||||
share/doc/bind9/rfc/rfc2845.txt
|
||||
share/doc/bind9/rfc/rfc2874.txt
|
||||
share/doc/bind9/rfc/rfc2929.txt
|
||||
share/doc/bind9/rfc/rfc2930.txt
|
||||
share/doc/bind9/rfc/rfc2931.txt
|
||||
share/doc/bind9/rfc/rfc3007.txt
|
||||
share/doc/bind9/rfc/rfc3008.txt
|
||||
share/doc/bind9/rfc/rfc952.txt
|
||||
@dirrm share/doc/bind9/rfc
|
||||
@dirrm share/doc/bind9/misc
|
||||
@dirrm share/doc/bind9/draft
|
||||
@dirrm share/doc/bind9/arm
|
||||
@dirrm share/doc/bind9
|
||||
@dirrm include/omapi
|
||||
@dirrm include/lwres
|
||||
@dirrm include/isc
|
||||
@dirrm include/dst
|
||||
@dirrm include/dns
|
||||
man/man8/lwresd.8
|
||||
man/man8/named.8
|
||||
man/man8/nsupdate.8
|
||||
man/man8/rndc.8
|
||||
man/man5/rndc.conf.5
|
||||
man/man8/dnssec-keygen.8
|
||||
man/man8/dnssec-makekeyset.8
|
||||
man/man8/dnssec-signkey.8
|
||||
man/man8/dnssec-signzone.8
|
||||
|
Loading…
Reference in a new issue