Move 9term from plan9 to x11.

This commit is contained in:
wiz 2000-12-14 01:01:32 +00:00
parent da0d9795c2
commit 414b26b55d
11 changed files with 2 additions and 429 deletions

View file

@ -1,24 +0,0 @@
# $NetBSD: Makefile,v 1.23 2000/08/25 02:33:44 hubertf Exp $
# FreeBSD Id: Makefile,v 1.5 1996/12/07 23:43:56 asami Exp
#
DISTNAME= 9term.1.6.3
PKGNAME= 9term-1.6.3
CATEGORIES= plan9
MASTER_SITES= ftp://ftp.ecf.toronto.edu/pub/plan9/matty/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.psrg.cs.usyd.edu.au/~matty/9term/index.html
# needs library and private header, but not during runtime
BUILD_DEPENDS= ${BUILD_ROOT}/editors/sam/${WRKDIR:T}/libframe/libframe.a:../../editors/sam:all
USE_X11= yes
NOT_FOR_PLATFORM= *-*-alpha #LP64 Problems
MANCOMPRESSED= yes
NO_WRKSUBDIR= yes
MAKE_ENV+= WRKDIR=${WRKDIR} PKGSRCDIR=${PKGSRCDIR}
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
$NetBSD: md5,v 1.2 1998/08/07 13:27:33 agc Exp $
MD5 (9term.1.6.3.tar.gz) = 064a4428aba417a7793d3252423faf0b

View file

@ -1,6 +0,0 @@
$NetBSD: patch-sum,v 1.3 2000/07/27 10:13:44 wiz Exp $
MD5 (patch-aa) = dd38f07ba471685c69b82062eff52809
MD5 (patch-ab) = 6524e60ec78013b00a8413912b7a2606
MD5 (patch-ac) = 8c1298bd326c2f5bf515ba937cf5e5fa
MD5 (patch-ad) = 87131649cf6866f45396405dc9c9d1e7

View file

@ -1,29 +0,0 @@
$NetBSD: patch-aa,v 1.6 2000/07/20 11:12:07 agc Exp $
--- libtext/Makefile.orig Thu Jun 2 03:01:19 1994
+++ libtext/Makefile Fri Sep 26 16:44:27 1997
@@ -5,14 +5,15 @@
#
# Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
# if your compiler supports posix-compatible compilation
-OS=-DSOLARIS
+OS=-DSUNOS -O2
+SAMDIR=${PKGSRCDIR}/editors/sam/${WRKDIR:T}
# add -Iincludedir for any include directories that need to be searched
# for posix header files
-INCS=-I. -I../include
+INCS=-I. -I$(SAMDIR)/include
# add name of library orderer - use ":" if none exists
-RANLIB=:
+RANLIB=ranlib
# add name of library
AR=ar
@@ -38,4 +39,4 @@
install: $(LIB)
-$(OBJ): ../include/u.h ../include/libc.h ../include/libg.h ../include/frame.h ../include/text.h
+$(OBJ): $(SAMDIR)/include/u.h $(SAMDIR)/include/libc.h $(SAMDIR)/include/libg.h $(SAMDIR)/include/frame.h text.h

View file

@ -1,281 +0,0 @@
$NetBSD: patch-ab,v 1.7 2000/07/20 11:12:07 agc Exp $
--- 9term/9term.c.orig Fri Jun 3 09:35:39 1994
+++ 9term/9term.c Fri Sep 26 16:45:48 1997
@@ -10,7 +10,13 @@
#include <frame.h>
#include <text.h>
+#include <sys/param.h>
+
+#if (defined(BSD) && BSD >= 199306)
+#include <sys/termios.h>
+#else
#include <sys/termio.h>
+#endif
#include <signal.h>
#include <sys/stat.h>
@@ -153,9 +159,9 @@
}
}
- setenv("TERM", "9term", 1);
+ O_setenv("TERM", "9term", 1);
/* Cope with BSD-oid systems. - cks */
- setenv("TERMCAP", "9term: :am:bl=^G:do=^J:nl=^J:", 1);
+ O_setenv("TERMCAP", "9term: :am:bl=^G:do=^J:nl=^J:", 1);
signal(SIGINT, SIG_IGN);
init_display(&argc, argv, cmd, resource);
@@ -718,7 +724,7 @@
texthighlight(t, t->length, t->length, F&~D);
#ifdef REMOTE
flushstream();
- killpg(r == quitchar ? SIGQUIT : SIGINT);
+ O_killpg(r == quitchar ? SIGQUIT : SIGINT);
#else
sendrunes(&r, 1);
#endif
@@ -804,7 +810,7 @@
* export a name-value pair to environment
*/
int
-setenv(char *name, char *value, int overwrite)
+O_setenv(char *name, char *value, int overwrite)
{
char *p;
--- 9term/9term.h.orig Thu Dec 15 14:49:15 1994
+++ 9term/9term.h Wed Oct 1 09:50:47 1997
@@ -31,7 +31,7 @@
extern int isig;
extern void specialchars(int);
-extern int setenv(char *, char *, int);
+extern int O_setenv(char *, char *, int);
extern void init_display(int *, char **, char**, char*);
#ifdef NEEDVARARG
extern void error();
@@ -58,13 +58,24 @@
extern void setborder(void);
extern void ctlmsg(Event *);
+#ifndef MAX
#define MAX(x, y) (((x) > (y)) ? (x) : (y))
+#endif
+#ifndef MIN
#define MIN(x, y) (((x) < (y)) ? (x) : (y))
+#endif
#ifndef NULL
#define NULL ((void *)0)
#endif
#ifdef SUNOS
+#define POSIXPTYS
+#define BSDPTYS
+#endif
+
+#include <sys/param.h>
+
+#if (defined(BSD) && BSD >= 199306)
#define POSIXPTYS
#define BSDPTYS
#endif
--- 9term/Makefile.orig Mon Mar 14 04:50:54 1994
+++ 9term/Makefile Fri Sep 26 16:44:27 1997
@@ -11,27 +11,29 @@
# Define RISCOS for Mips RISC/os
# Define BSDPTYS for BSD-style pty support
# Define POSIXPTYS for POSIX ptys
-OS=-DSOLARIS
-# where we'll install it
-BINDIR=/usr/pgrad/matty/bin/$(cputype)
+OS= -D_LIBXG_EXTENSION -DSUNOS
+
+SAMPATH=${PKGSRCDIR}/editors/sam/${WRKDIR:T}
+
+BINDIR=. # where we'll install it
HEADERFILE=9term.h
TARGET=9term
-INCLUDES=-I. -I../include -I/usr/openwin/include
-CFLAGS=-g $(OS) $(INCLUDES) -fno-builtin -D_LIBXG_EXTENSION
-LDFLAGS=-g -R/usr/openwin/lib -L/usr/openwin/lib -R/usr/ucblib -L/usr/ucblib
+INCLUDES=-I. -I../libtext -I$(SAMPATH)/include -I/usr/X11R6/include
+CFLAGS= -O2 $(OS) $(INCLUDES)
+LDFLAGS?=
CC=gcc
# change this if your X11 libraries are in different places
# or if you need extra libraries to load with X11 applications
-LIBS=../libtext/libtext.a ../libframe/libframe.a ../libXg/libXg.a
-XLIBS=-lXt -lX11
+LIBS=../libtext/libtext.a $(SAMPATH)/libframe/libframe.a $(SAMPATH)/libXg/libXg.a
+XLIBS= -L/usr/X11R6/lib -lXt -lX11
OBJECTS=9term.o command.o display.o pty.o
$(TARGET): $(OBJECTS)
- $(CC) $(LDFLAGS) -o $(TARGET) $(OBJECTS) $(LIBS) $(XLIBS) -lm -lucb
+ $(CC) $(LDFLAGS) -o $(TARGET) $(OBJECTS) $(LIBS) $(XLIBS) -lm
wloc: wloc.o
$(CC) $(LDFLAGS) -o wloc wloc.o $(LIBS) $(XLIBS) -lm
@@ -39,21 +41,17 @@
label: wloc
ln wloc label
-unicode: unicode.o
- $(CC) $(LDFLAGS) -o unicode unicode.o $(LIBS) $(XLIBS) -lm
-
install: $(TARGET) wloc label
cp $(TARGET) $(BINDIR)
chown root $(BINDIR)/$(TARGET)
chmod 04755 $(BINDIR)/$(TARGET)
mv wloc $(BINDIR)
mv label $(BINDIR)
- mv unicode $(BINDIR)
clean:
rm -f *.o core
nuke: clean
- rm -f $(TARGET) wloc label unicode
+ rm -f $(TARGET) wloc label
$(OBJECTS): 9term.h
--- 9term/command.c.orig Mon Mar 7 01:50:51 1994
+++ 9term/command.c Fri Sep 26 16:46:53 1997
@@ -13,7 +13,12 @@
#include <sys/wait.h>
#include <signal.h>
#include <grp.h>
+#include <sys/param.h>
+#if (defined(BSD) && BSD >= 199306)
+#include <termios.h>
+#else
#include <termio.h>
+#endif
#ifdef SOLARIS
#include <sys/stropts.h>
#endif
@@ -204,7 +209,7 @@
*/
void
-killpg(int sig)
+O_killpg(int sig)
{
if (comm_pid)
kill(-comm_pid, sig);
--- 9term/display.c.orig Thu Dec 15 14:48:28 1994
+++ 9term/display.c Fri Sep 26 16:44:28 1997
@@ -114,7 +114,7 @@
delwin(Widget w, XEvent *event, String *params, Cardinal *n)
{
if (w == _toplevel)
- killpg(SIGHUP);
+ O_killpg(SIGHUP);
}
/*
@@ -185,7 +185,7 @@
else if (!strcasecmp(s, "plan9"))
kbdmode = PLAN9;
if (s = get_resource(resource, class, "p9font", "P9font"))
- setenv("font", s, 1);
+ O_setenv("font", s, 1);
if (s = get_resource(resource, class, "highwater", "Highwater"))
highwater = atoi(s);
if (s = get_resource(resource, class, "lowwater", "Lowwater"))
@@ -230,7 +230,7 @@
#endif
/* export window id to environment */
sprintf(id, "%d", XtWindow(_toplevel));
- setenv("WINDOWID", id, 1);
+ O_setenv("WINDOWID", id, 1);
/* register mouse and keyboard events */
einit(Ekeyboard | Emouse);
--- 9term/pty.c.orig Fri Jul 22 16:47:29 1994
+++ 9term/pty.c Fri Sep 26 16:49:08 1997
@@ -12,7 +12,18 @@
#include <utmp.h>
#include <errno.h>
-#ifdef SUNOS
+
+#include <sys/param.h>
+
+#if (defined(BSD) && BSD >= 199306)
+# include <termios.h>
+
+/* # include <stropts.h> */
+ /* Isn't POSIX and portability so much fun? */
+# define VRPRNT VREPRINT
+#endif
+
+#if defined(SUNOS) && !(defined(BSD) && BSD >= 199306)
# undef _POSIX_SOURCE
# include <sys/termio.h>
# include <stropts.h>
@@ -41,7 +52,7 @@
# define VEOL2 _VEOL2
#endif
-#ifdef RISCOS
+#ifdef RISCOS
# include <sys/stat.h>
# include </usr/include/ctype.h> /* to defeat posix version */
# define VLNEXT V_LNEXT
@@ -49,10 +60,12 @@
# define VRPRNT V_RPRNT
# define VWERASE V_WERAS
#else
+#if !(defined(BSD) && BSD >= 199306)
# include <ctype.h>
#endif
+#endif
-#ifdef OSF1
+#if defined(OSF1)
# define V_START VSTART
# define V_STOP VSTOP
# define V_SUSP VSUSP
@@ -115,7 +128,7 @@
char udef, p9def;
};
-#if defined(SUNOS) || defined(IRIX) || defined(SOLARIS)
+#if defined(SUNOS) || defined(IRIX) || defined(SOLARIS) || (defined(BSD) && BSD >= 199306)
# define V_START VSTART
# define V_STOP VSTOP
# define V_SUSP VSUSP
@@ -139,7 +152,7 @@
#ifndef _POSIX_SOURCE
{ "eol2", 4, VEOL2, 0, 0 },
#endif
-#if !defined(_OSF_SOURCE) && !defined(_POSIX_SOURCE)
+#if !defined(_OSF_SOURCE) && !defined(_POSIX_SOURCE) && !(defined(BSD) && BSD >= 199306)
{ "swtch", 5, VSWTCH, 0, 0 },
#endif
{ "start", 5, V_START, ctrl('q'), ctrl('q') },
@@ -292,10 +305,16 @@
/* Insure some sanity. */
ttmode.c_lflag |= ECHO;
ttmode.c_oflag &= ~(ONLCR);
+#if !(defined(BSD) && BSD >= 199306)
ttmode.c_oflag |= ONLRET;
+#endif
} else {
ttmode.c_iflag = BRKINT | IGNPAR | ICRNL | IXON;
+#if (defined(BSD) && BSD >= 199306)
+ ttmode.c_oflag = OPOST;
+#else
ttmode.c_oflag = OPOST | ONLRET;
+#endif
ttmode.c_cflag = B9600 | PARENB | CS8 | CREAD;
ttmode.c_lflag = ISIG | ICANON | ECHO | ECHOK;
#ifdef __ultrix

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ac,v 1.3 1998/08/07 11:11:15 agc Exp $
--- /dev/null Fri Sep 26 16:38:09 1997
+++ Makefile Fri Sep 26 16:44:28 1997
@@ -0,0 +1,10 @@
+
+MAN=man
+all:
+ (cd libtext; make)
+ (cd 9term; make)
+install:
+ $(INSTALL) -c 9term/9term $(PREFIX)/bin/
+ $(INSTALL) -c 9term/9term.1 $(PREFIX)/$(MAN)/man1/
+ strip $(PREFIX)/bin/9term
+ gzip -9nf $(PREFIX)/man/man1/9term.1

View file

@ -1,56 +0,0 @@
$NetBSD: patch-ad,v 1.2 1998/08/07 11:11:15 agc Exp $
--- libtext/scroll.c.orig Fri Nov 19 08:14:25 1993
+++ libtext/scroll.c Wed Oct 29 10:33:41 1997
@@ -6,7 +6,9 @@
static Bitmap *_dkgrey;
+#ifndef MAX
#define MAX(x, y) ((x) > (y) ? (x) : (y))
+#endif
static
Rectangle
Return-Path: <sam-fans-owner@hawkwind.utcs.toronto.edu>
Received: by juno.ccc.amdahl.com (/\==/\ Smail #25.1)
id <m0xQKVA-0000M6C@juno.ccc.amdahl.com>; Tue, 28 Oct 97 14:52 PST
Received: from orpheus.amdahl.com by minerva.amdahl.com with smtp
(Smail3.1.29.1 #5) id m0xQKT5-0000oPC; Tue, 28 Oct 97 14:50 PST
Received: from hawkwind.utcs.utoronto.ca by orpheus.amdahl.com with smtp
(Smail3.1.29.1 #3) id m0xQKU5-0001EkC; Tue, 28 Oct 97 14:51 PST
Received: from finch.cse.psu.edu ([130.203.12.29]) by hawkwind.utcs.utoronto.ca with SMTP id <24684>; Tue, 28 Oct 1997 17:43:51 -0500
Received: (qmail 21504 invoked by uid 991); 28 Oct 1997 06:32:35 -0000
Message-ID: <19971028063235.21502.qmail@finch.cse.psu.edu>
To: sam-fans@hawkwind.utcs.toronto.edu
Subject: 9term bug
Date: Tue, 28 Oct 1997 01:32:35 -0500
From: Scott Schwartz <schwartz@finch.cse.psu.edu>
Hi all,
I don't recall if this has been reported or not, but libtext from fails
to initialize everything in a newly allocated Text. (bcheck is your
friend.)
--- libtext/text.c.orig Thu Dec 15 15:01:45 1994
+++ libtext/text.c Wed Oct 29 10:32:55 1997
@@ -4,7 +4,10 @@
#include <frame.h>
#include <text.h>
+#ifndef MAX
#define MAX(x, y) ((x > y) ? x : y)
+#endif
+
#define BUTTON(n) (1<<(n-1))
static Menu edit;
@@ -47,6 +50,7 @@
berror("textalloc: calloc");
t->length = 0;
t->base = 0;
+ t->end = 0;
t->p0 = 0;
t->p1 = 0;
t->pout = 0;

View file

@ -1 +0,0 @@
X11 program which emulates a plan9 window

View file

@ -1,10 +0,0 @@
9term is a terminal emulator which emulates an 8 1/2 window.
this version supports unicode. To see this support, cat one of
the utf files in an 8 1/2 window. Your Xserver must be able to
find the required fonts, and the `*p9font' x-resource must be
set to point to the fonts, maybe `/usr/X11R6/lib/X11/fonts/Xg/unicode.9.font'.
This port needs work, it is functional enough to get the feel
for 9term, but some of the features don't work with FreeBSD.
eric.

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 1997/11/06 10:03:51 agc Exp $
bin/9term
man/man1/9term.1.gz

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.192 2000/12/13 17:42:19 jlam Exp $
# $NetBSD: Makefile,v 1.193 2000/12/14 01:01:32 wiz Exp $
#
SUBDIR += 9term
SUBDIR += XF86Setup
SUBDIR += Xaw-Xpm
SUBDIR += Xaw3d