Add DragonFly support.
This commit is contained in:
parent
b8b72ab276
commit
41a06bf703
7 changed files with 151 additions and 16 deletions
|
@ -1,11 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.35 2005/12/11 11:45:44 markd Exp $
|
||||
$NetBSD: distinfo,v 1.36 2006/01/05 20:25:16 joerg Exp $
|
||||
|
||||
SHA1 (kdeutils-3.5.0.tar.bz2) = 194d20c78d61b41dda6c3a6f55f0e10b4718d0a8
|
||||
RMD160 (kdeutils-3.5.0.tar.bz2) = 0638cc14a1db465a05eaf915da62d1993a44f461
|
||||
Size (kdeutils-3.5.0.tar.bz2) = 2958132 bytes
|
||||
SHA1 (patch-aa) = 0e9c35666640bdd17b22c03fb06ad6c3eed3a382
|
||||
SHA1 (patch-ab) = c85392afdb34c52d309940d7a485d4d2b7b6faaf
|
||||
SHA1 (patch-ac) = 9b31039b0e3cc05dc4fb288ee8f66ebf3e440f6e
|
||||
SHA1 (patch-ad) = ad4fcdda6f9fc1b91e1f125421800e412e2ee0aa
|
||||
SHA1 (patch-ad) = 3504496bf4b0957e74ae999f16bc03ed3499371d
|
||||
SHA1 (patch-ae) = b4067b7e23253d51ed5d0bf545ee7044943a1721
|
||||
SHA1 (patch-an) = e13957a9fa0d23aebbe149ecaca7b9dacde5c9fb
|
||||
SHA1 (patch-ao) = b05b590635c258edc4db37851ac1635b5d9c9d39
|
||||
SHA1 (patch-ap) = 5058d3777d03f0ba18047592849c28bd318019ab
|
||||
SHA1 (patch-ao) = 06b87e5e2ad5c20f14a993949bc57c3a64225e56
|
||||
SHA1 (patch-ap) = 7f8a89156f6d419ca708bf5e55a57d30e5f94756
|
||||
SHA1 (patch-aq) = a76ff5042c3dec821026f512f6e83f5a3eaa3d91
|
||||
|
|
28
misc/kdeutils3/patches/patch-aa
Normal file
28
misc/kdeutils3/patches/patch-aa
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-aa,v 1.7 2006/01/05 20:25:16 joerg Exp $
|
||||
|
||||
--- ksim/monitors/disk/ksimdisk.cpp.orig 2005-11-16 20:47:00.000000000 +0000
|
||||
+++ ksim/monitors/disk/ksimdisk.cpp
|
||||
@@ -41,7 +41,13 @@
|
||||
#include <progress.h>
|
||||
#include <themetypes.h>
|
||||
|
||||
-#ifdef Q_OS_FREEBSD
|
||||
+#if defined(__DragonFly__)
|
||||
+#include <sys/time.h>
|
||||
+#include <sys/param.h>
|
||||
+#include <sys/resource.h>
|
||||
+#include <devstat.h>
|
||||
+#include <stdlib.h>
|
||||
+#elif defined(Q_OS_FREEBSD)
|
||||
#include <sys/param.h>
|
||||
#if __FreeBSD_version < 500101
|
||||
#include <sys/dkstat.h>
|
||||
@@ -343,7 +349,7 @@ void DiskView::updateData(DiskList &disk
|
||||
#endif
|
||||
|
||||
#ifdef Q_OS_FREEBSD
|
||||
-#if __FreeBSD_version < 500107
|
||||
+#if defined(__DragonFly__) || __FreeBSD_version < 500107
|
||||
#define devstat_getdevs(fd, stats) getdevs(stats)
|
||||
#define devstat_selectdevs selectdevs
|
||||
#define bytes_read(dev) (dev).bytes_read
|
13
misc/kdeutils3/patches/patch-ab
Normal file
13
misc/kdeutils3/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.11 2006/01/05 20:25:16 joerg Exp $
|
||||
|
||||
--- superkaramba/src/misc_python.cpp.orig 2005-12-29 17:08:09.000000000 +0000
|
||||
+++ superkaramba/src/misc_python.cpp
|
||||
@@ -425,7 +425,7 @@ PyObject* py_hide(PyObject *, PyObject *
|
||||
#include <sys/ioctl.h>
|
||||
#include <net/if.h>
|
||||
#include <arpa/inet.h>
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) || defined(__DragonFly__)
|
||||
#include <netinet/in.h>
|
||||
#endif
|
||||
#if defined(Q_OS_SOLARIS)
|
|
@ -1,10 +1,22 @@
|
|||
$NetBSD: patch-ad,v 1.3 2004/05/04 13:52:11 mrg Exp $
|
||||
$NetBSD: patch-ad,v 1.4 2006/01/05 20:25:16 joerg Exp $
|
||||
|
||||
--- ksim/monitors/filesystem/filesystemstats.cpp.orig 2003-06-27 23:39:05.000000000 +1000
|
||||
+++ ksim/monitors/filesystem/filesystemstats.cpp 2004-05-04 23:31:40.000000000 +1000
|
||||
@@ -58,8 +58,10 @@
|
||||
--- ksim/monitors/filesystem/filesystemstats.cpp.orig 2005-10-05 13:26:44.000000000 +0000
|
||||
+++ ksim/monitors/filesystem/filesystemstats.cpp
|
||||
@@ -30,7 +30,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/param.h>
|
||||
|
||||
#ifdef HAVE_STATVFS
|
||||
-#ifdef HAVE_SYS_STATVFS_H
|
||||
+#if defined(HAVE_SYS_STATVFS_H) && !defined(__DragonFly__)
|
||||
#include <sys/statvfs.h>
|
||||
#elif defined( HAVE_SYS_STATFS_H )
|
||||
#include <sys/statfs.h>
|
||||
@@ -56,10 +56,12 @@
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-#ifdef HAVE_STATVFS
|
||||
+#if defined(HAVE_STATVFS) && !defined(__DragonFly__)
|
||||
typedef struct statvfs ksim_statfs;
|
||||
+#define ksim_getfsstat getvfsstat
|
||||
#elif defined( HAVE_STATFS ) || defined( Q_OS_FREEBSD )
|
||||
|
@ -13,7 +25,16 @@ $NetBSD: patch-ad,v 1.3 2004/05/04 13:52:11 mrg Exp $
|
|||
#else
|
||||
typedef struct // fall back for (possibly) non-supported systems
|
||||
{
|
||||
@@ -159,9 +161,9 @@
|
||||
@@ -70,7 +72,7 @@ typedef struct // fall back for (possibl
|
||||
|
||||
int fsystemStats( const char * file, ksim_statfs & stats )
|
||||
{
|
||||
-#ifdef HAVE_STATVFS
|
||||
+#if defined(HAVE_STATVFS) && !defined(__DragonFly__)
|
||||
return statvfs( file, &stats );
|
||||
#elif defined( HAVE_STATFS ) || defined( Q_OS_FREEBSD )
|
||||
return statfs( file, &stats );
|
||||
@@ -159,9 +161,9 @@ FilesystemStats::List FilesystemStats::r
|
||||
#endif
|
||||
|
||||
#ifdef USE_FSSTAT
|
||||
|
|
13
misc/kdeutils3/patches/patch-ae
Normal file
13
misc/kdeutils3/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.3 2006/01/05 20:25:16 joerg Exp $
|
||||
|
||||
--- superkaramba/src/Makefile.in.orig 2005-12-29 17:14:39.000000000 +0000
|
||||
+++ superkaramba/src/Makefile.in
|
||||
@@ -518,7 +518,7 @@ superkaramba_SOURCES=main.cpp karamba.cp
|
||||
# kde_cfg_DATA = superkaramba.kcfg
|
||||
superkaramba_LDFLAGS = -Wl,-export-dynamic $(KDE_RPATH) $(all_libraries) $(PYTHONLIB) $(XMMS_LDFLAGS)
|
||||
#superkaramba_LDADD = -lkio $(LIB_KDEUI) $(XMMS_LDADD) $(LIBPYTHON) $(LIBKVM) $(MY_LIBKNEWSTUFF)
|
||||
-superkaramba_LDADD = -lkio $(LIB_KDEUI) $(XMMS_LIBS) $(LIBPYTHON) $(LIBKVM) $(MY_LIBKNEWSTUFF)
|
||||
+superkaramba_LDADD = -lkio -lknewstuff $(LIB_KDEUI) $(XMMS_LIBS) $(LIBPYTHON) $(LIBKVM) $(MY_LIBKNEWSTUFF)
|
||||
|
||||
# this is where the desktop file will go
|
||||
shelldesktopdir = $(kde_appsdir)/Utilities
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ao,v 1.11 2005/12/11 11:45:44 markd Exp $
|
||||
$NetBSD: patch-ao,v 1.12 2006/01/05 20:25:16 joerg Exp $
|
||||
|
||||
--- configure.orig 2004-04-06 02:55:31.000000000 +1200
|
||||
--- configure.orig 2005-11-26 07:19:12.000000000 +0000
|
||||
+++ configure
|
||||
@@ -32333,6 +32267,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
@@ -34076,6 +34076,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
|
||||
|
||||
|
@ -10,3 +10,28 @@ $NetBSD: patch-ao,v 1.11 2005/12/11 11:45:44 markd Exp $
|
|||
#include <sys/mount.h>
|
||||
|
||||
|
||||
@@ -34785,19 +34786,18 @@ cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
|
||||
+#include <math.h>
|
||||
+
|
||||
/* Override any gcc2 internal prototype to avoid an error. */
|
||||
#ifdef __cplusplus
|
||||
extern "C"
|
||||
#endif
|
||||
-/* We use char because int might match the return type of a gcc2
|
||||
- builtin and then its argument prototype would still apply. */
|
||||
-char isinf ();
|
||||
+
|
||||
+double d = 0.0;
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-isinf ();
|
||||
- ;
|
||||
- return 0;
|
||||
+ return isinf (d);
|
||||
}
|
||||
_ACEOF
|
||||
rm -f conftest.$ac_objext conftest$ac_exeext
|
||||
|
|
|
@ -1,8 +1,40 @@
|
|||
$NetBSD: patch-ap,v 1.3 2004/08/21 14:15:55 markd Exp $
|
||||
$NetBSD: patch-ap,v 1.4 2006/01/05 20:25:16 joerg Exp $
|
||||
|
||||
--- ksim/monitors/cpu/ksimcpu.cpp.orig 2004-07-18 07:13:06.000000000 +1200
|
||||
--- ksim/monitors/cpu/ksimcpu.cpp.orig 2005-10-05 13:26:45.000000000 +0000
|
||||
+++ ksim/monitors/cpu/ksimcpu.cpp
|
||||
@@ -264,6 +264,9 @@ void CpuView::updateCpu(CpuData &cpu, in
|
||||
@@ -44,7 +44,13 @@
|
||||
|
||||
#ifdef Q_OS_BSD4
|
||||
#include <sys/param.h>
|
||||
-#ifdef Q_OS_FREEBSD
|
||||
+#if defined(__DragonFly__)
|
||||
+#include <kinfo.h>
|
||||
+#include <err.h>
|
||||
+#include <sys/time.h>
|
||||
+#include <sys/resource.h>
|
||||
+
|
||||
+#elif defined Q_OS_FREEBSD
|
||||
#if __FreeBSD_version < 500101
|
||||
#include <sys/dkstat.h>
|
||||
#else
|
||||
@@ -235,7 +241,15 @@ void CpuView::updateCpu(CpuData &cpu, in
|
||||
fseek(m_procFile, 0L, SEEK_SET);
|
||||
#endif
|
||||
|
||||
-#ifdef Q_OS_FREEBSD
|
||||
+#ifdef __DragonFly__
|
||||
+ struct kinfo_cputime cp_time;
|
||||
+ if (kinfo_get_sched_cputime(&cp_time))
|
||||
+ err(1, "kinfo_get_sched_cputime");
|
||||
+ cpu.user = cp_time.cp_user;
|
||||
+ cpu.nice = cp_time.cp_nice;
|
||||
+ cpu.sys = cp_time.cp_sys;
|
||||
+ cpu.idle = cp_time.cp_idle;
|
||||
+#elif defined(Q_OS_FREEBSD)
|
||||
#warning "add support for SMP on FreeBSD"
|
||||
Q_UNUSED(cpuNumber);
|
||||
static int name2oid[2] = { 0, 3 };
|
||||
@@ -265,6 +279,9 @@ void CpuView::updateCpu(CpuData &cpu, in
|
||||
cpu.idle = cpuTime[CP_IDLE];
|
||||
#endif
|
||||
|
||||
|
|
Loading…
Reference in a new issue