Initial import of gnustep-make-1.5.0, a set of makefiles and templates for

GNUstep development.
This commit is contained in:
rh 2002-09-27 10:40:16 +00:00
parent 0cbef82639
commit 41b8141a5f
6 changed files with 323 additions and 0 deletions

5
devel/gnustep-make/DESCR Normal file
View file

@ -0,0 +1,5 @@
The GNUstep makefile package is a simple, powerful and extensible
way to write makefiles for a GNUstep-based project. It allows the
user to write a project without having to deal with the complex issues
associated with configuration, building, installation, and packaging.
It also allows the user to easily create cross-compiled binaries.

View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/09/27 10:40:16 rh Exp $
#
DISTNAME= gnustep-make-1.5.0
CATEGORIES= devel
MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/core/
MAINTAINER= rh@netbsd.org
HOMEPAGE= http://www.gnustep.org/
COMMENT= GNUstep makefile package
USE_GMAKE= YES
MAKEFILE= GNUmakefile
GNU_CONFIGURE= YES
GNU_CONFIGURE_PREFIX= ${PREFIX}/share/GNUstep
CONFIGURE_ENV+= INSTALL_PROGRAM="${INSTALL_SCRIPT}"
PLIST_SUBST+= GNUSTEP_HOST_CPU=${MACHINE_GNU_ARCH:S/i386/ix86/}
PLIST_SUBST+= APPEND_ELF=${APPEND_ELF}
.include "../../mk/bsd.pkg.mk"

210
devel/gnustep-make/PLIST Normal file
View file

@ -0,0 +1,210 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/09/27 10:40:16 rh Exp $
share/GNUstep/System/Makefiles/GNUstep-reset.sh
share/GNUstep/System/Makefiles/GNUstep.csh
share/GNUstep/System/Makefiles/GNUstep.sh
share/GNUstep/System/Makefiles/Instance/Shared/bundle.make
share/GNUstep/System/Makefiles/Instance/Shared/headers.make
share/GNUstep/System/Makefiles/Instance/Shared/java.make
share/GNUstep/System/Makefiles/Instance/application.make
share/GNUstep/System/Makefiles/Instance/bundle.make
share/GNUstep/System/Makefiles/Instance/clibrary.make
share/GNUstep/System/Makefiles/Instance/ctool.make
share/GNUstep/System/Makefiles/Instance/documentation.make
share/GNUstep/System/Makefiles/Instance/framework.make
share/GNUstep/System/Makefiles/Instance/gswapp.make
share/GNUstep/System/Makefiles/Instance/gswbundle.make
share/GNUstep/System/Makefiles/Instance/java-tool.make
share/GNUstep/System/Makefiles/Instance/java.make
share/GNUstep/System/Makefiles/Instance/library.make
share/GNUstep/System/Makefiles/Instance/objc.make
share/GNUstep/System/Makefiles/Instance/palette.make
share/GNUstep/System/Makefiles/Instance/resource-set.make
share/GNUstep/System/Makefiles/Instance/rules.make
share/GNUstep/System/Makefiles/Instance/service.make
share/GNUstep/System/Makefiles/Instance/subproject.make
share/GNUstep/System/Makefiles/Instance/test-application.make
share/GNUstep/System/Makefiles/Instance/test-library.make
share/GNUstep/System/Makefiles/Instance/test-tool.make
share/GNUstep/System/Makefiles/Instance/tool.make
share/GNUstep/System/Makefiles/Master/aggregate.make
share/GNUstep/System/Makefiles/Master/application.make
share/GNUstep/System/Makefiles/Master/bundle.make
share/GNUstep/System/Makefiles/Master/clibrary.make
share/GNUstep/System/Makefiles/Master/ctool.make
share/GNUstep/System/Makefiles/Master/documentation.make
share/GNUstep/System/Makefiles/Master/framework.make
share/GNUstep/System/Makefiles/Master/gswapp.make
share/GNUstep/System/Makefiles/Master/gswbundle.make
share/GNUstep/System/Makefiles/Master/java-tool.make
share/GNUstep/System/Makefiles/Master/java.make
share/GNUstep/System/Makefiles/Master/library.make
share/GNUstep/System/Makefiles/Master/objc.make
share/GNUstep/System/Makefiles/Master/palette.make
share/GNUstep/System/Makefiles/Master/resource-set.make
share/GNUstep/System/Makefiles/Master/rpm.make
share/GNUstep/System/Makefiles/Master/rules.make
share/GNUstep/System/Makefiles/Master/service.make
share/GNUstep/System/Makefiles/Master/source-distribution.make
share/GNUstep/System/Makefiles/Master/subproject.make
share/GNUstep/System/Makefiles/Master/test-application.make
share/GNUstep/System/Makefiles/Master/test-library.make
share/GNUstep/System/Makefiles/Master/test-tool.make
share/GNUstep/System/Makefiles/Master/tool.make
share/GNUstep/System/Makefiles/aggregate.make
share/GNUstep/System/Makefiles/application.make
share/GNUstep/System/Makefiles/bundle.make
share/GNUstep/System/Makefiles/clean_cpu.sh
share/GNUstep/System/Makefiles/clean_os.sh
share/GNUstep/System/Makefiles/clean_vendor.sh
share/GNUstep/System/Makefiles/clibrary.make
share/GNUstep/System/Makefiles/common.make
share/GNUstep/System/Makefiles/config.guess
share/GNUstep/System/Makefiles/config.sub
share/GNUstep/System/Makefiles/cpu.sh
share/GNUstep/System/Makefiles/ctool.make
share/GNUstep/System/Makefiles/documentation.make
share/GNUstep/System/Makefiles/executable.template
share/GNUstep/System/Makefiles/fixpath.sh
share/GNUstep/System/Makefiles/framework.make
share/GNUstep/System/Makefiles/gswapp.make
share/GNUstep/System/Makefiles/gswbundle.make
share/GNUstep/System/Makefiles/install-sh
share/GNUstep/System/Makefiles/${GNUSTEP_HOST_CPU}/${LOWER_OPSYS}${APPEND_ELF}/config.make
share/GNUstep/System/Makefiles/${GNUSTEP_HOST_CPU}/${LOWER_OPSYS}${APPEND_ELF}/user_home
share/GNUstep/System/Makefiles/${GNUSTEP_HOST_CPU}/${LOWER_OPSYS}${APPEND_ELF}/which_lib
share/GNUstep/System/Makefiles/java-executable.template
share/GNUstep/System/Makefiles/java-tool.make
share/GNUstep/System/Makefiles/java.make
share/GNUstep/System/Makefiles/jni.make
share/GNUstep/System/Makefiles/ld_lib_path.csh
share/GNUstep/System/Makefiles/ld_lib_path.sh
share/GNUstep/System/Makefiles/library-combo.make
share/GNUstep/System/Makefiles/library.make
share/GNUstep/System/Makefiles/messages.make
share/GNUstep/System/Makefiles/mkinstalldirs
share/GNUstep/System/Makefiles/names.make
share/GNUstep/System/Makefiles/objc.make
share/GNUstep/System/Makefiles/os.sh
share/GNUstep/System/Makefiles/palette.make
share/GNUstep/System/Makefiles/relative_path.sh
share/GNUstep/System/Makefiles/resource-set.make
share/GNUstep/System/Makefiles/rules.make
share/GNUstep/System/Makefiles/service.make
share/GNUstep/System/Makefiles/spec-debug-alone-rules.template
share/GNUstep/System/Makefiles/spec-debug-rules.template
share/GNUstep/System/Makefiles/spec-rules.template
share/GNUstep/System/Makefiles/subproject.make
share/GNUstep/System/Makefiles/target.make
share/GNUstep/System/Makefiles/test-application.make
share/GNUstep/System/Makefiles/test-library.make
share/GNUstep/System/Makefiles/test-tool.make
share/GNUstep/System/Makefiles/tool.make
share/GNUstep/System/Makefiles/transform_paths.sh
share/GNUstep/System/Makefiles/vendor.sh
share/GNUstep/System/Tools/debugapp
share/GNUstep/System/Tools/openapp
share/GNUstep/System/Tools/opentool
share/GNUstep/System/share/config.site
@dirrm share/GNUstep/System/share
@exec ${MKDIR} %D/share/GNUstep/System/Tools/ix86/${LOWER_OPSYS}elf/gnu-gnu-gnu
@dirrm share/GNUstep/System/Tools/ix86/${LOWER_OPSYS}elf/gnu-gnu-gnu
@dirrm share/GNUstep/System/Tools/ix86/${LOWER_OPSYS}elf
@dirrm share/GNUstep/System/Tools/ix86
@exec ${MKDIR} %D/share/GNUstep/System/Tools/Java
@dirrm share/GNUstep/System/Tools/Java
@dirrm share/GNUstep/System/Tools
@dirrm share/GNUstep/System/Makefiles/ix86/${LOWER_OPSYS}elf
@dirrm share/GNUstep/System/Makefiles/ix86
@dirrm share/GNUstep/System/Makefiles/Master
@dirrm share/GNUstep/System/Makefiles/Instance/Shared
@dirrm share/GNUstep/System/Makefiles/Instance
@exec ${MKDIR} %D/share/GNUstep/System/Makefiles/Additional
@dirrm share/GNUstep/System/Makefiles/Additional
@dirrm share/GNUstep/System/Makefiles
@exec ${MKDIR} %D/share/GNUstep/System/Library/Services
@dirrm share/GNUstep/System/Library/Services
@exec ${MKDIR} %D/share/GNUstep/System/Library/PostScript
@dirrm share/GNUstep/System/Library/PostScript
@exec ${MKDIR} %D/share/GNUstep/System/Library/Frameworks
@dirrm share/GNUstep/System/Library/Frameworks
@exec ${MKDIR} %D/share/GNUstep/System/Library/Colors
@dirrm share/GNUstep/System/Library/Colors
@exec ${MKDIR} %D/share/GNUstep/System/Library/Bundles
@dirrm share/GNUstep/System/Library/Bundles
@dirrm share/GNUstep/System/Library
@exec ${MKDIR} %D/share/GNUstep/System/Libraries/ix86/${LOWER_OPSYS}elf/gnu-gnu-gnu
@dirrm share/GNUstep/System/Libraries/ix86/${LOWER_OPSYS}elf/gnu-gnu-gnu
@dirrm share/GNUstep/System/Libraries/ix86/${LOWER_OPSYS}elf
@dirrm share/GNUstep/System/Libraries/ix86
@exec ${MKDIR} %D/share/GNUstep/System/Libraries/Resources
@dirrm share/GNUstep/System/Libraries/Resources
@exec ${MKDIR} %D/share/GNUstep/System/Libraries/Java
@dirrm share/GNUstep/System/Libraries/Java
@dirrm share/GNUstep/System/Libraries
@exec ${MKDIR} %D/share/GNUstep/System/Headers/ix86/${LOWER_OPSYS}elf
@dirrm share/GNUstep/System/Headers/ix86/${LOWER_OPSYS}elf
@dirrm share/GNUstep/System/Headers/ix86
@dirrm share/GNUstep/System/Headers
@exec ${MKDIR} %D/share/GNUstep/System/Documentation/man
@dirrm share/GNUstep/System/Documentation/man
@exec ${MKDIR} %D/share/GNUstep/System/Documentation/info
@dirrm share/GNUstep/System/Documentation/info
@exec ${MKDIR} %D/share/GNUstep/System/Documentation/User
@dirrm share/GNUstep/System/Documentation/User
@exec ${MKDIR} %D/share/GNUstep/System/Documentation/Developer
@dirrm share/GNUstep/System/Documentation/Developer
@dirrm share/GNUstep/System/Documentation
@exec ${MKDIR} %D/share/GNUstep/System/Developer/Palettes
@dirrm share/GNUstep/System/Developer/Palettes
@dirrm share/GNUstep/System/Developer
@exec ${MKDIR} %D/share/GNUstep/System/Applications
@dirrm share/GNUstep/System/Applications
@dirrm share/GNUstep/System
@exec ${MKDIR} %D/share/GNUstep/Network
@dirrm share/GNUstep/Network
@exec ${MKDIR} %D/share/GNUstep/Local/Users/Administrator
@dirrm share/GNUstep/Local/Users/Administrator
@dirrm share/GNUstep/Local/Users
@exec ${MKDIR} %D/share/GNUstep/Local/Tools/ix86/${LOWER_OPSYS}elf/gnu-gnu-gnu
@dirrm share/GNUstep/Local/Tools/ix86/${LOWER_OPSYS}elf/gnu-gnu-gnu
@dirrm share/GNUstep/Local/Tools/ix86/${LOWER_OPSYS}elf
@dirrm share/GNUstep/Local/Tools/ix86
@exec ${MKDIR} %D/share/GNUstep/Local/Tools/Java
@dirrm share/GNUstep/Local/Tools/Java
@dirrm share/GNUstep/Local/Tools
@exec ${MKDIR} %D/share/GNUstep/Local/Library/Services
@dirrm share/GNUstep/Local/Library/Services
@exec ${MKDIR} %D/share/GNUstep/Local/Library/PostScript
@dirrm share/GNUstep/Local/Library/PostScript
@exec ${MKDIR} %D/share/GNUstep/Local/Library/Frameworks
@dirrm share/GNUstep/Local/Library/Frameworks
@exec ${MKDIR} %D/share/GNUstep/Local/Library/Colors
@dirrm share/GNUstep/Local/Library/Colors
@exec ${MKDIR} %D/share/GNUstep/Local/Library/Bundles
@dirrm share/GNUstep/Local/Library/Bundles
@dirrm share/GNUstep/Local/Library
@exec ${MKDIR} %D/share/GNUstep/Local/Libraries/ix86/${LOWER_OPSYS}elf/gnu-gnu-gnu
@dirrm share/GNUstep/Local/Libraries/ix86/${LOWER_OPSYS}elf/gnu-gnu-gnu
@dirrm share/GNUstep/Local/Libraries/ix86/${LOWER_OPSYS}elf
@dirrm share/GNUstep/Local/Libraries/ix86
@exec ${MKDIR} %D/share/GNUstep/Local/Libraries/Resources
@dirrm share/GNUstep/Local/Libraries/Resources
@exec ${MKDIR} %D/share/GNUstep/Local/Libraries/Java
@dirrm share/GNUstep/Local/Libraries/Java
@dirrm share/GNUstep/Local/Libraries
@exec ${MKDIR} %D/share/GNUstep/Local/Headers/ix86/${LOWER_OPSYS}elf
@dirrm share/GNUstep/Local/Headers/ix86/${LOWER_OPSYS}elf
@dirrm share/GNUstep/Local/Headers/ix86
@dirrm share/GNUstep/Local/Headers
@exec ${MKDIR} %D/share/GNUstep/Local/Documentation/User
@dirrm share/GNUstep/Local/Documentation/User
@exec ${MKDIR} %D/share/GNUstep/Local/Documentation/Developer
@dirrm share/GNUstep/Local/Documentation/Developer
@dirrm share/GNUstep/Local/Documentation
@exec ${MKDIR} %D/share/GNUstep/Local/Developer/Palettes
@dirrm share/GNUstep/Local/Developer/Palettes
@dirrm share/GNUstep/Local/Developer
@exec ${MKDIR} %D/share/GNUstep/Local/Applications
@dirrm share/GNUstep/Local/Applications
@dirrm share/GNUstep/Local
@dirrm share/GNUstep

View file

@ -0,0 +1,62 @@
# $NetBSD: buildlink2.mk,v 1.1.1.1 2002/09/27 10:40:16 rh Exp $
#
.if !defined(GNUSTEP_MAKE_BUILDLINK2_MK)
GNUSTEP_MAKE_BUILDLINK2_MK= # defined
BUILDLINK_PACKAGES+= gnustep-make
BUILDLINK_DEPENDS.gnustep-make?= gnustep-make>=1.5.0
BUILDLINK_PKGSRCDIR.gnustep-make?= ../../devel/gnustep-make
EVAL_PREFIX+= BUILDLINK_PREFIX.gnustep-make=gnustep-make
BUILDLINK_PREFIX.gnustep-make_DEFAULT= ${LOCALBASE}
BUILDLINK_TARGETS+= gnustep-make-buildlink
GNUSTEP_ROOT= ${PREFIX}/share/GNUstep
GNUSTEP_LOCAL_ROOT= ${GNUSTEP_ROOT}/Local
GNUSTEP_SYSTEM_ROOT= ${GNUSTEP_ROOT}/System
GNUSTEP_NETWORK_ROOT= ${GNUSTEP_ROOT}/Network
GNUSTEP_MAKEFILES= ${GNUSTEP_SYSTEM_ROOT}/Makefiles
GNUSTEP_HOST= ${MACHINE_GNU_PLATFORM}
GNUSTEP_HOST_CPU= ${MACHINE_GNU_ARCH:S/i386/ix86/}
GNUSTEP_HOST_VENDOR= ${LOWER_VENDOR}
GNUSTEP_HOST_OS= ${LOWER_OPSYS}${APPEND_ELF}
GNUSTEP_USER_ROOT= ${WRKDIR}
GNUSTEP_PATHLIST= ${GNUSTEP_USER_ROOT}:${GNUSTEP_LOCAL_ROOT}:${GNUSTEP_NETWORK_ROOT}:${GNUSTEP_SYSTEM_ROOT}
GNUSTEP_FLATTENED= # defined
MAKE_ENV+= GNUSTEP_ROOT="${GNUSTEP_ROOT}"
MAKE_ENV+= GNUSTEP_LOCAL_ROOT="${GNUSTEP_LOCAL_ROOT}"
MAKE_ENV+= GNUSTEP_SYSTEM_ROOT="${GNUSTEP_SYSTEM_ROOT}"
MAKE_ENV+= GNUSTEP_NETWORK_ROOT="${GNUSTEP_NETWORK_ROOT}"
MAKE_ENV+= GNUSTEP_MAKEFILES="${GNUSTEP_MAKEFILES}"
MAKE_ENV+= GNUSTEP_HOST="${GNUSTEP_HOST}"
MAKE_ENV+= GNUSTEP_HOST_CPU="${GNUSTEP_HOST_CPU}"
MAKE_ENV+= GNUSTEP_HOST_VENDOR="${GNUSTEP_HOST_VENDOR}"
MAKE_ENV+= GNUSTEP_HOST_OS="${GNUSTEP_HOST_OS}"
MAKE_ENV+= GNUSTEP_USER_ROOT="${GNUSTEP_USER_ROOT}"
MAKE_ENV+= GNUSTEP_PATHLIST="${GNUSTEP_PATHLIST}"
MAKE_ENV+= GNUSTEP_FLATTENED=""
PLIST_SUBST+= GNUSTEP_HOST_CPU=${GNUSTEP_HOST_CPU}
PLIST_SUBST+= APPEND_ELF=${APPEND_ELF}
.if defined(GNU_CONFIGURE)
CONFIGURE_ENV+= GNUSTEP_ROOT="${GNUSTEP_ROOT}"
CONFIGURE_ENV+= GNUSTEP_LOCAL_ROOT="${GNUSTEP_LOCAL_ROOT}"
CONFIGURE_ENV+= GNUSTEP_SYSTEM_ROOT="${GNUSTEP_SYSTEM_ROOT}"
CONFIGURE_ENV+= GNUSTEP_NETWORK_ROOT="${GNUSTEP_NETWORK_ROOT}"
CONFIGURE_ENV+= GNUSTEP_MAKEFILES="${GNUSTEP_MAKEFILES}"
CONFIGURE_ENV+= GNUSTEP_HOST="${GNUSTEP_HOST}"
CONFIGURE_ENV+= GNUSTEP_HOST_CPU="${GNUSTEP_HOST_CPU}"
CONFIGURE_ENV+= GNUSTEP_HOST_VENDOR="${GNUSTEP_HOST_VENDOR}"
CONFIGURE_ENV+= GNUSTEP_HOST_OS="${GNUSTEP_HOST_OS}"
CONFIGURE_ENV+= GNUSTEP_USER_ROOT="${GNUSTEP_USER_ROOT}"
CONFIGURE_ENV+= GNUSTEP_PATHLIST="${GNUSTEP_PATHLIST}"
CONFIGURE_ENV+= GNUSTEP_FLATTENED=""
.endif
gnustep-make-buildlink: _BUILDLINK_USE
.endif # GNUSTEP_MAKE_BUILDLINK2_MK

View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2002/09/27 10:40:16 rh Exp $
SHA1 (gnustep-make-1.5.0.tar.gz) = 04eedb26fe34104548e5f5963cc11f5bed500709
Size (gnustep-make-1.5.0.tar.gz) = 312944 bytes
SHA1 (patch-aa) = 4969ea2cbd61e4bc2dab109abcbbdf5177ebdd8c

View file

@ -0,0 +1,20 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/09/27 10:40:17 rh Exp $
--- clean_os.sh.orig Wed Mar 6 21:51:06 2002
+++ clean_os.sh
@@ -22,6 +22,15 @@
# Nothing to clean right now
case "$1" in
+ # Remove version number for NetBSD
+ netbsdelf*)
+ echo netbsdelf
+ exit 0
+ ;;
+ netbsd*)
+ echo netbsd
+ exit 0
+ ;;
# Remove version number for FreeBSD
freebsd2*)
echo freebsdaout