Update php54 package to 5.4.6 (PHP 5.4.6).
PHP NEWS ||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||| 16 Aug 2012, PHP 5.4.6 - CLI Server: . Implemented FR #62700 (have the console output 'Listening on http://localhost:8000'). (pascal.chevrel@free.fr) - Core: . Fixed bug #62661 (Interactive php-cli crashes if include() is used in auto_prepend_file). (Laruence) . Fixed bug #62653: (unset($array[$float]) causes a crash). (Nikita Popov, Laruence) . Fixed bug #62565 (Crashes due non-initialized internal properties_table). (Felipe) . Fixed bug #60194 (--with-zend-multibyte and --enable-debug reports LEAK with run-test.php). (Laruence) - CURL: . Fixed bug #62499 (curl_setopt($ch, CURLOPT_COOKIEFILE, "") returns false). (r.hampartsumyan@gmail.com, Laruence) - DateTime: . Fixed Bug #62500 (Segfault in DateInterval class when extended). (Laruence) - Fileinfo: . Fixed bug #61964 (finfo_open with directory causes invalid free). (reeze.xia@gmail.com) - Intl: . Fixed bug #62564 (Extending MessageFormatter and adding property causes crash). (Felipe) - MySQLnd: . Fixed bug #62594 (segfault in mysqlnd_res_meta::set_mode). (Laruence) - readline: . Fixed bug #62612 (readline extension compilation fails with sapi/cli/cli.h: No such file). (Johannes) - Reflection: . Implemented FR #61602 (Allow access to name of constant used as default value). (reeze.xia@gmail.com) - SimpleXML: . Implemented FR #55218 Get namespaces from current node. (Lonny) - SPL: . Fixed bug #62616 (ArrayIterator::count() from IteratorIterator instance gives Segmentation fault). (Laruence, Gustavo) . Fixed bug #61527 (ArrayIterator gives misleading notice on next() when moved to the end). (reeze.xia@gmail.com) - Streams: . Fixed bug #62597 (segfault in php_stream_wrapper_log_error with ZTS build). (Laruence) - Zlib: . Fixed bug #55544 (ob_gzhandler always conflicts with zlib.output_compression). (Laruence)
This commit is contained in:
parent
f59cf9fd11
commit
41c5761052
7 changed files with 17 additions and 44 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.2 2012/07/25 13:16:01 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2012/08/17 15:34:01 taca Exp $
|
||||
|
||||
#
|
||||
# We can't omit PKGNAME here to handle PKG_OPTIONS.
|
||||
#
|
||||
PKGNAME= php-${PHP_BASE_VERS}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= lang
|
||||
|
||||
HOMEPAGE= http://www.php.net/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.2 2012/07/20 12:29:05 taca Exp $
|
||||
# $NetBSD: Makefile.common,v 1.3 2012/08/17 15:34:01 taca Exp $
|
||||
# used by lang/php54/Makefile.php
|
||||
# used by lang/php/ext.mk
|
||||
# used by meta-pkgs/php54-extensions/Makefile
|
||||
|
@ -38,7 +38,7 @@ EXTRACT_SUFX?= .tar.bz2
|
|||
MAINTAINER?= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE?= http://www.php.net/
|
||||
|
||||
PHP_BASE_VERS= 5.4.5
|
||||
PHP_BASE_VERS= 5.4.6
|
||||
|
||||
PHP_EXTENSION_DIR= lib/php/20120301
|
||||
PLIST_SUBST+= PHP_EXTENSION_DIR=${PHP_EXTENSION_DIR}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2012/07/25 13:01:05 fhajny Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2012/08/17 15:34:01 taca Exp $
|
||||
bin/phar
|
||||
bin/phar.phar
|
||||
bin/php
|
||||
|
@ -218,6 +218,7 @@ ${PLIST.suhosin}include/php/main/suhosin_logo.h
|
|||
${PLIST.suhosin}include/php/main/suhosin_patch.h
|
||||
include/php/main/win32_internal_function_disabled.h
|
||||
include/php/main/win95nt.h
|
||||
include/php/sapi/cli/cli.h
|
||||
lib/php/build/Makefile.global
|
||||
lib/php/build/acinclude.m4
|
||||
lib/php/build/config.guess
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.5 2012/07/31 12:23:12 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.6 2012/08/17 15:34:01 taca Exp $
|
||||
|
||||
SHA1 (php-5.4.5.tar.bz2) = b6c5e6653ba28e2f071bafe30c9691eddb950ba0
|
||||
RMD160 (php-5.4.5.tar.bz2) = 1f89a9b31d5e14765ad9c4acff43aad825e1f9d8
|
||||
Size (php-5.4.5.tar.bz2) = 11011780 bytes
|
||||
SHA1 (php-5.4.6.tar.bz2) = a092ff9632f96189ade4415ca1e0a89cbc289a4b
|
||||
RMD160 (php-5.4.6.tar.bz2) = 5bfc64635ce86a613d8af38bbde9fe76ef846c45
|
||||
Size (php-5.4.6.tar.bz2) = 11026249 bytes
|
||||
SHA1 (patch-acinclude.m4) = afead7122844e8290d9ef4fdb8deec3c40cf0746
|
||||
SHA1 (patch-configure) = 5930b32de104cda553c9701086ffdf35a93f8d97
|
||||
SHA1 (patch-ext_gd_config.m4) = 089f1c88bd4daa8ebc8911122423c1f88e5d84a0
|
||||
|
@ -13,11 +13,10 @@ SHA1 (patch-ext_pdo_config.m4) = 26a4ad02e5c6b7a54c3c54a6d026a3ccfed62c59
|
|||
SHA1 (patch-ext_phar_Makefile.frag) = 1af23d9135557bc7ba2f3627b317d4cbef37aaba
|
||||
SHA1 (patch-ext_phar_phar_phar.php) = 011f2d68048dbc63f5efcab4e23062daa9e8e08c
|
||||
SHA1 (patch-ext_standard_basic__functions.c) = 563fe67eb78b786cd46195026381ef22128e0841
|
||||
SHA1 (patch-main_main.c) = 3535bd480d176a488405555d03f3bf7e2ce22ad5
|
||||
SHA1 (patch-main_main.c) = 3e8f62eed3daadf2c93adeade234e378e792be04
|
||||
SHA1 (patch-main_streams_cast.c) = ebf23f9908340be3d1f947c4112ec940f9324ecb
|
||||
SHA1 (patch-php.ini-development) = 79512bd276adaed6bcf5f7f28e965f8a6b589add
|
||||
SHA1 (patch-php.ini-production) = f5d275abe7668a139999b3607e99f271450f56ae
|
||||
SHA1 (patch-run-tests.php) = ff80b8ad52d7c0a43fa318ed9bffca9d7b3e688d
|
||||
SHA1 (patch-sapi_cgi_Makefile.frag) = ba16463cc2a350df1db80c78ac9aec44b20d4bfe
|
||||
SHA1 (patch-sapi_fpm_fpm__fpm_sockets.c) = 378bfa7f4d1eb1dcc0af25f426cd3e62d1b9290d
|
||||
SHA1 (patch-sapi_fpm_fpm__fpm_sockets.h) = 28ee07f01464b44c2bbdea6a8073e636e064b453
|
||||
SHA1 (patch-sapi_fpm_fpm__fpm_sockets.h) = 012cfc14cb912cee3045ca1741876161ee44e8d5
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: patch-main_main.c,v 1.1 2012/07/25 13:16:02 fhajny Exp $
|
||||
$NetBSD: patch-main_main.c,v 1.2 2012/08/17 15:34:01 taca Exp $
|
||||
|
||||
Fix fd leak on SunOS (https://bugs.php.net/bug.php?id=47675).
|
||||
|
||||
--- main/main.c.orig 2012-06-13 04:54:23.000000000 +0000
|
||||
+++ main/main.c
|
||||
@@ -2388,7 +2388,7 @@ PHPAPI int php_execute_script(zend_file_
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
$NetBSD: patch-sapi_fpm_fpm__fpm_sockets.c,v 1.1 2012/07/31 12:23:12 fhajny Exp $
|
||||
|
||||
Silly bug. 'sun' is of course taken on SunOS.
|
||||
--- sapi/fpm/fpm/fpm_sockets.c.orig 2012-07-18 06:19:16.000000000 +0000
|
||||
+++ sapi/fpm/fpm/fpm_sockets.c
|
||||
@@ -455,11 +455,11 @@ int fpm_socket_get_listening_queue(int s
|
||||
|
||||
#endif
|
||||
|
||||
-int fpm_socket_unix_test_connect(struct sockaddr_un *sun, size_t socklen) /* {{{ */
|
||||
+int fpm_socket_unix_test_connect(struct sockaddr_un *fpm_sun, size_t socklen) /* {{{ */
|
||||
{
|
||||
int fd;
|
||||
|
||||
- if (!sun || sun->sun_family != AF_UNIX) {
|
||||
+ if (!fpm_sun || fpm_sun->sun_family != AF_UNIX) {
|
||||
return -1;
|
||||
}
|
||||
|
||||
@@ -467,7 +467,7 @@ int fpm_socket_unix_test_connect(struct
|
||||
return -1;
|
||||
}
|
||||
|
||||
- if (connect(fd, (struct sockaddr *)sun, socklen) == -1) {
|
||||
+ if (connect(fd, (struct sockaddr *)fpm_sun, socklen) == -1) {
|
||||
return -1;
|
||||
}
|
||||
|
|
@ -1,14 +1,15 @@
|
|||
$NetBSD: patch-sapi_fpm_fpm__fpm_sockets.h,v 1.1 2012/07/31 12:23:12 fhajny Exp $
|
||||
$NetBSD: patch-sapi_fpm_fpm__fpm_sockets.h,v 1.2 2012/08/17 15:34:01 taca Exp $
|
||||
|
||||
Silly bug. 'sun' is of course taken on SunOS.
|
||||
--- sapi/fpm/fpm/fpm_sockets.h.orig 2012-07-18 06:19:16.000000000 +0000
|
||||
|
||||
--- sapi/fpm/fpm/fpm_sockets.h.orig 2012-08-15 04:26:05.000000000 +0000
|
||||
+++ sapi/fpm/fpm/fpm_sockets.h
|
||||
@@ -25,7 +25,7 @@
|
||||
enum fpm_address_domain fpm_sockets_domain_from_address(char *addr);
|
||||
int fpm_sockets_init_main();
|
||||
int fpm_socket_get_listening_queue(int sock, unsigned *cur_lq, unsigned *max_lq);
|
||||
-int fpm_socket_unix_test_connect(struct sockaddr_un *sun, size_t socklen);
|
||||
+int fpm_socket_unix_test_connect(struct sockaddr_un *fpm_sun, size_t socklen);
|
||||
+int fpm_socket_unix_test_connect(struct sockaddr_un *sock, size_t socklen);
|
||||
|
||||
|
||||
static inline int fd_set_blocked(int fd, int blocked) /* {{{ */
|
||||
|
|
Loading…
Reference in a new issue