Updated databases/pear-MDB2_Driver_pgsql to 1.5.0b2
1.5.0b2 - fixed bug #12117: disconnect() does not work as documented - fixed bug #13481: getTableConstraintDefinition() may return incomplete results - fixed bug #13877: UNIQUE index not always recognized as constraint - fixed bug #14292: alterTable() cannot change column type when no implicit cast is defined - fixed bug #14510: getTableFieldDefinition() does not unquote defaults - fixed bug #14828: unixtimestamp() generates invalid SQL for non-constant argument - fixed bug #15056: tableInfo does not work with pgsql schemas (added support to table schemas to Manager module) 1.5.0b1 - request #12731: added truncateTable() in the Manager module - request #12732: added vacuum() in the Manager module for OPTIMIZE/VACUUM TABLE abstraction - request #12800: added alterDatabase() in the Manager module - fixed bug #12846: missing escape in getSequenceName() on PostgreSQL 8.2.4 [thanks to Stephane Berthelot] - fixed bug #12920: added new error info and fixed escape method if connection doesn't exist [afz] - fixed bug #12922: use standaloneQuery() in alterDatabase() [afz] - fixed bug #12924: correctly handle internal expected errors even with custom error handling - added standaloneQuery() and databaseExists() - fixed bug #13112: the Reverse module does not know the timestamptz data type - request #13106: added unixtimestamp() in the Function module - fixed bug #13281: list FOREIGN KEY constraints in listTableConstraints() in the Manager module - fixed bug #13356: added float4 to _mapNativeDatatype() - fixed query in getTableConstraintDefinition() for FK constraints in the Reverse module (thanks to Andre Restivo) 1.5.0a2 - fixed bug #12376: getTableConstraintDefinition() in the Reverse module uses incorrect column number in certain cases (thanks to Dennis Birne) - request #12338: added 'disable_smart_seqname' option to make improved getSequenceName() behaviour optional (thanks to Dennis Birne) (@see bug #9106) - request #12012: added collation support in createDatabase() 1.5.0a1 - initial support for FOREIGN KEY and CHECK constraints in the Reverse and Manager modules - fixed bug #10986: Using more random statement names (request #11625) - request #11297: added support for "schema.table" (or "owner.table") notation in the Reverse module (related to bug #11207) - fixed bug #11428: propagate quote() errors with invalid data types - fixed bug in MDB2_Statement_pgsql::_execute(), called property of invalid object - fixed bug #11624: getSequenceName() returning incorrect results with multiple schemas and 'SET search_path' - fixed bug #11652: failed prepared queries containing the "::type" style of casting - fixed bug #11694: remove data type cast from DEFAULT value in getTableFieldDefinition() in the Reverse module - fixed bug #11753: NOTICEs in alterTable() in the Manager module - fixed bug #11790: avoid array_diff() because it has a memory leak in PHP 5.1.x - fixed some E_STRICT errors with PHP5 - fixed bug #12083: createTable() in the Manager module now returns MDB2_OK on success, as documented - fixed bug #12269: tableInfo() in the Reverse module detect 'clob' data type as first option
This commit is contained in:
parent
e36dbc9b63
commit
42154e243d
4 changed files with 12 additions and 41 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.2 2008/07/13 17:55:38 tonnerre Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2009/01/19 20:14:00 abs Exp $
|
||||
|
||||
DISTNAME= MDB2_Driver_pgsql-1.4.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= MDB2_Driver_pgsql-1.5.0b2
|
||||
CATEGORIES= databases
|
||||
|
||||
MAINTAINER= adrianp@NetBSD.org
|
||||
|
@ -9,7 +8,9 @@ HOMEPAGE= http://pear.php.net/package/MDB2_Driver_pgsql
|
|||
COMMENT= Pgsql MDB2 driver
|
||||
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-pgsql-[0-9]*:../../databases/php-pgsql
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-pear-MDB2-[0-9]*:../../databases/pear-MDB2
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-pear-MDB2>=2.5:../../databases/pear-MDB2
|
||||
|
||||
PEAR_DIRRM_EXCLUDE= lib/php/MDB2
|
||||
|
||||
.include "../../lang/php/pear.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2008/10/19 18:36:19 adrianp Exp $
|
||||
$NetBSD: distinfo,v 1.4 2009/01/19 20:14:00 abs Exp $
|
||||
|
||||
SHA1 (pear/MDB2_Driver_pgsql-1.4.1.tgz) = 07a69e5ebd8a0d920ac372f3666b39f2601c2a82
|
||||
RMD160 (pear/MDB2_Driver_pgsql-1.4.1.tgz) = 0a102683779d3b8ee38ce7716221fec14ab7c25c
|
||||
Size (pear/MDB2_Driver_pgsql-1.4.1.tgz) = 33839 bytes
|
||||
SHA1 (patch-aa) = 6099865afba02de82ad9d00508d67d6800684316
|
||||
SHA1 (patch-ab) = 38331e9b8a6615d765712d45e0ac67e641f19519
|
||||
SHA1 (pear/MDB2_Driver_pgsql-1.5.0b2.tgz) = 712f64c96d6524a255927ae6bd6bd09269b6194d
|
||||
RMD160 (pear/MDB2_Driver_pgsql-1.5.0b2.tgz) = 19aa2f77a24fcc17f418f480ecab035e1ff4c5f1
|
||||
Size (pear/MDB2_Driver_pgsql-1.5.0b2.tgz) = 41046 bytes
|
||||
SHA1 (patch-aa) = f22b73962e5831b34501d9932f53413cfbda919d
|
||||
|
|
|
@ -1,19 +1,10 @@
|
|||
$NetBSD: patch-aa,v 1.2 2008/07/13 17:55:38 tonnerre Exp $
|
||||
$NetBSD: patch-aa,v 1.3 2009/01/19 20:14:00 abs Exp $
|
||||
|
||||
--- ../package.xml.orig 2007-05-03 21:07:38.000000000 +0200
|
||||
+++ ../package.xml
|
||||
@@ -63,7 +63,7 @@ open todo items:
|
||||
<file baseinstalldir="/" md5sum="4d4cf683f8847cede4f8b298a492f777" name="MDB2/Driver/Reverse/pgsql.php" role="php">
|
||||
<tasks:replace from="@package_version@" to="version" type="package-info" />
|
||||
</file>
|
||||
- <file baseinstalldir="/" md5sum="d995b8777e9a44fd123fd97ae32578f7" name="MDB2/Driver/pgsql.php" role="php">
|
||||
+ <file baseinstalldir="/" md5sum="818fd28ff1e7dd933eaccd20f0a264ab" name="MDB2/Driver/pgsql.php" role="php">
|
||||
<tasks:replace from="@package_version@" to="version" type="package-info" />
|
||||
</file>
|
||||
<file baseinstalldir="/" md5sum="3e790ed8bf0b3b91ec518cdab9eba271" name="tests/MDB2_nonstandard_pgsql.php" role="test" />
|
||||
@@ -83,9 +83,6 @@ open todo items:
|
||||
<channel>pear.php.net</channel>
|
||||
<min>2.4.1</min>
|
||||
<min>2.5.0b2</min>
|
||||
</package>
|
||||
- <extension>
|
||||
- <name>pgsql</name>
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.2 2008/10/19 18:36:19 adrianp Exp $
|
||||
|
||||
--- MDB2/Driver/pgsql.php.orig 2007-05-03 19:07:38.000000000 +0000
|
||||
+++ MDB2/Driver/pgsql.php
|
||||
@@ -1351,7 +1351,7 @@ class MDB2_Statement_pgsql extends MDB2_
|
||||
}
|
||||
$value = $this->values[$parameter];
|
||||
$type = array_key_exists($parameter, $this->types) ? $this->types[$parameter] : null;
|
||||
- if (is_resource($value) || $type == 'clob' || $type == 'blob') {
|
||||
+ if (is_resource($value) || $type == 'clob' || $type == 'blob' || $this->options['lob_allow_url_include']) {
|
||||
if (!is_resource($value) && preg_match('/^(\w+:\/\/)(.*)$/', $value, $match)) {
|
||||
if ($match[1] == 'file://') {
|
||||
$value = $match[2];
|
||||
@@ -1432,4 +1432,4 @@ class MDB2_Statement_pgsql extends MDB2_
|
||||
return $result;
|
||||
}
|
||||
}
|
||||
-?>
|
||||
\ No newline at end of file
|
||||
+?>
|
Loading…
Reference in a new issue