geography/qgis: Update to 3.10.7 (LTS)

This update is prompted by 3.8 not building with qt 5.15.  (Builds,
starts, and shows layers from a project on NetBSD 8/amd64.)

Packaging changes: Drop patches cherrypicked from upstream.

Upstream changes:

  1. What's new in Version 3.10 'A Coruña'?
  =========================================

This release has following new features:

- Map Tools: Show 3D length for LineStringZ features in identify derived attributes
- Symbology: Customizable default resampling settings for newly-added raster layers
- Symbology: Add "extract symbols" action to QGS/QGZ project file context menu in browser
- Symbology: Improved copy/paste of symbols
- Symbology: "Center of segment" placement mode for marker and hash line symbol layers
- Symbology: Allow array values as a valid result for data defined offset
- Labelling: Allow creation and editing of text formats and label settings through style manager dialog
- Labelling: New text "background" setting for marker symbol backgrounds
- Labelling: Callouts support
- Labelling: Add multiline alignment property to the change label tool
- Labelling: Allow display of unplaced labels
- Labelling: Add "overrun distance" setting for line labels
- Labelling: Allow data defined control over "label every part of multipart features" setting
- Labelling:  Expose "label all parts" option via label properties tool
- Labelling: Support vertical text orientation
- Labelling: Expose font kerning setting
- Rendering: Allow rendering raster layers outside the reported extent
- Rendering:  Add option to georeference PDFs and TIFs to save map canvas as image/PDF
- Rendering: new map canvas image decoration
- Rendering:  logarithmic scale method for graduated renderer
- 3D Features: Measurement tool in 3D map view
- 3D Features: Billboard Rendering for Points
- 3D Features: 3D On-Screen Navigation
- Print Layouts: Right-to-left arrangement for legends
- Print Layouts: Control margin under legend group and subgroup headings
- Print Layouts: Allow data defined settings in text formats
- Print Layouts: @scale_value variable
- Print Layouts: Add above/below segments placement option for scalebar labels
- Print Layouts: Horizontal placement option for scale bar labels
- Print Layouts: Add option to simplify PDF or SVG exports
- Print Layouts: Improved SVG layered exports
- Print Layouts: Add an indicator in the status bar while a map redraw is occurring in the background
- Print Layouts: GeoPDF Export
- Print Layouts: Data defined control over grid properties
- Print Layouts: "fit segment size" mode for map grid interval
- Print Layouts: layout map item extent to an existing bookmark
- Expressions: New expression functions
- Digitising: GPS timestamp support
- Data Management: Composite Foreign Keys
- Data Management: Add circular data dependencies
- Analysis Tools: Stored filter expressions
- Analysis Tools: New operator for Raster Calculator
- Processing: new algorithm point to layer
- Processing: allow defining model parameters as advanced
- Processing: All GDAL based algorithms now support free-form "additional parameters"
- Processing: Add metatile size parameter to XYZ tiles algorithm
- Processing: New parameter type for colors
- Processing: New algorithm "Create style database from project"
- Processing: Allow file filter and default value to be set for file/folder inputs in models
- Processing: New algorithm "Combine style databases"
- Processing: Generate XYZ tiles using multiple threads
- Processing: New algorithms for exporting and importing to/from map layers
- Processing: New algorithm "Split features by character"
- Processing: New algorithm Climb Along Line
- Processing: Port Create Grid algorithm to C++
- General: Show news items on welcome page
- General: Add a separate unit choice for milliradians (SI definition) vs mil (NATO definition)
- General: Enable widget filtering in Interface Customization dialog
- General: Improved auto-fix broken layers
- General: Bookmark Revamp
- General: "Reselect Features" action in Edit -> Select menu
- General: Parallelize snap index build
- Data Providers: Handle read-write support for .shz and .shp.zip
- Data Providers: oracle provider: add support for auth manager
- Data Providers: Improved PostGIS raster support
- Data Providers: Oracle - Database transaction support
- Data Providers: Add support for z/m dimensions to delimited text layers
- Data Providers: Static data providers
- QGIS Server: Using SVG in QGIS Server
- QGIS Server: WMS dimension
- QGIS Server: Server OAPIF (aka WFS3) support
- Programmability: New class QgsBookmarkManager
- Programmability: New API for provider database connections
This commit is contained in:
gdt 2020-06-21 13:51:49 +00:00
parent 371f50611c
commit 421d13a769
12 changed files with 101 additions and 211 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.93 2020/06/17 14:01:15 gdt Exp $
# $NetBSD: Makefile,v 1.94 2020/06/21 13:51:49 gdt Exp $
DISTNAME= qgis-3.8.3
PKGREVISION= 10
DISTNAME= qgis-3.10.7
CATEGORIES= geography
MASTER_SITES= https://qgis.org/downloads/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,5 @@
@comment $NetBSD: PLIST,v 1.10 2019/10/29 19:30:11 bouyer Exp $
@comment $NetBSD: PLIST,v 1.11 2020/06/21 13:51:49 gdt Exp $
@comment $NetBSD: PLIST,v 1.11 2020/06/21 13:51:49 gdt Exp $
bin/qgis
bin/qgis_bench
include/qgis/Bezier3D.h
@ -14,8 +15,7 @@ include/qgis/TriangleInterpolator.h
include/qgis/Triangulation.h
include/qgis/Vector3D.h
include/qgis/characterwidget.h
include/qgis/mersenne-twister.h
include/qgis/nlohmann/json_fwd.hpp
include/qgis/json_fwd.hpp
include/qgis/qgis.h
include/qgis/qgis_analysis.h
include/qgis/qgis_core.h
@ -29,10 +29,13 @@ include/qgis/qgs25drendererwidget.h
include/qgis/qgs3drendererregistry.h
include/qgis/qgsabstract3drenderer.h
include/qgis/qgsabstractcontentcache.h
include/qgis/qgsabstractdatabaseproviderconnection.h
include/qgis/qgsabstractdatasourcewidget.h
include/qgis/qgsabstractgeometry.h
include/qgis/qgsabstractgeopdfexporter.h
include/qgis/qgsabstractlayoutiterator.h
include/qgis/qgsabstractmetadatabase.h
include/qgis/qgsabstractproviderconnection.h
include/qgis/qgsabstractreportsection.h
include/qgis/qgsabstractvaliditycheck.h
include/qgis/qgsaction.h
@ -54,6 +57,7 @@ include/qgis/qgsannotationmanager.h
include/qgis/qgsannotationregistry.h
include/qgis/qgsapplication.h
include/qgis/qgsarchive.h
include/qgis/qgsarrowsymbollayer.h
include/qgis/qgsarrowsymbollayerwidget.h
include/qgis/qgsaspectfilter.h
include/qgis/qgsattributedialog.h
@ -108,10 +112,13 @@ include/qgis/qgsbinarywidgetwrapper.h
include/qgis/qgsblendmodecombobox.h
include/qgis/qgsblockingnetworkrequest.h
include/qgis/qgsblureffect.h
include/qgis/qgsbookmarkmanager.h
include/qgis/qgsbookmarkmodel.h
include/qgis/qgsbox3d.h
include/qgis/qgsbrightnesscontrastfilter.h
include/qgis/qgsbrowserdockwidget.h
include/qgis/qgsbrowserdockwidget_p.h
include/qgis/qgsbrowserguimodel.h
include/qgis/qgsbrowsermodel.h
include/qgis/qgsbrowserproxymodel.h
include/qgis/qgsbrowsertreeview.h
@ -121,16 +128,29 @@ include/qgis/qgscachedfeatureiterator.h
include/qgis/qgscacheindex.h
include/qgis/qgscacheindexfeatureid.h
include/qgis/qgscadutils.h
include/qgis/qgscallout.h
include/qgis/qgscalloutsregistry.h
include/qgis/qgscalloutwidget.h
include/qgis/qgscategorizedsymbolrenderer.h
include/qgis/qgscategorizedsymbolrendererwidget.h
include/qgis/qgscharacterselectordialog.h
include/qgis/qgscheckablecombobox.h
include/qgis/qgscheckboxconfigdlg.h
include/qgis/qgscheckboxfieldformatter.h
include/qgis/qgscheckboxsearchwidgetwrapper.h
include/qgis/qgscheckboxwidgetfactory.h
include/qgis/qgscheckboxwidgetwrapper.h
include/qgis/qgscircle.h
include/qgis/qgscircularstring.h
include/qgis/qgsclassificationcustom.h
include/qgis/qgsclassificationequalinterval.h
include/qgis/qgsclassificationjenks.h
include/qgis/qgsclassificationlogarithmic.h
include/qgis/qgsclassificationmethod.h
include/qgis/qgsclassificationmethodregistry.h
include/qgis/qgsclassificationprettybreaks.h
include/qgis/qgsclassificationquantile.h
include/qgis/qgsclassificationstandarddeviation.h
include/qgis/qgsclassificationwidgetwrapper.h
include/qgis/qgsclassificationwidgetwrapperfactory.h
include/qgis/qgsclipper.h
@ -309,6 +329,11 @@ include/qgis/qgsfocuswatcher.h
include/qgis/qgsfontbutton.h
include/qgis/qgsfontutils.h
include/qgis/qgsformannotation.h
include/qgis/qgsgdaldataitems.h
include/qgis/qgsgdalguiprovider.h
include/qgis/qgsgdalprovider.h
include/qgis/qgsgdalsourceselect.h
include/qgis/qgsgdalutils.h
include/qgis/qgsgenericfeatureselectionmanager.h
include/qgis/qgsgeometry.h
include/qgis/qgsgeometryanglecheck.h
@ -352,6 +377,13 @@ include/qgis/qgsgeometryutils.h
include/qgis/qgsgeometryvalidator.h
include/qgis/qgsgeonodeconnection.h
include/qgis/qgsgeonoderequest.h
include/qgis/qgsgeopackagedataitems.h
include/qgis/qgsgeopackageitemguiprovider.h
include/qgis/qgsgeopackageprojectstorage.h
include/qgis/qgsgeopackageprojectstoragedialog.h
include/qgis/qgsgeopackageprojectstorageguiprovider.h
include/qgis/qgsgeopackageproviderconnection.h
include/qgis/qgsgeopackagerasterwritertask.h
include/qgis/qgsgeos.h
include/qgis/qgsgloweffect.h
include/qgis/qgsgml.h
@ -410,6 +442,7 @@ include/qgis/qgskeyvaluewidgetwrapper.h
include/qgis/qgslabelfeature.h
include/qgis/qgslabelingengine.h
include/qgis/qgslabelingenginesettings.h
include/qgis/qgslabelinggui.h
include/qgis/qgslabelsearchtree.h
include/qgis/qgslayerdefinition.h
include/qgis/qgslayermetadata.h
@ -441,6 +474,7 @@ include/qgis/qgslayoutdesignerinterface.h
include/qgis/qgslayouteffect.h
include/qgis/qgslayoutexporter.h
include/qgis/qgslayoutframe.h
include/qgis/qgslayoutgeopdfexporter.h
include/qgis/qgslayoutgridsettings.h
include/qgis/qgslayoutguidecollection.h
include/qgis/qgslayoutitem.h
@ -562,6 +596,7 @@ include/qgis/qgsmaprenderercustompainterjob.h
include/qgis/qgsmaprendererjob.h
include/qgis/qgsmaprendererparalleljob.h
include/qgis/qgsmaprenderersequentialjob.h
include/qgis/qgsmaprendererstagedrenderjob.h
include/qgis/qgsmaprenderertask.h
include/qgis/qgsmapsettings.h
include/qgis/qgsmapsettingsutils.h
@ -570,6 +605,7 @@ include/qgis/qgsmaptip.h
include/qgis/qgsmaptool.h
include/qgis/qgsmaptooladvanceddigitizing.h
include/qgis/qgsmaptoolcapture.h
include/qgis/qgsmaptooldigitizefeature.h
include/qgis/qgsmaptooledit.h
include/qgis/qgsmaptoolemitpoint.h
include/qgis/qgsmaptoolextent.h
@ -635,6 +671,8 @@ include/qgis/qgsnewhttpconnection.h
include/qgis/qgsnewmemorylayerdialog.h
include/qgis/qgsnewnamedialog.h
include/qgis/qgsnewogrconnection.h
include/qgis/qgsnewsfeedmodel.h
include/qgis/qgsnewsfeedparser.h
include/qgis/qgsnewvectorlayerdialog.h
include/qgis/qgsninecellfilter.h
include/qgis/qgsnmeaconnection.h
@ -644,7 +682,18 @@ include/qgis/qgsnumericscalebarrenderer.h
include/qgis/qgsobjectcustomproperties.h
include/qgis/qgsofflineediting.h
include/qgis/qgsogcutils.h
include/qgis/qgsogrconnpool.h
include/qgis/qgsogrdataitems.h
include/qgis/qgsogrdbconnection.h
include/qgis/qgsogrdbsourceselect.h
include/qgis/qgsogrdbtablemodel.h
include/qgis/qgsogrguiprovider.h
include/qgis/qgsogrhelperfunctions.h
include/qgis/qgsogritemguiprovider.h
include/qgis/qgsogrprovider.h
include/qgis/qgsogrsourceselect.h
include/qgis/qgsogrtransaction.h
include/qgis/qgsogrutils.h
include/qgis/qgsopacitywidget.h
include/qgis/qgsoptional.h
include/qgis/qgsoptionalexpression.h
@ -710,6 +759,7 @@ include/qgis/qgsprocessingmodeloutput.h
include/qgis/qgsprocessingmodelparameter.h
include/qgis/qgsprocessingmultipleselectiondialog.h
include/qgis/qgsprocessingoutputs.h
include/qgis/qgsprocessingparameterdefinitionwidget.h
include/qgis/qgsprocessingparameters.h
include/qgis/qgsprocessingparametertype.h
include/qgis/qgsprocessingparametertypeimpl.h
@ -730,9 +780,13 @@ include/qgis/qgsprojectionselectionwidget.h
include/qgis/qgsprojectmetadata.h
include/qgis/qgsprojectproperty.h
include/qgis/qgsprojectstorage.h
include/qgis/qgsprojectstorageguiprovider.h
include/qgis/qgsprojectstorageguiregistry.h
include/qgis/qgsprojectstorageregistry.h
include/qgis/qgsprojectstylealgorithms.h
include/qgis/qgsprojecttranslator.h
include/qgis/qgsprojectversion.h
include/qgis/qgsprojectviewsettings.h
include/qgis/qgsprojutils.h
include/qgis/qgsproperty.h
include/qgis/qgsproperty_p.h
@ -740,6 +794,8 @@ include/qgis/qgspropertyassistantwidget.h
include/qgis/qgspropertycollection.h
include/qgis/qgspropertyoverridebutton.h
include/qgis/qgspropertytransformer.h
include/qgis/qgsproviderguimetadata.h
include/qgis/qgsproviderguiregistry.h
include/qgis/qgsprovidermetadata.h
include/qgis/qgsproviderregistry.h
include/qgis/qgsproxyprogresstask.h
@ -801,6 +857,7 @@ include/qgis/qgsreferencedgeometry.h
include/qgis/qgsregularpolygon.h
include/qgis/qgsrelation.h
include/qgis/qgsrelationaggregatesearchwidgetwrapper.h
include/qgis/qgsrelationcontext.h
include/qgis/qgsrelationeditorwidget.h
include/qgis/qgsrelationmanager.h
include/qgis/qgsrelationreferenceconfigdlg.h
@ -813,8 +870,10 @@ include/qgis/qgsrelationwidgetwrapper.h
include/qgis/qgsrelief.h
include/qgis/qgsrenderchecker.h
include/qgis/qgsrendercontext.h
include/qgis/qgsrenderedfeaturehandlerinterface.h
include/qgis/qgsrenderer.h
include/qgis/qgsrendererpropertiesdialog.h
include/qgis/qgsrendererrange.h
include/qgis/qgsrendererrasterpropertieswidget.h
include/qgis/qgsrendererregistry.h
include/qgis/qgsrendererwidget.h
@ -874,11 +933,14 @@ include/qgis/qgssqliteutils.h
include/qgis/qgssqlstatement.h
include/qgis/qgsstatisticalsummary.h
include/qgis/qgsstatusbar.h
include/qgis/qgsstoredexpressionmanager.h
include/qgis/qgsstringstatisticalsummary.h
include/qgis/qgsstringutils.h
include/qgis/qgsstyle.h
include/qgis/qgsstyleentityvisitor.h
include/qgis/qgsstyleexportimportdialog.h
include/qgis/qgsstylegroupselectiondialog.h
include/qgis/qgsstyleitemslistwidget.h
include/qgis/qgsstylemanagerdialog.h
include/qgis/qgsstylemodel.h
include/qgis/qgsstylesavedialog.h
@ -980,6 +1042,7 @@ include/qgis/qgsvectorlayerlabelprovider.h
include/qgis/qgsvectorlayerrenderer.h
include/qgis/qgsvectorlayersaveasdialog.h
include/qgis/qgsvectorlayerselectionmanager.h
include/qgis/qgsvectorlayerserverproperties.h
include/qgis/qgsvectorlayertools.h
include/qgis/qgsvectorlayerundocommand.h
include/qgis/qgsvectorlayerundopassthroughcommand.h
@ -1046,7 +1109,7 @@ lib/libqgis_core.so.${PKGVERSION}
lib/libqgis_gui.so
lib/libqgis_gui.so.${PKGVERSION}
lib/libqgis_native.so
lib/libqgis_native.so.3.8.3
lib/libqgis_native.so.${PKGVERSION}
lib/qgis/crssync
lib/qgis/plugins/libarcgisfeatureserverprovider.so
lib/qgis/plugins/libarcgismapserverprovider.so
@ -1056,7 +1119,6 @@ lib/qgis/plugins/libdb2provider.so
lib/qgis/plugins/libdelimitedtextprovider.so
lib/qgis/plugins/libesritokenauthmethod.so
lib/qgis/plugins/libevis.so
lib/qgis/plugins/libgdalprovider.so
lib/qgis/plugins/libgeometrycheckerplugin.so
lib/qgis/plugins/libgeonodeprovider.so
lib/qgis/plugins/libgeorefplugin.so
@ -1067,7 +1129,6 @@ lib/qgis/plugins/libmdalprovider.so
lib/qgis/plugins/libmssqlprovider.so
lib/qgis/plugins/liboauth2authmethod.so
lib/qgis/plugins/libofflineeditingplugin.so
lib/qgis/plugins/libogrprovider.so
lib/qgis/plugins/libowsprovider.so
lib/qgis/plugins/libpkcs12authmethod.so
lib/qgis/plugins/libpkipathsauthmethod.so
@ -1080,7 +1141,6 @@ lib/qgis/plugins/libwfsprovider.so
lib/qgis/plugins/libwmsprovider.so
man/man1/qgis.1
share/applications/org.qgis.qgis.desktop
share/metainfo/org.qgis.qgis.appdata.xml
share/icons/hicolor/128x128/apps/qgis.png
share/icons/hicolor/128x128/mimetypes/qgis-mime.png
share/icons/hicolor/128x128/mimetypes/qgis-qgs.png
@ -1183,6 +1243,7 @@ share/icons/hicolor/scalable/mimetypes/qgis_qgs.svg
share/icons/hicolor/scalable/mimetypes/qgis_qlr.svg
share/icons/hicolor/scalable/mimetypes/qgis_qml.svg
share/icons/hicolor/scalable/mimetypes/qgis_qpt.svg
share/metainfo/org.qgis.qgis.appdata.xml
share/qgis/FindQGIS.cmake
share/qgis/doc/AUTHORS
share/qgis/doc/CONTRIBUTORS
@ -2469,16 +2530,13 @@ share/qgis/resources/cpt-city-qgis-min/wkp/tubs/COPYING.xml
share/qgis/resources/cpt-city-qgis-min/wkp/tubs/DESC.xml
share/qgis/resources/cpt-city-qgis-min/wkp/tubs/nrwc.svg
share/qgis/resources/customization.xml
share/qgis/resources/data/README_world_map.md
share/qgis/resources/data/contributors.json
share/qgis/resources/data/contributors.qml
share/qgis/resources/data/qgis-hackfests.json
share/qgis/resources/data/qgis-hackfests.qml
share/qgis/resources/data/world_map.dbf
share/qgis/resources/data/world_map.prj
share/qgis/resources/data/world_map.qix
share/qgis/resources/data/world_map.qml
share/qgis/resources/data/world_map.shp
share/qgis/resources/data/world_map.shx
share/qgis/resources/data/world_map.gpkg
share/qgis/resources/data/world_map_generalize.model3
share/qgis/resources/metadata-ISO/LinkPropertyLookupTable.csv
share/qgis/resources/metadata-ISO/country_code_ISO_3166.csv
share/qgis/resources/metadata-ISO/language_codes_ISO_639.csv

View file

@ -1,8 +1,6 @@
@comment $NetBSD: PLIST.python,v 1.5 2019/10/29 19:30:11 bouyer Exp $
@comment $NetBSD: PLIST.python,v 1.6 2020/06/21 13:51:49 gdt Exp $
lib/libqgispython.so
lib/libqgispython.so.${PKGVERSION}
lib/qgis/plugins/libarcgisfeatureserverprovider.so
lib/qgis/plugins/libarcgismapserverprovider.so
share/qgis/python/console/__init__.py
share/qgis/python/console/console.py
share/qgis/python/console/console_compile_apis.py
@ -188,6 +186,7 @@ share/qgis/python/plugins/processing/algs/gdal/polygonize.py
share/qgis/python/plugins/processing/algs/gdal/proximity.py
share/qgis/python/plugins/processing/algs/gdal/rasterize.py
share/qgis/python/plugins/processing/algs/gdal/rasterize_over.py
share/qgis/python/plugins/processing/algs/gdal/rasterize_over_fixed_value.py
share/qgis/python/plugins/processing/algs/gdal/rearrange_bands.py
share/qgis/python/plugins/processing/algs/gdal/retile.py
share/qgis/python/plugins/processing/algs/gdal/rgb2pct.py
@ -622,6 +621,7 @@ share/qgis/python/plugins/processing/algs/qgis/BasicStatistics.py
share/qgis/python/plugins/processing/algs/qgis/BoxPlot.py
share/qgis/python/plugins/processing/algs/qgis/Buffer.py
share/qgis/python/plugins/processing/algs/qgis/CheckValidity.py
share/qgis/python/plugins/processing/algs/qgis/Climb.py
share/qgis/python/plugins/processing/algs/qgis/ConcaveHull.py
share/qgis/python/plugins/processing/algs/qgis/CreateAttributeIndex.py
share/qgis/python/plugins/processing/algs/qgis/CreateConstantRaster.py
@ -1249,7 +1249,9 @@ share/qgis/python/plugins/processing/script/ScriptUtils.py
share/qgis/python/plugins/processing/script/__init__.py
share/qgis/python/plugins/processing/tests/AlgorithmsTestBase.py
share/qgis/python/plugins/processing/tests/CheckValidityAlgorithm.py
share/qgis/python/plugins/processing/tests/GdalAlgorithmsTest.py
share/qgis/python/plugins/processing/tests/GdalAlgorithmsGeneralTest.py
share/qgis/python/plugins/processing/tests/GdalAlgorithmsRasterTest.py
share/qgis/python/plugins/processing/tests/GdalAlgorithmsVectorTest.py
share/qgis/python/plugins/processing/tests/Grass7AlgorithmsImageryTest.py
share/qgis/python/plugins/processing/tests/Grass7AlgorithmsRasterTest.py
share/qgis/python/plugins/processing/tests/Grass7AlgorithmsVectorTest.py
@ -1349,6 +1351,7 @@ share/qgis/python/qgis/core/additions/markerlinesymbollayer.py
share/qgis/python/qgis/core/additions/metaenum.py
share/qgis/python/qgis/core/additions/processing.py
share/qgis/python/qgis/core/additions/projectdirtyblocker.py
share/qgis/python/qgis/core/additions/providermetadata.py
share/qgis/python/qgis/core/additions/qgsfeature.py
share/qgis/python/qgis/core/additions/qgsfunction.py
share/qgis/python/qgis/core/additions/qgsgeometry.py

View file

@ -1,18 +1,12 @@
$NetBSD: distinfo,v 1.16 2020/06/21 00:30:04 gdt Exp $
$NetBSD: distinfo,v 1.17 2020/06/21 13:51:49 gdt Exp $
SHA1 (qgis-3.8.3.tar.bz2) = 4ac18e9818e86433901158185e2c807cf418a043
RMD160 (qgis-3.8.3.tar.bz2) = dd90e89d522924cedb5152826eae426ad7aa1754
SHA512 (qgis-3.8.3.tar.bz2) = afe1e5c565c63c7a031da4217339661d1f481a0f1c1672bf197edf334bdb9b1abb22c88fe2ed3d3f1c3ebbe08d51708499cabfbff5e312ad6f39833407df14d8
Size (qgis-3.8.3.tar.bz2) = 82720462 bytes
SHA1 (qgis-3.10.7.tar.bz2) = 3c2f972e5c8ad91d848cd84ee6c7c975cea4c4f3
RMD160 (qgis-3.10.7.tar.bz2) = d38d179ee5ed3f999f47cc3bfcd0fe25e6afb6dc
SHA512 (qgis-3.10.7.tar.bz2) = b10d81d24c7cfb8b285b6d9884dfe19ba33b032cd843d29b879159d203454fd359a669047b677baf515d92ce331ba66f59dc2466beae2048920b2c0da0c3d666
Size (qgis-3.10.7.tar.bz2) = 102154692 bytes
SHA1 (patch-cmake_FindQwt.cmake) = bd0c082e53b8647fcdeb671b932180ec16de49d9
SHA1 (patch-mac_CMakeLists.txt) = 2468c0a629738ce78cccb784395eb1f41049cc73
SHA1 (patch-mac_cmake_1qt.cmake.in) = d74f7201849ef6dd83f39251e466eb04c791c0e6
SHA1 (patch-python_core_conversions.sip) = 41df73f8438569392f2158d83c89e86ae8024319
SHA1 (patch-src_analysis_interpolation_qgsinterpolator.h) = 13e48b38dbe2c2e3a134da7d551a81067ffe25bd
SHA1 (patch-src_core_CMakeLists.txt) = f476770fcb488385723def8aecaa8146de18d624
SHA1 (patch-src_core_dxf_qgsdxfpaintengine.h) = 1c574fa457bb9fbbf3fc5421dd806875a883c518
SHA1 (patch-src_core_geometry_qgscurve.h) = 890b19e0821ac63de53e348ad43ee7b080b9c361
SHA1 (patch-src_core_qgsapplication.cpp) = 9300b9af85281c1b766560e72e52658930f50a12
SHA1 (patch-src_core_symbology_qgssymbollayer.h) = f79e02a6b5440f802ef41126004f8fee92f4f28a
SHA1 (patch-src_crssync_CMakeLists.txt) = 49b551cd2231704dac0872b7c8893b5bdda3e0ad
SHA1 (patch-src_gui_qgsmapoverviewcanvas.cpp) = c0caaae20b12d9363addb1117c9ae1e788e246a9
SHA1 (patch-src_crssync_CMakeLists.txt) = a3f4f9d0ac47bafb7c23931528bbdcbbf08b6098

View file

@ -1,15 +1,15 @@
# $NetBSD: options.mk,v 1.16 2019/11/03 19:30:34 rillig Exp $
# $NetBSD: options.mk,v 1.17 2020/06/21 13:51:49 gdt Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.qgis
PKG_SUPPORTED_OPTIONS= python
# Don't enable python by default because it is not
# supported by gdal-lib and as a result we get a
# warning when qgis is launched.
# XXX fix gdal-lib and reenable this.
# \todo Explain why there is even an option; python is so central and
# qgis is so huge that it is hard to imagine someone wanting to build
# qgis without python.
PKG_SUGGESTED_OPTIONS+= python
.include "../../mk/bsd.options.mk"
# \todo Flip sense of option (if it isn't just removed).
.if empty(PKG_OPTIONS:Mpython)
CMAKE_ARGS+= -DWITH_BINDINGS:BOOL=FALSE
PYTHON_FOR_BUILD_ONLY= YES

View file

@ -1,88 +0,0 @@
$NetBSD: patch-python_core_conversions.sip,v 1.1 2020/06/21 00:30:04 gdt Exp $
Accomodate sip 4.19.23 and qt 5.15
From
https://git.archlinux.org/svntogit/community.git/plain/trunk/qgis-pyqt-5.15.patch?h=packages/qgis&id=fef9f4c085355242e6455de901813e838cc24fd6
--- python/core/conversions.sip.orig 2019-09-13 12:11:09.000000000 +0000
+++ python/core/conversions.sip
@@ -1435,79 +1435,6 @@ template <TYPE>
%End
};
-template <TYPE>
-%MappedType QVector< TYPE* >
-{
-%TypeHeaderCode
-#include <QVector>
-%End
-
-%ConvertFromTypeCode
- // Create the list
- PyObject *l = PyList_New(sipCpp->size());
-
- if (!l)
- return NULL;
-
- // Set the dictionary elements.
- for( int i = 0; i < sipCpp->size(); i++ )
- {
- TYPE *t = sipCpp->at(i);
- PyObject *tobj = sipConvertFromType(t, sipType_TYPE, sipTransferObj);
-
- if (tobj == NULL || PyList_SetItem(l, i, tobj) < 0)
- {
- Py_DECREF(tobj);
- Py_DECREF(l);
- return NULL;
- }
- }
-
- return l;
-%End
-
-%ConvertToTypeCode
- // Check the type if that is all that is required.
- if (sipIsErr == NULL)
- {
- if (!PyList_Check(sipPy))
- return 0;
-
- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i)
- {
- if (!sipCanConvertToType(PyList_GET_ITEM(sipPy, i), sipType_TYPE, SIP_NOT_NONE))
- return 0;
- }
-
- return 1;
- }
-
- QVector<TYPE*> *v = new QVector<TYPE*>( PyList_GET_SIZE(sipPy) );
-
- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i)
- {
- int state;
-
- TYPE *t = reinterpret_cast<TYPE *>(sipConvertToType(PyList_GET_ITEM(sipPy, i), sipType_TYPE, sipTransferObj, SIP_NOT_NONE, &state, sipIsErr));
-
- if (*sipIsErr)
- {
- sipReleaseType(t, sipType_TYPE, state);
- delete v;
- return 0;
- }
-
- v->replace( i, t );
-
- sipReleaseType(t, sipType_TYPE, state);
- }
-
- *sipCppPtr = v;
-
- return sipGetState(sipTransferObj);
-%End
-};
-
%MappedType QMap<qint64, QgsFeature*>
{
%TypeHeaderCode

View file

@ -1,12 +0,0 @@
$NetBSD: patch-src_analysis_interpolation_qgsinterpolator.h,v 1.1 2019/10/29 19:30:11 bouyer Exp $
--- src/analysis/interpolation/qgsinterpolator.h.orig 2019-10-28 16:22:37.673002396 +0100
+++ src/analysis/interpolation/qgsinterpolator.h 2019-10-28 16:22:51.870493221 +0100
@@ -19,6 +19,7 @@
#define QGSINTERPOLATOR_H
#include <QVector>
+#include <QList>
#include "qgis_sip.h"
#include "qgis_analysis.h"

View file

@ -1,16 +0,0 @@
$NetBSD: patch-src_core_dxf_qgsdxfpaintengine.h,v 1.1 2020/06/20 17:52:05 gdt Exp $
Deal with QT 5.15, from upstream.
https://github.com/qgis/QGIS/issues/37005
https://github.com/qgis/QGIS/commit/31f586ec.patch
--- src/core/dxf/qgsdxfpaintengine.h.orig 2019-09-13 12:11:09.000000000 +0000
+++ src/core/dxf/qgsdxfpaintengine.h
@@ -22,6 +22,7 @@
#include "qgis_core.h"
#include <QPaintEngine>
+#include <QPainterPath>
#include "qgsabstractgeometry.h"
class QgsPoint;

View file

@ -1,19 +0,0 @@
$NetBSD: patch-src_core_geometry_qgscurve.h,v 1.1 2020/06/20 17:52:05 gdt Exp $
Deal with QT 5.15, from upstream.
https://github.com/qgis/QGIS/issues/37005
https://github.com/qgis/QGIS/commit/31f586ec.patch
--- src/core/geometry/qgscurve.h.orig 2019-09-13 12:11:09.000000000 +0000
+++ src/core/geometry/qgscurve.h
@@ -22,9 +22,9 @@
#include "qgis_sip.h"
#include "qgsabstractgeometry.h"
#include "qgsrectangle.h"
+#include <QPainterPath>
class QgsLineString;
-class QPainterPath;
/**
* \ingroup core

View file

@ -1,16 +0,0 @@
$NetBSD: patch-src_core_symbology_qgssymbollayer.h,v 1.1 2020/06/20 17:52:05 gdt Exp $
Deal with QT 5.15, from upstream.
https://github.com/qgis/QGIS/issues/37005
https://github.com/qgis/QGIS/commit/31f586ec.patch
--- src/core/symbology/qgssymbollayer.h.orig 2019-09-13 12:11:09.000000000 +0000
+++ src/core/symbology/qgssymbollayer.h
@@ -26,6 +26,7 @@
#include <QSet>
#include <QDomDocument>
#include <QDomElement>
+#include <QPainterPath>
#include "qgssymbol.h"
#include "qgsfields.h"

View file

@ -1,14 +1,17 @@
$NetBSD: patch-src_crssync_CMakeLists.txt,v 1.2 2016/07/01 16:15:18 bouyer Exp $
$NetBSD: patch-src_crssync_CMakeLists.txt,v 1.3 2020/06/21 13:51:49 gdt Exp $
Fix executing dynamically-linked executable from the build directory
--- src/crssync/CMakeLists.txt.orig 2016-06-26 16:02:58.000000000 +0200
+++ src/crssync/CMakeLists.txt 2016-06-26 16:04:09.000000000 +0200
@@ -22,7 +22,7 @@
)
ELSE(MSVC AND NOT USING_NMAKE)
\todo Explain if this should be filed upstream or not.
--- src/crssync/CMakeLists.txt.orig 2020-06-19 12:10:56.000000000 +0000
+++ src/crssync/CMakeLists.txt
@@ -33,7 +33,7 @@ ELSEIF(CMAKE_CROSSCOMPILING)
)
ELSE()
ADD_CUSTOM_TARGET(synccrsdb
- COMMAND ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/crssync
+ COMMAND env LD_LIBRARY_PATH=${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/../lib ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/crssync
DEPENDS crssync
)
ENDIF(MSVC AND NOT USING_NMAKE)
ENDIF()

View file

@ -1,16 +0,0 @@
$NetBSD: patch-src_gui_qgsmapoverviewcanvas.cpp,v 1.1 2020/06/20 17:52:05 gdt Exp $
Deal with QT 5.15, from upstream.
https://github.com/qgis/QGIS/issues/37005
https://github.com/qgis/QGIS/commit/31f586ec.patch
--- src/gui/qgsmapoverviewcanvas.cpp.orig 2019-09-13 12:11:09.000000000 +0000
+++ src/gui/qgsmapoverviewcanvas.cpp
@@ -24,6 +24,7 @@
#include "qgsmaptopixel.h"
#include <QPainter>
+#include <QPainterPath>
#include <QPaintEvent>
#include <QResizeEvent>
#include <QMouseEvent>