Don't try to detect the pkgconfig directory, hard-wire the one used in
pkgsrc. It seems like the detection sometimes picked up the wrong value. Adjust PLIST and bump revision.
This commit is contained in:
parent
13a90f5748
commit
424291cbdb
4 changed files with 36 additions and 4 deletions
|
@ -1,7 +1,8 @@
|
||||||
# $NetBSD: Makefile,v 1.1 2013/03/17 19:37:19 markd Exp $
|
# $NetBSD: Makefile,v 1.2 2013/04/01 12:14:33 joerg Exp $
|
||||||
|
|
||||||
DISTNAME= 3.1.2
|
DISTNAME= 3.1.2
|
||||||
PKGNAME= eigen3-3.1.2
|
PKGNAME= eigen3-3.1.2
|
||||||
|
PKGREVISION= 1
|
||||||
CATEGORIES= math
|
CATEGORIES= math
|
||||||
MASTER_SITES= http://bitbucket.org/eigen/eigen/get/
|
MASTER_SITES= http://bitbucket.org/eigen/eigen/get/
|
||||||
DIST_SUBDIR= eigen3
|
DIST_SUBDIR= eigen3
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
@comment $NetBSD: PLIST,v 1.1 2013/03/17 19:37:19 markd Exp $
|
@comment $NetBSD: PLIST,v 1.2 2013/04/01 12:14:33 joerg Exp $
|
||||||
include/eigen3/Eigen/Array
|
include/eigen3/Eigen/Array
|
||||||
include/eigen3/Eigen/Cholesky
|
include/eigen3/Eigen/Cholesky
|
||||||
include/eigen3/Eigen/CholmodSupport
|
include/eigen3/Eigen/CholmodSupport
|
||||||
|
@ -323,4 +323,4 @@ include/eigen3/unsupported/Eigen/src/SparseExtra/RandomSetter.h
|
||||||
include/eigen3/unsupported/Eigen/src/Splines/Spline.h
|
include/eigen3/unsupported/Eigen/src/Splines/Spline.h
|
||||||
include/eigen3/unsupported/Eigen/src/Splines/SplineFitting.h
|
include/eigen3/unsupported/Eigen/src/Splines/SplineFitting.h
|
||||||
include/eigen3/unsupported/Eigen/src/Splines/SplineFwd.h
|
include/eigen3/unsupported/Eigen/src/Splines/SplineFwd.h
|
||||||
share/pkgconfig/eigen3.pc
|
lib/pkgconfig/eigen3.pc
|
||||||
|
|
|
@ -1,5 +1,6 @@
|
||||||
$NetBSD: distinfo,v 1.1 2013/03/17 19:37:19 markd Exp $
|
$NetBSD: distinfo,v 1.2 2013/04/01 12:14:33 joerg Exp $
|
||||||
|
|
||||||
SHA1 (eigen3/3.1.2.tar.bz2) = b788877a4d4b1685ee2a5d738a65b04b6a21ff3d
|
SHA1 (eigen3/3.1.2.tar.bz2) = b788877a4d4b1685ee2a5d738a65b04b6a21ff3d
|
||||||
RMD160 (eigen3/3.1.2.tar.bz2) = 6bfb07d444445b36fb6aa0e9ff0108bb69b67f10
|
RMD160 (eigen3/3.1.2.tar.bz2) = 6bfb07d444445b36fb6aa0e9ff0108bb69b67f10
|
||||||
Size (eigen3/3.1.2.tar.bz2) = 1052120 bytes
|
Size (eigen3/3.1.2.tar.bz2) = 1052120 bytes
|
||||||
|
SHA1 (patch-CMakeLists.txt) = c6b9aa6c9f100416d12640a8968e02d881238f36
|
||||||
|
|
30
math/eigen3/patches/patch-CMakeLists.txt
Normal file
30
math/eigen3/patches/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,30 @@
|
||||||
|
$NetBSD: patch-CMakeLists.txt,v 1.1 2013/04/01 12:14:34 joerg Exp $
|
||||||
|
|
||||||
|
--- CMakeLists.txt.orig 2013-03-31 22:44:57.000000000 +0000
|
||||||
|
+++ CMakeLists.txt
|
||||||
|
@@ -284,24 +284,10 @@ install(FILES
|
||||||
|
DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Devel
|
||||||
|
)
|
||||||
|
|
||||||
|
-if(EIGEN_BUILD_PKGCONFIG)
|
||||||
|
- SET(path_separator ":")
|
||||||
|
- STRING(REPLACE ${path_separator} ";" pkg_config_libdir_search "$ENV{PKG_CONFIG_LIBDIR}")
|
||||||
|
- message(STATUS "searching for 'pkgconfig' directory in PKG_CONFIG_LIBDIR ( $ENV{PKG_CONFIG_LIBDIR} ), ${CMAKE_INSTALL_PREFIX}/share, and ${CMAKE_INSTALL_PREFIX}/lib")
|
||||||
|
- FIND_PATH(pkg_config_libdir pkgconfig ${pkg_config_libdir_search} ${CMAKE_INSTALL_PREFIX}/share ${CMAKE_INSTALL_PREFIX}/lib ${pkg_config_libdir_search})
|
||||||
|
- if(pkg_config_libdir)
|
||||||
|
- SET(pkg_config_install_dir ${pkg_config_libdir})
|
||||||
|
- message(STATUS "found ${pkg_config_libdir}/pkgconfig" )
|
||||||
|
- else(pkg_config_libdir)
|
||||||
|
- SET(pkg_config_install_dir ${CMAKE_INSTALL_PREFIX}/share)
|
||||||
|
- message(STATUS "pkgconfig not found; installing in ${pkg_config_install_dir}" )
|
||||||
|
- endif(pkg_config_libdir)
|
||||||
|
-
|
||||||
|
configure_file(eigen3.pc.in eigen3.pc)
|
||||||
|
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/eigen3.pc
|
||||||
|
- DESTINATION ${pkg_config_install_dir}/pkgconfig
|
||||||
|
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig"
|
||||||
|
)
|
||||||
|
-endif(EIGEN_BUILD_PKGCONFIG)
|
||||||
|
|
||||||
|
add_subdirectory(Eigen)
|
||||||
|
|
Loading…
Reference in a new issue