Update sysutils/znapzend to 0.15.2
Changelog: - improved systemd integration - new fat release so that znapzend dependencies can be built without internet access - better osx portability - sudo/pfexec fixes - no more multiline error messages
This commit is contained in:
parent
404adc5544
commit
4254da49e6
4 changed files with 15 additions and 51 deletions
|
@ -1,22 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.7 2015/11/25 23:45:10 wiedi Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2016/02/21 15:19:59 wiedi Exp $
|
||||
|
||||
DISTNAME= znapzend-0.14.1
|
||||
DISTNAME= znapzend-0.15.2
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=oetiker/}
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
||||
MAINTAINER= wiedi@frubar.net
|
||||
HOMEPAGE= https://github.com/oetiker/znapzend/
|
||||
COMMENT= ZFS send/receive backup system
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= # none
|
||||
USE_TOOLS+= perl gmake
|
||||
|
||||
CONFIGURE_ARGS+= --enable-pkgonly
|
||||
|
||||
TEST_TARGET= test
|
||||
|
||||
DEPENDS+= p5-Mojolicious>=5.08:../../www/p5-Mojolicious
|
||||
DEPENDS+= p5-Mojo-IOLoop-ForkCall>=0.12:../../devel/p5-Mojo-IOLoop-ForkCall
|
||||
DEPENDS+= p5-Mojolicious>=6.46:../../www/p5-Mojolicious
|
||||
DEPENDS+= p5-Mojo-IOLoop-ForkCall>=0.17:../../devel/p5-Mojo-IOLoop-ForkCall
|
||||
DEPENDS+= p5-Test-Harness>=3.35:../../devel/p5-Test-Harness
|
||||
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.7 2015/12/08 21:22:45 wiedi Exp $
|
||||
$NetBSD: distinfo,v 1.8 2016/02/21 15:19:59 wiedi Exp $
|
||||
|
||||
SHA1 (znapzend-0.14.1.tar.gz) = 5ca2f8255433c54b39ac4c36317a28f2a170df0d
|
||||
RMD160 (znapzend-0.14.1.tar.gz) = 5c596b29f92190f811226b51d41b76a0c66972e3
|
||||
SHA512 (znapzend-0.14.1.tar.gz) = aef7c22eabe8afe21e28a839c27aed0aa6ba6025f3c61a897b77609f64280cdc10ead1a813ea5fe4b47831a7a679ce15bea2ca3890885eb2b6091c4f53dad604
|
||||
Size (znapzend-0.14.1.tar.gz) = 137009 bytes
|
||||
SHA1 (patch-Makefile.in) = 661e103e54748b3d3ebecbd7cef1044468087511
|
||||
SHA1 (patch-lib_Makefile.in) = 879ab9ac43781e270e40eb92d236e915a9e14c8e
|
||||
SHA1 (znapzend-0.15.2.tar.gz) = 3e2e6d1c3dac0e453fd2bddcb36e18c17720ff8f
|
||||
RMD160 (znapzend-0.15.2.tar.gz) = 450de7e87d87bf30ffbac221cf76c8e4190e21f9
|
||||
SHA512 (znapzend-0.15.2.tar.gz) = ff0eadee22dfec91d6d011ebb2636b7188abd00ed64267cf9773f3b34d7cc4a1046834ae0e7e41913cf5e30221e3a4e43c67d73d657cee9a7c10c64f0a5d16be
|
||||
Size (znapzend-0.15.2.tar.gz) = 142052 bytes
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-Makefile.in,v 1.2 2015/12/08 21:22:45 wiedi Exp $
|
||||
|
||||
There is no thirdparty stuff to install
|
||||
Also fix bashisms
|
||||
|
||||
--- Makefile.in.orig 2015-10-12 06:53:47.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -900,13 +900,13 @@ CHANGES: VERSION
|
||||
git log --simplify-merges --full-history --no-merges --pretty=format:'%ai %d %s -- %an' > CHANGES
|
||||
|
||||
all-local:
|
||||
- $(AM_V_GEN)[ "$(MISSING_PERL_MODULES)" == "" ] || $(GMAKE) get-thirdparty-modules
|
||||
+ $(AM_V_GEN)[ "$(MISSING_PERL_MODULES)" = "" ] || $(GMAKE) get-thirdparty-modules
|
||||
|
||||
install-exec-hook:
|
||||
- $(AM_V_GEN)[ "$(PERL5LIB)" == "" ] || cd "$(DESTDIR)$(exec_prefix)" && $(PERL) -i -p -e 's{.*# PERL5LIB}{use lib qw($(PERL5LIB)); # PERL5LIB}' $(BIN)
|
||||
+ $(AM_V_GEN)[ "$(PERL5LIB)" = "" ] || cd "$(DESTDIR)$(exec_prefix)" && $(PERL) -i -p -e 's{.*# PERL5LIB}{use lib qw($(PERL5LIB)); # PERL5LIB}' $(BIN)
|
||||
$(AM_V_GEN)cd "$(DESTDIR)$(exec_prefix)" && $(PERL) -i -p -e 's{.*# LIBDIR}{use lib qw($(libdir)); # LIBDIR}' $(BIN)
|
||||
$(AM_V_GEN)cd "$(DESTDIR)$(exec_prefix)" && $(PERL) -i -p -e 's{^#!.*perl.*}{#!$(PERL)};' $(BIN)
|
||||
- $(AM_V_GEN)cp -fr $(THIRDPARTY_DIR)/lib/perl5/* $(DESTDIR)$(libdir)
|
||||
+ #$(AM_V_GEN)cp -fr $(THIRDPARTY_DIR)/lib/perl5/* $(DESTDIR)$(libdir)
|
||||
|
||||
dist-hook: $(POD) $(MAN) CHANGES
|
||||
$(AM_V_GEN)cd $(distdir) && $(PERL) -i -p -e '"$(PACKAGE_VERSION)" =~ /(\d+)\.(\d+)\.(\d+)/ and $$v = sprintf("%d.%03d%03d",$$1,$$2,$$3) and s/^\$$VERSION\s+=\s+".+?"/\$$VERSION = "$$d"/;' $(BIN)
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-lib_Makefile.in,v 1.1 2015/11/25 23:45:10 wiedi Exp $
|
||||
|
||||
Extra slash confuses OSX
|
||||
|
||||
--- lib/Makefile.in.orig 2015-10-12 06:53:47.000000000 +0000
|
||||
+++ lib/Makefile.in
|
||||
@@ -236,7 +236,7 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-PM := $(shell find ./ -name "*.pm")
|
||||
+PM := $(shell find . -name "*.pm")
|
||||
nobase_data_DATA = $(PM)
|
||||
all: all-am
|
||||
|
Loading…
Reference in a new issue