py-borgbackup: updated to 1.2.7

Version 1.2.7 (2023-12-02)
--------------------------

For upgrade and compatibility hints, please also read the section "Upgrade Notes"
above.

Fixes:

- docs: CVE-2023-36811 upgrade steps: consider checkpoint archives,
- check/compact: fix spurious reappearance of orphan chunks since borg 1.2,
  this consists of 2 fixes:

  - for existing chunks: check --repair: recreate shadow index,
  - for newly created chunks: update shadow index when doing a double-put,
- LockRoster.modify: no KeyError if element was already gone,
- create --X-from-command: run subcommands with a clean environment,
- list --sort-by: support "archive" as alias of "name",
- fix rc and msg if arg parsing throws an exception,

Other changes:

- support and test on Python 3.12
- include unistd.h in _chunker.c (fix for Python 3.13)
- allow msgpack 1.0.6 and 1.0.7
- TAM issues: show tracebacks, improve borg check logging,
- replace "datetime.utcfromtimestamp" with custom helper to avoid
  deprecation warnings when using Python 3.12
- vagrant:

  - use generic/debian9 box, fixes
  - add VM with debian bookworm / test on OpenSSL 3.0.x.
- docs:

  - not only attack/unsafe, can also be a fs issue,
  - point to CVE-2023-36811 upgrade steps from borg 1.1 to 1.2 upgrade steps,
  - upgrade steps needed for all kinds of repos (including "none" encryption mode),
  - upgrade steps: talk about consequences of borg check,
  - upgrade steps: remove period that could be interpreted as part of the command
  - automated-local.rst: use GPT UUID for consistent udev rule
  - create disk/partition sector backup by disk serial number,
  - update macOS hint about full disk access
  - clarify borg prune -a option description,
  - readthedocs: also build offline docs (HTMLzip),
  - frontends: add "check.rebuild_refcounts" message
This commit is contained in:
adam 2024-02-16 20:37:04 +00:00
parent 191f0469ee
commit 42644411d2
4 changed files with 24 additions and 46 deletions

View File

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.48 2023/10/24 22:11:11 wiz Exp $
# $NetBSD: Makefile,v 1.49 2024/02/16 20:37:04 adam Exp $
DISTNAME= borgbackup-1.2.6
DISTNAME= borgbackup-1.2.7
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 2
CATEGORIES= sysutils python
MASTER_SITES= ${MASTER_SITE_PYPI:=b/borgbackup/}
@ -10,19 +9,20 @@ MAINTAINER= bsiegert@NetBSD.org
HOMEPAGE= https://github.com/borgbackup/borg
COMMENT= Deduplicating backup program with compression and encryption
LICENSE= modified-bsd
USE_LANGUAGES= c c++
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm-[0-9]*:../../devel/py-setuptools_scm
TOOL_DEPENDS+= ${PYPKGPREFIX}-pkgconfig-[0-9]*:../../devel/py-pkgconfig
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools-[0-9]*:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm>=1.7:../../devel/py-setuptools_scm
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
DEPENDS+= ${PYPKGPREFIX}-msgpack>=1.0.1:../../devel/py-msgpack
DEPENDS+= ${PYPKGPREFIX}-packaging-[0-9]*:../../devel/py-packaging
TEST_DEPENDS+= ${PYPKGPREFIX}-dateutil-[0-9]*:../../time/py-dateutil
TEST_DEPENDS+= ${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test
USE_LANGUAGES= c c++
PYTHON_SELF_CONFLICT= yes
PYTHON_VERSIONS_INCOMPATIBLE= 27
PYTHON_SELF_CONFLICT= yes
# DISTUTILS_BUILDDIR_IN_TEST_ENV= yes
USE_PKG_RESOURCES= yes
MAKE_ENV+= BORG_OPENSSL_PREFIX=${SSLBASE:Q}
MAKE_ENV+= BORG_LZ4_PREFIX=${BUILDLINK_PREFIX.lz4}
@ -34,14 +34,10 @@ INSTALLATION_DIRS+= ${PKGMANDIR}/man1
post-install:
${INSTALL_MAN} ${WRKSRC}/docs/man/*1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
# doesn't work due to file name mismatch errors
do-test:
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX}
.include "../../archivers/lz4/buildlink3.mk"
.include "../../archivers/zstd/buildlink3.mk"
.include "../../devel/py-cython/buildlink3.mk"
.include "../../lang/python/wheel.mk"
.include "../../security/libb2/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../devel/py-cython/buildlink3.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,6 +1,13 @@
@comment $NetBSD: PLIST,v 1.13 2023/03/24 07:08:55 wiz Exp $
@comment $NetBSD: PLIST,v 1.14 2024/02/16 20:37:04 adam Exp $
bin/borg
bin/borgfs
${PYSITELIB}/${WHEEL_INFODIR}/AUTHORS
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/entry_points.txt
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/borg/__init__.py
${PYSITELIB}/borg/__init__.pyc
${PYSITELIB}/borg/__init__.pyo
@ -235,13 +242,6 @@ ${PYSITELIB}/borg/version.pyo
${PYSITELIB}/borg/xattr.py
${PYSITELIB}/borg/xattr.pyc
${PYSITELIB}/borg/xattr.pyo
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
man/man1/borg-benchmark-crud.1
man/man1/borg-benchmark.1
man/man1/borg-break-lock.1

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.33 2023/09/29 08:10:33 wiz Exp $
$NetBSD: distinfo,v 1.34 2024/02/16 20:37:04 adam Exp $
BLAKE2s (borgbackup-1.2.6.tar.gz) = 544ba97f49a688f8a48d0a9ee0ad6b3130a67607e5c31b7351ef0b9e8c307c15
SHA512 (borgbackup-1.2.6.tar.gz) = 264bf023f4a53f79d8359e1ed0678c7572ad24776e0ddbc5d3446f548629ecea1e0798c33df4464573b1258f47220c86ca964673501dd9b3018484f1f86280f7
Size (borgbackup-1.2.6.tar.gz) = 4355451 bytes
SHA1 (patch-src_borg_helpers_msgpack.py) = 64723191c16805dbf27b0e0c20315ad93c00b06e
BLAKE2s (borgbackup-1.2.7.tar.gz) = 4fb2d009422cd29229ab6b9f93527a6bc7c6ba83c791bd8c693915c82cc879ad
SHA512 (borgbackup-1.2.7.tar.gz) = 313f495d09bff9d2106a2354d02e8b5478dbce279ccfe863d22bbca40fe1bef94fc575e4ae45585a776689fa0058982c4c009c423ac948cc229e15bb5eb5f2bc
Size (borgbackup-1.2.7.tar.gz) = 4370372 bytes

View File

@ -1,17 +0,0 @@
$NetBSD: patch-src_borg_helpers_msgpack.py,v 1.1 2023/09/29 08:10:33 wiz Exp $
Allow msgpack up to 1.0.7.
Loosely based on
https://github.com/borgbackup/borg/commit/cdcab4df6851b5d3da6ac5435bcaeb8aa1d632b5
--- src/borg/helpers/msgpack.py.orig 2023-08-31 21:08:57.000000000 +0000
+++ src/borg/helpers/msgpack.py
@@ -182,7 +182,7 @@ def is_slow_msgpack():
def is_supported_msgpack():
# DO NOT CHANGE OR REMOVE! See also requirements and comments in setup.py.
import msgpack
- return (0, 5, 6) <= msgpack.version <= (1, 0, 5) and \
+ return (0, 5, 6) <= msgpack.version <= (1, 0, 7) and \
msgpack.version not in [(1, 0, 1), ] # < add bad releases here to deny list