py-llvmlite: updated to 0.30.0

v0.30.0:
This release adds support for half-precision float and schedules the
deprecation of memset/memcpy accepting 5 arguments (cf. LLVM change).
* Fix use of -fPIC flag in wheels
* Remove restriction on sphinx version from Anaconda distro
* fix for block labels which contain "interesting" characters
* Deprecate the use of memset/memcpy with alias
* Add fp16 Intrinsics
* Add Half-Precision Type
* Add -fPIC flag for manylinux1 wheel building
* Fix incorrect hierarchy in the documentation for ir.Constant.
* Update docs
* Fix leak on string returning APIs.
This commit is contained in:
adam 2019-10-19 14:10:00 +00:00
parent f42e1bd827
commit 4286315098
3 changed files with 21 additions and 11 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.9 2019/06/02 09:02:45 adam Exp $
# $NetBSD: Makefile,v 1.10 2019/10/19 14:10:00 adam Exp $
DISTNAME= llvmlite-0.29.0
DISTNAME= llvmlite-0.30.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=l/llvmlite/}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.8 2019/06/02 09:02:45 adam Exp $
$NetBSD: distinfo,v 1.9 2019/10/19 14:10:00 adam Exp $
SHA1 (llvmlite-0.29.0.tar.gz) = d5aa70d1a608fd12c225f6177493b431d1f70387
RMD160 (llvmlite-0.29.0.tar.gz) = 9d2518a9f68e07a6ec48682960d6bb4214bf1682
SHA512 (llvmlite-0.29.0.tar.gz) = 6b73d400625a057c2b6bfc3883d516a3e6e1cb56576a8e6f4b52c8cfa30365c2375a5d938e4bfe326f0de0cb1e470028181840e7ccd9c25c2ffe099549567f03
Size (llvmlite-0.29.0.tar.gz) = 109342 bytes
SHA1 (patch-ffi_build.py) = a3241ffc7f208b709053fb04a5225290363ba284
SHA1 (llvmlite-0.30.0.tar.gz) = b353b936f8d46b1bd1fc72813e099270aad877af
RMD160 (llvmlite-0.30.0.tar.gz) = 602cafebbbd51be6782cca04f054b76f17aec2fc
SHA512 (llvmlite-0.30.0.tar.gz) = 2ac376cf708c1e451b188d8ebf8699208e2507f0eeac4e256fde0d5545409601d4b4935346fe5c6a152d34ac194ab88003f1f84c13a7fbe0a6e8f66340ade41a
Size (llvmlite-0.30.0.tar.gz) = 110771 bytes
SHA1 (patch-ffi_build.py) = 9f160e60cc664e8596a74915b7fcda757bd86332

View file

@ -1,10 +1,20 @@
$NetBSD: patch-ffi_build.py,v 1.4 2019/01/02 15:42:17 adam Exp $
$NetBSD: patch-ffi_build.py,v 1.5 2019/10/19 14:10:00 adam Exp $
Allow building with LLVM 9.0.x.
Add NetBSD support.
--- ffi/build.py.orig 2018-07-10 14:46:02.000000000 +0000
--- ffi/build.py.orig 2019-10-10 19:15:38.000000000 +0000
+++ ffi/build.py
@@ -157,6 +157,8 @@ def main():
@@ -109,7 +109,7 @@ def main_posix(kind, library_ext):
out = out.decode('latin1')
print(out)
- if not (out.startswith('8.0.') or out.startswith('7.0.')
+ if not (out.startswith('9.0.') or out.startswith('8.0.') or out.startswith('7.0.')
or out.startswith('7.1.')):
msg = (
"Building llvmlite requires LLVM 7.0+ Be sure to "
@@ -158,6 +158,8 @@ def main():
main_posix('linux', '.so')
elif sys.platform.startswith(('freebsd','openbsd')):
main_posix('freebsd', '.so')