py-django-formtools: updated to 2.5.1
2.5.1 (2023-12-19) - Version 2.5 was never released on PyPi due to a pyproject.toml misconfiguration. 2.5 (2023-11-28) - Confirmed support for Python 3.12 and Django 5.0. - Replaced deprecated pkg_resources usage by importlib.metadata. - Applied PEP 621 (replaced setup.py with pyproject.toml). - Removed Python 3.7 support. - Updated translations (Galician, Portuguese, Slovenian, Serbian).
This commit is contained in:
parent
f2f8aa6a8c
commit
428baa2b9c
4 changed files with 32 additions and 15 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.13 2023/08/08 12:16:08 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.14 2024/01/14 20:58:02 adam Exp $
|
||||
|
||||
DISTNAME= django-formtools-2.4.1
|
||||
DISTNAME= django-formtools-2.5.1
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=d/django-formtools/}
|
||||
|
@ -10,12 +10,14 @@ HOMEPAGE= https://django-formtools.readthedocs.io/
|
|||
COMMENT= Collection of assorted utilities for specific form use cases
|
||||
LICENSE= mit
|
||||
|
||||
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools>=61.2:../../devel/py-setuptools
|
||||
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm-[0-9]*:../../devel/py-setuptools_scm
|
||||
DEPENDS+= ${PYPKGPREFIX}-django>=3.2:../../www/py-django3
|
||||
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
|
||||
DEPENDS+= ${PYPKGPREFIX}-django>=3.2:../../www/py-django
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 27
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../lang/python/wheel.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2023/05/10 09:02:47 adam Exp $
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
|
||||
${PYSITELIB}/${EGG_INFODIR}/requires.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
||||
@comment $NetBSD: PLIST,v 1.5 2024/01/14 20:58:03 adam Exp $
|
||||
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
|
||||
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
|
||||
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
|
||||
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
|
||||
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
|
||||
${PYSITELIB}/formtools/__init__.py
|
||||
${PYSITELIB}/formtools/__init__.pyc
|
||||
${PYSITELIB}/formtools/__init__.pyo
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.9 2023/08/08 12:16:08 adam Exp $
|
||||
$NetBSD: distinfo,v 1.10 2024/01/14 20:58:03 adam Exp $
|
||||
|
||||
BLAKE2s (django-formtools-2.4.1.tar.gz) = c91bac5ab65ab1b8d90197c75382863c509a301c2ba7d2ccdf794becfd17c9f6
|
||||
SHA512 (django-formtools-2.4.1.tar.gz) = 713d138186b9b213de508d82c0981d78c2be4143dc0c3885e9ec56590a6940e089713638e6fbb05a4a9366dc9544ae83c338c380d2840099823d35f09debbd9d
|
||||
Size (django-formtools-2.4.1.tar.gz) = 87172 bytes
|
||||
BLAKE2s (django-formtools-2.5.1.tar.gz) = cad8e215c490eba09073110f5c732ece25607f6d209977cc26520ed55f6914dd
|
||||
SHA512 (django-formtools-2.5.1.tar.gz) = 6b02ebeed472f8a971db648cb6d6feb219f164a02b3eb1cb7db9fb31791ebf70677fd8233629a2e3d454037f1d8b584470eece26395df227e2f12e49962a4358
|
||||
Size (django-formtools-2.5.1.tar.gz) = 88637 bytes
|
||||
SHA1 (patch-pyproject.toml) = 12e3dbe119d9c2d8380f7d20e7ae3f39fbb98053
|
||||
|
|
15
www/py-django-formtools/patches/patch-pyproject.toml
Normal file
15
www/py-django-formtools/patches/patch-pyproject.toml
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-pyproject.toml,v 1.1 2024/01/14 20:58:03 adam Exp $
|
||||
|
||||
Do not install tests.
|
||||
|
||||
--- pyproject.toml.orig 2024-01-14 20:56:10.434397211 +0000
|
||||
+++ pyproject.toml
|
||||
@@ -53,7 +53,7 @@ license-files = ["LICENSE"]
|
||||
zip-safe = false
|
||||
|
||||
[tool.setuptools.packages.find]
|
||||
-exclude = ["tests"] # tests.*
|
||||
+exclude = ["tests", "tests.*"]
|
||||
namespaces = false
|
||||
|
||||
[tool.setuptools_scm]
|
Loading…
Reference in a new issue