Update to 0.70:

- Improve register handling and support with XMS.
  - Fix some issues with deleting open files.(windows only issue)
  - Add dummpy LPT1 class. (windows only issue)
  - Improve some of the internal dos commands. (choice, copy and shift)
  - Improve ROM area. (for games that use it for random numbers or
    overwrite it as some sort of detection thing)
  - Improve compatibility of dynamic core by making it handle certain
    pagefaults earlier.
  - Move internal dos tables around so we have more umb memory.
  - Add some dos tables.
  - Dynamic core supports io exceptions.
  - Move some interrupt handlers to XT Bios locations.
  - Add a dynamic fpu on x86.
  - Improve fpu on non-x86.
  - Trapflag gets strickt priority over hardware IRQs.
  - Trapflag support for the dynamic core.
  - Add dummy TRx handling.
  - Fix a few rarely used character functions.
  - Improve auto cycle guessing code.
  - Improve and extend the joystick support.
  - Add autofire support.
  - Improve the mapper so you can map keys to the joystick and vice versa.
  - A few game specific video card fixes.
  - Fix some 64 bit cpu bugs.
  - Add support for certain cdrom detection schemes.
  - Improve HSG/Red Book support.
  - Improve MSCDEX.
  - Improve dynamic core support under intel macs.
  - Add basic support for clipper programs.
  - Add support for different keyboard layouts.
  - Add auto core guessing.
  - Fix a few flags bugs.
  - Fix a few small cpu bugs.
  - Improve soundblaster detection rate by various programs.
  - Improve EMS emulation. (allow mapping of non standard regions)
  - Improve keyboard input codes on various OS-es.
  - Fix problems with filenames having stackdata in them.
  - Changed a few basic operations in DOSBox so they take emulated time.
  - Improve dos ioctl functions.
  - Improve DOS functions when dealing with virtual drive.
  - Improve FAT drives.
  - Better handling of volume-labels in file functions.
  - Image disk cycling capability. (prompt)
  - Try to reduce the impact of using an analog joystick.
  - Several measures to avoid code invalidation on certain types
    of self modification in the dynamic core.
  - Add dynamic core memory function inlining.
  - A few small mouse improvements. (some games are using things they
    shouldn't)
  - Add nullmodem emulation.(h-a-l-9000)
  - Some small cga and hercules fixes.
  - Add more scalers (hq2x/hq3x/sai). (Kronuz)
  - Change configuration file loading support. It now supports
    multiple configuration files.
  - Make dynamic core capable of running some win32s programs.
  - Fix and add some rare soundblaster modes. (Srecko)
  - Better soundblaster mixer controls. (Srecko)
  - Make soundblaster installation under windows much easier.
  - Add device control channel handling.
  - GEMMIS support (ems under windows).
  - Support more colours in win 3. (vasyl)
  - Don't show unmounted drives in windows filemanager.
  - Fix some bugs in the int13 handler.
  - Simulate some side-effects of bios interrupt handlers on flags.
  - Add IPX functions needed by netbios.
  - Make ports take emulated time.
  - Tabcompletion is now aware of the CD command.
  - Add suppport for the dac pel mask.
  - Fixes to hercules emulation, better detection and bank switching.
  - Fixes to tandy emulation, 640x200x16 mode and different sizes bank.
  - EGA/VGA memory changes detection for faster rendering.
  - Gus 16 bit fixes.
  - Many timer improvements.
  - Some pcjr fixes.
  - Some booter fixes.
  - Many small fixes.
This commit is contained in:
xtraeme 2007-03-26 06:31:55 +00:00
parent a0845ea96a
commit 42a0c0e4af
5 changed files with 54 additions and 7 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.19 2007/01/20 02:25:31 rillig Exp $
# $NetBSD: Makefile,v 1.20 2007/03/26 06:31:55 xtraeme Exp $
DISTNAME= dosbox-0.65
PKGREVISION= 3
DISTNAME= dosbox-0.70
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=dosbox/}
@ -10,6 +9,7 @@ HOMEPAGE= http://dosbox.sourceforge.net/
COMMENT= Multi-platform DOS emulator using SDL
USE_LANGUAGES= c c++
USE_TOOLS+= autoconf
GNU_CONFIGURE= yes
CPPFLAGS.SunOS+= -DDISABLE_JOYSTICK
INSTALLATION_DIRS= share/doc/dosbox
@ -19,6 +19,9 @@ SUBST_STAGE.fixme= post-patch
SUBST_FILES.fixme= docs/dosbox.1
SUBST_SED.fixme= -e s,/usr/share/,${PREFIX}/share/,g
pre-configure:
cd ${WRKSRC} && autoconf
post-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dosbox

View file

@ -1,9 +1,12 @@
$NetBSD: distinfo,v 1.11 2007/01/20 02:25:31 rillig Exp $
$NetBSD: distinfo,v 1.12 2007/03/26 06:31:55 xtraeme Exp $
SHA1 (dosbox-0.65.tar.gz) = 4e9b65c9c2091ab30a952e3b7e63b74df605f419
RMD160 (dosbox-0.65.tar.gz) = 1d05002ae0ddcac74071180d0fa81aba3092e6f1
Size (dosbox-0.65.tar.gz) = 848989 bytes
SHA1 (dosbox-0.70.tar.gz) = de2f63b7246c0e1f7a473b0d4571c4da391a340e
RMD160 (dosbox-0.70.tar.gz) = 85654a664d66d7c1d1d51370d429f503029cb924
Size (dosbox-0.70.tar.gz) = 934649 bytes
SHA1 (patch-aa) = 3393501f0d438e53a55481dc0e237c2bb2a75d3e
SHA1 (patch-ab) = c4555ed9e6337380f52f271025d8f55ed7602aa6
SHA1 (patch-ac) = 84c2a3173a483ccb62917da0b48fd2083963a13b
SHA1 (patch-ad) = 3c0c0eabceb4cefa07918ae1d558e553ff18d592
SHA1 (patch-ae) = f25206fbe82e10443bde2dae49da14441af9ad70
SHA1 (patch-af) = e9984dd18682cacec0985bc354568277bfc1b7cd
SHA1 (patch-ag) = daada4d1c8e9cf35d2d47c8561c0788251ada536

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ae,v 1.1 2007/03/26 06:31:55 xtraeme Exp $
--- configure.in.orig 2007-02-28 20:56:16.000000000 +0100
+++ configure.in 2007-03-26 08:17:48.000000000 +0200
@@ -331,6 +331,10 @@
AC_DEFINE(LINUX, 1, [Compiling on GNU/Linux])
AC_DEFINE(C_DIRECTSERIAL, 1, [ Define to 1 if you want serial passthrough support (Win32, Posix and OS/2).])
;;
+ *-*-freebsd* | *-*-dragonfly* | *-*-netbsd* | *-*-openbsd*)
+ AC_DEFINE(BSD, 1, [Compiling on BSD])
+ AC_DEFINE(C_DIRECTSERIAL, 1, [ Define to 1 if you want serial passthrough support.])
+ ;;
*-*-os2-emx*)
AC_DEFINE(OS2, 1, [Compiling on OS/2 EMX])
AC_DEFINE(C_DIRECTSERIAL, 1, [ Define to 1 if you want serial passthrough support (Win32, Posix and OS/2).])

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1 2007/03/26 06:31:55 xtraeme Exp $
--- src/hardware/serialport/misc_util.h.orig 2007-03-26 08:21:57.000000000 +0200
+++ src/hardware/serialport/misc_util.h 2007-03-26 08:22:08.000000000 +0200
@@ -6,7 +6,7 @@
#include "SDL_net.h"
#include "support.h"
-#if defined LINUX || defined OS2
+#if defined LINUX || defined OS2 || defined BSD
#define NATIVESOCKETS
#elif defined WIN32

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ag,v 1.1 2007/03/26 06:31:55 xtraeme Exp $
--- src/hardware/serialport/misc_util.cpp.orig 2007-03-26 08:23:25.000000000 +0200
+++ src/hardware/serialport/misc_util.cpp 2007-03-26 08:23:49.000000000 +0200
@@ -6,7 +6,7 @@
// C++ SDLnet wrapper
// Socket inheritance
-#if defined LINUX || defined OS2
+#if defined LINUX || defined OS2 || defined BSD
#define CAPWORD (NETWRAPPER_TCP|NETWRAPPER_TCP_NATIVESOCKET)
#ifdef OS2
typedef int socklen_t;