Fix build when ipv6 support is not enabled. Pointed out by wa1ter at

myrealbox.com in tech-pkg@.
This commit is contained in:
jmmv 2004-11-03 13:41:43 +00:00
parent 46922d4544
commit 42d1dc7550
2 changed files with 25 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.28 2004/10/29 14:57:15 jmmv Exp $
$NetBSD: distinfo,v 1.29 2004/11/03 13:41:43 jmmv Exp $
SHA1 (evolution-2.0.2.tar.bz2) = cc2c5d4f9547f5b442487605d9addb29baf52866
Size (evolution-2.0.2.tar.bz2) = 15400311 bytes
SHA1 (patch-aa) = 736bef73496b360a8b0ce1901c2969c6d5ae29e1
SHA1 (patch-ab) = 871a322eefd1a42e7197da764d49cd1d24f6535d
SHA1 (patch-ac) = 410be27f7dab5eccf8e0887474546c2b3600fe80

View file

@ -0,0 +1,23 @@
$NetBSD: patch-ac,v 1.10 2004/11/03 13:41:43 jmmv Exp $
--- camel/camel-service.c.orig 2004-10-11 17:24:23.000000000 +0200
+++ camel/camel-service.c
@@ -36,6 +36,9 @@
#include <errno.h>
#include <sys/poll.h>
+#ifndef ENABLE_IPv6
+#include <sys/socket.h>
+#endif
#include "e-util/e-msgport.h"
@@ -896,7 +899,7 @@ camel_getaddrinfo(const char *name, cons
else
memcpy (&myhints, hints, sizeof (myhints));
- myhints.ai_faimily = AF_INET;
+ myhints.ai_family = AF_INET;
hints = &myhints;
#endif