update to 0.9.1

changes:
        Fixes for compiling on nearly every platform,
	including improved 64bit support
	MSDOS Support
	Add support for sending packets
	OpenBSD pf format support
	IrDA capture (Linux only)

appearently filtering in ieee802_11_radio packets works now
pkgsrc: enabled IPv6 for NetBSD too
This commit is contained in:
drochner 2005-07-13 14:31:49 +00:00
parent eac6d35d8d
commit 4323568256
4 changed files with 20 additions and 24 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.25 2005/05/22 20:08:25 jlam Exp $
# $NetBSD: Makefile,v 1.26 2005/07/13 14:31:49 drochner Exp $
DISTNAME= libpcap-0.8.3
DISTNAME= libpcap-0.9.1
SVR4_PKGNAME= lpcap
CATEGORIES= net
MASTER_SITES= http://www.tcpdump.org/release/
@ -13,15 +13,12 @@ NOT_FOR_PLATFORM+= Interix-*-* # no raw interface access
PKG_INSTALLATION_TYPES= overwrite pkgviews
# tarball contains invalid dir entry libpcap-0.8.3/.; breaks "first" extract
EXTRACT_ELEMENTS= libpcap-0.8.3/./*
GNU_CONFIGURE= yes
USE_TOOLS+= bison gm4 lex
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "SunOS" || ${OPSYS} == "Linux"
.if ${OPSYS} == "SunOS" || ${OPSYS} == "Linux" || ${OPSYS} == "NetBSD"
. if exists(/usr/include/netinet/ip6.h)
CONFIGURE_ARGS+= --enable-ipv6
. endif

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.7 2005/05/30 16:46:21 yyamano Exp $
$NetBSD: distinfo,v 1.8 2005/07/13 14:31:49 drochner Exp $
SHA1 (libpcap-0.8.3.tar.gz) = 24de556bf3dc960ad6c9839ad936037a7c8045e5
RMD160 (libpcap-0.8.3.tar.gz) = f50e9db9d648100cdc9fcbbecde14bfccac2b2b5
Size (libpcap-0.8.3.tar.gz) = 302551 bytes
SHA1 (patch-aa) = 4b0ac3ceb09302f3916a55c05f6dd505df6c086d
SHA1 (libpcap-0.9.1.tar.gz) = e89b48ea8e32da72d276fdf9983ab0d92cfcb076
RMD160 (libpcap-0.9.1.tar.gz) = 13a5fda8a92ada0697c2fe2ef28de9f4067ec430
Size (libpcap-0.9.1.tar.gz) = 421812 bytes
SHA1 (patch-ab) = d6769dd3b6467d20618b1dad3b6a817de19854f8

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.1 2005/05/30 16:46:21 yyamano Exp $
--- nametoaddr.c.orig 2003-11-20 03:13:48.000000000 +0900
+++ nametoaddr.c
@@ -390,7 +390,7 @@ pcap_ether_hostton(const char *name)
* compile on one of 3.x or 4.x).
*/
#if !defined(sgi) && !defined(__NetBSD__) && !defined(__FreeBSD__) && \
- !defined(_UNICOSMP)
+ !defined(_UNICOSMP) && !defined(__APPLE__)
extern int ether_hostton(char *, struct ether_addr *);
#endif

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1 2005/07/13 14:31:49 drochner Exp $
--- pcap-int.h.orig 2005-07-13 13:32:55.000000000 +0200
+++ pcap-int.h
@@ -103,6 +103,7 @@ struct pcap_md {
* Ultrix, DEC OSF/1^H^H^H^H^H^H^H^H^HDigital UNIX^H^H^H^H^H^H^H^H^H^H^H^H
* Tru64 UNIX, and NetBSD pad to make everything line up on a nice boundary.
*/
+#include <sys/param.h>
#if defined(ultrix) || defined(__osf__) || (defined(__NetBSD__) && __NetBSD_Version__ > 106000000)
#define PCAP_FDDIPAD 3
#endif