Forgot to add the new patches for allegro-4.2.2

This commit is contained in:
reinoud 2012-02-20 15:40:55 +00:00
parent f011aa8d35
commit 43279d5af7
3 changed files with 38 additions and 0 deletions

View file

@ -0,0 +1,12 @@
$NetBSD: patch-CMakeLists.txt,v 1.1 2012/02/20 15:40:55 reinoud Exp $
--- CMakeLists.txt.orig 2011-03-24 23:18:50.000000000 +0000
+++ CMakeLists.txt
@@ -434,6 +434,7 @@ if(ALLEGRO_UNIX) # not MACOSX
set(ALLEGRO_WITH_OSSDIGI 1)
set(ALLEGRO_WITH_OSSMIDI 1)
include_directories(SYSTEM ${OSS_INCLUDE_DIR})
+ list(APPEND PLATFORM_LIBS ossaudio)
endif(OSS_FOUND)
endif(WANT_OSS)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-docs_CMakeLists.txt,v 1.1 2012/02/20 15:40:55 reinoud Exp $
--- docs/CMakeLists.txt.orig 2009-10-30 23:05:30.000000000 +0000
+++ docs/CMakeLists.txt
@@ -8,7 +8,7 @@ if(NOT WANT_DOCS OR CMAKE_CROSSCOMPILING
return()
endif()
-set(DOCDIR "doc" CACHE STRING "Install docs into $DOCDIR/allegro-$VERSION")
+set(DOCDIR "share/doc" CACHE STRING "Install docs into $DOCDIR/allegro-$VERSION")
set(ACTUAL_DOC_DIR "${DOCDIR}/allegro-${ALLEGRO_VERSION}")
add_executable(makedoc

View file

@ -0,0 +1,13 @@
$NetBSD: patch-xdga2-include,v 1.1 2012/02/20 15:40:55 reinoud Exp $
--- src/x/xdga2.c.orig 2007-03-24 15:02:01.000000000 +0000
+++ src/x/xdga2.c
@@ -23,7 +23,7 @@
#if (defined ALLEGRO_XWINDOWS_WITH_XF86DGA2) && ((!defined ALLEGRO_WITH_MODULES) || (defined ALLEGRO_MODULE))
#include <X11/Xlib.h>
-#include <X11/extensions/xf86dga.h>
+#include <X11/extensions/Xxf86dga.h>
#define RESYNC() XDGASync(_xwin.display, _xwin.screen);