Update to 1.3.0:

FLAC 1.3.0 (26-May-2013)

    General:
        Move development to Xiph.org git repository.
        The --sector-align option of flac has been deprecated and may not exist in future versions. shntool provides similar functionality.
        Support for the RF64 and Wave64 formats in flac (see below).
        Better handling of cuesheets with non-CD-DA sample rates.
        The --ignore-chunk-sizes option has been added to the flac command line tool.
    FLAC format:
        (none)
    Ogg FLAC format:
        (none)
    flac:
        Added support for encoding from and decoding to the RF64 format, and a new corresponding option --force-rf64-format. (SF #1762502). --keep-foreign-metadata is also supported.
        Added support for encoding from and decoding to the Sony Wave64 format, and a new corresponding option --force-wave64-format. (SF #1769582). --keep-foreign-metadata is also supported.
        Added new options --preserve-modtime and --no-preserve-modtime to specify whether or not output files should copy the timestamp and permissions from their input files. The default is --preserve-modtime as in previous versions. (SF #1805428).
        Allow MM:SS:FF and MM:SS.SS time formats in non-CD-DA cuesheets. (SF #1947353, SF #2182432)
        The --sector-align option of flac has been deprecated and may not exist in future versions. shntool provides similar functionality. (SF #1805946)
        Improved error message when user attempts to decode a non-FLAC file (SF #2222789).
        Fix bug where flac was disallowing use of --replay-gain when encoding from stdin (SF #1840124).
        Fix bug with fractional seconds on some locales (SF #1815517, SF #1858012).
        Read and write appropriate channel masks for 6.1 and 7.1 surround input WAV files. Documentation was also updated.
        Correct Wave64 GUIDs.
        Support 56kHz to 192kHz gain analysis (patch from Earl Chew)
        Add ability to handle utf8 filenames on Windows (large set of patches from Janne Hyvärinen)
    metaflac:
        Allow MM:SS:FF and MM:SS.SS time formats in non-CD-DA cuesheets. (SF #1947353, SF #2182432)
    plugins:
        Minor updates for XMMS plugin.
        Winamp2 plugin was dropped because Nullsoft has provided native FLAC support since 2006.
    build system:
        Fixes for autotools (including SF #1859664).
        Fixes for MinGW (including SF #2000973, SF #2209829).
        Fixes for gcc (including SF #1834168, SF #2002481).
        Fixes for Sun Studio/Forte (SF #1701960).
        Fixes for windows builds (including SF #1676822, SF #1756624, SF #1809863, SF #1911149).
        Fixes for FreeBSD and OpenBSD.
        Compile with GNU gcc _FORTIFY_SOURCE=2 and stack protection where those features are detected.
        Enable a bunch of GCC compiler warnings and fix code that generates warnings.
    documentation:
        Document --ignore-chunk-sizes and --apply-replaygain-which-is-not-lossless option for flac.
    libraries:
        libFLAC encoder was defaulting to level 0 compression instead of 5 (SF #1816825).
        Fix bug in bitreader handling of read callback returning a short count (SF #2490454).
        Improve decoder's ability to distinguish between a FLAC sync code and an MPEG one (SF #2491433).
    Interface changes:
        libFLAC:
            Added FLAC__format_blocksize_is_subset()
        libFLAC++:
            Add a number of convienience methods.
This commit is contained in:
wiz 2013-06-12 20:31:51 +00:00
parent 614c649c0d
commit 435b213ee7
8 changed files with 10 additions and 286 deletions

View file

@ -1,12 +1,12 @@
# $NetBSD: Makefile,v 1.46 2012/09/11 23:59:36 asau Exp $
# $NetBSD: Makefile,v 1.47 2013/06/12 20:31:51 wiz Exp $
DISTNAME= flac-1.2.1
PKGREVISION= 1
DISTNAME= flac-1.3.0
CATEGORIES= audio archivers
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=flac/}
MASTER_SITES= http://downloads.xiph.org/releases/flac/
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://flac.sourceforge.net/
HOMEPAGE= http://xiph.org/flac/
COMMENT= Free lossless audio codec
LICENSE= modified-bsd AND gnu-gpl-v2 AND gnu-lgpl-v2.1

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.12 2009/06/14 17:32:08 joerg Exp $
@comment $NetBSD: PLIST,v 1.13 2013/06/12 20:31:51 wiz Exp $
bin/flac
bin/metaflac
include/FLAC++/all.h
@ -24,191 +24,6 @@ man/man1/metaflac.1
share/aclocal/libFLAC++.m4
share/aclocal/libFLAC.m4
share/doc/${PKGNAME}/FLAC.tag
share/doc/${PKGNAME}/html/api/+_2all_8h-source.html
share/doc/${PKGNAME}/html/api/+_2export_8h-source.html
share/doc/${PKGNAME}/html/api/+_2export_8h.html
share/doc/${PKGNAME}/html/api/+_2metadata_8h-source.html
share/doc/${PKGNAME}/html/api/+_2metadata_8h.html
share/doc/${PKGNAME}/html/api/all_8h-source.html
share/doc/${PKGNAME}/html/api/annotated.html
share/doc/${PKGNAME}/html/api/assert_8h-source.html
share/doc/${PKGNAME}/html/api/callback_8h-source.html
share/doc/${PKGNAME}/html/api/callback_8h.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Decoder_1_1File-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Decoder_1_1File.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Decoder_1_1File.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Decoder_1_1Stream-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Decoder_1_1Stream.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Decoder_1_1Stream.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Decoder_1_1Stream_1_1State-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Decoder_1_1Stream_1_1State.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Encoder_1_1File-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Encoder_1_1File.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Encoder_1_1File.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Encoder_1_1Stream-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Encoder_1_1Stream.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Encoder_1_1Stream.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Encoder_1_1Stream_1_1State-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Encoder_1_1Stream_1_1State.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Application-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Application.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Application.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Chain-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Chain.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Chain_1_1Status-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Chain_1_1Status.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1CueSheet-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1CueSheet.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1CueSheet.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1CueSheet_1_1Track-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1CueSheet_1_1Track.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Iterator-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Iterator.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Padding-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Padding.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Padding.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Picture-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Picture.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Picture.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Prototype-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Prototype.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Prototype.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1SeekTable-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1SeekTable.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1SeekTable.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1SimpleIterator-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1SimpleIterator.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1SimpleIterator_1_1Status-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1SimpleIterator_1_1Status.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1StreamInfo-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1StreamInfo.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1StreamInfo.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Unknown-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Unknown.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1Unknown.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1VorbisComment-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1VorbisComment.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1VorbisComment.png
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1VorbisComment_1_1Entry-members.html
share/doc/${PKGNAME}/html/api/classFLAC_1_1Metadata_1_1VorbisComment_1_1Entry.html
share/doc/${PKGNAME}/html/api/classes.html
share/doc/${PKGNAME}/html/api/decoder_8h-source.html
share/doc/${PKGNAME}/html/api/decoder_8h.html
share/doc/${PKGNAME}/html/api/dir_000000.html
share/doc/${PKGNAME}/html/api/dir_000001.html
share/doc/${PKGNAME}/html/api/dir_000002.html
share/doc/${PKGNAME}/html/api/dirs.html
share/doc/${PKGNAME}/html/api/doxygen.css
share/doc/${PKGNAME}/html/api/doxygen.png
share/doc/${PKGNAME}/html/api/encoder_8h-source.html
share/doc/${PKGNAME}/html/api/encoder_8h.html
share/doc/${PKGNAME}/html/api/export_8h-source.html
share/doc/${PKGNAME}/html/api/export_8h.html
share/doc/${PKGNAME}/html/api/files.html
share/doc/${PKGNAME}/html/api/format_8h-source.html
share/doc/${PKGNAME}/html/api/format_8h.html
share/doc/${PKGNAME}/html/api/functions.html
share/doc/${PKGNAME}/html/api/functions_func.html
share/doc/${PKGNAME}/html/api/functions_vars.html
share/doc/${PKGNAME}/html/api/globals.html
share/doc/${PKGNAME}/html/api/globals_0x66.html
share/doc/${PKGNAME}/html/api/globals_0x67.html
share/doc/${PKGNAME}/html/api/globals_defs.html
share/doc/${PKGNAME}/html/api/globals_enum.html
share/doc/${PKGNAME}/html/api/globals_eval.html
share/doc/${PKGNAME}/html/api/globals_func.html
share/doc/${PKGNAME}/html/api/globals_type.html
share/doc/${PKGNAME}/html/api/globals_vars.html
share/doc/${PKGNAME}/html/api/group__flac.html
share/doc/${PKGNAME}/html/api/group__flac__callbacks.html
share/doc/${PKGNAME}/html/api/group__flac__decoder.html
share/doc/${PKGNAME}/html/api/group__flac__encoder.html
share/doc/${PKGNAME}/html/api/group__flac__export.html
share/doc/${PKGNAME}/html/api/group__flac__format.html
share/doc/${PKGNAME}/html/api/group__flac__metadata.html
share/doc/${PKGNAME}/html/api/group__flac__metadata__level0.html
share/doc/${PKGNAME}/html/api/group__flac__metadata__level1.html
share/doc/${PKGNAME}/html/api/group__flac__metadata__level2.html
share/doc/${PKGNAME}/html/api/group__flac__metadata__object.html
share/doc/${PKGNAME}/html/api/group__flac__stream__decoder.html
share/doc/${PKGNAME}/html/api/group__flac__stream__encoder.html
share/doc/${PKGNAME}/html/api/group__flacpp.html
share/doc/${PKGNAME}/html/api/group__flacpp__decoder.html
share/doc/${PKGNAME}/html/api/group__flacpp__encoder.html
share/doc/${PKGNAME}/html/api/group__flacpp__export.html
share/doc/${PKGNAME}/html/api/group__flacpp__metadata.html
share/doc/${PKGNAME}/html/api/group__flacpp__metadata__level0.html
share/doc/${PKGNAME}/html/api/group__flacpp__metadata__level1.html
share/doc/${PKGNAME}/html/api/group__flacpp__metadata__level2.html
share/doc/${PKGNAME}/html/api/group__flacpp__metadata__object.html
share/doc/${PKGNAME}/html/api/group__porting.html
share/doc/${PKGNAME}/html/api/group__porting__1__1__2__to__1__1__3.html
share/doc/${PKGNAME}/html/api/group__porting__1__1__3__to__1__1__4.html
share/doc/${PKGNAME}/html/api/group__porting__1__1__4__to__1__2__0.html
share/doc/${PKGNAME}/html/api/hierarchy.html
share/doc/${PKGNAME}/html/api/index.html
share/doc/${PKGNAME}/html/api/metadata_8h-source.html
share/doc/${PKGNAME}/html/api/metadata_8h.html
share/doc/${PKGNAME}/html/api/modules.html
share/doc/${PKGNAME}/html/api/ordinals_8h-source.html
share/doc/${PKGNAME}/html/api/stream__decoder_8h-source.html
share/doc/${PKGNAME}/html/api/stream__decoder_8h.html
share/doc/${PKGNAME}/html/api/stream__encoder_8h-source.html
share/doc/${PKGNAME}/html/api/stream__encoder_8h.html
share/doc/${PKGNAME}/html/api/structFLAC____EntropyCodingMethod-members.html
share/doc/${PKGNAME}/html/api/structFLAC____EntropyCodingMethod.html
share/doc/${PKGNAME}/html/api/structFLAC____EntropyCodingMethod__PartitionedRice-members.html
share/doc/${PKGNAME}/html/api/structFLAC____EntropyCodingMethod__PartitionedRice.html
share/doc/${PKGNAME}/html/api/structFLAC____EntropyCodingMethod__PartitionedRiceContents-members.html
share/doc/${PKGNAME}/html/api/structFLAC____EntropyCodingMethod__PartitionedRiceContents.html
share/doc/${PKGNAME}/html/api/structFLAC____Frame-members.html
share/doc/${PKGNAME}/html/api/structFLAC____Frame.html
share/doc/${PKGNAME}/html/api/structFLAC____FrameFooter-members.html
share/doc/${PKGNAME}/html/api/structFLAC____FrameFooter.html
share/doc/${PKGNAME}/html/api/structFLAC____FrameHeader-members.html
share/doc/${PKGNAME}/html/api/structFLAC____FrameHeader.html
share/doc/${PKGNAME}/html/api/structFLAC____IOCallbacks-members.html
share/doc/${PKGNAME}/html/api/structFLAC____IOCallbacks.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamDecoder-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamDecoder.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamEncoder-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamEncoder.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__Application-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__Application.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__CueSheet-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__CueSheet.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__CueSheet__Index-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__CueSheet__Index.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__CueSheet__Track-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__CueSheet__Track.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__Padding-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__Padding.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__Picture-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__Picture.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__SeekPoint-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__SeekPoint.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__SeekTable-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__SeekTable.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__StreamInfo-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__StreamInfo.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__Unknown-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__Unknown.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__VorbisComment-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__VorbisComment.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__VorbisComment__Entry-members.html
share/doc/${PKGNAME}/html/api/structFLAC____StreamMetadata__VorbisComment__Entry.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe-members.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe__Constant-members.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe__Constant.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe__Fixed-members.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe__Fixed.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe__LPC-members.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe__LPC.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe__Verbatim-members.html
share/doc/${PKGNAME}/html/api/structFLAC____Subframe__Verbatim.html
share/doc/${PKGNAME}/html/changelog.html
share/doc/${PKGNAME}/html/comparison.html
share/doc/${PKGNAME}/html/comparison__chopin_prelude_24.html

View file

@ -1,11 +1,6 @@
$NetBSD: distinfo,v 1.20 2010/11/19 12:53:16 obache Exp $
$NetBSD: distinfo,v 1.21 2013/06/12 20:31:51 wiz Exp $
SHA1 (flac-1.2.1.tar.gz) = bd54354900181b59db3089347cc84ad81e410b38
RMD160 (flac-1.2.1.tar.gz) = bd3223c848054f0a75d11200b30f903bdd375bfc
Size (flac-1.2.1.tar.gz) = 2009217 bytes
SHA1 (patch-ad) = 9df5668bb5ffc0850be0a3b34ada825642752874
SHA1 (flac-1.3.0.tar.xz) = a136e5748f8fb1e6c524c75000a765fc63bb7b1b
RMD160 (flac-1.3.0.tar.xz) = 6ced4a7ab2f1b0e583830b0ddc37a842703ee4c9
Size (flac-1.3.0.tar.xz) = 1084256 bytes
SHA1 (patch-af) = a91054ce5d37ac2dc88725fa68c59413b5f52067
SHA1 (patch-ag) = 39cd81f6ad7451c572d5e5c3c697c7afaa1c65a4
SHA1 (patch-ah) = 8a2b3d16731c5a41df5679cae915233ed63fdef0
SHA1 (patch-ay) = f3af19f5f005538580a607887e23679cc0e7f0f2
SHA1 (patch-az) = 2cb3b188d14f388b20831e189317312709d926a8

View file

@ -1,26 +0,0 @@
$NetBSD: patch-ad,v 1.5 2007/01/07 12:25:05 wiz Exp $
--- include/FLAC/ordinals.h.orig 2006-11-20 07:05:18.000000000 +0000
+++ include/FLAC/ordinals.h
@@ -32,7 +32,7 @@
#ifndef FLAC__ORDINALS_H
#define FLAC__ORDINALS_H
-#if !(defined(_MSC_VER) || defined(__BORLANDC__) || defined(__EMX__))
+#if !(defined(_MSC_VER) || defined(__BORLANDC__) || defined(__EMX__) || defined(__INTERIX))
#include <inttypes.h>
#endif
@@ -59,8 +59,12 @@ typedef int32_t FLAC__int32;
typedef int64_t FLAC__int64;
typedef uint16_t FLAC__uint16;
typedef uint32_t FLAC__uint32;
+#if defined __INTERIX
+typedef u_int64_t FLAC__uint64;
+#else
typedef uint64_t FLAC__uint64;
#endif
+#endif
typedef int FLAC__bool;

View file

@ -1,16 +0,0 @@
$NetBSD: patch-ag,v 1.4 2007/11/21 12:47:05 drochner Exp $
--- src/libFLAC/Makefile.am.orig 2007-09-14 23:06:17.000000000 +0200
+++ src/libFLAC/Makefile.am
@@ -94,9 +94,10 @@ extra_ogg_sources = \
ogg_encoder_aspect.c \
ogg_helper.c \
ogg_mapping.c
+extra_ogg_libs = -logg
endif
# see 'http://www.gnu.org/software/libtool/manual.html#Libtool-versioning' for numbering convention
-libFLAC_la_LDFLAGS = -version-info 10:0:2 -lm $(LOCAL_EXTRA_LDFLAGS)
+libFLAC_la_LDFLAGS = -version-info 10:0:2 -lm $(LOCAL_EXTRA_LDFLAGS) $(extra_ogg_libs)
libFLAC_la_SOURCES = \
bitmath.c \
bitreader.c \

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ah,v 1.4 2007/11/21 12:47:05 drochner Exp $
--- src/libFLAC/Makefile.in.orig 2007-09-16 22:05:12.000000000 +0200
+++ src/libFLAC/Makefile.in
@@ -278,8 +278,9 @@ EXTRA_DIST = \
@FLaC__HAS_OGG_TRUE@ ogg_helper.c \
@FLaC__HAS_OGG_TRUE@ ogg_mapping.c
+@FLaC__HAS_OGG_TRUE@extra_ogg_libs = -logg
# see 'http://www.gnu.org/software/libtool/manual.html#Libtool-versioning' for numbering convention
-libFLAC_la_LDFLAGS = -version-info 10:0:2 -lm $(LOCAL_EXTRA_LDFLAGS)
+libFLAC_la_LDFLAGS = -version-info 10:0:2 -lm $(LOCAL_EXTRA_LDFLAGS) $(extra_ogg_libs)
libFLAC_la_SOURCES = \
bitmath.c \
bitreader.c \

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ay,v 1.1 2008/12/29 05:36:40 obache Exp $
--- include/share/alloc.h.orig 2007-09-12 05:32:21.000000000 +0000
+++ include/share/alloc.h
@@ -29,8 +29,10 @@
#include <limits.h> /* for SIZE_MAX */
#if !defined _MSC_VER && !defined __MINGW32__ && !defined __EMX__
+#ifdef HAVE_STDINT_H
#include <stdint.h> /* for SIZE_MAX in case limits.h didn't get it */
#endif
+#endif
#include <stdlib.h> /* for size_t, malloc(), etc */
#ifndef SIZE_MAX

View file

@ -1,14 +0,0 @@
$NetBSD: patch-az,v 1.1 2009/06/05 20:47:30 rillig Exp $
memcpy() needs this.
--- examples/cpp/encode/file/main.cpp.orig 2007-09-13 17:58:03.000000000 +0200
+++ examples/cpp/encode/file/main.cpp 2009-06-05 22:39:37.000000000 +0200
@@ -30,6 +30,7 @@
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include "FLAC++/metadata.h"
#include "FLAC++/encoder.h"