Restrict necessity of libvolume_id to using linux/freebsd/netbsd hald backends.

Fixes build failure on platforms using dummy backend, as PR 40291.
This commit is contained in:
obache 2009-01-03 01:28:34 +00:00
parent efebc46dbf
commit 438b358b86
2 changed files with 27 additions and 17 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.10 2008/12/22 11:06:15 jmcneill Exp $ $NetBSD: distinfo,v 1.11 2009/01/03 01:28:34 obache Exp $
SHA1 (hal-0.5.11.tar.bz2) = 1ddb7895d2ddc2464b553ad11f7ba38860478ae9 SHA1 (hal-0.5.11.tar.bz2) = 1ddb7895d2ddc2464b553ad11f7ba38860478ae9
RMD160 (hal-0.5.11.tar.bz2) = 741cfe82f0bc2d67106b24cfe526a754ab36e45f RMD160 (hal-0.5.11.tar.bz2) = 741cfe82f0bc2d67106b24cfe526a754ab36e45f
@ -19,6 +19,6 @@ SHA1 (patch-am) = 6a4940006e583300d9a983511bdcb05268f74b1a
SHA1 (patch-an) = 0307b2f0f6bb5e4a6d7bf837163e74749b7d24b2 SHA1 (patch-an) = 0307b2f0f6bb5e4a6d7bf837163e74749b7d24b2
SHA1 (patch-ao) = 9099fa4783921a0389b874b8f6d3f7b890810b34 SHA1 (patch-ao) = 9099fa4783921a0389b874b8f6d3f7b890810b34
SHA1 (patch-ap) = 4846d30f51239cca5ea895c700d7a7b15efd948e SHA1 (patch-ap) = 4846d30f51239cca5ea895c700d7a7b15efd948e
SHA1 (patch-na) = 77b7c505bf3644fe19f26463eb1272b7cb3ceaf6 SHA1 (patch-na) = f4344e2aa02e67c968f9723495c533c3a9a199fd
SHA1 (patch-nb) = 1693b7a2faa5bee20a594f0b60b8ff6caea0efdc SHA1 (patch-nb) = 1693b7a2faa5bee20a594f0b60b8ff6caea0efdc
SHA1 (patch-nc) = 32453e49734902749ce24eb4364fc7f531986227 SHA1 (patch-nc) = 32453e49734902749ce24eb4364fc7f531986227

View file

@ -1,8 +1,8 @@
$NetBSD: patch-na,v 1.3 2008/12/20 21:11:05 jmcneill Exp $ $NetBSD: patch-na,v 1.4 2009/01/03 01:28:34 obache Exp $
--- configure.in.orig 2008-05-07 19:24:31.000000000 -0400 --- configure.in.orig 2008-05-07 23:24:31.000000000 +0000
+++ configure.in 2008-12-20 15:28:11.000000000 -0500 +++ configure.in
@@ -448,7 +448,7 @@ @@ -448,7 +448,7 @@ AM_CONDITIONAL([HAVE_LIBPCI], [test "x$U
AC_ARG_WITH([backend], AC_ARG_WITH([backend],
AS_HELP_STRING([--with-backend=<name>], AS_HELP_STRING([--with-backend=<name>],
@ -11,7 +11,7 @@ $NetBSD: patch-na,v 1.3 2008/12/20 21:11:05 jmcneill Exp $
[backend=$withval]) [backend=$withval])
if ! test -z "$with_backend" ; then if ! test -z "$with_backend" ; then
HALD_BACKEND="$with_backend" HALD_BACKEND="$with_backend"
@@ -457,6 +457,9 @@ @@ -457,6 +457,9 @@ else
*-*-solaris*) *-*-solaris*)
HALD_BACKEND="solaris" HALD_BACKEND="solaris"
;; ;;
@ -21,7 +21,7 @@ $NetBSD: patch-na,v 1.3 2008/12/20 21:11:05 jmcneill Exp $
*-*-freebsd*) *-*-freebsd*)
HALD_BACKEND="freebsd" HALD_BACKEND="freebsd"
;; ;;
@@ -472,6 +475,7 @@ @@ -472,6 +475,7 @@ AM_CONDITIONAL(HALD_COMPILE_DUMMY, [test
AM_CONDITIONAL(HALD_COMPILE_LINUX, [test x$HALD_BACKEND = xlinux], [Compiling for Linux]) AM_CONDITIONAL(HALD_COMPILE_LINUX, [test x$HALD_BACKEND = xlinux], [Compiling for Linux])
AM_CONDITIONAL(HALD_COMPILE_FREEBSD, [test x$HALD_BACKEND = xfreebsd], [Compiling for FreeBSD]) AM_CONDITIONAL(HALD_COMPILE_FREEBSD, [test x$HALD_BACKEND = xfreebsd], [Compiling for FreeBSD])
AM_CONDITIONAL(HALD_COMPILE_SOLARIS, [test x$HALD_BACKEND = xsolaris], [Compiling for Solaris]) AM_CONDITIONAL(HALD_COMPILE_SOLARIS, [test x$HALD_BACKEND = xsolaris], [Compiling for Solaris])
@ -29,16 +29,26 @@ $NetBSD: patch-na,v 1.3 2008/12/20 21:11:05 jmcneill Exp $
AC_SUBST(HALD_BACKEND) AC_SUBST(HALD_BACKEND)
dnl DBUS API is subject to changes dnl DBUS API is subject to changes
@@ -644,6 +648,8 @@ @@ -641,13 +645,14 @@ fi
case "$host" in AC_MSG_RESULT($have_glib_2_14)
*-*-solaris*)
;; # volume_id
+*-*-darwin*) -case "$host" in
+ ;; -*-*-solaris*)
*) - ;;
-*)
+case "$HALD_BACKEND" in
+linux|freebsd|netbsd)
PKG_CHECK_MODULES(VOLUME_ID, [$volume_id_module]) PKG_CHECK_MODULES(VOLUME_ID, [$volume_id_module])
AC_SUBST(VOLUME_ID_CFLAGS) AC_SUBST(VOLUME_ID_CFLAGS)
@@ -1004,6 +1010,9 @@ AC_SUBST(VOLUME_ID_LIBS)
+ ;;
+*)
+ ;;
esac
# OS specific libs
@@ -1004,6 +1009,9 @@ hald/linux/addons/Makefile
hald/solaris/Makefile hald/solaris/Makefile
hald/solaris/probing/Makefile hald/solaris/probing/Makefile
hald/solaris/addons/Makefile hald/solaris/addons/Makefile
@ -48,7 +58,7 @@ $NetBSD: patch-na,v 1.3 2008/12/20 21:11:05 jmcneill Exp $
hald/freebsd/Makefile hald/freebsd/Makefile
hald/freebsd/probing/Makefile hald/freebsd/probing/Makefile
hald/freebsd/libprobe/Makefile hald/freebsd/libprobe/Makefile
@@ -1014,6 +1023,7 @@ @@ -1014,6 +1022,7 @@ libhal-storage/Makefile
tools/Makefile tools/Makefile
tools/freebsd/Makefile tools/freebsd/Makefile
tools/linux/Makefile tools/linux/Makefile