Remove www/openjdk7-icedtea-plugin. Superseded by www/icedtea-web.
This commit is contained in:
parent
2230fcb758
commit
4391e0ecec
6 changed files with 0 additions and 104 deletions
|
@ -1 +0,0 @@
|
|||
This is a Java plugin for NPR compatible browsers.
|
|
@ -1,41 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.6 2010/05/23 10:50:42 tnn Exp $
|
||||
#
|
||||
|
||||
DISTNAME= # from icedtea-extras.mk
|
||||
PKGNAME= openjdk7-icedtea-plugin-1.12.0.20100521
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= # from icedtea-extras.mk
|
||||
|
||||
MAINTAINER= tnn@NetBSD.org
|
||||
HOMEPAGE= http://icedtea.classpath.org/
|
||||
COMMENT= Java browser plugin
|
||||
#LICENSE= # GPL2 + Classpath exception
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
ICEDTEA_PACKAGE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
WRKSRC= ${WRKDIR}/${ICEDTEA}
|
||||
|
||||
CONFIGURE_ARGS+= --enable-npplugin
|
||||
|
||||
BUILDLINK_PASSTHRU_DIRS+= ${PREFIX}/java/openjdk7
|
||||
PREPEND_PATH+= ${PREFIX}/java/openjdk7/bin
|
||||
|
||||
SUBST_CLASSES+= fix-paths
|
||||
SUBST_STAGE.fix-paths= pre-configure
|
||||
SUBST_MESSAGE.fix-paths= Fixing paths.
|
||||
SUBST_FILES.fix-paths= plugin/icedteanp/IcedTeaNPPlugin.cc
|
||||
SUBST_SED.fix-paths+= -e 's,%s/../../bin/java,${PREFIX}/java/openjdk7/bin/java,g'
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_PROGRAM} ${WRKSRC}/plugin.build/icedteanp/IcedTeaNPPlugin.so
|
||||
|
||||
INSTALLATION_DIRS+= lib/netscape/plugins
|
||||
|
||||
do-install:
|
||||
${INSTALL_LIB} ${WRKSRC}/plugin.build/icedteanp/IcedTeaNPPlugin.so ${DESTDIR}${PREFIX}/lib/netscape/plugins
|
||||
|
||||
BUILDLINK_API_DEPENDS.xulrunner+= xulrunner>=1.9.1.3nb6
|
||||
.include "../../lang/openjdk7/icedtea-extras.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,2 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/10/14 11:39:25 tnn Exp $
|
||||
lib/netscape/plugins/IcedTeaNPPlugin.so
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.5 2010/05/23 10:50:42 tnn Exp $
|
||||
|
||||
SHA1 (openjdk7/8dc6e1ff8ccf.tar.bz2) = 280e3a66c737c928facdeeb2533215e084513088
|
||||
RMD160 (openjdk7/8dc6e1ff8ccf.tar.bz2) = 50d96c6c81deff07016649498e6efd7f950108cf
|
||||
Size (openjdk7/8dc6e1ff8ccf.tar.bz2) = 4581125 bytes
|
||||
SHA1 (openjdk7/apache-ant-1.8.1-bin.tar.bz2) = 0e0359f04b3d84fed75b3a1ab02cbc415c8864a1
|
||||
RMD160 (openjdk7/apache-ant-1.8.1-bin.tar.bz2) = 2666bd4ca16228a09a7c696cdb7c6108404f21b5
|
||||
Size (openjdk7/apache-ant-1.8.1-bin.tar.bz2) = 6702817 bytes
|
||||
SHA1 (openjdk7/rhino1_7R2.zip) = 3bb380cfb7f6febb87a64b2dee7fa308042f37e4
|
||||
RMD160 (openjdk7/rhino1_7R2.zip) = 58ae321829ac701e442bfbfed3d6f87b2bb6ba4c
|
||||
Size (openjdk7/rhino1_7R2.zip) = 2996867 bytes
|
||||
SHA1 (openjdk7/xalan-j_2_7_1-bin.zip) = 681f04e180de88264bd3df68946001efb0bc2ff1
|
||||
RMD160 (openjdk7/xalan-j_2_7_1-bin.zip) = d7174fcc9dd8b3876b5a9c8cde021953475b57f8
|
||||
Size (openjdk7/xalan-j_2_7_1-bin.zip) = 17336979 bytes
|
||||
SHA1 (patch-aa) = 799f3b8ed3376bde6e200beb1de0a07d8b04f4dc
|
||||
SHA1 (patch-ad) = 7bd1c85839426fd57815286a6e698af265837896
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2010/05/23 10:50:42 tnn Exp $
|
||||
|
||||
--- plugin/icedteanp/IcedTeaPluginRequestProcessor.cc.orig 2010-05-20 13:37:32.000000000 +0000
|
||||
+++ plugin/icedteanp/IcedTeaPluginRequestProcessor.cc
|
||||
@@ -512,8 +512,6 @@ PluginRequestProcessor::sendMember(std::
|
||||
|
||||
NPIdentifier member_identifier;
|
||||
|
||||
- NPIdentifier member_identifier;
|
||||
-
|
||||
int method_id;
|
||||
int instance_id;
|
||||
long reference;
|
|
@ -1,31 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.2 2010/05/23 10:50:42 tnn Exp $
|
||||
|
||||
--- acinclude.m4.orig 2010-05-20 13:37:32.000000000 +0000
|
||||
+++ acinclude.m4
|
||||
@@ -287,7 +287,7 @@ AC_DEFUN([FIND_JAVAH],
|
||||
JAVAH=no
|
||||
])
|
||||
AC_MSG_RESULT(${JAVAH})
|
||||
- if test "x${JAVAH}" == "xno"; then
|
||||
+ if test "x${JAVAH}" = "xno"; then
|
||||
JAVAH=${JAVAH_DEFAULT}
|
||||
fi
|
||||
AC_PATH_PROG(JAVAH, "${JAVAH}")
|
||||
@@ -320,7 +320,7 @@ AC_DEFUN([FIND_JAR],
|
||||
JAR=no
|
||||
])
|
||||
AC_MSG_RESULT(${JAR})
|
||||
- if test "x${JAR}" == "xno"; then
|
||||
+ if test "x${JAR}" = "xno"; then
|
||||
JAR=${JAR_DEFAULT}
|
||||
fi
|
||||
AC_PATH_PROG(JAR, "${JAR}")
|
||||
@@ -854,7 +854,7 @@ AC_DEFUN([ENABLE_HG],
|
||||
[
|
||||
AC_MSG_CHECKING(whether to retrieve the source code from Mercurial)
|
||||
AC_ARG_ENABLE([hg],
|
||||
- [AS_HELP_STRING(--enable-hg,download source code from Mercurial [[default=depends on project]])],
|
||||
+ [AS_HELP_STRING(--enable-hg,download source code from Mercurial)],
|
||||
[
|
||||
case "${enableval}" in
|
||||
no)
|
Loading…
Reference in a new issue