Add an patch to fixes CVE-2008-1097, taken from upstream repository.

Bump PKGREVISION.
This commit is contained in:
obache 2009-08-08 04:41:07 +00:00
parent 32fd9630a8
commit 43c05dd44a
3 changed files with 23 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.21 2009/01/27 04:38:44 obache Exp $
# $NetBSD: Makefile,v 1.22 2009/08/08 04:41:07 obache Exp $
#
DISTNAME= GraphicsMagick-1.3.5
PKGREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=graphicsmagick/} \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.3/

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.17 2009/01/27 04:38:44 obache Exp $
$NetBSD: distinfo,v 1.18 2009/08/08 04:41:07 obache Exp $
SHA1 (GraphicsMagick-1.3.5.tar.gz) = f0a8ba6ccfd03be3fa1d29eaa55b8faa73e5e7a2
RMD160 (GraphicsMagick-1.3.5.tar.gz) = cef96710a916954ecce894b03e058aaf5a304480
Size (GraphicsMagick-1.3.5.tar.gz) = 7386555 bytes
SHA1 (patch-ab) = f4e501afbfb5822a6803be76826e70de9a4cee15

View file

@ -0,0 +1,19 @@
$NetBSD: patch-ab,v 1.1 2009/08/08 04:41:08 obache Exp $
Detect improper rows, columns, or depth.
Fixes CVE-2008-1097 "Memory corruption in ImageMagick's PCX coder".
http://cvs.graphicsmagick.org/cgi-bin/cvsweb.cgi/GraphicsMagick/coders/pcx.c.diff?r1=1.135;r2=1.136
--- coders/pcx.c.orig 2008-11-07 17:36:01.000000000 +0000
+++ coders/pcx.c
@@ -302,6 +302,9 @@ static Image *ReadPCXImage(const ImageIn
*/
image->columns=(pcx_info.right-pcx_info.left)+1;
image->rows=(pcx_info.bottom-pcx_info.top)+1;
+ if ((image->columns == 0) || (image->rows == 0) ||
+ (pcx_info.bits_per_pixel == 0))
+ ThrowReaderException(CorruptImageError,ImproperImageHeader,image);
image->depth=pcx_info.bits_per_pixel <= 8 ? 8 : QuantumDepth;
image->units=PixelsPerInchResolution;
image->x_resolution=pcx_info.horizontal_resolution;