Update databases/mongo-c-driver to 1.8.0.

- The zLib and Snappy compression libraries are bundled if not
  available.
  Wire protocol compression is enabled on Windows.
- mongoc_collection_find_and_modify_with_opts now respects a
  "writeConcern" field in the "extra" BSON document in its
  mongoc_find_and_modify_opts_t.
- The command functions mongoc_client_read_write_command_with_opts,
  mongoc_database_read_write_command_with_opts, and
  mongoc_collection_read_write_command_with_opts now ignore the
  "read_prefs" parameter.
- mongoc_collection_create_index and
  mongoc_collection_create_index_with_opts
  are both now deprecated. Use mongoc_database_write_command_with_opts
  instead; a guide to creating an index using that function has been
  added.
- Use select, not WSAPoll, on Windows.
- Always mark a server "Unknown" after a network error (besides a
  timeout).
- mongoc_client_pool_t sends platform metadata to the server; before,
  only a single mongoc_client_t did.
- New stream method mongoc_stream_timed_out.
- Wire version checks introduced in 1.8.0 will prevent the driver from
  connecting to a future MongoDB server version if its wire protocol is
  incompatible.
- New CMake option ENABLE_MAINTAINER_FLAGS.
This commit is contained in:
fhajny 2017-09-26 14:18:21 +00:00
parent e8a910a2c2
commit 441f2827eb
4 changed files with 37 additions and 15 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.26 2017/08/17 17:04:35 fhajny Exp $
# $NetBSD: Makefile,v 1.27 2017/09/26 14:18:21 fhajny Exp $
DISTNAME= mongo-c-driver-1.7.0
DISTNAME= mongo-c-driver-1.8.0
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_GITHUB:=mongodb/}
@ -43,4 +43,5 @@ PYTHON_FOR_BUILD_ONLY= yes
# libbson and mongo-c-driver released are tied
BUILDLINK_API_DEPENDS.libbson+= libbson>=${PKGVERSION_NOREV}
.include "../../devel/libbson/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.14 2017/09/09 16:14:23 dholland Exp $
@comment $NetBSD: PLIST,v 1.15 2017/09/26 14:18:21 fhajny Exp $
bin/mongoc-stat
include/libmongoc-1.0/mongoc-apm.h
include/libmongoc-1.0/mongoc-bulk-operation.h
@ -25,21 +25,21 @@ include/libmongoc-1.0/mongoc-log.h
include/libmongoc-1.0/mongoc-macros.h
include/libmongoc-1.0/mongoc-matcher.h
include/libmongoc-1.0/mongoc-opcode.h
${PLIST.ssl}include/libmongoc-1.0/mongoc-rand.h
include/libmongoc-1.0/mongoc-rand.h
include/libmongoc-1.0/mongoc-read-concern.h
include/libmongoc-1.0/mongoc-read-prefs.h
include/libmongoc-1.0/mongoc-server-description.h
include/libmongoc-1.0/mongoc-socket.h
${PLIST.ssl}include/libmongoc-1.0/mongoc-ssl.h
include/libmongoc-1.0/mongoc-ssl.h
include/libmongoc-1.0/mongoc-stream-buffered.h
include/libmongoc-1.0/mongoc-stream-file.h
include/libmongoc-1.0/mongoc-stream-gridfs.h
include/libmongoc-1.0/mongoc-stream-socket.h
${PLIST.ssl}include/libmongoc-1.0/mongoc-stream-tls-libressl.h
${PLIST.ssl}include/libmongoc-1.0/mongoc-stream-tls-openssl.h
${PLIST.ssl}include/libmongoc-1.0/mongoc-stream-tls-secure-channel.h
${PLIST.ssl}include/libmongoc-1.0/mongoc-stream-tls-secure-transport.h
${PLIST.ssl}include/libmongoc-1.0/mongoc-stream-tls.h
include/libmongoc-1.0/mongoc-stream-tls-libressl.h
include/libmongoc-1.0/mongoc-stream-tls-openssl.h
include/libmongoc-1.0/mongoc-stream-tls-secure-channel.h
include/libmongoc-1.0/mongoc-stream-tls-secure-transport.h
include/libmongoc-1.0/mongoc-stream-tls.h
include/libmongoc-1.0/mongoc-stream.h
include/libmongoc-1.0/mongoc-topology-description.h
include/libmongoc-1.0/mongoc-uri.h
@ -254,6 +254,7 @@ man/man3/mongoc_collection_validate.3
man/man3/mongoc_collection_write_command_with_opts.3
man/man3/mongoc_common_task_examples.3
man/man3/mongoc_connection_pooling.3
man/man3/mongoc_create_indexes.3
man/man3/mongoc_cursor_clone.3
man/man3/mongoc_cursor_current.3
man/man3/mongoc_cursor_destroy.3
@ -462,6 +463,7 @@ man/man3/mongoc_stream_socket_get_socket.3
man/man3/mongoc_stream_socket_new.3
man/man3/mongoc_stream_socket_t.3
man/man3/mongoc_stream_t.3
man/man3/mongoc_stream_timed_out.3
man/man3/mongoc_stream_tls_t.3
man/man3/mongoc_stream_uncork.3
man/man3/mongoc_stream_write.3
@ -477,6 +479,7 @@ man/man3/mongoc_uri_copy.3
man/man3/mongoc_uri_destroy.3
man/man3/mongoc_uri_get_auth_mechanism.3
man/man3/mongoc_uri_get_auth_source.3
man/man3/mongoc_uri_get_compressors.3
man/man3/mongoc_uri_get_database.3
man/man3/mongoc_uri_get_hosts.3
man/man3/mongoc_uri_get_mechanism_properties.3
@ -495,11 +498,13 @@ man/man3/mongoc_uri_get_username.3
man/man3/mongoc_uri_get_write_concern.3
man/man3/mongoc_uri_new.3
man/man3/mongoc_uri_new_for_host_port.3
man/man3/mongoc_uri_new_with_error.3
man/man3/mongoc_uri_option_is_bool.3
man/man3/mongoc_uri_option_is_int32.3
man/man3/mongoc_uri_option_is_utf8.3
man/man3/mongoc_uri_set_auth_mechanism.3
man/man3/mongoc_uri_set_auth_source.3
man/man3/mongoc_uri_set_compressors.3
man/man3/mongoc_uri_set_database.3
man/man3/mongoc_uri_set_mechanism_properties.3
man/man3/mongoc_uri_set_option_as_bool.3

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.25 2017/09/09 16:15:45 dholland Exp $
$NetBSD: distinfo,v 1.26 2017/09/26 14:18:21 fhajny Exp $
SHA1 (mongo-c-driver-1.7.0.tar.gz) = 92c4a951e3c38ec3ea14d7d545be1afce3b59fb6
RMD160 (mongo-c-driver-1.7.0.tar.gz) = 703cdf6f76238f5dc7fdc00ca33168958fa923ca
SHA512 (mongo-c-driver-1.7.0.tar.gz) = 4e383da2d35ad7b09519b14778242ed36703eec31dae1f8bf486dca32b9cfc71ff810faa30b80512c38ef7c9d1bb3643a0153c4a74c102e0a0a8178eb598f46e
Size (mongo-c-driver-1.7.0.tar.gz) = 7151766 bytes
SHA1 (mongo-c-driver-1.8.0.tar.gz) = 7205b94b98752fd88ae0e16b0a0793d50469f4f2
RMD160 (mongo-c-driver-1.8.0.tar.gz) = 1222e806009f456a47f51ae74079287e67df9454
SHA512 (mongo-c-driver-1.8.0.tar.gz) = c5df689121436c542dc59d7cf13199aa3e3db7aad1ebfe4529e996ecc8c48f645ddcbbe3a46f14ef06004415c12db6f806e76d1e2601ec5e52ee4430baca250c
Size (mongo-c-driver-1.8.0.tar.gz) = 7342685 bytes
SHA1 (patch-configure) = 13c0bf97cdad469d4f592564231f88b0222fa2a1
SHA1 (patch-src_mongoc_mongoc-cursor.c) = 9e0ada19f237972c9671bd90ff656ab9249f694f
SHA1 (patch-tests_test-mongoc-stream-tls-error.c) = 457bf0c4692e39955c7cb2988324d386b7975cb5

View file

@ -0,0 +1,15 @@
$NetBSD: patch-tests_test-mongoc-stream-tls-error.c,v 1.1 2017/09/26 14:18:21 fhajny Exp $
Match conditioning on usage and definition.
--- tests/test-mongoc-stream-tls-error.c.orig 2017-09-07 23:03:30.000000000 +0000
+++ tests/test-mongoc-stream-tls-error.c
@@ -338,7 +338,7 @@ test_stream_tls_error_install (TestSuite
{
#if !defined(MONGOC_ENABLE_SSL_SECURE_CHANNEL) && \
!defined(MONGOC_ENABLE_SSL_LIBRESSL)
-#if !defined(__APPLE__)
+#if !defined(__APPLE__) && !defined(__sun)
TestSuite_Add (suite, "/TLS/hangup", test_mongoc_tls_hangup);
#endif