SoftHSM is an implementation of a cryptographic store accessible through a
PKCS#11 interface. You can use it to explore PKCS#11 without having a Hardware Security Module. It is being developed as a part of the OpenDNSSEC project. SoftHSM uses Botan for its cryptographic operations.
This commit is contained in:
parent
df0c97fa37
commit
445d3b8627
7 changed files with 122 additions and 0 deletions
4
security/softhsm/DESCR
Normal file
4
security/softhsm/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
SoftHSM is an implementation of a cryptographic store accessible through a
|
||||
PKCS#11 interface. You can use it to explore PKCS#11 without having a
|
||||
Hardware Security Module. It is being developed as a part of the OpenDNSSEC
|
||||
project. SoftHSM uses Botan for its cryptographic operations.
|
45
security/softhsm/Makefile
Normal file
45
security/softhsm/Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2010/03/13 17:47:56 pettai Exp $
|
||||
#
|
||||
|
||||
DISTNAME= softhsm-1.1.3
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.opendnssec.org/files/source/
|
||||
|
||||
MAINTAINER= pettai@nordu.net
|
||||
HOMEPAGE= http://www.opendnssec.se/wiki/SoftHSM/
|
||||
COMMENT= Cryptographic store accessible through a PKCS#11 interface
|
||||
LICENSE= 2-clause-bsd
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
BUILD_DEFS+= VARBASE
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX:Q}
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/softhsm
|
||||
|
||||
SUBST_CLASSES+= paths
|
||||
SUBST_FILES.paths= ${WRKSRC}/Makefile.in
|
||||
SUBST_STAGE.paths= post-patch
|
||||
SUBST_SED.paths= -e 's,@EGDIR@,${EGDIR},'
|
||||
|
||||
CXXFLAGS.NetBSD+= -D_NETBSD_SOURCE
|
||||
|
||||
CONF_FILES= ${EGDIR}/softhsm.conf ${PKG_SYSCONFDIR}/softhsm.conf
|
||||
|
||||
INSTALLATION_DIRS= ${EGDIR} ${VARBASE}/softhsm
|
||||
INSTALLATION_DIRS+= etc bin lib
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
pre-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/softhsm.conf ${DESTDIR}${EGDIR}
|
||||
|
||||
.include "../../databases/sqlite3/buildlink3.mk"
|
||||
.include "../../security/botan/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
9
security/softhsm/PLIST
Normal file
9
security/softhsm/PLIST
Normal file
|
@ -0,0 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/03/13 17:47:56 pettai Exp $
|
||||
bin/softhsm
|
||||
bin/softhsm-keyconv
|
||||
lib/libsofthsm.la
|
||||
man/man1/softhsm-keyconv.1
|
||||
man/man1/softhsm.1
|
||||
man/man5/softhsm.conf.5
|
||||
share/examples/softhsm/softhsm.conf
|
||||
share/examples/softhsm/softhsm.conf.sample
|
15
security/softhsm/buildlink3.mk
Normal file
15
security/softhsm/buildlink3.mk
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2010/03/13 17:47:56 pettai Exp $
|
||||
|
||||
BUILDLINK_TREE+= softhsm
|
||||
|
||||
.if !defined(SOFTHSM_BUILDLINK3_MK)
|
||||
SOFTHSM_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.softhsm+= softhsm>=1.1.1
|
||||
BUILDLINK_PKGSRCDIR.softhsm?= ../../wip/softhsm
|
||||
|
||||
.include "../../databases/sqlite3/buildlink3.mk"
|
||||
.include "../../security/botan/buildlink3.mk"
|
||||
.endif # SOFTHSM_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -softhsm
|
6
security/softhsm/distinfo
Normal file
6
security/softhsm/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/03/13 17:47:56 pettai Exp $
|
||||
|
||||
SHA1 (softhsm-1.1.3.tar.gz) = 042deb3027262e8f890b92f5ad633f1ca0d84e5c
|
||||
RMD160 (softhsm-1.1.3.tar.gz) = b955d9fd3cfd03126108d12845df4d658ec236b8
|
||||
Size (softhsm-1.1.3.tar.gz) = 392508 bytes
|
||||
SHA1 (patch-aa) = 5277cf016704aad9b96e7a38b4432a59c9eadb73
|
14
security/softhsm/options.mk
Normal file
14
security/softhsm/options.mk
Normal file
|
@ -0,0 +1,14 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2010/03/13 17:47:56 pettai Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.softhsm
|
||||
PKG_SUPPORTED_OPTIONS= sigver
|
||||
PKG_SUGGESTED_OPTIONS=
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
###
|
||||
### Signature verification for debugging
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Msigver)
|
||||
CONFIGURE_ARGS+= --enable-sigver
|
||||
.endif
|
29
security/softhsm/patches/patch-aa
Normal file
29
security/softhsm/patches/patch-aa
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2010/03/13 17:47:56 pettai Exp $
|
||||
|
||||
--- Makefile.in.orig 2009-12-22 23:14:34.000000000 +0100
|
||||
+++ Makefile.in 2009-12-22 23:16:23.000000000 +0100
|
||||
@@ -256,6 +256,7 @@
|
||||
softhsmdbdir = @softhsmdbdir@
|
||||
srcdir = @srcdir@
|
||||
sysconfdir = @sysconfdir@
|
||||
+EGDIR = @EGDIR@
|
||||
target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
@@ -833,11 +834,11 @@
|
||||
|
||||
|
||||
install-data-hook:
|
||||
- test -d ${sysconfdir} || \
|
||||
- ${INSTALL} -d ${DESTDIR}${sysconfdir}
|
||||
- test -f ${sysconfdir}/softhsm.conf || \
|
||||
- ${INSTALL_DATA} ${top_builddir}/softhsm.conf ${DESTDIR}${sysconfdir}
|
||||
- ${INSTALL_DATA} ${top_builddir}/softhsm.conf ${DESTDIR}${sysconfdir}/softhsm.conf.sample
|
||||
+ test -d ${EGDIR} || \
|
||||
+ ${INSTALL} -d ${DESTDIR}${EGDIR}
|
||||
+ test -f ${EGDIR}/softhsm.conf || \
|
||||
+ ${INSTALL_DATA} ${top_builddir}/softhsm.conf ${DESTDIR}${EGDIR}
|
||||
+ ${INSTALL_DATA} ${top_builddir}/softhsm.conf ${DESTDIR}${EGDIR}/softhsm.conf.sample
|
||||
test -d ${softhsmdbdir} || \
|
||||
${INSTALL} -d -m 700 ${DESTDIR}${softhsmdbdir}
|
||||
|
Loading…
Reference in a new issue