Make this package build on NetBSD 1.6.2.
Patch provided by Bernhard "Burnhard" Riedel in private email. - Remove C99-ism. - Force to use texinfo>=4.2.
This commit is contained in:
parent
61f12b892b
commit
445ec02112
5 changed files with 71 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.45 2004/12/01 21:24:30 xtraeme Exp $
|
||||
# $NetBSD: Makefile,v 1.46 2004/12/08 03:51:54 minskim Exp $
|
||||
# FreeBSD Id: Makefile,v 1.16 1997/07/13 18:49:29 max Exp
|
||||
#
|
||||
|
||||
|
@ -17,6 +17,7 @@ GNU_CONFIGURE= yes
|
|||
WRKSRC= ${WRKDIR}/gv
|
||||
|
||||
USE_MAKEINFO= yes
|
||||
TEXINFO_REQD= 4.2
|
||||
INFO_FILES= gv.info
|
||||
|
||||
XAW_TYPE= 3d
|
||||
|
|
|
@ -1,4 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.8 2004/12/01 21:24:30 xtraeme Exp $
|
||||
$NetBSD: distinfo,v 1.9 2004/12/08 03:51:54 minskim Exp $
|
||||
|
||||
SHA1 (gv-3.6.0.tar.gz) = fbe0d9c3ca514dba9a83ba8fe3d6f79489a1c69c
|
||||
Size (gv-3.6.0.tar.gz) = 542676 bytes
|
||||
SHA1 (patch-aa) = 8dc4c7882e5416ec4773905e2f8700cdbea1c2cf
|
||||
SHA1 (patch-ab) = c2738bfc2db5f041fb0e1c73eff55c2b1895093c
|
||||
SHA1 (patch-ac) = eb1007d4a10b7e9bfcfa22ecd19d2694914ab208
|
||||
|
|
20
print/gv/patches/patch-aa
Normal file
20
print/gv/patches/patch-aa
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-aa,v 1.11 2004/12/08 03:51:54 minskim Exp $
|
||||
|
||||
--- src/main.c.orig Mon Nov 15 22:34:31 2004
|
||||
+++ src/main.c
|
||||
@@ -256,6 +256,7 @@ int main(argc, argv)
|
||||
Dimension maximum_width,maximum_height;
|
||||
unsigned int gwidth=0,gheight=0;
|
||||
int dim_forced;
|
||||
+ int c;
|
||||
|
||||
/*### initializing global variables ####################################*/
|
||||
|
||||
@@ -284,7 +285,6 @@ int main(argc, argv)
|
||||
#endif
|
||||
|
||||
/*### Manage GNU command line arguments ########################*/
|
||||
- int c;
|
||||
while ((c = getopt_long (argc, argv, "vhu", GNU_longOptions, NULL))
|
||||
!= -1)
|
||||
{
|
24
print/gv/patches/patch-ab
Normal file
24
print/gv/patches/patch-ab
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-ab,v 1.6 2004/12/08 03:51:54 minskim Exp $
|
||||
|
||||
--- src/ps.c.orig Mon Nov 15 14:43:29 2004
|
||||
+++ src/ps.c
|
||||
@@ -501,15 +501,15 @@ unc_ok:
|
||||
doc->beginheader = position;
|
||||
section_len = line_len;
|
||||
} else if (iscomment(line,"%PDF-") && cmd_scan_pdf) {
|
||||
-
|
||||
- /* PDF hack to set DELAYSAFER on interpreter invocation */
|
||||
- pdf_delaysafer_hack = 1;
|
||||
-
|
||||
struct document *retval = NULL;
|
||||
FILE *tmpfile = (FILE*)NULL;
|
||||
char *filename_dsc;
|
||||
char cmd[512];
|
||||
char s[512];
|
||||
+
|
||||
+ /* PDF hack to set DELAYSAFER on interpreter invocation */
|
||||
+ pdf_delaysafer_hack = 1;
|
||||
+
|
||||
filename_dsc=file_getTmpFilename(NULL,filename_raw);
|
||||
sprintf(cmd,cmd_scan_pdf,filename,filename_dsc);
|
||||
INFMESSAGE(is PDF)
|
21
print/gv/patches/patch-ac
Normal file
21
print/gv/patches/patch-ac
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-ac,v 1.7 2004/12/08 03:51:54 minskim Exp $
|
||||
|
||||
--- src/resource.c.orig Sun Nov 14 02:16:12 2004
|
||||
+++ src/resource.c
|
||||
@@ -126,6 +126,7 @@ XrmDatabase resource_buildDatabase(displ
|
||||
#ifdef VMS
|
||||
int b;
|
||||
#endif
|
||||
+ String rpath;
|
||||
|
||||
BEGINMESSAGE(resource_buildDatabase)
|
||||
|
||||
@@ -150,7 +151,7 @@ XrmDatabase resource_buildDatabase(displ
|
||||
// s = XtResolvePathname(display,"app-defaults",NULL,NULL,NULL,NULL,0,NULL);
|
||||
/* #endif */
|
||||
|
||||
- String rpath = GV_XtNewString(GV_LIBDIR);
|
||||
+ rpath = GV_XtNewString(GV_LIBDIR);
|
||||
if (rpath) {
|
||||
INFSMESSAGE(merging system resource file into database,rpath)
|
||||
XrmCombineFileDatabase(rpath,&db,True);
|
Loading…
Reference in a new issue