Update pam_radius to 1.4.0. Changelog only says "many changes".
This commit is contained in:
parent
19ffb8bc71
commit
446a9ffa06
6 changed files with 27 additions and 57 deletions
|
@ -1,22 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.5 2015/09/26 20:01:27 bsiegert Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2015/09/26 20:58:06 bsiegert Exp $
|
||||
|
||||
PKGNAME= ${DISTNAME:S/_/-/}
|
||||
DISTNAME= pam_radius-1.3.17
|
||||
DISTNAME= pam_radius-1.4.0
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/old/
|
||||
MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.freeradius.org/pam_radius_auth/
|
||||
COMMENT= PAM module for authentication against a RADIUS server
|
||||
|
||||
NO_CONFIGURE= YES
|
||||
EXTRACT_SUFX= .tar.gz
|
||||
USE_TOOLS+= gmake
|
||||
GNU_CONFIGURE= yes
|
||||
EXTRACT_USING= bsdtar
|
||||
|
||||
INSTALLATION_DIRS= lib/security share/doc/pam-radius share/examples/pam-radius
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/INSTALL ${DESTDIR}${PREFIX}/share/doc/pam-radius
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${PREFIX}/share/doc/pam-radius
|
||||
${INSTALL_DATA} ${WRKSRC}/README.rst ${DESTDIR}${PREFIX}/share/doc/pam-radius
|
||||
${INSTALL_DATA} ${WRKSRC}/USAGE ${DESTDIR}${PREFIX}/share/doc/pam-radius
|
||||
${INSTALL_DATA} ${WRKSRC}/pam_radius_auth.conf \
|
||||
${DESTDIR}${PREFIX}/share/examples/pam-radius
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/06/14 18:13:35 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2015/09/26 20:58:06 bsiegert Exp $
|
||||
lib/security/pam_radius_auth.so
|
||||
share/doc/pam-radius/INSTALL
|
||||
share/doc/pam-radius/README
|
||||
share/doc/pam-radius/README.rst
|
||||
share/doc/pam-radius/USAGE
|
||||
share/examples/pam-radius/pam_radius_auth.conf
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2015/09/26 20:01:27 bsiegert Exp $
|
||||
$NetBSD: distinfo,v 1.4 2015/09/26 20:58:06 bsiegert Exp $
|
||||
|
||||
SHA1 (pam_radius-1.3.17.tar.gz) = 7623ca1b636bba729c69c3f50254b856bb4519a7
|
||||
RMD160 (pam_radius-1.3.17.tar.gz) = c3873d5a4275170420f98c2f37def0593293f463
|
||||
Size (pam_radius-1.3.17.tar.gz) = 31341 bytes
|
||||
SHA1 (patch-Makefile) = 192a300d690aa096fd31b3ffdb2394761ded23cc
|
||||
SHA1 (patch-pam_radius_auth.c) = ac1886fc20757a3787f57071c514e4518b4c25bd
|
||||
SHA1 (pam_radius-1.4.0.tar.gz) = 161af24355b79736bb63ba1cf9e627f9ca6e1671
|
||||
RMD160 (pam_radius-1.4.0.tar.gz) = 765bf1d81243504b6fccbab4032baba424dd8d33
|
||||
Size (pam_radius-1.4.0.tar.gz) = 179458 bytes
|
||||
SHA1 (patch-src_pam__radius__auth.h) = e17931e1789636f6bccf80e51d2f875d36ed7681
|
||||
|
|
|
@ -1,7 +0,0 @@
|
|||
--- Makefile 2007-03-25 23:22:11.000000000 -0500
|
||||
+++ Makefile 2012-11-30 15:29:34.000000000 -0600
|
||||
@@ -17,3 +17,3 @@
|
||||
#
|
||||
-CFLAGS = -Wall -fPIC
|
||||
+CFLAGS = -Wall -fPIC -DNO_STATIC_MODULES
|
||||
#
|
|
@ -1,36 +0,0 @@
|
|||
--- pam_radius_auth.c 2007-03-26 04:36:13.000000000 -0500
|
||||
+++ pam_radius_auth.c 2012-11-30 15:53:29.000000000 -0600
|
||||
@@ -58,6 +58,5 @@
|
||||
#include <errno.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
-#ifdef sun
|
||||
#include <security/pam_appl.h>
|
||||
-#endif
|
||||
#include <security/pam_modules.h>
|
||||
@@ -184,3 +183,3 @@
|
||||
while(*ip_str != '.' && *ip_str != '\0' && count < 4) {
|
||||
- if(!isdigit(*ip_str)) {
|
||||
+ if(!isdigit((unsigned char)*ip_str)) {
|
||||
return((UINT4)0);
|
||||
@@ -220,3 +219,3 @@
|
||||
digit_count = 0;
|
||||
- } else if(!isdigit(*addr)) {
|
||||
+ } else if(!isdigit((unsigned char)*addr)) {
|
||||
dot_count = 5;
|
||||
@@ -276,3 +275,3 @@
|
||||
if (!server->port) {
|
||||
- if (p && isdigit(*p)) { /* the port looks like it's a number */
|
||||
+ if (p && isdigit((unsigned char)*p)) { /* the port looks like it's a number */
|
||||
unsigned int i = atoi(p) & 0xffff;
|
||||
@@ -768,3 +767,4 @@
|
||||
{
|
||||
- int salen, total_length;
|
||||
+ socklen_t salen;
|
||||
+ int total_length;
|
||||
fd_set set;
|
||||
@@ -1101,3 +1101,3 @@
|
||||
if (!strcmp("root", user)) {
|
||||
- user = userinfo;
|
||||
+ user = (char *)userinfo;
|
||||
DPRINT(LOG_DEBUG, "Username now %s from ruser", user);
|
13
security/pam-radius/patches/patch-src_pam__radius__auth.h
Normal file
13
security/pam-radius/patches/patch-src_pam__radius__auth.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-src_pam__radius__auth.h,v 1.1 2015/09/26 20:58:06 bsiegert Exp $
|
||||
|
||||
--- src/pam_radius_auth.h.orig 2014-12-17 22:00:59.000000000 +0000
|
||||
+++ src/pam_radius_auth.h
|
||||
@@ -83,7 +83,7 @@ typedef struct radius_conf_t {
|
||||
*************************************************************************/
|
||||
|
||||
#ifndef CONST
|
||||
-# if defined(__sun) || defined(__linux__) || defined(__FreeBSD__) || defined(__APPLE__)
|
||||
+# if defined(__sun) || defined(__linux__) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__APPLE__)
|
||||
/*
|
||||
* On older versions of Solaris, you may have to change this to:
|
||||
* #define CONST
|
Loading…
Reference in a new issue