* Install Geo information.
* Depend on py-mako, so maps get be generated. * Don't discard badly checksummed packets. * Clean-up.
This commit is contained in:
parent
8c911972ee
commit
447ded3504
6 changed files with 32 additions and 39 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.64 2011/02/09 08:37:10 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.65 2011/02/11 11:12:14 adam Exp $
|
||||
|
||||
DISTNAME= ntop-4.0.3
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ntop/}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -13,10 +14,11 @@ LICENSE= gnu-gpl-v3
|
|||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
CONFLICTS= ntop-[0-9]*
|
||||
DEPENDS+= ${PYPKGPREFIX}-mako-[0-9]*:../../devel/py-mako
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= aclocal autoconf autoheader automake gawk gmake
|
||||
USE_TOOLS+= aclocal autoconf autoheader automake gawk gmake gunzip
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/share/ntop
|
||||
|
@ -47,7 +49,6 @@ pre-configure:
|
|||
libtoolize -c -f; cp m4/libtool.m4 libtool.m4.in; \
|
||||
cat acinclude.m4.in libtool.m4.in acinclude.m4.ntop > acinclude.m4; \
|
||||
aclocal; autoheader; automake -a --foreign -i; autoconf
|
||||
# cp ${PREFIX}/share/libtool/config/ltmain.sh .; \
|
||||
|
||||
.include "../../databases/gdbm/buildlink3.mk"
|
||||
.include "../../databases/rrdtool/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.12 2010/07/22 21:10:52 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.13 2011/02/11 11:12:14 adam Exp $
|
||||
bin/ntop
|
||||
lib/libcpacketPlugin-${PKGVERSION}.so
|
||||
lib/libcpacketPlugin.so
|
||||
|
@ -406,6 +406,8 @@ share/ntop/html/web.gif
|
|||
share/ntop/html/wheel.gif
|
||||
share/ntop/html/white_bg.gif
|
||||
share/ntop/html/zoom.js
|
||||
share/ntop/ntop/GeoIPASNum.dat
|
||||
share/ntop/ntop/GeoLiteCity.dat
|
||||
share/ntop/ntop/ntop-cert.pem
|
||||
share/ntop/ntop/oui.txt.gz
|
||||
share/ntop/ntop/specialMAC.txt.gz
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.17 2011/02/09 08:37:10 adam Exp $
|
||||
$NetBSD: distinfo,v 1.18 2011/02/11 11:12:14 adam Exp $
|
||||
|
||||
SHA1 (ntop-4.0.3.tgz) = e7c31eabf31f61758e97d69398176520c1cb5613
|
||||
RMD160 (ntop-4.0.3.tgz) = a7b0f15409fee6b53b7c10d8b397fe0ade13120f
|
||||
Size (ntop-4.0.3.tgz) = 39191671 bytes
|
||||
SHA1 (patch-aa) = e04050a3ca4364898f3d0bf892290f90cc23b092
|
||||
SHA1 (patch-ab) = f989f36ef5ea96d6e1256496ad44879956d0c723
|
||||
SHA1 (patch-aa) = ccc5cb9532ba8591db5d131c06b516d4ae92cb4e
|
||||
SHA1 (patch-ab) = 7b8a00bc8e107f33b9bf0199ce4a7c9cb5fc1bc5
|
||||
SHA1 (patch-ac) = f947853ed8f4f77f55f75adedacf16b179513202
|
||||
SHA1 (patch-pbuf.c) = 92bb03cd3bb82b60cfbc958ab2854308b36a653d
|
||||
|
|
|
@ -1,27 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.13 2010/07/22 21:10:52 adam Exp $
|
||||
$NetBSD: patch-aa,v 1.14 2011/02/11 11:12:15 adam Exp $
|
||||
|
||||
--- Makefile.am.orig 2010-04-25 12:52:28.000000000 +0000
|
||||
+++ Makefile.am
|
||||
@@ -74,9 +74,7 @@ ETTER_PASSIVE_DOWNLOAD_PARMS = "rev=HEAD
|
||||
NTOPDATA = ntop-cert.pem \
|
||||
$(ETTER_PASSIVE) \
|
||||
oui.txt.gz \
|
||||
- specialMAC.txt.gz \
|
||||
- GeoIPASNum.dat \
|
||||
- GeoLiteCity.dat
|
||||
+ specialMAC.txt.gz
|
||||
|
||||
NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
|
||||
html/*.css html/*.dtd \
|
||||
@@ -157,8 +155,6 @@ man_MANS = ntop.8
|
||||
.PHONY: snapshot
|
||||
|
||||
|
||||
-acinclude.m4: acinclude.m4.ntop libtool.m4.in
|
||||
- @cat acinclude.m4.ntop libtool.m4.in >acinclude.m4
|
||||
|
||||
CLEANLIST = `ls -l $(DESTDIR)$(libdir)/*ntop*.so $(DESTDIR)$(libdir)/*Plugin*.so | \
|
||||
grep -v $(VERSION) | \
|
||||
@@ -336,7 +332,7 @@ install: install-recursive
|
||||
install-selinux-policy:
|
||||
chcon -t textrel_shlib_t $(DESTDIR)$(libdir)/*ntop*.so
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ab,v 1.19 2011/02/09 08:37:10 adam Exp $
|
||||
$NetBSD: patch-ab,v 1.20 2011/02/11 11:12:15 adam Exp $
|
||||
|
||||
--- configure.in.orig 2010-10-24 10:01:01.000000000 +0000
|
||||
+++ configure.in
|
||||
|
@ -33,19 +33,16 @@ $NetBSD: patch-ab,v 1.19 2011/02/09 08:37:10 adam Exp $
|
|||
PCAP_ROOT=`cd ${PCAP_ROOT} && pwd`
|
||||
CORELIBS="${CORELIBS} -L$PCAP_ROOT -lpcap"
|
||||
INCS="${INCS} -I$PCAP_ROOT"
|
||||
@@ -1829,11 +1842,7 @@ if test -f "GeoLiteCity.dat"; then
|
||||
@@ -1829,8 +1842,6 @@ if test -f "GeoLiteCity.dat"; then
|
||||
else
|
||||
if test -f "3rd_party/GeoLiteCity.dat.gz"; then
|
||||
cp 3rd_party/GeoLiteCity.dat.gz .
|
||||
- else
|
||||
- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
|
||||
fi
|
||||
-
|
||||
- gunzip GeoLiteCity.dat.gz
|
||||
fi
|
||||
|
||||
dnl> --------
|
||||
@@ -1843,11 +1852,8 @@ if test -f "GeoIPASNum.dat"; then
|
||||
gunzip GeoLiteCity.dat.gz
|
||||
@@ -1843,8 +1852,6 @@ if test -f "GeoIPASNum.dat"; then
|
||||
else
|
||||
if test -f "3rd_party/GeoIPASNum.dat.gz"; then
|
||||
cp 3rd_party/GeoIPASNum.dat.gz .
|
||||
|
@ -53,7 +50,4 @@ $NetBSD: patch-ab,v 1.19 2011/02/09 08:37:10 adam Exp $
|
|||
- wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
|
||||
fi
|
||||
|
||||
- gunzip GeoIPASNum.dat.gz
|
||||
fi
|
||||
else
|
||||
AC_MSG_RESULT(Please install GeoIP (http://www.maxmind.com/))
|
||||
gunzip GeoIPASNum.dat.gz
|
||||
|
|
15
net/ntop/patches/patch-pbuf.c
Normal file
15
net/ntop/patches/patch-pbuf.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-pbuf.c,v 1.1 2011/02/11 11:12:15 adam Exp $
|
||||
|
||||
Do not discard packets with bad checksum.
|
||||
Bad checksum may occur when local interface has hardware-assisted checksumming.
|
||||
|
||||
--- pbuf.c.orig 2011-02-11 10:00:09.000000000 +0000
|
||||
+++ pbuf.c
|
||||
@@ -1175,7 +1175,6 @@ static void processIpPkt(const u_char *b
|
||||
&& (in_cksum((const u_short *)bp, hlen, 0) != 0)
|
||||
) {
|
||||
incrementTrafficCounter(&myGlobals.device[actualDeviceId].rcvdPktStats.badChecksum, 1);
|
||||
- return;
|
||||
}
|
||||
|
||||
/*
|
Loading…
Reference in a new issue