net/dnsdist: Update to 1.3.2
New features: - Add support for more than one TLS certificate - Add a negative ttl option to the packet cache - Add the ability to dump a summary of the cache content - Add netmask-based {ex,in}clusions to DynblockRulesGroup - Add DNSAction.NoOp to debug dynamic blocks - Add SetECSAction to set an arbitrary outgoing ecs value - Add support for rotating certificates and keys
This commit is contained in:
parent
e9cd6002d7
commit
44976552c5
5 changed files with 8 additions and 56 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.6 2018/02/27 11:06:35 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2018/08/04 21:40:53 minskim Exp $
|
||||
|
||||
DISTNAME= dnsdist-1.2.1
|
||||
DISTNAME= dnsdist-1.3.2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= https://downloads.powerdns.com/releases/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -11,7 +11,7 @@ COMMENT= Highly DNS-, DoS- and abuse-aware loadbalancer
|
|||
LICENSE= gnu-gpl-v2
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LANGUAGES= c c++11
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
|
|
@ -1,12 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.4 2018/02/27 11:06:35 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.5 2018/08/04 21:40:53 minskim Exp $
|
||||
|
||||
SHA1 (dnsdist-1.2.1.tar.bz2) = 96d7510dcc866444a60785cee63c12b1f596cb3c
|
||||
RMD160 (dnsdist-1.2.1.tar.bz2) = 8484636a2bdd1b49e841c07670dbf12d1ebee8f6
|
||||
SHA512 (dnsdist-1.2.1.tar.bz2) = 0f88fbe15d79e5b6240343a660b4207502523877114056dfce7995079f48bdfd9d901bae1e018edc2286af5a110b1ffe2503fc196d2bda9ca9a85d76ff585d28
|
||||
Size (dnsdist-1.2.1.tar.bz2) = 866549 bytes
|
||||
SHA1 (patch-dns.hh) = 13834e3d9f48b3095ce4912540c7d0d275c3a3a3
|
||||
SHA1 (patch-dnsdist-console.cc) = ee5f40a2257128eb7fcc2b581ec9aa997c1b7358
|
||||
SHA1 (patch-dnsdist.cc) = 2b2bf569c134019dd8a5d4f3df104fdd16a47a31
|
||||
SHA1 (dnsdist-1.3.2.tar.bz2) = 6934250d90bb5de4a723cad3572ad2225be9211e
|
||||
RMD160 (dnsdist-1.3.2.tar.bz2) = 4b19dc9a1e6ba008a10be136385d1a297dbb1f87
|
||||
SHA512 (dnsdist-1.3.2.tar.bz2) = af7c360d6a5255bc9588622747b8939d30669e2d7d749275b30a9be8cf306a92768327057a93bfa901c44ac8a7572c9bb801a7f6ceca6d736f3e9c71f80f5726
|
||||
Size (dnsdist-1.3.2.tar.bz2) = 918200 bytes
|
||||
SHA1 (patch-ext_json11_json11.cpp) = 9fb12578d80103b8b92e984a483cbda98fd83db8
|
||||
SHA1 (patch-iputils.hh) = 78ffc93b3062d18a02a9ea67e4c6d58d8df7bdbb
|
||||
SHA1 (patch-qtype.hh) = 4551be1e303a31d34030c363849398923f5ff987
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-dns.hh,v 1.1 2017/03/31 20:49:51 fhajny Exp $
|
||||
|
||||
Add NetBSD support.
|
||||
|
||||
--- dns.hh.orig 2016-12-29 12:45:46.000000000 +0000
|
||||
+++ dns.hh
|
||||
@@ -146,7 +146,7 @@ struct EDNS0Record
|
||||
|
||||
static_assert(sizeof(EDNS0Record) == 4, "EDNS0Record size must be 4");
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__APPLE__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__FreeBSD_kernel__)
|
||||
+#if defined(__FreeBSD__) || defined(__APPLE__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__FreeBSD_kernel__) || defined(__NetBSD__)
|
||||
#include <machine/endian.h>
|
||||
#elif __linux__ || __GNU__
|
||||
# include <endian.h>
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-dnsdist-console.cc,v 1.2 2017/08/22 17:00:35 fhajny Exp $
|
||||
|
||||
Add NetBSD support.
|
||||
|
||||
--- dnsdist-console.cc.orig 2017-08-21 12:52:09.000000000 +0000
|
||||
+++ dnsdist-console.cc
|
||||
@@ -23,7 +23,7 @@
|
||||
#include "sodcrypto.hh"
|
||||
#include "pwd.h"
|
||||
|
||||
-#if defined (__OpenBSD__)
|
||||
+#if defined (__OpenBSD__) || defined (__NetBSD__)
|
||||
#include <readline/readline.h>
|
||||
#include <readline/history.h>
|
||||
#else
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-dnsdist.cc,v 1.1 2017/03/31 20:49:51 fhajny Exp $
|
||||
|
||||
Add NetBSD support.
|
||||
|
||||
--- dnsdist.cc.orig 2016-12-29 12:45:46.000000000 +0000
|
||||
+++ dnsdist.cc
|
||||
@@ -27,7 +27,7 @@
|
||||
#include <limits>
|
||||
#include "dolog.hh"
|
||||
|
||||
-#if defined (__OpenBSD__)
|
||||
+#if defined (__OpenBSD__) || defined (__NetBSD__)
|
||||
#include <readline/readline.h>
|
||||
#else
|
||||
#include <editline/readline.h>
|
Loading…
Reference in a new issue