Addition of gnome-libs-0.27, the libaries for the GNU Network Object
Model Environment, to the NetBSD packages collection.
This commit is contained in:
parent
966ce7c90d
commit
44a5d4a763
9 changed files with 303 additions and 0 deletions
32
x11/gnome-libs/Makefile
Normal file
32
x11/gnome-libs/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# $NetBSD: Makefile,v 1.1 1998/09/04 22:14:25 agc Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gnome-libs-0.27
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/v0.27/ \
|
||||
ftp://ftp.gnome.org/pub/GNOME/sources/ \
|
||||
ftp://ftp.geo.net/pub/gnome/v0.27/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
|
||||
DEPENDS+= gettext-0.10:../../misc/gettext
|
||||
DEPENDS+= gtk+-1.1.1:../../x11/gtk
|
||||
DEPENDS+= tiff-3.4:../../graphics/tiff
|
||||
DEPENDS+= jpeg-6b:../../graphics/jpeg
|
||||
DEPENDS+= giflib-3.0:../../graphics/giflib
|
||||
DEPENDS+= png-1.0.2:../../graphics/png
|
||||
DEPENDS+= xpm-3.4k:../../graphics/xpm
|
||||
DEPENDS+= imlib-1.7:../../graphics/imlib
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_X11= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
CONFIGURE_ARGS+= --localstatedir=${X11BASE}/lib/X11/Gnome/var --with-glib-prefix=${LOCALBASE}
|
||||
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE}
|
||||
|
||||
pre-build:
|
||||
(cd ${WRKSRC}/support; ${GMAKE} gnomesupport.h)
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
x11/gnome-libs/files/md5
Normal file
3
x11/gnome-libs/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1 1998/09/04 22:14:26 agc Exp $
|
||||
|
||||
MD5 (gnome-libs-0.27.tar.gz) = 61883a7f9d1f7d91a00dbc9e91b6b991
|
64
x11/gnome-libs/patches/patch-aa
Normal file
64
x11/gnome-libs/patches/patch-aa
Normal file
|
@ -0,0 +1,64 @@
|
|||
$NetBSD: patch-aa,v 1.1 1998/09/04 22:14:26 agc Exp $
|
||||
|
||||
Use our own version of libtool
|
||||
Set CPPFLAGS correctly so that it finds all the pre-req header files
|
||||
Comment out erroneous settings of the INSTALL variable.
|
||||
|
||||
--- configure.orig Fri Aug 7 02:01:30 1998
|
||||
+++ configure Fri Aug 14 14:59:42 1998
|
||||
@@ -78,6 +78,9 @@
|
||||
# Initialize some other variables.
|
||||
subdirs=
|
||||
MFLAGS= MAKEFLAGS=
|
||||
+CFLAGS="-I../intl -I$X11BASE/include -I$LOCALBASE/include"
|
||||
+CPPFLAGS="-I../intl -I$X11BASE/include -I$LOCALBASE/include -I$LOCALBASE/include/giflib"
|
||||
+LDFLAGS="-L$X11BASE/lib -L$LOCALBASE/lib"
|
||||
# Maximum number of lines to put in a shell here document.
|
||||
ac_max_here_lines=12
|
||||
|
||||
@@ -1621,6 +1624,7 @@
|
||||
|
||||
|
||||
# Always use our own libtool.
|
||||
+if false; then
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
|
||||
|
||||
@@ -1700,6 +1704,7 @@
|
||||
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig \
|
||||
$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
|
||||
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
|
||||
+fi
|
||||
|
||||
|
||||
echo $ac_n "checking whether to enable maintainer-specific portions of Makefiles""... $ac_c" 1>&6
|
||||
@@ -6711,10 +6716,10 @@
|
||||
top_srcdir="$ac_dots$ac_given_srcdir" ;;
|
||||
esac
|
||||
|
||||
- case "$ac_given_INSTALL" in
|
||||
- [/$]*) INSTALL="$ac_given_INSTALL" ;;
|
||||
- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
|
||||
- esac
|
||||
+# case "$ac_given_INSTALL" in
|
||||
+# [/$]*) INSTALL="$ac_given_INSTALL" ;;
|
||||
+# *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
|
||||
+# esac
|
||||
|
||||
echo creating "$ac_file"
|
||||
rm -f "$ac_file"
|
||||
@@ -6980,10 +6985,10 @@
|
||||
*) # Relative path.
|
||||
ac_sub_cache_file="$ac_dots$cache_file" ;;
|
||||
esac
|
||||
- case "$ac_given_INSTALL" in
|
||||
- [/$]*) INSTALL="$ac_given_INSTALL" ;;
|
||||
- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
|
||||
- esac
|
||||
+# case "$ac_given_INSTALL" in
|
||||
+# [/$]*) INSTALL="$ac_given_INSTALL" ;;
|
||||
+# *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
|
||||
+# esac
|
||||
|
||||
echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
|
||||
# The eval makes quoting arguments work.
|
13
x11/gnome-libs/patches/patch-ab
Normal file
13
x11/gnome-libs/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1 1998/09/04 22:14:26 agc Exp $
|
||||
|
||||
--- libgnomeui/Makefile.in.orig Sat Aug 15 15:49:03 1998
|
||||
+++ libgnomeui/Makefile.in Sat Aug 15 15:48:19 1998
|
||||
@@ -349,7 +349,7 @@
|
||||
ted_demo_DEPENDENCIES = $(top_builddir)/libgnomeui/libgnomeui.la \
|
||||
$(top_builddir)/libgnome/libgnome.la
|
||||
ted_demo_LDFLAGS =
|
||||
-stock_demo_OBJECTS = stock_demo.o
|
||||
+stock_demo_OBJECTS = stock_demo.o gnome-stock.o
|
||||
stock_demo_DEPENDENCIES = $(top_builddir)/libgnomeui/libgnomeui.la \
|
||||
$(top_builddir)/libgnome/libgnome.la
|
||||
stock_demo_LDFLAGS =
|
22
x11/gnome-libs/patches/patch-ac
Normal file
22
x11/gnome-libs/patches/patch-ac
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ac,v 1.1 1998/09/04 22:14:26 agc Exp $
|
||||
|
||||
Use NetBSD's libtool
|
||||
|
||||
--- libgtktty/configure 1998/09/01 21:20:44 1.1
|
||||
+++ libgtktty/configure 1998/09/01 21:21:08
|
||||
@@ -1936,6 +1936,7 @@
|
||||
|
||||
|
||||
# Always use our own libtool.
|
||||
+if false; then
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
|
||||
|
||||
@@ -2015,6 +2016,7 @@
|
||||
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig \
|
||||
$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
|
||||
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
|
||||
+fi
|
||||
|
||||
|
||||
|
15
x11/gnome-libs/patches/patch-ad
Normal file
15
x11/gnome-libs/patches/patch-ad
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ad,v 1.1 1998/09/04 22:14:26 agc Exp $
|
||||
|
||||
Don't try to strip a script.
|
||||
|
||||
--- Makefile.in 1998/09/02 07:47:48 1.1
|
||||
+++ Makefile.in 1998/09/02 07:47:53
|
||||
@@ -51,7 +51,7 @@
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
-INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
+INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
|
||||
transform = @program_transform_name@
|
||||
|
||||
NORMAL_INSTALL = :
|
1
x11/gnome-libs/pkg/COMMENT
Normal file
1
x11/gnome-libs/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
libaries for the GNU Network Object Model Environment
|
11
x11/gnome-libs/pkg/DESCR
Normal file
11
x11/gnome-libs/pkg/DESCR
Normal file
|
@ -0,0 +1,11 @@
|
|||
This package provides the libaries for GNOME.
|
||||
|
||||
From the GNOME home page:
|
||||
|
||||
GNOME stands for GNU Network Object Model Environment. The GNOME
|
||||
project intends to build a complete, user-friendly desktop based
|
||||
entirely on free software. GNOME is part of the GNU project, and
|
||||
GNOME is part of the OpenSource(tm) movement. The desktop will
|
||||
consist of small utilities and larger applications which share a
|
||||
consistent look and feel. GNOME uses GTK+ as the GUI toolkit for all
|
||||
GNOME-compliant applications.
|
142
x11/gnome-libs/pkg/PLIST
Normal file
142
x11/gnome-libs/pkg/PLIST
Normal file
|
@ -0,0 +1,142 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 1998/09/04 22:14:27 agc Exp $
|
||||
bin/dns-helper
|
||||
bin/gnome_segv
|
||||
bin/gnome-config
|
||||
bin/htmltest
|
||||
include/gnome.h
|
||||
include/libgnome/gnome-config.h
|
||||
include/libgnome/gnome-defs.h
|
||||
include/libgnome/gnome-fileconvert.h
|
||||
include/libgnome/gnome-hook.h
|
||||
include/libgnome/gnome-dl.h
|
||||
include/libgnome/gnome-dentry.h
|
||||
include/libgnome/gnome-exec.h
|
||||
include/libgnome/gnome-help.h
|
||||
include/libgnome/gnome-history.h
|
||||
include/libgnome/gnome-i18n.h
|
||||
include/libgnome/gnome-mime.h
|
||||
include/libgnome/gnome-parse.h
|
||||
include/libgnome/gnome-score.h
|
||||
include/libgnome/gnome-string.h
|
||||
include/libgnome/gnome-triggers.h
|
||||
include/libgnome/gnome-util.h
|
||||
include/libgnome/libgnome.h
|
||||
include/libgnomeui/gnome-about.h
|
||||
include/libgnomeui/gnome-actionarea.h
|
||||
include/libgnomeui/gnome-app.h
|
||||
include/libgnomeui/gnome-appbar.h
|
||||
include/libgnomeui/gnome-app-helper.h
|
||||
include/libgnomeui/gnome-app-util.h
|
||||
include/libgnomeui/gnome-calculator.h
|
||||
include/libgnomeui/gnome-canvas.h
|
||||
include/libgnomeui/gnome-canvas-image.h
|
||||
include/libgnomeui/gnome-canvas-line.h
|
||||
include/libgnomeui/gnome-canvas-rect-ellipse.h
|
||||
include/libgnomeui/gnome-canvas-text.h
|
||||
include/libgnomeui/gnome-canvas-util.h
|
||||
include/libgnomeui/gnome-canvas-widget.h
|
||||
include/libgnomeui/gnome-client.h
|
||||
include/libgnomeui/gnome-color-selector.h
|
||||
include/libgnomeui/gnome-dateedit.h
|
||||
include/libgnomeui/gnome-dentry-edit.h
|
||||
include/libgnomeui/gnome-dialog.h
|
||||
include/libgnomeui/gnome-dialog-util.h
|
||||
include/libgnomeui/gnome-dns.h
|
||||
include/libgnomeui/gnome-entry.h
|
||||
include/libgnomeui/gnome-file-entry.h
|
||||
include/libgnomeui/gnome-font-selector.h
|
||||
include/libgnomeui/gnome-geometry.h
|
||||
include/libgnomeui/gnome-ice.h
|
||||
include/libgnomeui/gnome-icon-list.h
|
||||
include/libgnomeui/gnome-icon-sel.h
|
||||
include/libgnomeui/gnome-lamp.h
|
||||
include/libgnomeui/gnome-less.h
|
||||
include/libgnomeui/gnome-messagebox.h
|
||||
include/libgnomeui/gnome-mdi.h
|
||||
include/libgnomeui/gnome-mdi-child.h
|
||||
include/libgnomeui/gnome-number-entry.h
|
||||
include/libgnomeui/gnome-net.h
|
||||
include/libgnomeui/gnome-popupmenu.h
|
||||
include/libgnomeui/gtkdial.h
|
||||
include/libgnomeui/gnome-preferences.h
|
||||
include/libgnomeui/gnome-propertybox.h
|
||||
include/libgnomeui/gnome-properties.h
|
||||
include/libgnomeui/gnome-pixmap.h
|
||||
include/libgnomeui/gnome-scores.h
|
||||
include/libgnomeui/gnome-startup.h
|
||||
include/libgnomeui/gnome-rootwin.h
|
||||
include/libgnomeui/gnome-stock.h
|
||||
include/libgnomeui/gnome-types.h
|
||||
include/libgnomeui/gnome-uidefs.h
|
||||
include/libgnomeui/gnometypebuiltins.h
|
||||
include/libgnomeui/gtkcalendar.h
|
||||
include/libgnomeui/gtkcauldron.h
|
||||
include/libgnomeui/gtklayout.h
|
||||
include/libgnomeui/gtkspell.h
|
||||
include/libgnomeui/gtk-clock.h
|
||||
include/libgnomeui/gtk-ted.h
|
||||
include/libgnomeui/gtk-plug.h
|
||||
include/libgnomeui/gtk-socket.h
|
||||
include/libgnomeui/libgnomeui.h
|
||||
include/gtk-xmhtml/miniparse.h
|
||||
include/gtk-xmhtml/HTML.h
|
||||
include/gtk-xmhtml/XmHTML.h
|
||||
include/gtk-xmhtml/XmHTMLI.h
|
||||
include/gtk-xmhtml/XmHTMLP.h
|
||||
include/gtk-xmhtml/gtk-xmhtml-p.h
|
||||
include/gtk-xmhtml/gtk-xmhtml.h
|
||||
include/gtk-xmhtml/toolkit.h
|
||||
include/gtktty/gtkled.h
|
||||
include/gtktty/gtkterm.h
|
||||
include/gtktty/gtkvtemu.h
|
||||
include/gtktty/gtktty.h
|
||||
include/gtktty/libgtktty.h
|
||||
include/zvt/zvtterm.h
|
||||
include/zvt/vtx.h
|
||||
include/zvt/lists.h
|
||||
include/zvt/subshell.h
|
||||
include/zvt/vt.h
|
||||
lib/gnome-libs/include/gnomesupport.h
|
||||
lib/gnome-libs/include/gnome-argp.h
|
||||
lib/gnome-libs/include/getopt.h
|
||||
lib/gnome-libs/include/long-options.h
|
||||
lib/gnome-libs/include/argp.h
|
||||
lib/gnome-libs/include/error.h
|
||||
lib/gnomeConf.sh
|
||||
lib/libgnome.so.26.0
|
||||
lib/libgnome.a
|
||||
lib/libgnomesupport.so.0.0
|
||||
lib/libgnomesupport.a
|
||||
lib/libgnomeui.so.26.0
|
||||
lib/libgnomeui.a
|
||||
lib/libgtkxmhtml.so.0.0
|
||||
lib/libgtkxmhtml.a
|
||||
lib/libgtktty.so.0.4
|
||||
lib/libgtktty.a
|
||||
lib/libzvt.a
|
||||
lib/libzvt.so.0.0
|
||||
share/locale/de/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/fr/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/it/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/ko/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/cs/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/es/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/no/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/fi/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/ga/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/pt/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/ja/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/sv/LC_MESSAGES/gnome-libs.mo
|
||||
share/pixmaps/calculator-font.xpm
|
||||
share/gtkrc
|
||||
@dirrm html
|
||||
@dirrm include/libgnome
|
||||
@dirrm include/libgnomeui
|
||||
@dirrm include/gtk-xmhtml
|
||||
@dirrm include/gtktty
|
||||
@dirrm include/zvt
|
||||
@dirrm lib/X11/Gnome/var/games
|
||||
@dirrm lib/X11/Gnome/var
|
||||
@dirrm lib/X11/Gnome
|
||||
@dirrm lib/gnome-libs/include
|
||||
@dirrm lib/gnome-libs
|
Loading…
Reference in a new issue