Add support for SOCKS versions 4 and 5.

This commit is contained in:
scottr 2000-04-07 18:52:25 +00:00
parent 482037da84
commit 44b9b3b7ab
3 changed files with 28 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.24 2000/01/15 17:37:53 hubertf Exp $
# $NetBSD: Makefile,v 1.25 2000/04/07 18:52:25 scottr Exp $
#
DISTNAME= lynx2-8-2
@ -24,6 +24,18 @@ CONFIGURE_ENV+= LIBS="-lm -ltermcap" CPPFLAGS="-Dunix -DNOPORT"
CONFIGURE_ENV+= LIBS="-lm -ltermcap" CPPFLAGS=-Dunix
.endif
# Include SOCKS firewall support
.if defined(USE_SOCKS) && (${USE_SOCKS} == 4 || ${USE_SOCKS} == 5)
CONFIGURE_ENV+= CFLAGS=-I${PREFIX}/include # XXX
.if ${USE_SOCKS} == 4
CONFIGURE_ARGS+= --with-socks
DEPENDS+= socks4-2.2:../../net/socks4
.else
CONFIGURE_ARGS+= --with-socks5
DEPENDS+= socks5-1.0.2:../../net/socks5
.endif
.endif
# The patches for this code are from the KAME project:
# ftp://ftp.kame.net/pub/kame/misc/lynx-282-v6-19991008b.diff.gz
.include "../../mk/bsd.prefs.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: patch-sum,v 1.3 2000/01/15 22:55:47 hubertf Exp $
$NetBSD: patch-sum,v 1.4 2000/04/07 18:52:25 scottr Exp $
MD5 (patch-aa) = 942c697d7fb475b233323ad95ea95dec
MD5 (patch-ab) = 677e54c7bd58e6745cb2ca6531858f66
@ -26,3 +26,4 @@ MD5 (patch-aw) = c11e03da666e50b679a4cc2e99877138
MD5 (patch-ax) = 072e5b6ec0e892c41f6408012a378a41
MD5 (patch-ay) = dc6dc3b9cc9afeee83358cd917401fbf
MD5 (patch-az) = 9207782cf50647e1df42f50c9f5e0a71
MD5 (patch-ba) = b687b1899db1a35f4dba37b75b8fe269

13
www/lynx/patches/patch-ba Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ba,v 1.1 2000/04/07 18:52:26 scottr Exp $
--- configure.orig Sat May 29 22:27:26 1999
+++ configure Fri Apr 7 13:28:11 2000
@@ -5479,7 +5479,7 @@
LIBS="$LIBS -L$cf_cv_use_libsocks"
;;
esac
-LIBS="$LIBS -lsocks"
+LIBS="$LIBS -lsocks4"
cat >> confdefs.h <<\EOF
#define SOCKS 1
EOF