wm: Add yeahwm.

YeahWM is a h* window manager for X based on evilwm and aewm.

Features:

   * Sloppy Focus.
   * BeOS-like tabbed titles, which can be repositioned.
   * Support for Xinerama.
   * Simple Appearance.
   * Good keyboard control.
   * Creative usage of the mouse.
   * Respects aspect size hints.
   * Solid resize and move operations.
   * Virtual Desktops.
   * "Magic" screen edges for desktop switching.
   * Snapping to other windows and screen borders when moving windows.
   * Small binary size(ca. 23kb).
   * Little resource usage.
This commit is contained in:
nia 2020-10-11 08:56:37 +00:00
parent 0a7e64d5cf
commit 44ccab492d
7 changed files with 100 additions and 1 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.152 2020/10/10 20:11:51 nia Exp $
# $NetBSD: Makefile,v 1.153 2020/10/11 08:56:37 nia Exp $
#
COMMENT= X11 window managers, configuration tools, and themes
@ -109,5 +109,6 @@ SUBDIR+= xfce4-wm
SUBDIR+= xfce4-wm-themes
SUBDIR+= xmonad
SUBDIR+= xmonad-contrib
SUBDIR+= yeahwm
.include "../mk/misc/category.mk"

17
wm/yeahwm/DESCR Normal file
View file

@ -0,0 +1,17 @@
YeahWM is a h* window manager for X based on evilwm and aewm.
Features:
* Sloppy Focus.
* BeOS-like tabbed titles, which can be repositioned.
* Support for Xinerama.
* Simple Appearance.
* Good keyboard control.
* Creative usage of the mouse.
* Respects aspect size hints.
* Solid resize and move operations.
* Virtual Desktops.
* "Magic" screen edges for desktop switching.
* Snapping to other windows and screen borders when moving windows.
* Small binary size(ca. 23kb).
* Little resource usage.

30
wm/yeahwm/Makefile Normal file
View file

@ -0,0 +1,30 @@
# $NetBSD: Makefile,v 1.1 2020/10/11 08:56:37 nia Exp $
DISTNAME= yeahwm_0.3.5
PKGNAME= ${DISTNAME:S/_/-/g}
CATEGORIES= wm
MASTER_SITES= http://phrat.de/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://phrat.de/
COMMENT= Minimal X window manager with BeOS-like tabbed titles
LICENSE= evilwm-license
WRKSRC= ${WRKDIR}/yeahwm-${PKGVERSION_NOREV}
MAKE_FLAGS+= CC=${CC}
MAKE_FLAGS+= XROOT=${X11BASE}
INSTALLATION_DIRS+= bin
INSTALLATION_DIRS+= ${PKGMANDIR}/man1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/yeahwm \
${DESTDIR}${PREFIX}/bin/yeahwm
${INSTALL_MAN} ${WRKSRC}/yeahwm.1 \
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/yeahwm.1
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
wm/yeahwm/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2020/10/11 08:56:37 nia Exp $
bin/yeahwm
man/man1/yeahwm.1

8
wm/yeahwm/distinfo Normal file
View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1 2020/10/11 08:56:37 nia Exp $
SHA1 (yeahwm_0.3.5.tar.gz) = 0ab7b2bddf86958c19c5c34a88c4d5c7b78fb5c8
RMD160 (yeahwm_0.3.5.tar.gz) = 4af2e72dd12580faff7a87d9f3e4fa23525b153e
SHA512 (yeahwm_0.3.5.tar.gz) = bf75f484c0e21437d32ca590ebc79a127bc879738c4b845f9ea0bfd2de15d1b7455b131bf12d51b053008c6f6d60c071351ea13130bd3c5727932b419c54592a
Size (yeahwm_0.3.5.tar.gz) = 23465 bytes
SHA1 (patch-Makefile) = 4c42bdb58322706fd861e9915ba0ef1e03c9fe83
SHA1 (patch-config.h) = 25d48e444dfe4dcbfd6e624d4c9f89edb5a8a1cd

View file

@ -0,0 +1,14 @@
$NetBSD: patch-Makefile,v 1.1 2020/10/11 08:56:37 nia Exp $
Let pkgsrc take care of stripping.
--- Makefile.orig 2004-11-21 18:11:04.000000000 +0000
+++ Makefile
@@ -56,7 +56,6 @@ all: yeahwm
yeahwm: $(OBJS)
$(CC) $(CFLAGS) $(OBJS) -o $@ $(LDFLAGS)
- strip yeahwm
allinone:
cat yeahwm.h $(SRCS) | sed 's/^#include.*yeahwm.*$$//' > allinone.c

View file

@ -0,0 +1,26 @@
$NetBSD: patch-config.h,v 1.1 2020/10/11 08:56:37 nia Exp $
Use a font that might actually be installed.
Avoid Motif dependency.
--- config.h.orig 2004-11-21 18:17:42.000000000 +0000
+++ config.h
@@ -4,7 +4,7 @@
/* default settings */
-#define DEF_FONT "variable"
+#define DEF_FONT "fixed"
#define DEF_ABG "steel blue" /*background for active windows*/
#define DEF_BG "grey50" /*background for inactive windows*/
#define DEF_FG "snow" /*color for window title*/
@@ -22,7 +22,7 @@
/* Use Motif hints to find if a window should be borderless.
To use this option, you need to have the Motif development files installed. */
-#define MWM_HINTS
+/* #define MWM_HINTS */
/* You can save a few bytes if you know you won't need colour map support
(eg for 16 or more bit displays) */