Decompressor for old bzip (.bz) compressed files. Does not include the
patented compression code.
This commit is contained in:
parent
e0bec16c22
commit
4503718dc8
6 changed files with 114 additions and 0 deletions
21
archivers/bunzip/Makefile
Normal file
21
archivers/bunzip/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1999/05/23 20:55:29 tv Exp $
|
||||
|
||||
DISTNAME= bunzip021.c
|
||||
PKGNAME= bunzip-0.21
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
EXTRACT_SUFX= .gz
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.muraroa.demon.co.uk/
|
||||
|
||||
NO_WRKSUBDIR=
|
||||
EXTRACT_CMD= ${GZCAT} ${DOWNLOADED_DISTFILE} >${DISTNAME}
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${LINK.c} -o bunzip ${DISTNAME}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bunzip ${PREFIX}/bin/
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
archivers/bunzip/files/md5
Normal file
3
archivers/bunzip/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/05/23 20:55:29 tv Exp $
|
||||
|
||||
MD5 (bunzip021.c.gz) = 2a1843ca28bc1b5bfc2b7a7b10dccfd3
|
72
archivers/bunzip/patches/patch-aa
Normal file
72
archivers/bunzip/patches/patch-aa
Normal file
|
@ -0,0 +1,72 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/05/23 20:55:29 tv Exp $
|
||||
|
||||
--- bunzip021.c.orig Sun May 23 16:48:42 1999
|
||||
+++ bunzip021.c Sun May 23 16:52:27 1999
|
||||
@@ -400,7 +400,8 @@
|
||||
|
||||
Int32 bytesIn, bytesOut;
|
||||
Bool verbose, veryVerbose;
|
||||
-Bool compressing, keepInputFiles;
|
||||
+#define compressing False
|
||||
+Bool keepInputFiles;
|
||||
UInt32 globalCrc;
|
||||
|
||||
#define OM_FILES_TO_FILES 1
|
||||
@@ -2376,17 +2377,13 @@
|
||||
"\nusage: %s [flags and input files in any order]\n"
|
||||
"\n"
|
||||
" Flags: -d force decompression\n"
|
||||
- " -f force compression\n"
|
||||
" -c output to standard out\n"
|
||||
" -v, -V be verbose, or very verbose\n"
|
||||
" -k keep (don't delete) input files\n"
|
||||
" -L display software license\n"
|
||||
" -1 .. -9 set block size of 100k .. 900k\n"
|
||||
"\n"
|
||||
- " If invoked as `bzip', the default action is to compress.\n"
|
||||
- " as `bunzip', the default action is to decompress.\n"
|
||||
- "\n"
|
||||
- " If no file names are given, bzip compresses or decompresses\n"
|
||||
+ " If no file names are given, bunzip decompresses\n"
|
||||
" from standard input to standard output. You can combine\n"
|
||||
" flags, so `-v -e -4' means the same as -ve4 or -4ev, &c.\n"
|
||||
"\n"
|
||||
@@ -2542,7 +2539,6 @@
|
||||
}
|
||||
|
||||
keepInputFiles = False;
|
||||
- compressing = True;
|
||||
verbose = False;
|
||||
veryVerbose = False;
|
||||
|
||||
@@ -2550,12 +2546,6 @@
|
||||
opMode = OM_STDIN_TO_STDOUT; else
|
||||
opMode = OM_FILES_TO_FILES;
|
||||
|
||||
- if ( (strcmp ( "bunzip", progName ) == 0) ||
|
||||
- (strcmp ( "BUNZIP", progName ) == 0) ||
|
||||
- (strcmp ( "bunzip.exe", progName ) == 0) ||
|
||||
- (strcmp ( "BUNZIP.EXE", progName ) == 0) )
|
||||
- compressing = False;
|
||||
-
|
||||
if (compressing) blockSize100k = 9;
|
||||
|
||||
for (aa = argList; aa != NULL; aa = aa->link)
|
||||
@@ -2564,8 +2554,7 @@
|
||||
switch (aa->name[j]) {
|
||||
case 'Q': break;
|
||||
case 'c': opMode = OM_FILE_TO_STDOUT; break;
|
||||
- case 'd': compressing = False; break;
|
||||
- case 'f': compressing = True; break;
|
||||
+ case 'd': break;
|
||||
case 'v': verbose = True; break;
|
||||
case 'k': keepInputFiles = True; break;
|
||||
case '1': blockSize100k = 1; break;
|
||||
@@ -2593,7 +2582,6 @@
|
||||
exit ( 1 );
|
||||
}
|
||||
|
||||
- compressing = False;
|
||||
if ( !compressing ) blockSize100k = 0;
|
||||
|
||||
{
|
1
archivers/bunzip/pkg/COMMENT
Normal file
1
archivers/bunzip/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
Decompressor for bzip .bz files
|
15
archivers/bunzip/pkg/DESCR
Normal file
15
archivers/bunzip/pkg/DESCR
Normal file
|
@ -0,0 +1,15 @@
|
|||
Please use bzip2, which is the successor of this older bzip version.
|
||||
This port stays for compatibility reasons. A discussion of the
|
||||
advantages of bzip2 over bzip 0.21 is given on the homepage.
|
||||
|
||||
In short: bzip2 is faster, more reliable and *patent free*
|
||||
|
||||
This program may or may not infringe certain US patents pertaining
|
||||
to arithmetic coding and to the block-sorting transformation itself.
|
||||
Opinions differ as to the precise legal status of some of the
|
||||
algorithms used. Nevertheless, you should be aware that commercial
|
||||
use of this program could render you liable to unfriendly legal
|
||||
action.
|
||||
|
||||
[This package contains a DECOMPRESS-ONLY version, bunzip, which
|
||||
provides less legal problems than the full bzip program.]
|
2
archivers/bunzip/pkg/PLIST
Normal file
2
archivers/bunzip/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/05/23 20:55:29 tv Exp $
|
||||
bin/bunzip
|
Loading…
Reference in a new issue