brotli: update to 1.0.9.
Version 1.0.9 contains a fix to "integer overflow" problem. This happens when "one-shot" decoding API is used (or input chunk for streaming API is not limited), input size (chunk size) is larger than 2GiB, and input contains uncompressed blocks. After the overflow happens, `memcpy` is invoked with a gigantic `num` value, that will likely cause the crash.
This commit is contained in:
parent
8f1c906d7d
commit
450511c07d
3 changed files with 12 additions and 13 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.7 2019/04/19 17:56:52 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2020/08/31 08:45:44 wiz Exp $
|
||||
|
||||
DISTNAME= brotli-1.0.7
|
||||
PKGREVISION= 1
|
||||
DISTNAME= brotli-1.0.9
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=google/}
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.7 2019/04/19 17:56:52 adam Exp $
|
||||
$NetBSD: distinfo,v 1.8 2020/08/31 08:45:44 wiz Exp $
|
||||
|
||||
SHA1 (brotli-1.0.7.tar.gz) = ee64a380152aa20fbc1098fe3799104884c570c1
|
||||
RMD160 (brotli-1.0.7.tar.gz) = f46d51bb06fa08ed80d9d2d6bc72cbd243b0653e
|
||||
SHA512 (brotli-1.0.7.tar.gz) = a82362aa36d2f2094bca0b2808d9de0d57291fb3a4c29d7c0ca0a37e73087ec5ac4df299c8c363e61106fccf2fe7f58b5cf76eb97729e2696058ef43b1d3930a
|
||||
Size (brotli-1.0.7.tar.gz) = 23827908 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = f5d1d5f4471ce820cfb9c574be61fae4693de4d6
|
||||
SHA1 (brotli-1.0.9.tar.gz) = ddfefdf2593b3f03eec221a7f4ceaa710e5a2e6b
|
||||
RMD160 (brotli-1.0.9.tar.gz) = aef7f7c6f4f1cea3c8dd84563598de17a6118c0e
|
||||
SHA512 (brotli-1.0.9.tar.gz) = b8e2df955e8796ac1f022eb4ebad29532cb7e3aa6a4b6aee91dbd2c7d637eee84d9a144d3e878895bb5e62800875c2c01c8f737a1261020c54feacf9f676b5f5
|
||||
Size (brotli-1.0.9.tar.gz) = 486984 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = ab1b60d2ae23e7976339c127dab7f5296c8a791b
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.1 2019/04/19 17:56:52 adam Exp $
|
||||
$NetBSD: patch-CMakeLists.txt,v 1.2 2020/08/31 08:45:44 wiz Exp $
|
||||
|
||||
Use shared libraries for linking the main executable.
|
||||
|
||||
--- CMakeLists.txt.orig 2019-04-19 17:41:26.000000000 +0000
|
||||
--- CMakeLists.txt.orig 2020-08-27 14:12:55.000000000 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -183,7 +183,7 @@ endif()
|
||||
@@ -216,7 +216,7 @@ endif()
|
||||
|
||||
# Build the brotli executable
|
||||
add_executable(brotli ${BROTLI_CLI_C})
|
||||
|
@ -12,4 +12,4 @@ Use shared libraries for linking the main executable.
|
|||
+target_link_libraries(brotli ${BROTLI_LIBRARIES})
|
||||
|
||||
# Installation
|
||||
if(NOT BROTLI_BUNDLED_MODE)
|
||||
if(NOT BROTLI_EMSCRIPTEN)
|
||||
|
|
Loading…
Reference in a new issue