Initial import of FreeBSD devel ports into NetBSD

packages system.
This commit is contained in:
agc 1997-10-06 14:06:09 +00:00
parent 690fb0bd9c
commit 450dc62227
54 changed files with 1066 additions and 0 deletions

89
devel/Makefile Normal file
View file

@ -0,0 +1,89 @@
# FreeBSD Id: Makefile,v 1.78 1997/10/01 08:32:59 cracauer Exp
#
SUBDIR += SWIG
SUBDIR += asl
SUBDIR += autoconf
SUBDIR += automake
SUBDIR += bcc
SUBDIR += boehm-gc
SUBDIR += cflow
SUBDIR += crossgo32
SUBDIR += crossgo32-djgpp2
SUBDIR += crossgo32-djgpp2-pdcurses
SUBDIR += crosssco
SUBDIR += cs
SUBDIR += cutils
SUBDIR += cxref
SUBDIR += ddd
SUBDIR += dmake
SUBDIR += f77flow
SUBDIR += fpp
SUBDIR += gcc11
SUBDIR += gdb
SUBDIR += gdbtk
SUBDIR += gindent
SUBDIR += gmake
SUBDIR += id-utils
SUBDIR += ilu
SUBDIR += lclint
SUBDIR += libdlmalloc
SUBDIR += libmalloc
SUBDIR += libslang
SUBDIR += linux_devel
SUBDIR += linuxgdb
SUBDIR += m4
SUBDIR += makedepend
SUBDIR += mkmf
SUBDIR += mprof
SUBDIR += noweb
SUBDIR += omniBroker
SUBDIR += omniORB
SUBDIR += p5-B
SUBDIR += p5-BSD-Resource
SUBDIR += p5-C-Scan
SUBDIR += p5-ConfigReader
SUBDIR += p5-Curses
SUBDIR += p5-Data-Dumper
SUBDIR += p5-Data-Flow
SUBDIR += p5-Data-ShowTable
SUBDIR += p5-Date-Manip
SUBDIR += p5-Devel-DProf
SUBDIR += p5-Devel-Peek
SUBDIR += p5-Devel-Symdump
SUBDIR += p5-Errno
SUBDIR += p5-File-BasicFlock
SUBDIR += p5-File-Lock
SUBDIR += p5-File-Slurp
SUBDIR += p5-File-Tools
SUBDIR += p5-Filter
SUBDIR += p5-FreezeThaw
SUBDIR += p5-Include
SUBDIR += p5-IniConf
SUBDIR += p5-Ioctl
SUBDIR += p5-PV
SUBDIR += p5-Penguin
SUBDIR += p5-Penguin-Easy
SUBDIR += p5-Proc-Simple
SUBDIR += p5-Religion
SUBDIR += p5-Resources
SUBDIR += p5-Sort-Versions
SUBDIR += p5-Storable
SUBDIR += p5-Term-ReadKey
SUBDIR += p5-Time
SUBDIR += p5-TimeDate
SUBDIR += p5-TraceFuncs
SUBDIR += pccts
SUBDIR += portlint
SUBDIR += prcs
SUBDIR += sawt
SUBDIR += scogdb
SUBDIR += tclcheck
SUBDIR += tkcvs
SUBDIR += tvision
SUBDIR += vtcl
SUBDIR += xmake
SUBDIR += xwpe
SUBDIR += xxgdb
.include <bsd.port.subdir.mk>

27
devel/autoconf/Makefile Normal file
View file

@ -0,0 +1,27 @@
# New ports collection makefile for: autoconf
# Version required: 2.12
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
# FreeBSD Id: Makefile,v 1.12 1997/06/13 20:00:47 max Exp
#
DISTNAME= autoconf-2.12
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
post-install:
@if [ ! -f ${PREFIX}/info/dir ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
@install-info ${PREFIX}/info/autoconf.info ${PREFIX}/info/dir
@install-info ${PREFIX}/info/standards.info ${PREFIX}/info/dir
.include <bsd.port.mk>

1
devel/autoconf/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (autoconf-2.12.tar.gz) = 8d7a2b2eda07601308c3031197c78b8a

View file

@ -0,0 +1,21 @@
--- ./Makefile.in.org Wed Nov 22 10:09:44 1995
+++ ./Makefile.in Thu Mar 28 23:02:49 1996
@@ -131,15 +131,15 @@
*) echo Error: Autoconf requires GNU m4 1.1 or later; exit 1 ;; \
esac
for p in $(ASCRIPTS); do \
- $(INSTALL_PROGRAM) $$p $(bindir)/`echo $$p|sed '$(transform)'`; \
+ $(INSTALL) $$p $(bindir)/`echo $$p|sed '$(transform)'`; \
done
for i in $(M4FILES) acconfig.h; do \
$(INSTALL_DATA) $(srcdir)/$$i $(acdatadir)/$$i; \
done
-if test -f autoscan; then \
- $(INSTALL_PROGRAM) autoscan $(bindir)/`echo autoscan|sed '$(transform)'`; \
+ $(INSTALL) autoscan $(bindir)/`echo autoscan|sed '$(transform)'`; \
for i in acfunctions acheaders acidentifiers acprograms \
- acmakevars; do \
+ acmakevars config.guess config.sub; do \
$(INSTALL_DATA) $(srcdir)/$$i $(acdatadir)/$$i; \
done; \
else :; fi

View file

@ -0,0 +1,10 @@
--- autoconf.texi.orig Wed Nov 27 03:09:46 1996
+++ autoconf.texi Fri Jun 13 16:29:42 1997
@@ -4,6 +4,7 @@
@settitle Autoconf
@c For double-sided printing, uncomment:
@c @setchapternewpage odd
+@dircategory Programming & development tools
@c %**end of header
@set EDITION 2.12

View file

@ -0,0 +1,17 @@
--- standards.texi.orig Fri Oct 11 11:32:48 1996
+++ standards.texi Fri Jun 13 16:26:11 1997
@@ -4,12 +4,13 @@
@settitle GNU Coding Standards
@c UPDATE THIS DATE WHENEVER YOU MAKE CHANGES!
@set lastupdate 9 September 1996
+@dircategory Programming & development tools
@c %**end of header
@ifinfo
@format
START-INFO-DIR-ENTRY
-* Standards: (standards). GNU coding standards.
+* Standards: (standards). GNU coding standards.
END-INFO-DIR-ENTRY
@end format
@end ifinfo

View file

@ -0,0 +1 @@
Automatically configure source code on many Un*x platforms

7
devel/autoconf/pkg/DESCR Normal file
View file

@ -0,0 +1,7 @@
Autoconf is an extensible package of m4 macros that produce shell
scripts to automatically configure software source code packages.
These scripts can adapt the packages to many kinds of UNIX-like
systems without manual user intervention. Autoconf creates a
configuration script for a package from a template file that lists the
operating system features that the package can use, in the form of m4
macro calls.

29
devel/autoconf/pkg/PLIST Normal file
View file

@ -0,0 +1,29 @@
bin/autoconf
bin/autoheader
bin/autoreconf
bin/autoscan
bin/autoupdate
bin/ifnames
@unexec install-info --delete %D/info/autoconf.info %D/info/dir
@unexec install-info --delete %D/info/standards.info %D/info/dir
info/autoconf.info
info/standards.info
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/autoconf.info %D/info/dir
@exec install-info %D/info/standards.info %D/info/dir
share/autoconf/acconfig.h
share/autoconf/acfunctions
share/autoconf/acgeneral.m4
share/autoconf/acheaders
share/autoconf/acidentifiers
share/autoconf/acmakevars
share/autoconf/acoldnames.m4
share/autoconf/acprograms
share/autoconf/acspecific.m4
share/autoconf/autoconf.m4
share/autoconf/autoconf.m4f
share/autoconf/autoheader.m4
share/autoconf/autoheader.m4f
share/autoconf/config.guess
share/autoconf/config.sub
@dirrm share/autoconf

23
devel/automake/Makefile Normal file
View file

@ -0,0 +1,23 @@
# New ports collection makefile for: automake
# Version required: 1.2
# Date created: 15 March 1997
# Whom: FUJIMOTO Kensaku <fujimoto@oscar.elec.waseda.ac.jp>
#
# FreeBSD Id: Makefile,v 1.5 1997/09/19 09:29:04 max Exp
#
DISTNAME= automake-1.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MAINTAINER= fujimoto@oscar.elec.waseda.ac.jp
GNU_CONFIGURE= yes
CONFIGURE_ENV= PERL=/usr/bin/perl
STRIP= # none
pre-install:
@if [ ! -f ${PREFIX}/info/dir ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
.include <bsd.port.mk>

1
devel/automake/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (automake-1.2.tar.gz) = 87c072945c73d0ab64db051bfae9c664

View file

@ -0,0 +1,25 @@
--- automake.texi.orig Fri Sep 19 06:13:10 1997
+++ automake.texi Fri Sep 19 06:17:06 1997
@@ -1,6 +1,7 @@
\input texinfo @c -*-texinfo-*-
@c %**start of header
@setfilename automake.info
+@dircategory Programming & development tools
@settitle automake
@setchapternewpage off
@c %**end of header
@@ -9,12 +10,12 @@
@dircategory GNU admin
@direntry
-* automake: (automake). Making Makefile.in's
+* Automake: (automake). Making Makefile.in's
@end direntry
@dircategory Individual utilities
@direntry
-* aclocal: (automake)Invoking aclocal Generating aclocal.m4
+* Aclocal: (automake)Invoking aclocal Generating aclocal.m4
@end direntry
@ifinfo

View file

@ -0,0 +1,11 @@
--- Makefile.in.orig Mon Jun 23 11:25:50 1997
+++ Makefile.in Fri Sep 19 18:19:19 1997
@@ -196,7 +196,7 @@
.texi.info:
@cd $(srcdir) && rm -f $@ $@-[0-9] $@-[0-9][0-9]
cd $(srcdir) \
- && $(MAKEINFO) `echo $< | sed 's,.*/,,'`
+ && $(MAKEINFO) --no-split `echo $< | sed 's,.*/,,'`
.texi.dvi:
TEXINPUTS=$(srcdir):$$TEXINPUTS \

View file

@ -0,0 +1 @@
GNU Standards-compliant Makefile generator

6
devel/automake/pkg/DESCR Normal file
View file

@ -0,0 +1,6 @@
Automake is an experimental Makefile generator. It was inspired by
the 4.4BSD make and include files, but aims to be portable and to
conform to the GNU standards for Makefile variables and targets.
Automake assumes the project uses autoconf. If you want automatic
dependency tracking support, the use of GNU make is also required.

78
devel/automake/pkg/PLIST Normal file
View file

@ -0,0 +1,78 @@
bin/aclocal
bin/automake
@unexec install-info --delete %D/info/automake.info %D/info/dir
info/automake.info
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/automake.info %D/info/dir
share/aclocal/ccstdc.m4
share/aclocal/cond.m4
share/aclocal/cygwin.m4
share/aclocal/dmalloc.m4
share/aclocal/error.m4
share/aclocal/header.m4
share/aclocal/init.m4
share/aclocal/install.m4
share/aclocal/lispdir.m4
share/aclocal/maintainer.m4
share/aclocal/missing.m4
share/aclocal/mktime.m4
share/aclocal/obstack.m4
share/aclocal/protos.m4
share/aclocal/ptrdiff.m4
share/aclocal/regex.m4
share/aclocal/sanity.m4
share/aclocal/strtod.m4
share/aclocal/termios.m4
share/aclocal/winsz.m4
share/automake/COPYING
share/automake/INSTALL
share/automake/acinstall
share/automake/ansi2knr.1
share/automake/ansi2knr.c
share/automake/clean-hdr.am
share/automake/clean-kr.am
share/automake/clean.am
share/automake/comp-vars.am
share/automake/compile.am
share/automake/config.guess
share/automake/config.sub
share/automake/data-clean.am
share/automake/data.am
share/automake/dejagnu.am
share/automake/depend.am
share/automake/depend2.am
share/automake/dist-vars.am
share/automake/elisp-comp
share/automake/footer.am
share/automake/header-vars.am
share/automake/header.am
share/automake/install-sh
share/automake/kr-extra.am
share/automake/library.am
share/automake/libs-clean.am
share/automake/libs.am
share/automake/libtool.am
share/automake/lisp-clean.am
share/automake/lisp.am
share/automake/ltlib-clean.am
share/automake/ltlib.am
share/automake/ltlibrary.am
share/automake/mans-vars.am
share/automake/mdate-sh
share/automake/missing
share/automake/mkinstalldirs
share/automake/program.am
share/automake/progs-clean.am
share/automake/progs.am
share/automake/remake-hdr.am
share/automake/remake.am
share/automake/scripts.am
share/automake/subdirs.am
share/automake/tags-clean.am
share/automake/tags.am
share/automake/texi-vers.am
share/automake/texinfo.tex
share/automake/texinfos.am
share/automake/ylwrap
@dirrm share/aclocal
@dirrm share/automake

24
devel/boehm-gc/Makefile Normal file
View file

@ -0,0 +1,24 @@
# New ports collection makefile for: boehm-gc
# Version required: 4.10
# Date created: 15 November 1996
# Whom: Mike McGaughey <mmcg@cs.monash.edu.au>
#
# FreeBSD Id: Makefile,v 1.1 1996/11/16 01:51:25 jdp Exp
#
DISTNAME= gc4.10
PKGNAME= boehm-gc-4.10
CATEGORIES= devel
MASTER_SITES= ftp://ftp.parc.xerox.com/pub/gc/
MAINTAINER= mmcg@cs.monash.edu.au
WRKSRC= ${WRKDIR}/gc
MAN3= gc.3
ALL_TARGET= FreeBSD-pkg-all
INSTALL_TARGET= FreeBSD-pkg-install
MAKE_ENV+= CP="${CP}"
MAKE_ENV+= INSTALL_DATA="${INSTALL_DATA}"
MAKE_ENV+= INSTALL_MAN="${INSTALL_MAN}"
.include <bsd.port.mk>

1
devel/boehm-gc/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (gc4.10.tar.gz) = 8281966ed48e630d64f0ebc00f68d617

View file

@ -0,0 +1,90 @@
*** Makefile.orig Mon Feb 19 09:45:47 1996
--- Makefile Fri Nov 15 14:19:11 1996
***************
*** 13,19 ****
# The above doesn't work with gas, which doesn't run cpp.
# Define AS as `gcc -c -x assembler-with-cpp' instead.
! CFLAGS= -O -DNO_SIGNALS -DALL_INTERIOR_POINTERS -DSILENT
# Setjmp_test may yield overly optimistic results when compiled
# without optimization.
--- 13,45 ----
# The above doesn't work with gas, which doesn't run cpp.
# Define AS as `gcc -c -x assembler-with-cpp' instead.
! # We want this to be a drop-in linkable library, hence the -DREDIRECT.
! # The new c++-t and c++-nt (test and notest) are because we don't want
! # to fill anyone's log with leak messages! - MMCG
!
! CFLAGS= -O -DNO_SIGNALS -DALL_INTERIOR_POINTERS -DSILENT \
! -DREDIRECT_MALLOC=GC_malloc
!
! LEAKFLAGS=$(CFLAGS) -DFIND_LEAK
!
! all: gc.a gctest
!
! FreeBSD-pkg-all: fbsd-libgc.a fbsd-libleak.a
!
! fbsd-libgc.a:
! make CFLAGS="$(CFLAGS)" clean c++-t
! mv gc.a fbsd-libgc.a
!
! fbsd-libleak.a:
! make CFLAGS="$(LEAKFLAGS)" clean c++-nt
! mv gc.a fbsd-libleak.a
!
! FreeBSD-pkg-install: FreeBSD-pkg-all
! ${CP} fbsd-libgc.a libgc.a
! ${CP} fbsd-libleak.a libleak.a
! ${INSTALL_DATA} libleak.a libgc.a ${PREFIX}/lib
! ${INSTALL_DATA} gc.h gc_cpp.h ${PREFIX}/include
! ${INSTALL_MAN} gc.man ${PREFIX}/man/man3/gc.3
# Setjmp_test may yield overly optimistic results when compiled
# without optimization.
***************
*** 124,131 ****
# not time-critical anyway.
# Set SPECIALCFLAGS to -q nodirect_code on Encore.
- all: gc.a gctest
-
pcr: PCR-Makefile gc_private.h gc_hdrs.h gc.h config.h mach_dep.o $(SRCS)
make -f PCR-Makefile depend
make -f PCR-Makefile
--- 150,155 ----
***************
*** 170,182 ****
./if_mach SPARC SUNOS5 $(CXX) $(CXXFLAGS) -o test_cpp $(srcdir)/test_cpp.cc gc_cpp.o gc.a -lthread -ldl
./if_not_there test_cpp $(CXX) $(CXXFLAGS) -o test_cpp $(srcdir)/test_cpp.cc gc_cpp.o gc.a
c++: gc_cpp.o $(srcdir)/gc_cpp.h test_cpp
rm -f on_sparc_sunos5
./if_mach SPARC SUNOS5 touch on_sparc_sunos5
./if_mach SPARC SUNOS5 $(AR) rus gc.a gc_cpp.o
./if_not_there on_sparc_sunos5 $(AR) ru gc.a gc_cpp.o
./if_not_there on_sparc_sunos5 $(RANLIB) gc.a || cat /dev/null
- ./test_cpp 1
dyn_load_sunos53.o: dyn_load.c
$(CC) $(CFLAGS) -DSUNOS53_SHARED_LIB -c $(srcdir)/dyn_load.c -o $@
--- 194,211 ----
./if_mach SPARC SUNOS5 $(CXX) $(CXXFLAGS) -o test_cpp $(srcdir)/test_cpp.cc gc_cpp.o gc.a -lthread -ldl
./if_not_there test_cpp $(CXX) $(CXXFLAGS) -o test_cpp $(srcdir)/test_cpp.cc gc_cpp.o gc.a
+ c++-t: c++
+ ./test_cpp 1
+
+ c++-nt: c++
+ @echo "Use ./test_cpp 1 to test the leak library"
+
c++: gc_cpp.o $(srcdir)/gc_cpp.h test_cpp
rm -f on_sparc_sunos5
./if_mach SPARC SUNOS5 touch on_sparc_sunos5
./if_mach SPARC SUNOS5 $(AR) rus gc.a gc_cpp.o
./if_not_there on_sparc_sunos5 $(AR) ru gc.a gc_cpp.o
./if_not_there on_sparc_sunos5 $(RANLIB) gc.a || cat /dev/null
dyn_load_sunos53.o: dyn_load.c
$(CC) $(CFLAGS) -DSUNOS53_SHARED_LIB -c $(srcdir)/dyn_load.c -o $@

View file

@ -0,0 +1,72 @@
*** gc.man.orig Fri Nov 15 08:56:14 1996
--- gc.man Fri Nov 15 09:30:14 1996
***************
*** 9,15 ****
... malloc(...) ...
.br
.sp
! cc ... gc.a
.LP
.SH DESCRIPTION
.I GC_malloc
--- 9,17 ----
... malloc(...) ...
.br
.sp
! cc ... -lgc
! .sp
! cc ... -lleak
.LP
.SH DESCRIPTION
.I GC_malloc
***************
*** 67,72 ****
--- 69,116 ----
This may temporarily write protect pages in the heap. See the README file for more information on how this interacts with system calls that write to the heap.
.LP
Other facilities not discussed here include limited facilities to support incremental collection on machines without appropriate VM support, provisions for providing more explicit object layout information to the garbage collector, more direct support for ``weak'' pointers, support for ``abortable'' garbage collections during idle time, etc.
+ .LP
+ .SH "PORT INFORMATION"
+ .LP
+ In this (FreeBSD package) installation,
+ .I gc.h
+ and
+ .I gc_cpp.h
+ will probably be found in
+ .I /usr/local/include,
+ and the libraries in
+ .I /usr/local/lib.
+ .LP
+ These libraries have been compiled as drop-in replacements
+ for malloc and free (which is to say, all malloc
+ calls will allocate garbage-collectable data).
+ There is no need to include "gc.h" in your C files unless you want
+ access to the debugging (and other) functions defined there,
+ or unless you want to explicitly use
+ .I GC_malloc_uncollectable
+ for some allocations.
+ Just link against them whenever you want either garbage
+ collection or leak detection.
+ .LP
+ The C++ header file, "gc_cpp.h",
+ .I is
+ necessary for C++ programs, to obtain the appropriate
+ definitions of the
+ .I new
+ and
+ .I delete
+ operators.
+ The comments in both of these header files presently
+ provide far better documentation
+ for the package than this man page;
+ look there for more information.
+ .LP
+ Both libraries are compiled without (explicit) support
+ for the experimental
+ .I gc
+ extension of
+ .I g++.
+ This may or may not make a difference.
.LP
.SH "SEE ALSO"
The README and gc.h files in the distribution. More detailed definitions of the functions exported by the collector are given there. (The above list is not complete.)

View file

@ -0,0 +1 @@
Garbage collection and memory leak detection for C and C++.

23
devel/boehm-gc/pkg/DESCR Normal file
View file

@ -0,0 +1,23 @@
The Boehm-Weiser garbage collection package, for C and C++ -
garbage collection and memory leak detection libraries.
A garbage collector is something which automatically frees malloc'd
memory for you by working out what parts of memory your program
no longer has pointers to. As a result, garbage collectors can also
inform you of memory leaks (if they find memory they can free, it means
you have lost all of your pointers to it, but you didn't free it).
This package has two libraries and some include files:
libgc.a - a garbage collection library, replaces malloc/free/new/delete/etc
with versions that do automatic garbage collection
libleak.a - a leak detection library, which is just libgc.a compiled with
different switches.
C programs may be linked against either of these, and should run (with
GC or leak detection) without change. C++ programs must include a header
to use garbage collection, though leak detection should work without
such source code modifications. See the man page and header files.
-- Mike McGaughey <mmcg@cs.monash.edu.au>
ps: garbage collection is addictive.

5
devel/boehm-gc/pkg/PLIST Normal file
View file

@ -0,0 +1,5 @@
include/gc.h
include/gc_cpp.h
lib/libgc.a
lib/libleak.a
man/man3/gc.3.gz

31
devel/gindent/Makefile Normal file
View file

@ -0,0 +1,31 @@
# New ports collection makefile for: indent
# Version required: 1.9.1
# Date created: 28 August 1997
# Whom: Kapil Chowksey <kchowksey@hss.hns.com>
#
# FreeBSD Id: Makefile,v 1.1.1.1 1997/08/29 09:20:00 obrien Exp
#
DISTNAME= indent-1.9.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MAINTAINER= kchowksey@hss.hns.com
MAN1= indent.1
post-install:
@mv ${PREFIX}/bin/indent ${PREFIX}/bin/indent
@strip ${PREFIX}/bin/indent
@test -d ${PREFIX}/info || ${MKDIR} ${PREFIX}/info \
&& chmod a+rx ${PREFIX}/info
@if [ ! -f ${PREFIX}/info/dir ]; then \
if [ -f /usr/share/info/dir ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
else \
touch ${PREFIX}/info/dir ; \
fi ; \
fi
@install-info ${PREFIX}/info/indent.info ${PREFIX}/info/dir
.include <bsd.port.mk>

1
devel/gindent/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (indent-1.9.1.tar.gz) = 21b5f78c7ade93fa7d33f79ff48d3982

View file

@ -0,0 +1,18 @@
--- makefile.in.orig Thu Aug 28 17:48:56 1997
+++ makefile.in Thu Aug 28 17:50:29 1997
@@ -51,6 +51,7 @@
exec_prefix = ${prefix}
bindir = $(exec_prefix)/bin
infodir = ${prefix}/info
+mandir = ${prefix}/man
#### End of system configuration section. ####
@@ -126,6 +127,7 @@
install: all
${INSTALL_PROGRAM} indent ${bindir}/indent
${INSTALL_DATA} ${srcdir}/indent.info ${infodir}/indent.info
+ ${INSTALL_DATA} ${srcdir}/indent.1 ${mandir}/man1/indent.1
# Cleaning up

View file

@ -0,0 +1 @@
GNU indent.

2
devel/gindent/pkg/DESCR Normal file
View file

@ -0,0 +1,2 @@
The `indent' program changes the appearance of a C program by
inserting or deleting whitespace.

6
devel/gindent/pkg/PLIST Normal file
View file

@ -0,0 +1,6 @@
bin/indent
man/man1/indent.1.gz
info/indent.info
@unexec install-info --delete %D/info/indent.info %D/info/dir
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/indent.info %D/info/dir

26
devel/gmake/Makefile Normal file
View file

@ -0,0 +1,26 @@
# New ports collection makefile for: GNU make
# Version required: 3.75
# Date created: 11 September 1994
# Whom: jkh
#
# FreeBSD Id: Makefile,v 1.16 1997/06/13 20:00:47 max Exp
#
DISTNAME= make-3.75
PKGNAME= gmake-3.75
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
GNU_CONFIGURE= yes
MAN1= gmake.1
# joerg@freebsd.org says our getloadavg() no longer requires setgid kmem
post-install:
/bin/chmod g-s ${PREFIX}/bin/gmake
/usr/bin/chgrp ${BINGRP} ${PREFIX}/bin/gmake
@if [ ! -f ${PREFIX}/info/dir ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
@install-info ${PREFIX}/info/make.info ${PREFIX}/info/dir
.include <bsd.port.mk>

1
devel/gmake/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (make-3.75.tar.gz) = f3dd5a2bc74aee00b9f3c38f5d438f60

View file

@ -0,0 +1,62 @@
--- Makefile.in.orig Thu Aug 29 06:13:09 1996
+++ Makefile.in Thu Jun 12 20:53:26 1997
@@ -79,7 +79,7 @@
# Number to put on the man page filename.
manext = 1
# Prefix to put on installed `make' binary file name.
-binprefix =
+binprefix = g
# Prefix to put on installed `make' man page file name.
manprefix = $(binprefix)
@@ -130,14 +130,14 @@
.SUFFIXES:
.SUFFIXES: .o .c .h .ps .dvi .info .texinfo
-all: make
+all: make info
info: make.info
dvi: make.dvi
# Some makes apparently use .PHONY as the default goal if it is before `all'.
.PHONY: all check info dvi
make.info: make.texinfo
- $(MAKEINFO) -I$(srcdir) $(srcdir)/make.texinfo -o make.info
+ rm -f make.info* && $(MAKEINFO) --no-split -I$(srcdir) $(srcdir)/make.texinfo -o make.info
make.dvi: make.texinfo
$(TEXI2DVI) $(srcdir)/make.texinfo
@@ -175,6 +175,8 @@
installdirs:
$(SHELL) ${srcdir}/mkinstalldirs $(bindir) $(infodir) $(mandir)
+ rm -f $(bindir)/$(binprefix)make $(infodir)/make.info \
+ $(mandir)/$(manprefix)make.$(manext)
$(bindir)/$(binprefix)make: make
$(INSTALL_PROGRAM) make $@.new
@@ -204,10 +206,10 @@
# line so we notice real errors from install-info.
# We use `$(SHELL) -c' because some shells do not
# fail gracefully when there is an unknown command.
- if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
- if [ -r ./make.info ]; then dir=.; else dir=$(srcdir); fi; \
- install-info --infodir=$(infodir) $$dir/make.info; \
- else true; fi
+# if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
+# if [ -r ./make.info ]; then dir=.; else dir=$(srcdir); fi; \
+# install-info --infodir=$(infodir) $$dir/make.info; \
+# else true; fi
$(mandir)/$(manprefix)make.$(manext): make.man
$(INSTALL_DATA) $(srcdir)/make.man $@
@@ -250,7 +252,8 @@
$(SHELL) config.status
glob/Makefile: config.status $(srcdir)/glob/Makefile.in
$(SHELL) config.status
-config.h: stamp-config ;
+config.h: stamp-config
+
stamp-config: config.status $(srcdir)/config.h.in
$(SHELL) config.status
touch stamp-config

View file

@ -0,0 +1,13 @@
--- make.texinfo.orig Mon Jul 15 01:30:15 1996
+++ make.texinfo Thu Jun 12 20:37:09 1997
@@ -2,6 +2,10 @@
@c %**start of header
@setfilename make.info
@settitle GNU @code{make}
+@dircategory Programming & development tools
+@direntry
+* Gmake: (make). The GNU Make utility.
+@end direntry
@setchapternewpage odd
@c %**end of header

1
devel/gmake/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
GNU version of 'make' utility

3
devel/gmake/pkg/DESCR Normal file
View file

@ -0,0 +1,3 @@
This directory contains the release of GNU Make.
All bugs reported for previous test releases have been fixed.
Some bugs surely remain.

6
devel/gmake/pkg/PLIST Normal file
View file

@ -0,0 +1,6 @@
bin/gmake
man/man1/gmake.1.gz
@unexec install-info --delete %D/info/make.info %D/info/dir
info/make.info
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/make.info %D/info/dir

21
devel/id-utils/Makefile Normal file
View file

@ -0,0 +1,21 @@
# New ports collection makefile for: id-utils
# Version required: 3.2
# Date created: 22 Aug 1996
# Whom: pst@freebsd.org
#
# FreeBSD Id: Makefile,v 1.4 1996/11/18 10:22:47 asami Exp
#
DISTNAME= id-utils-3.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MAINTAINER= pst@FreeBSD.ORG
# need to byte-compile a .el file
BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs
GNU_CONFIGURE= yes
USE_GMAKE= yes
.include <bsd.port.mk>

1
devel/id-utils/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (id-utils-3.2.tar.gz) = 758213344bfd1b70723b10cdb2beaef3

View file

@ -0,0 +1 @@
The classic Berkeley gid/lid tools for looking up variables in code.

16
devel/id-utils/pkg/DESCR Normal file
View file

@ -0,0 +1,16 @@
`mkid' is a simple, fast, high-capacity, language-independent
identifier database tool. Actually, the term `identifier' is too
limiting--`mkid' stores tokens, be they program identifiers of any
form, literal numbers, or words of human-readable text. Database
queries can be issued from the command-line, or from within emacs,
serving as an augmented tags facility.
`mkid' was originally written by Greg McGary <gkm@gnu.ai.mit.edu>
and posted to comp.sources.unix in September 1987. It was then
maintained and enhanced by a loose knit group of programmers on the
Internet led by Tom Horsley <Tom.Horsley@mail.hcsc.com>. Tom released
`mkid2' on comp.sources.unix in March, 1991. Since then, Greg McGary
has resumed maintenance and is releasing an improved version 3 under GPL.
Version 3 is an interim release. Version 4 will follow in the coming
months and include a cscope clone plus other improvements.

14
devel/id-utils/pkg/PLIST Normal file
View file

@ -0,0 +1,14 @@
bin/mkid
bin/lid
bin/fid
bin/fnid
bin/xtokid
bin/eid
bin/aid
bin/gid
bin/defid
info/id-utils.info
share/emacs/site-lisp/id-utils.elc
share/id-lang.map
share/locale/de/LC_MESSAGES/id-utils.mo
share/locale/fr/LC_MESSAGES/id-utils.mo

24
devel/m4/Makefile Normal file
View file

@ -0,0 +1,24 @@
# New ports collection makefile for: m4
# Version required: 1.4
# Date created: 25 October 1994
# Whom: mr
#
# FreeBSD Id: Makefile,v 1.7 1997/06/16 08:22:35 max Exp
#
DISTNAME= m4-1.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
GNU_CONFIGURE=yes
CONFIGURE_ARGS= --program-prefix=g
post-install:
@${MKDIR} ${PREFIX}/share/examples/gm4
${INSTALL_DATA} ${WRKSRC}/examples/*.m4 ${PREFIX}/share/examples/gm4
@if [ ! -f ${PREFIX}/info/dir ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
@install-info ${PREFIX}/info/m4.info ${PREFIX}/info/dir
.include <bsd.port.mk>

1
devel/m4/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (m4-1.4.tar.gz) = 9eb2dd07740b2d2f3c7adb3e8d299bda

11
devel/m4/patches/patch-aa Normal file
View file

@ -0,0 +1,11 @@
--- doc/Makefile.in.orig Sun Nov 6 05:52:26 1994
+++ doc/Makefile.in Mon Jun 16 16:08:39 1997
@@ -40,7 +40,7 @@
info: m4.info
m4.info: m4.texinfo version.texi
- cd $(srcdir) && $(MAKEINFO) m4.texinfo
+ cd $(srcdir) && rm -f m4.info* && $(MAKEINFO) --no-split m4.texinfo
dvi: m4.dvi

19
devel/m4/patches/patch-ab Normal file
View file

@ -0,0 +1,19 @@
--- doc/m4.texinfo.orig Mon Oct 31 09:07:39 1994
+++ doc/m4.texinfo Mon Jun 16 16:36:44 1997
@@ -2,6 +2,7 @@
@c %**start of header
@setfilename m4.info
@settitle GNU macro processor
+@dircategory Programming & development tools
@finalout
@c %**end of header
@@ -17,7 +18,7 @@
@ifinfo
@format
START-INFO-DIR-ENTRY
-* m4: (m4). A powerful macro processor.
+* Gm4: (m4). A powerful macro processor.
END-INFO-DIR-ENTRY
@end format
@end ifinfo

1
devel/m4/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
GNU's m4.

27
devel/m4/pkg/DESCR Normal file
View file

@ -0,0 +1,27 @@
GNU `m4'
********
GNU `m4' is an implementation of the traditional UNIX macro
processor. It is mostly SVR4 compatible, although it has some
extensions (for example, handling more than 9 positional parameters to
macros). `m4' also has builtin functions for including files, running
shell commands, doing arithmetic, etc. Autoconf needs GNU `m4' for
generating `configure' scripts, but not for running them.
GNU `m4' was originally written by Rene Seindal, with subsequent
changes by Franc,ois Pinard and other volunteers on the Internet. All
names and email addresses can be found in the file `THANKS' from the
GNU `m4' distribution.
This is release 1.3. It is now to be considered stable, future
releases are only meant to fix bugs, increase speed, or improve
documentation. However...
An experimental feature, which would improve `m4' usefulness, allows
for changing the syntax for what is a "word" in `m4'. You should use:
./configure --enable-changeword
if you want this feature compiled in. The current implementation slows
down `m4' considerably and is hardly acceptable. So, it might go away,
do not count on it yet.

32
devel/m4/pkg/PLIST Normal file
View file

@ -0,0 +1,32 @@
bin/gm4
@unexec install-info --delete %D/info/m4.info %D/info/dir
info/m4.info
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/m4.info %D/info/dir
share/examples/gm4/capitalize.m4
share/examples/gm4/comments.m4
share/examples/gm4/ddivert.m4
share/examples/gm4/debug.m4
share/examples/gm4/esyscmd.m4
share/examples/gm4/exp.m4
share/examples/gm4/file.m4
share/examples/gm4/foreach.m4
share/examples/gm4/forloop.m4
share/examples/gm4/fstab.m4
share/examples/gm4/hanoi.m4
share/examples/gm4/incl-test.m4
share/examples/gm4/include.m4
share/examples/gm4/indir.m4
share/examples/gm4/misc.m4
share/examples/gm4/multiquotes.m4
share/examples/gm4/patsubst.m4
share/examples/gm4/pushpop.m4
share/examples/gm4/regexp.m4
share/examples/gm4/reverse.m4
share/examples/gm4/sync-lines.m4
share/examples/gm4/sysv-args.m4
share/examples/gm4/trace.m4
share/examples/gm4/translit.m4
share/examples/gm4/undivert.m4
share/examples/gm4/wrap.m4
@dirrm share/examples/gm4

33
devel/noweb/Makefile Normal file
View file

@ -0,0 +1,33 @@
# New ports collection makefile for: noweb
# Version required: noweb-2.8a
# Date created: 29 July 1995
# Whom: Thomas Gellekum <tg@freebsd.org>
#
# FreeBSD Id: Makefile,v 1.10 1997/09/15 07:22:06 tg Exp
#
DISTNAME= noweb-2.8a
CATEGORIES= devel
MASTER_SITES= ftp://ftp.cs.virginia.edu/pub/nr/
EXTRACT_SUFX= .tgz
MAINTAINER= tg@freebsd.org
BUILD_DEPENDS= icont:${PORTSDIR}/lang/icon
RUN_DEPENDS= iconx:${PORTSDIR}/lang/icon
WRKSRC= ${WRKDIR}/src
MAN1= cpif.1 nodefs.1 noroots.1 noweb.1 noindex.1 \
nuweb2noweb.1 notangle.1 sl2h.1 htmltoc.1
MAN7= nowebstyle.7 nowebfilters.7
.if !defined(NOMANCOMPRESS)
post-install:
@rm ${PREFIX}/man/man1/noweave.1*
@rm ${PREFIX}/man/man1/nountangle.1*
ln -sf ${PREFIX}/man/man1/notangle.1.gz ${PREFIX}/man/man1/noweave.1.gz
ln -sf ${PREFIX}/man/man1/notangle.1.gz ${PREFIX}/man/man1/nountangle.1.gz
.endif
.include <bsd.port.mk>

1
devel/noweb/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (noweb-2.8a.tgz) = 91892be37bc26dd83ba7d1188cd4c028

View file

@ -0,0 +1,54 @@
--- Makefile.orig Sat Sep 13 23:27:50 1997
+++ Makefile Mon Sep 15 09:23:19 1997
@@ -2,13 +2,13 @@
# See file COPYRIGHT for more information.
#
# Adjust these two lines for your ANSI C compiler
-CC=gcc
-CFLAGS=
+#CC=gcc
+#CFLAGS=
# If you have Icon, you should use the Icon versions of the noweb pipeline.
-# Set LIBSRC=icon
-LIBSRC=awk
+LIBSRC=icon
+#LIBSRC=awk
# If you have no Icon compiler, but do have icont, make ICONC=icont
-ICONC=iconc
+ICONC=icont
ICONT=icont
# BIN is where the commands (notangle, noweave, nountangle, noroots) land
@@ -18,13 +18,13 @@
# MAN7EXT is the extension for the nowebstyle man page (usually 7)
# TEXINPUTS is the directory for TeX macro files
# ELISP is the directory for emacs lisp files, or /dev/null not to install
-BIN=/usr/local/noweb
-LIB=/usr/local/noweb/lib
-MAN=/usr/local/noweb/man
+BIN=${PREFIX}/bin
+LIB=${PREFIX}/share/noweb
+MAN=${PREFIX}/man
MANEXT=1
MAN7EXT=7
-TEXINPUTS=/usr/local/tex/inputs
-ELISP=/dev/null
+TEXINPUTS=${LIB}/tex
+ELISP=${PREFIX}/share/emacs/site-lisp
# change WEAVE if you want a different version of noweave to be installed
WEAVE=noweave
@@ -114,11 +114,11 @@
rm -f $(CATDIR)/nountangle.$(MANEXT).gz
(cd $(CATDIR); ln notangle.$(MANEXT).gz nountangle.$(MANEXT).gz)
install-tex:
- -mkdir $(TEXINPUTS) 2>/dev/null
+ -mkdir -p $(TEXINPUTS) 2>/dev/null
cp tex/nwmac.tex tex/noweb.sty $(TEXINPUTS)
install-elisp:
- -mkdir $(ELISP) 2>/dev/null
+ -mkdir -p $(ELISP) 2>/dev/null
cp elisp/noweb-mode.el $(ELISP)
checkin:

1
devel/noweb/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
A simple, extensible literate-programming tool.

22
devel/noweb/pkg/DESCR Normal file
View file

@ -0,0 +1,22 @@
INTRODUCTION --- WHAT IS NOWEB, ANYWAY?
noweb is a literate-programming tool like FunnelWEB or nuweb, only
simpler. A noweb file contains program source code interleaved with
documentation. When noweb is invoked, it writes the program source
code to the output files mentioned in the noweb file, and it writes
a TeX file for typeset documentation.
noweb is designed to meet the needs of literate programmers while
remaining as simple as possible. Its primary advantages are
simplicity, extensibility, and language-independence. noweb works
``out of the box'' with any programming language, and supports TeX,
latex, and HTML (Mosaic) back ends. A back end to support full
hypertext or indexing takes about 250 lines; a simpler one can be
written in 40 lines of awk. The primary sacrifice relative to WEB
is that code is not prettyprinted.
If you're brand new to literate programming, check out the FAQ for
the USENET newsgroup comp.programming.literate. There are also some
resources available through the noweb home page:
http://www.cs.virginia.edu/~nr/noweb

53
devel/noweb/pkg/PLIST Normal file
View file

@ -0,0 +1,53 @@
bin/htmltoc
bin/nodefs
bin/noindex
bin/noroff
bin/noroots
bin/notangle
bin/nountangle
bin/noweave
bin/noweb
bin/nuweb2noweb
bin/cpif
bin/sl2h
share/emacs/site-lisp/noweb-mode.el
share/noweb/autodefs.c
share/noweb/autodefs.icon
share/noweb/autodefs.lrtl
share/noweb/autodefs.pascal
share/noweb/autodefs.promela
share/noweb/autodefs.sml
share/noweb/autodefs.tex
share/noweb/autodefs.yacc
share/noweb/disambiguate
share/noweb/elide
share/noweb/emptydefn
share/noweb/finduses
share/noweb/l2h
share/noweb/markup
share/noweb/mnt
share/noweb/noidx
share/noweb/nt
share/noweb/tmac.w
share/noweb/toascii
share/noweb/tohtml
share/noweb/totex
share/noweb/toroff
share/noweb/unmarkup
share/noweb/tex/noweb.sty
share/noweb/tex/nwmac.tex
man/man1/cpif.1.gz
man/man1/nodefs.1.gz
man/man1/noroots.1.gz
man/man1/noweb.1.gz
man/man1/noindex.1.gz
man/man1/nuweb2noweb.1.gz
man/man1/notangle.1.gz
man/man1/sl2h.1.gz
man/man1/htmltoc.1.gz
man/man1/nountangle.1.gz
man/man1/noweave.1.gz
man/man7/nowebstyle.7.gz
man/man7/nowebfilters.7.gz
@dirrm share/noweb/tex
@dirrm share/noweb