from KAME/netbsd repository
This commit is contained in:
parent
ac926ffdae
commit
45b20285eb
8 changed files with 155 additions and 0 deletions
60
mail/smtpfeed/Makefile
Normal file
60
mail/smtpfeed/Makefile
Normal file
|
@ -0,0 +1,60 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1999/11/29 08:06:32 itojun Exp $
|
||||
# KAME $Id: Makefile,v 1.1.1.1 1999/11/29 08:06:32 itojun Exp $
|
||||
# Based on FreeBSD Id: Makefile,v 1.27 1999/04/03 08:25:18 itojun Exp
|
||||
#
|
||||
|
||||
DISTNAME= smtpfeed-1.02
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://ftp.kyoto.wide.ad.jp/pub/mail/smtpfeed/ \
|
||||
ftp://ftp.kyoto.wide.ad.jp/pub/mail/sendmail/ \
|
||||
ftp://ftp.sendmail.org/ucb/src/sendmail/ \
|
||||
http://freefall.freebsd.org/~itojun/distfiles/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SENDMAIL}${EXTRACT_SUFX} \
|
||||
${SENDMAILPATCH}.patch.gz
|
||||
|
||||
MAINTAINER= itojun@itojun.org
|
||||
HOMEPAGE= http://www.kyoto.wide.ad.jp/mta/sendmail.html#smtpfeed
|
||||
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX} ${SENDMAIL}${EXTRACT_SUFX}
|
||||
PATCH_SENDMAIL_ARGS= -d ${WRKSRC_SENDMAIL} -E ${PATCH_DIST_STRIP}
|
||||
NO_PACKAGE= "complex configuration for sendmail.cf needed"
|
||||
|
||||
SENDMAILVER= 8.9.3
|
||||
SENDMAIL= sendmail.${SENDMAILVER}
|
||||
SENDMAILDIR= sendmail-${SENDMAILVER}
|
||||
SENDMAILPATCH= sendmail893+3.2W
|
||||
WRKSRC_SMTPFEED= ${WRKSRC}
|
||||
WRKSRC_SENDMAIL= ${WRKDIR}/${SENDMAILDIR}/src
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec
|
||||
# use bind8?
|
||||
#CONFIGURE_ARGS+= --with-bind8
|
||||
|
||||
DOCS= COPYRIGHT FEATURES FEATURES.j FYI FYI.j INSTALL INSTALL.j \
|
||||
OPTIONS OPTIONS.j README README.j RELEASE.NOTE SIGNAL SIGNAL.j TODO
|
||||
DOCDIR= ${PREFIX}/share/doc/smtpfeed
|
||||
|
||||
post-patch:
|
||||
@${ECHO_MSG} "===> Applying smtpfeed patch ${SENDMAILPATCH} to ${SENDMAIL}"
|
||||
@(cd ${_DISTDIR}; for i in ${SENDMAILPATCH}.patch.gz; do \
|
||||
${GZCAT} $$i | ${PATCH} ${PATCH_SENDMAIL_ARGS}; \
|
||||
done)
|
||||
|
||||
post-build:
|
||||
@${ECHO_MSG} "===> Building patched ${SENDMAIL}"
|
||||
@(cd ${WRKSRC_SENDMAIL}; sh makesendmail -f site.config-v6.kame)
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCDIR}
|
||||
for i in ${DOCS}; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$i ${DOCDIR}; \
|
||||
done
|
||||
.endif
|
||||
@${SED} -e 's#/usr/local#${PREFIX}#' ${PKGDIR}/MESSAGE
|
||||
|
||||
install-sendmail:
|
||||
(cd ${WRKSRC_SENDMAIL}; sh makesendmail install)
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
mail/smtpfeed/files/md5
Normal file
5
mail/smtpfeed/files/md5
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/11/29 08:06:32 itojun Exp $
|
||||
|
||||
MD5 (smtpfeed-1.02.tar.gz) = a1e2f6c7174742e71e06c3561c7c277e
|
||||
MD5 (sendmail.8.9.3.tar.gz) = efedacfbce84a71d1cfb0e617b84596e
|
||||
MD5 (sendmail893+3.2W.patch.gz) = 77e2183c40e304a2b1410a5bb041cd46
|
12
mail/smtpfeed/patches/patch-aa
Normal file
12
mail/smtpfeed/patches/patch-aa
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/11/29 08:06:32 itojun Exp $
|
||||
|
||||
--- Makefile.in.orig Sun Jan 18 23:02:21 1998
|
||||
+++ Makefile.in Sun Jan 18 23:02:34 1998
|
||||
@@ -70,7 +70,6 @@
|
||||
${RM} -f ${OBJS} ${OBJADDS} ${TARGET} res_send.c
|
||||
|
||||
install:
|
||||
- -mv -f ${DEST}/${TARGET} ${DEST}/${TARGET}.old
|
||||
${INSTALL} ${TARGET} ${DEST}
|
||||
|
||||
gcc2-lint:
|
24
mail/smtpfeed/patches/patch-ab
Normal file
24
mail/smtpfeed/patches/patch-ab
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 1999/11/29 08:06:32 itojun Exp $
|
||||
|
||||
--- configure.in- Sun May 16 23:33:06 1999
|
||||
+++ configure.in Sun May 16 23:33:28 1999
|
||||
@@ -221,7 +221,7 @@
|
||||
[#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netinet/in.h>
|
||||
-#include <resolv.h>], [_res_ext.nsaddr_list[0].ss_family = 1;],
|
||||
+#include <resolv.h>], [_res_ext.nsaddr_list[0].__ss_family = 1;],
|
||||
[AC_DEFINE(RESOLVER_KAME)
|
||||
resolver=kame],
|
||||
[AC_TRY_COMPILE(dnl
|
||||
--- configure- Sun May 16 23:33:04 1999
|
||||
+++ configure Sun May 16 23:33:17 1999
|
||||
@@ -1371,7 +1371,7 @@
|
||||
#include <netinet/in.h>
|
||||
#include <resolv.h>
|
||||
int main() {
|
||||
-_res_ext.nsaddr_list[0].ss_family = 1;
|
||||
+_res_ext.nsaddr_list[0].__ss_family = 1;
|
||||
; return 0; }
|
||||
EOF
|
||||
if { (eval echo configure:1378: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
1
mail/smtpfeed/pkg/COMMENT
Normal file
1
mail/smtpfeed/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
SMTP Fast Exploding External Deliverer for Sendmail
|
17
mail/smtpfeed/pkg/DESCR
Normal file
17
mail/smtpfeed/pkg/DESCR
Normal file
|
@ -0,0 +1,17 @@
|
|||
SMTP feed -- SMTP Fast Exploding External Deliverer for Sendmail
|
||||
|
||||
Smtpfeed is a SMTP delivery agent which is called by sendmail, and it
|
||||
improves required time to complete delivery of copies of a message to
|
||||
recipients of huge number.
|
||||
|
||||
This delay of delivery by sendmail causes by the fact that implementation
|
||||
of SMTP delivery routine in sendmail processes all delivery in a series.
|
||||
By this reason, when it takes long time for delivery to one recipient
|
||||
which is in a huge list, delivery to following recipients is greatly
|
||||
influenced.
|
||||
|
||||
To avoid such a problem, delivery agents should be implemented so that
|
||||
a delivery is not influenced by preceding delivery: DNS query and
|
||||
SMTP delivery par destination should be processed in parallel.
|
||||
Smtpfeed is the SMTP delivery agent for sendmail implemented with this
|
||||
idea.
|
18
mail/smtpfeed/pkg/MESSAGE
Normal file
18
mail/smtpfeed/pkg/MESSAGE
Normal file
|
@ -0,0 +1,18 @@
|
|||
**************************************************************
|
||||
smtpfeed is installed into /usr/local/libexec/smtpfeed.
|
||||
You'll need to perform 3 steps, (a) to (c), to make smtpfeed
|
||||
work:
|
||||
(a) replace /etc/sendmail.cf
|
||||
(b) replace sendmail with the patched sendmail
|
||||
(c) setting up /etc/syslog.conf
|
||||
|
||||
(a) depends on what kind of configuration tool you are using
|
||||
with sendmail.cf. Read through documentation in
|
||||
/usr/local/share/doc/smtpfeed for details.
|
||||
(b) can be done by performing "make install-sendmail" in the
|
||||
port directory.
|
||||
WARNING: Existing sendmail will be overwritten right away!
|
||||
Backup by yourself for safety.
|
||||
(c) is the easiest of the three items; see file named INSTALL
|
||||
in /usr/local/share/doc/smtpfeed.
|
||||
**************************************************************
|
18
mail/smtpfeed/pkg/PLIST
Normal file
18
mail/smtpfeed/pkg/PLIST
Normal file
|
@ -0,0 +1,18 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/11/29 08:06:33 itojun Exp $
|
||||
libexec/smtpfeed
|
||||
share/doc/smtpfeed/COPYRIGHT
|
||||
share/doc/smtpfeed/FEATURES
|
||||
share/doc/smtpfeed/FEATURES.j
|
||||
share/doc/smtpfeed/FYI
|
||||
share/doc/smtpfeed/FYI.j
|
||||
share/doc/smtpfeed/INSTALL
|
||||
share/doc/smtpfeed/INSTALL.j
|
||||
share/doc/smtpfeed/OPTIONS
|
||||
share/doc/smtpfeed/OPTIONS.j
|
||||
share/doc/smtpfeed/README
|
||||
share/doc/smtpfeed/README.j
|
||||
share/doc/smtpfeed/RELEASE.NOTE
|
||||
share/doc/smtpfeed/SIGNAL
|
||||
share/doc/smtpfeed/SIGNAL.j
|
||||
share/doc/smtpfeed/TODO
|
||||
@dirrm share/doc/smtpfeed
|
Loading…
Reference in a new issue