fix a fix: "#define HANDLE_MULTIBYTE 0" doesn't work as expected if

it is tested for by "#if defined"...
This commit is contained in:
drochner 2002-12-17 14:45:12 +00:00
parent 84e01f1a33
commit 45b8efe0b5
4 changed files with 22 additions and 46 deletions

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.7 2002/11/25 05:39:33 schmonz Exp $
$NetBSD: distinfo,v 1.8 2002/12/17 14:45:12 drochner Exp $
SHA1 (bash-2.05b.tar.gz) = b3e158877f94e66ec1c8ef604e994851ee388b09
Size (bash-2.05b.tar.gz) = 1956216 bytes
SHA1 (patch-aa) = 7ea440ffc3c3051fc589c8b0a9015feb7f1e7093
SHA1 (patch-aa) = 481cfa2962a799ec6444519949935dcadd942915
SHA1 (patch-ab) = 1a2fc87648b7e73a4987454bb249149ae15bed93
SHA1 (patch-ac) = 38d134c25aa12fec1dda7b1d0c7f8cf512b4b2cb
SHA1 (patch-ad) = 11f38c1a531578fa9947aed0a6b16537560877e9
SHA1 (patch-ac) = 6528085df706bd8741b8d460e5766a4be6f95ca2
SHA1 (patch-ad) = 412b45000cbd26e5dbacb4c414351c70d73ae62f
SHA1 (patch-ae) = c0e5564d5e57a04d8458e67fb391df0d890e6f38

View file

@ -1,21 +1,13 @@
$NetBSD: patch-aa,v 1.9 2002/11/25 05:39:34 schmonz Exp $
$NetBSD: patch-aa,v 1.10 2002/12/17 14:45:13 drochner Exp $
--- config-bot.h.orig Tue Apr 16 17:01:03 2002
+++ config-bot.h
@@ -104,11 +104,16 @@
/* For platforms which support the ISO C amendement 1 functionality we
support user defined character classes. */
/* Solaris 2.5 has a bug: <wchar.h> must be included before <wctype.h>. */
+#if defined (__NetBSD__)
+# define HANDLE_MULTIBYTE 0
+#endif
--- config-bot.h.orig Tue Apr 16 23:01:03 2002
+++ config-bot.h Tue Dec 17 15:34:52 2002
@@ -107,7 +107,7 @@
#if defined (HAVE_WCTYPE_H) && defined (HAVE_WCHAR_H)
# include <wchar.h>
# include <wctype.h>
# if defined (HAVE_MBSRTOWCS) /* system is supposed to support XPG5 */
+# if !defined (HANDLE_MULTIBYTE)
-# if defined (HAVE_MBSRTOWCS) /* system is supposed to support XPG5 */
+# if defined (HAVE_MBSRTOWCS) /* system is supposed to support XPG5 */ && !defined(__NetBSD__)
# define HANDLE_MULTIBYTE 1
+# endif
# endif
#endif

View file

@ -1,21 +1,13 @@
$NetBSD: patch-ac,v 1.7 2002/11/25 05:39:35 schmonz Exp $
$NetBSD: patch-ac,v 1.8 2002/12/17 14:45:13 drochner Exp $
--- include/shmbutil.h.orig Mon May 6 13:58:39 2002
+++ include/shmbutil.h
@@ -30,11 +30,16 @@
/* For platforms which support the ISO C amendement 1 functionality we
support user defined character classes. */
/* Solaris 2.5 has a bug: <wchar.h> must be included before <wctype.h>. */
+#if defined (__NetBSD__)
+# define HANDLE_MULTIBYTE 0
+#endif
--- include/shmbutil.h.orig Mon May 6 19:58:39 2002
+++ include/shmbutil.h Tue Dec 17 15:27:20 2002
@@ -33,7 +33,7 @@
#if defined (HAVE_WCTYPE_H) && defined (HAVE_WCHAR_H)
# include <wchar.h>
# include <wctype.h>
# if defined (HAVE_MBSRTOWCS) /* system is supposed to support XPG5 */
+# if !defined(HANDLE_MULTIBYTE)
-# if defined (HAVE_MBSRTOWCS) /* system is supposed to support XPG5 */
+# if defined (HAVE_MBSRTOWCS) /* system is supposed to support XPG5 */ && !defined(__NetBSD__)
# define HANDLE_MULTIBYTE 1
+# endif
# endif
#endif /* HAVE_WCTYPE_H && HAVE_WCHAR_H */

View file

@ -1,21 +1,13 @@
$NetBSD: patch-ad,v 1.3 2002/11/25 05:39:36 schmonz Exp $
$NetBSD: patch-ad,v 1.4 2002/12/17 14:45:13 drochner Exp $
--- lib/readline/rlmbutil.h.orig Thu Dec 20 09:54:38 2001
+++ lib/readline/rlmbutil.h
@@ -32,11 +32,16 @@
/* For platforms which support the ISO C amendement 1 functionality we
support user defined character classes. */
/* Solaris 2.5 has a bug: <wchar.h> must be included before <wctype.h>. */
+#if defined (__NetBSD__)
+# define HANDLE_MULTIBYTE 0
+#endif
--- lib/readline/rlmbutil.h.orig Thu Dec 20 15:54:38 2001
+++ lib/readline/rlmbutil.h Tue Dec 17 15:35:45 2002
@@ -35,7 +35,7 @@
#if defined (HAVE_WCTYPE_H) && defined (HAVE_WCHAR_H)
# include <wchar.h>
# include <wctype.h>
# if defined (HAVE_MBSRTOWCS) /* system is supposed to support XPG5 */
+# if !defined(HANDLE_MULTIBYTE)
-# if defined (HAVE_MBSRTOWCS) /* system is supposed to support XPG5 */
+# if defined (HAVE_MBSRTOWCS) /* system is supposed to support XPG5 */ && !defined(__NetBSD__)
# define HANDLE_MULTIBYTE 1
+# endif
# endif
#endif